none
Make excel 2010 default to open files in Excel

    Question

  • We have recently installed a new computer with Office 2010 from the net (no CD delivered with an OEM version)

    We have problems with our invoice program, so we installed Excel 2003 so we can extract data from that system to excel.

    When we open an excel file, it automatically starts with office 2003 instead of excel 2010.

    How can we change this?

    We are running Windows 7.

    Tuesday, September 14, 2010 10:18 AM

Answers

  • Actually, you probably installed Office 2010 with the Click-To-Run technology. this means your Office 2010 is running in its own little virtual bubble with it's own virtual registry hence why you can't find the executable to change the file association.

    Learn more about Click-to Run in an

    An overview of Microsoft Office Click-to-Run for Office 2010

    to repair the file association so that it opens with Office 2010, you will need to do a repair of Office 2010 from the control panel.

    if not follow the solution section of this KB: http://support.microsoft.com/kb/982426

    Hope that helps you out!

    Wednesday, October 13, 2010 8:01 PM
  • We have recently installed a new computer with Office 2010 from the net (no CD delivered with an OEM version)

    We have problems with our invoice program, so we installed Excel 2003 so we can extract data from that system to excel.

    When we open an excel file, it automatically starts with office 2003 instead of excel 2010.

    How can we change this?

    We are running Windows 7.


    I think we've got two different issues here, one about getting an Exe when installing from the web vs. CD.  The original topic here though is about getting Excel 2010 to be the default application to open when you've got multiple versions of Excel on a machine.

    Whichever version is installed last becomes the default version when opening files.

    Here is the KB article for 2010, there are others for the previous versions but the concept is the same.

    Version Installation Order
    Microsoft Office XP First
    Microsoft Office 2003 Second
    2007 Office suites and programs Third
    Microsoft Office 2010 suites and programs (32-bit only) Fourth

    You must install the earliest version of Office first. For example, if you want to use both Office 2003 and Office 2010 programs on the same computer, install Office 2003 first.

    Hope that helps!

    Ryan


    Please remember to mark this as "answer" if it resolves/answers your issue.
    Friday, September 17, 2010 3:43 PM
    Answerer
  • Hi,

    Have you tried opening Excel 2010 first and then open the file in that format.  I know I had to do this with some Workbooks and eventually it sorted itself out as 2010 became the 'default' Excel and files 'remembered' where they were last viewed - don't ask me how because it's beyond me, but somehow it worked. Hope it's a simple answer for you that works also.

    Cheers, Angus

    Friday, September 17, 2010 6:35 PM

All replies

  • Have you tried:

    - Right click on an excel file type e.g. .xls
    - Select "Open with..."
    - Then pick (or browse to) the loction for the Excel 2010  (e.g. C:\Program Files\Microsoft Office\Office14\EXCEL.EXE)

    or do it via control panel

    Control Panel -> All Control Panel Items -> Default Programs -> Set Associations

    HTH

    - AL

    Tuesday, September 14, 2010 1:05 PM
  • open with doesn't work because office 2010 isn't installed from CD.

    So there isn't an .exe file available.

    By control panel isn't possible neither.

    Tuesday, September 14, 2010 8:18 PM
  • Hi,

    Try to use this command line:

    Click Start->Run and type it

    <path to version which is current default eg Office11>\excel.exe /unregserver
    <path to version which is desired default eg Office14>\excel.exe /regserver

    Hope it helps.

    Wednesday, September 15, 2010 8:45 AM
    Moderator
  • Ok - when I read your initial post I assumed you meant you had Office 2010 installed locally but just didnt have the CD!

    It "sounds" like you're saying you don't have Office 2010 locally installed at all (hence why you can't point to the excel.exe)

    So I'm guessing when you're saying you have "Office 2010 from the net" you mean you're using something like "Office Web Apps"  ?

    Could you confirm.

    Thanks
    - AL

    Wednesday, September 15, 2010 10:02 AM
  • Hi Jennifer,

     

    I have exactly the same problem as Tom. I downloaded Office from the Microsoft Store. The download makes the software virtualized so I cannot even find a .exe file on my hard disk to do as you suggest. There are icons for word that got loaded here on my PC.

    C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Microsoft Office Home and Business (English)

    But when you try to associate office with a program in the standard programs screen in Windows 7, you cannot find an .exe to associate the file too. Therefore nothing opens when you click in windows explorer for example unless you open Excel first and then file/open.

    Please can you tell me how to get office .exe's available in the standard program set-up screen in Windows 7 when Office has been downloaded and is I believe virtualized. or a path to a word.exe or excel.exe

    Thanks a lot

     

    Thursday, September 16, 2010 12:34 PM
  • The problem is apparently "known" by MS.

    When you install Office 2010 from CD you get exe files and Office is "registerd" in the register.

    But when you install Office from the Microsoft store, it isn't registered and you don't have an exe file.

     

    Thursday, September 16, 2010 6:56 PM
  • We have recently installed a new computer with Office 2010 from the net (no CD delivered with an OEM version)

    We have problems with our invoice program, so we installed Excel 2003 so we can extract data from that system to excel.

    When we open an excel file, it automatically starts with office 2003 instead of excel 2010.

    How can we change this?

    We are running Windows 7.


    I think we've got two different issues here, one about getting an Exe when installing from the web vs. CD.  The original topic here though is about getting Excel 2010 to be the default application to open when you've got multiple versions of Excel on a machine.

    Whichever version is installed last becomes the default version when opening files.

    Here is the KB article for 2010, there are others for the previous versions but the concept is the same.

    Version Installation Order
    Microsoft Office XP First
    Microsoft Office 2003 Second
    2007 Office suites and programs Third
    Microsoft Office 2010 suites and programs (32-bit only) Fourth

    You must install the earliest version of Office first. For example, if you want to use both Office 2003 and Office 2010 programs on the same computer, install Office 2003 first.

    Hope that helps!

    Ryan


    Please remember to mark this as "answer" if it resolves/answers your issue.
    Friday, September 17, 2010 3:43 PM
    Answerer
  • Hi,

    Have you tried opening Excel 2010 first and then open the file in that format.  I know I had to do this with some Workbooks and eventually it sorted itself out as 2010 became the 'default' Excel and files 'remembered' where they were last viewed - don't ask me how because it's beyond me, but somehow it worked. Hope it's a simple answer for you that works also.

    Cheers, Angus

    Friday, September 17, 2010 6:35 PM
  • Actually, you probably installed Office 2010 with the Click-To-Run technology. this means your Office 2010 is running in its own little virtual bubble with it's own virtual registry hence why you can't find the executable to change the file association.

    Learn more about Click-to Run in an

    An overview of Microsoft Office Click-to-Run for Office 2010

    to repair the file association so that it opens with Office 2010, you will need to do a repair of Office 2010 from the control panel.

    if not follow the solution section of this KB: http://support.microsoft.com/kb/982426

    Hope that helps you out!

    Wednesday, October 13, 2010 8:01 PM
  • Had a 2003 pre-existing installation, then I installed 2010 to work with the new features. 2003 is still the default for .xls files. I tried the Open With... option, but no dice.
    Wednesday, October 20, 2010 7:40 PM
  • Not true. Had a 2003 pre-existing installation, then I installed 2010 to work with the new features. However, 2003 (installed first) is still the default for .xls files. I'd like for 2010 to be the default for .xls files.
    Wednesday, October 20, 2010 7:42 PM
  • Had a 2003 pre-existing installation, then I installed 2010 to work with the new features. 2003 is still the default for .xls files. I tried the unregserver/regserver option, but no dice.
    Wednesday, October 20, 2010 7:43 PM
  • How can i tell if i have "Click to Run?" because i have  similar problem
    Sunday, November 21, 2010 9:35 PM