none
How to delete conversation history in LYNC 2010

    Question

  • There are recent or miss conversation history under the lync conversation icon All,Missed and Calls.

    When i right click on individual history and try to delete it, it does'nt work.

    May I know how can I delete all this conversation history?

    I had delete all the history in the outlook conversation history folder but in the LYNC it still shows the history.

    Wednesday, February 27, 2013 2:50 AM

Answers

  • There is no easy way to just clear it, what you have to do is disable the function which deletes the information you looking to get rid of. So, from the upper right corner of the Lync client click the drop down arrow next to the gear icon and select > Tools > Options > Personal. Then uncheck the box “save call logs in my email Conversation....". This deletes dialed, received, missed ect. For IM’s there is another check box above the “save call logs” named “Save Instant message conversation in my email Conversation….”, uncheck that as well to remove the history. Same goes for “Activity Feeds”.

    Then click ok and logoff, and then log back in.

    You can then re-enable the function(s) by checking the box again or just leave unchecked if you don’t want the history.

    • Marked as answer by cmy24 Friday, March 01, 2013 3:03 AM
    Thursday, February 28, 2013 3:07 AM
  • hi,

    have you tried deleting lync users's config files stored in  C:\Users\UserName\AppData\Local\Microsoft\Communicator\sip_username@domain.com ?

    regards,



    If this post meets your needs, please Vote/Propose/Mark it. Have a nice day

    • Marked as answer by cmy24 Friday, March 01, 2013 8:40 AM
    Friday, March 01, 2013 4:22 AM
  • Sorry about that, one more step.  Go back to Tools > Options > Personal > look for "Personal Information Manager" and select drop down to "none" and then click ok. Once you do that it removes the pointer to converstion history.


    • Edited by Kevin Fanton Friday, March 01, 2013 4:55 AM
    • Marked as answer by cmy24 Friday, March 01, 2013 7:56 AM
    Friday, March 01, 2013 4:46 AM
  • Hi,

    PLease delete the old history in the Lync client. Right click the history message and click the Delete Conversation.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Sean Xiao
    TechNet Community Support

    • Marked as answer by cmy24 Saturday, March 02, 2013 8:02 AM
    Friday, March 01, 2013 8:08 AM
  • Usually these things are not that hard to do but I now see what you’re saying about right click not deleting. Its an odd issue that I have not seen before. Im only seeing this issue with EWS (Exchange Web Services). I just ran this in my lab and it should do the fix.

    Here is the workaround:

    Log off and exit Lync client.

    You need to get to the AppData folder, but by default its a hidden folder.

    Open Windows explorer by pressing the keyboard shortcut ‘Win+E’. (the Win button has the Windows logo on your keyboard).

    In the Windows explorer, click on Organize on the toolbar and then click on Folder and search options.

    In the folder options window, go to View tab and check the option Show hidden files, folders, and drives under Advanced settings. Click OK.

    That’s it. Now you can able to see all the hidden files and folders in your PC by visiting the location of folder. If your unsure of the steps follow this link http://www.blogtechnika.com/how-to-hide-files-and-folders-and-access-them-in-windows-7/

    Next go to c:\users\username\AppData\Local\Microsoft\Communicator\then open your sip namefolder, and within that folder is a file called EWSFoldersipname@domain.com.cache and right click and delete.

    Login to Lync again, and that should have cleared everything in the cache.

    If you want to turn back on logging just go back to the Lync tools as describe previously and then just recheck the boxes.



    • Edited by Kevin Fanton Friday, March 01, 2013 5:02 PM added link
    • Marked as answer by cmy24 Saturday, March 02, 2013 8:01 AM
    Friday, March 01, 2013 4:32 PM

All replies

  • There is no easy way to just clear it, what you have to do is disable the function which deletes the information you looking to get rid of. So, from the upper right corner of the Lync client click the drop down arrow next to the gear icon and select > Tools > Options > Personal. Then uncheck the box “save call logs in my email Conversation....". This deletes dialed, received, missed ect. For IM’s there is another check box above the “save call logs” named “Save Instant message conversation in my email Conversation….”, uncheck that as well to remove the history. Same goes for “Activity Feeds”.

    Then click ok and logoff, and then log back in.

    You can then re-enable the function(s) by checking the box again or just leave unchecked if you don’t want the history.

    • Marked as answer by cmy24 Friday, March 01, 2013 3:03 AM
    Thursday, February 28, 2013 3:07 AM
  • Hi Kevin, I had try the steps as mention above, after restart all the conversation and calls history is still remain under the conversation TAB......any idea why?
    Friday, March 01, 2013 3:05 AM
  • hi,

    have you tried deleting lync users's config files stored in  C:\Users\UserName\AppData\Local\Microsoft\Communicator\sip_username@domain.com ?

    regards,



    If this post meets your needs, please Vote/Propose/Mark it. Have a nice day

    • Marked as answer by cmy24 Friday, March 01, 2013 8:40 AM
    Friday, March 01, 2013 4:22 AM
  • Sorry about that, one more step.  Go back to Tools > Options > Personal > look for "Personal Information Manager" and select drop down to "none" and then click ok. Once you do that it removes the pointer to converstion history.


    • Edited by Kevin Fanton Friday, March 01, 2013 4:55 AM
    • Marked as answer by cmy24 Friday, March 01, 2013 7:56 AM
    Friday, March 01, 2013 4:46 AM
  • Hi,

    If you do that, the it conversation history would not be stored in the outlook conversation history folder any more.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Sean Xiao
    TechNet Community Support

    Friday, March 01, 2013 7:16 AM
  • Sorry about that, one more step.  Go back to Tools > Options > Personal > look for "Personal Information Manager" and select drop down to "none" and then click ok. Once you do that it removes the pointer to converstion history.



    I had try this but when i change back the personal information manager to microsoft exchange or microsoft outlook again in the conversation TAB still shows back the old history..........
    Friday, March 01, 2013 7:58 AM
  • Hi,

    PLease delete the old history in the Lync client. Right click the history message and click the Delete Conversation.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Sean Xiao
    TechNet Community Support

    • Marked as answer by cmy24 Saturday, March 02, 2013 8:02 AM
    Friday, March 01, 2013 8:08 AM
  • hi,

    have you tried deleting lync users's config files stored in  C:\Users\UserName\AppData\Local\Microsoft\Communicator\sip_username@domain.com ?

    regards,



    If this post meets your needs, please Vote/Propose/Mark it. Have a nice day


    Hi Xilxyu, I am using windows xp 32 bit and i cant find the config file as you mention above........?
    Friday, March 01, 2013 8:41 AM
  • Usually these things are not that hard to do but I now see what you’re saying about right click not deleting. Its an odd issue that I have not seen before. Im only seeing this issue with EWS (Exchange Web Services). I just ran this in my lab and it should do the fix.

    Here is the workaround:

    Log off and exit Lync client.

    You need to get to the AppData folder, but by default its a hidden folder.

    Open Windows explorer by pressing the keyboard shortcut ‘Win+E’. (the Win button has the Windows logo on your keyboard).

    In the Windows explorer, click on Organize on the toolbar and then click on Folder and search options.

    In the folder options window, go to View tab and check the option Show hidden files, folders, and drives under Advanced settings. Click OK.

    That’s it. Now you can able to see all the hidden files and folders in your PC by visiting the location of folder. If your unsure of the steps follow this link http://www.blogtechnika.com/how-to-hide-files-and-folders-and-access-them-in-windows-7/

    Next go to c:\users\username\AppData\Local\Microsoft\Communicator\then open your sip namefolder, and within that folder is a file called EWSFoldersipname@domain.com.cache and right click and delete.

    Login to Lync again, and that should have cleared everything in the cache.

    If you want to turn back on logging just go back to the Lync tools as describe previously and then just recheck the boxes.



    • Edited by Kevin Fanton Friday, March 01, 2013 5:02 PM added link
    • Marked as answer by cmy24 Saturday, March 02, 2013 8:01 AM
    Friday, March 01, 2013 4:32 PM
  • Hi Kevin, under c:\ i can't find the users directory... which windows version you are using?

    Saturday, March 02, 2013 8:01 AM
  • Hi,

    Go to All Programs > Accessories > Command Prompt > do not click on the Command Prompt, what you want to do is just right click on Command prompt > and select “Run as Administrator”.

    Once the command prompt opens type this in and hit enter: attrib -s -h C:\users

    If you still don’t see the users folder check to see if your windows install is on another drive or partition such as d:\

    Saturday, March 02, 2013 8:07 PM