none
Visio 2010 Professional No Database Tab

    Question

  • Hi,

    I have Visio Professional 2010 installed (Version 14.0.5128.5000 64-bit) but I don't see any database option on the ribbon.

    I thought that Visio 2010 Professional let you reverse engineer databases. Is that correct? The help files that I've seen mention going to the "database" menu but I don't see it.

     

    Thanks


    g
    Thursday, December 23, 2010 7:56 PM

Answers

  • Do you see the tab when you go to File/New/Software and Database/Database Model Diagram/Create?

    If you still don't see the Database tab on the ribbon in a new Database Model Diagram go to File/Options/Trust Center/ Trust Center Settings.../Add-ins/Disable all Application Add-ins (may impair functionality) is unchecked.

    • Marked as answer by Croix Monday, December 27, 2010 10:00 PM
    Friday, December 24, 2010 8:57 PM
  • To clarify, make sure that Disable all Application Add-ins (may impair functionality) is unchecked. If it's checked the Database Modeling Diagram solution will not load and you won't get the Database tab on the Ribbon.

    The Database tab should show on the Ribbon at the top of the Visio window when you have a Database Model Diagram drawing loaded in Professional or Premium.

    File|Home|Insert|Design|Data|Review|View|Database

    • Marked as answer by Croix Monday, December 27, 2010 10:00 PM
    Friday, December 24, 2010 9:02 PM

All replies

  • The assumption is that you opened the Data Model Template from the Software and Database section.

    The usual choices include: a. installed without all of the features, b. installed the standard version.

    al

     


    If this answer solves your problem, please check Mark as Answered. If this answer helps, please click the Vote as Helpful button. Al Edlund Visio MVP
    Thursday, December 23, 2010 10:26 PM
  • Do you see the tab when you go to File/New/Software and Database/Database Model Diagram/Create?

    If you still don't see the Database tab on the ribbon in a new Database Model Diagram go to File/Options/Trust Center/ Trust Center Settings.../Add-ins/Disable all Application Add-ins (may impair functionality) is unchecked.

    • Marked as answer by Croix Monday, December 27, 2010 10:00 PM
    Friday, December 24, 2010 8:57 PM
  • To clarify, make sure that Disable all Application Add-ins (may impair functionality) is unchecked. If it's checked the Database Modeling Diagram solution will not load and you won't get the Database tab on the Ribbon.

    The Database tab should show on the Ribbon at the top of the Visio window when you have a Database Model Diagram drawing loaded in Professional or Premium.

    File|Home|Insert|Design|Data|Review|View|Database

    • Marked as answer by Croix Monday, December 27, 2010 10:00 PM
    Friday, December 24, 2010 9:02 PM
  • Thank you Aaron. I did what you said and the "Database" tab showed up.

     


    g
    Monday, December 27, 2010 9:59 PM