none
Excel 2003 - There is a problem sending the command to the program

    Question

  • I'm using Excel 2003 running on Window 7. My problem is very strange. I can only open my excel file when I was in Excel program but not in other application like trying to opening the excel file by double click the filename in  exploxer, lotus email.  Have also go Excel program -> tools- options - general and unchecked the " ignore other applications" but still cannot open my excel file. 

    • Moved by Jennifer ZhanModerator Tuesday, November 16, 2010 7:51 AM (From:Office 2007 Application Compatibility)
    Sunday, November 14, 2010 5:04 AM

Answers

  • Hi,

    This sounds like a problem with the file associations in Windows. The first thing to try is to force Excel to reconstruct all the proper association information. You do that by following these steps:

    1. Make sure that Excel is not running (exit the program).
    2. Click the Start button to displays the Start menu.
    3. From the Start menu, choose Run. Windows displays the Run dialog box.
    4. In the Open box, enter the full path name to your Excel program, followed by the /regserver switch. If the full path name includes spaces, surround the full path name by quote marks. The following is an example of what you can enter in the Open box (your path may be different):

    "c:\Program Files\Microsoft Office\Office\Excel.exe" /regserver

    Click OK.

    If you still cannot double-click on a workbook to open it, try these steps:

    1. Get out of Excel completely.
    2. Open a My Computer window.
    3. Choose Tool | Folder Options. You should see the Folder Options dialog box.
    4. Make sure the File Types tab is displayed.
    5. In the list of registered file types, find and select the entry for XLS (Microsoft Excel Worksheet).
    6. Depending on your version of Windows, click on either the Edit or the Advanced button. You should see the Edit File Type dialog box.
    7. In the list of actions, choose Open.
    8. Click the Edit button. Windows displays the Editing Action dialog box.
    9. The Application Used to Perform Action box contains the actual command line used to start Word. Double-check the line to make sure there are no strange extra filenames at the end of the command line.
    10. Make sure the Use DDE check box is selected, and that the DDE Message box is set to the following:
     [open("%1")]
    

    Click on OK and Close all the other open dialog boxes.

    Tuesday, November 16, 2010 7:50 AM

All replies

  • Hi,

    This sounds like a problem with the file associations in Windows. The first thing to try is to force Excel to reconstruct all the proper association information. You do that by following these steps:

    1. Make sure that Excel is not running (exit the program).
    2. Click the Start button to displays the Start menu.
    3. From the Start menu, choose Run. Windows displays the Run dialog box.
    4. In the Open box, enter the full path name to your Excel program, followed by the /regserver switch. If the full path name includes spaces, surround the full path name by quote marks. The following is an example of what you can enter in the Open box (your path may be different):

    "c:\Program Files\Microsoft Office\Office\Excel.exe" /regserver

    Click OK.

    If you still cannot double-click on a workbook to open it, try these steps:

    1. Get out of Excel completely.
    2. Open a My Computer window.
    3. Choose Tool | Folder Options. You should see the Folder Options dialog box.
    4. Make sure the File Types tab is displayed.
    5. In the list of registered file types, find and select the entry for XLS (Microsoft Excel Worksheet).
    6. Depending on your version of Windows, click on either the Edit or the Advanced button. You should see the Edit File Type dialog box.
    7. In the list of actions, choose Open.
    8. Click the Edit button. Windows displays the Editing Action dialog box.
    9. The Application Used to Perform Action box contains the actual command line used to start Word. Double-check the line to make sure there are no strange extra filenames at the end of the command line.
    10. Make sure the Use DDE check box is selected, and that the DDE Message box is set to the following:
     [open("%1")]
    

    Click on OK and Close all the other open dialog boxes.

    Tuesday, November 16, 2010 7:50 AM
  • I'm sorry but I'm having similar problem with Excel. However just like jaslee00 I'm using Windows 7. And there is not Files Types Tab any more...
    Thursday, September 08, 2011 9:02 AM
  • "C:\Program Files\Microsoft Office\OFFICE11\excel.exe" /regserver

    result:

    One of your object libraries (stdole32.tlb) is missing or dammaged. Please run Setup to install it.

    I dit this

    result is the same

    i'm using Windows 7 and office 2003

    Wednesday, September 14, 2011 4:11 PM
  • On Windows 7 it stops on point4. There is no File Types tab on Windows 7
    Monday, October 10, 2011 11:00 AM
  • Hi,

    I started experiencing the same problem, after re-tracing my steps I realised that a setting i had changed may be causing this.

    Within the Tools>Options>General Tab of excel i had checked the setting 'Ignore other applications' and after this point i could no longer open any other Excel file without receiving the error ' there is a problem sending the command to the program'. The only method for opening excel file from this point was through opening the excel program and using file>open from the tool bar.

    I have now unchecked the 'Ignore other applications' setting and my excel files will now open as normal.

    Hope this information may be of some use.

     

    • Proposed as answer by huxscoder Thursday, June 28, 2012 7:49 AM
    • Unproposed as answer by huxscoder Thursday, June 28, 2012 7:52 AM
    Tuesday, November 08, 2011 8:32 AM
  • Ah!  After months of troubleshooting, this FINALLY worked! Thank you!!!

    Tuesday, September 04, 2012 3:07 PM
  • There is No Option to choose TOOL or folder options in windows 7 after openning My Computer

    also please explain what the regserver bit is as you mention below.

    "c:\Program Files\Microsoft Office\Office\Excel.exe" /regserver

    Wednesday, October 17, 2012 12:51 AM
  • did you ever find a way to get excell 2003 files to open properly in IE7?
    Friday, February 08, 2013 4:51 AM
  • Oh My....GOD BLESS YOU!  After searching the web on and off for two weeks, I found your remedy and it worked for me.  I was ripping my hair out (and my desktop was getting cluttered with documents I did NOT want to save but was forced to in order to read them.  Thank you thank you thank you!

    Monday, June 24, 2013 10:59 PM
  • Resetting the users local profile worked for me.

    After resetting the profile I have opened Excel and removed the tick from 'Ignore other applications'. Re-booted the machine to ensure the change has stuck. This now allows me to open all Excel spreadsheets every time. 



    David Fraser

    Wednesday, August 21, 2013 9:11 AM