none
Cannot remove additional mailbox

    Question

  • I gave myself full access rights to a user's mailbox and did what I needed to do using OWA. But now, in my Outlook I have their mailbox and I can't remove it. Their name does NOT appear in 'open additional mailbox'

    If I remove full access rights on ESM I can't open the mailbox in Outlook, and if I give myself full access rights again I can. But I can't remove or close it. I tried the REGEDIT HKCU edit and so removed the key with the user's name in it and restarted Oulktook. The mailbox added itself while I watched.

    I deleted my Mail profile then added it back using another profile name. The ^$^%$^$ mailbox still appears.

    Any ideas on how to get rid of it?

    Thanks

    Thursday, September 30, 2010 2:30 AM

Answers

  • I too have experienced this issue too, with a lousy resolution.  So far what I've found to work is having to go into ADSIEdit.msc, Domain context, and drill down to the account you wish to be removed from, and look for the "MSExchDelegateListLink" attribute and remove yourself from that list.  The next time you start Outlook 2010, the ghost "additional" mailbox should disappear after a few minutes.

    I am a little disturbed that I would still have access to this other mailbox AFTER I removed the permissions to it, but because of this MSExchDelegateListLink attribute, that I still did.

    If you go to the location in Outlook to Add addition mailboxes, and add one, it seems that you see the rest.  Doesn't help with removing the one you no long have access to.  So, it's hard to say if it's one bug or two, the mailboxPermission PS command exchange uses, doesn't seem to check/clear the MSExchDelegateListLink attribute, and possibly another bug with Outlook not actually listing "Addition Mailboxes" unless you add one, then you see many.

    • Proposed as answer by Korbyn Saturday, October 16, 2010 6:43 PM
    • Marked as answer by TheTrueDrBob Tuesday, October 30, 2012 7:22 PM
    Saturday, October 16, 2010 6:40 PM

All replies

  • Hi,

    What version of Outlook and Exchange server are you using?

    When you try to remove this additional mailbox, do you receive any error messages?
    Also you can refer to following articles to get more information about how to remove exchange server mailbox.
    Remove-Mailbox

    http://technet.microsoft.com/en-us/library/aa995948.aspx

    How to Delete an Exchange Server Mail Box:

    http://www.tech-faq.com/how-to-delete-an-exchange-server-mail-box.html

    Hope that helps.

    • Proposed as answer by stin Tuesday, October 09, 2012 4:40 PM
    Friday, October 01, 2010 5:49 AM
  • I'm running Outlook 2010 x86 and Exchange 2010 SP1.

    The error message when I try and close the mailbox is "This group of folders is associated with an email account. To remove the account click the File tab, and on the Info tab, click Account Settings. Select the email account, then click remove."

    But it's not there!

    I don't wish to delete the mailbox as it belongs to an active user. I simply wish to remove it from my Outlook.

    Friday, October 01, 2010 7:03 PM
  • Hi,

    As the warning indicates, you have to remove the account to remove the folders. Then you can add this account again.

    Tuesday, October 05, 2010 1:19 AM
  • Hi,

    As the warning indicates, you have to remove the account to remove the folders. Then you can add this account again.


    What he is saying, is that there isn't a way to remove the account from Outlook. The accounts in question don't show up in the File > Account Settings > Account Settings > Outlook Profile > More Settings > Advanced.

    I too am having this problem, and so is another admin here. I would be interested to know if you enabled online archive TheTrueDrBob, because we hadn't experienced this problem until we turned on Exchange Archiving on the mailboxes in question.

    Friday, October 15, 2010 7:03 PM
  • I too have experienced this issue too, with a lousy resolution.  So far what I've found to work is having to go into ADSIEdit.msc, Domain context, and drill down to the account you wish to be removed from, and look for the "MSExchDelegateListLink" attribute and remove yourself from that list.  The next time you start Outlook 2010, the ghost "additional" mailbox should disappear after a few minutes.

    I am a little disturbed that I would still have access to this other mailbox AFTER I removed the permissions to it, but because of this MSExchDelegateListLink attribute, that I still did.

    If you go to the location in Outlook to Add addition mailboxes, and add one, it seems that you see the rest.  Doesn't help with removing the one you no long have access to.  So, it's hard to say if it's one bug or two, the mailboxPermission PS command exchange uses, doesn't seem to check/clear the MSExchDelegateListLink attribute, and possibly another bug with Outlook not actually listing "Addition Mailboxes" unless you add one, then you see many.

    • Proposed as answer by Korbyn Saturday, October 16, 2010 6:43 PM
    • Marked as answer by TheTrueDrBob Tuesday, October 30, 2012 7:22 PM
    Saturday, October 16, 2010 6:40 PM
  • I am also seeing this with Outlook 2010 and Exchange 2010 SP1.  The accounts have been removed from the profile settings, yet they still show up in Outlook.  I've deleted profiles, deleted all the files including the .OST files, created new profiles with different names, but whatever I do, when I open the mailbox, the additional account folders are there.

    I also created a profile on a seperate machine with Outlook 2007 and the additional accounts are NOT there.  I need to try this with a seperate machine and Outlook 2010 to be sure, but this seems to be a problem with Outlook 2010 at the client vs in AD/Exchange.

    We do NOT have Exchange Archiving setup on any of our mailboxes.

    Tuesday, October 19, 2010 3:43 AM
  • I also have the same issue with Outlook 2010 and SP1, just tried the adsitedit fix and waiting to see if it it disappears.

     

    Tuesday, October 19, 2010 1:06 PM
  • It worked.

     

    Tuesday, October 19, 2010 2:30 PM
  • I found the following article on this and why it happens. 

    http://www.stevieg.org/2010/08/auto-mapping-shared-mailboxes-in-exchange-2010-sp1-with-outlook-2010/

    It turns out this is a feature according to this article.  In the comments below the article you will see that others still had to go remove themselves from the MSExchDelegateListLink attribute, and we had to do the same.  My question is why, when I remove full mailbox access from the mailbox in question, doesn't the MSExchDelegateListLink attribute get removed? 

    The information here in this thread and in the article I've linked solved this for us.  Fortunately we have few additional mailboxes where users have full mailbox access outside of their own.

    Tuesday, October 19, 2010 4:13 PM
  • Using Exchange 2010 SP1 and 2008 R2 and Outlook 2010 (migrated from exchange 2007 SP2)

    I am facing the same problem

    Problem only appeared after upgrading to Exchange 2010 SP1

    Tried all possible ways to remove additional mailboxes all fruitless 

    i have noticed when editing schema 

    there are no values in this attribute for user

    msExchDelegateListLink

     

    and there are multiple values for following attribute 

    msExchDelegateListBL

     

    and I tried to delete these values but I receive following message 

    "The attribute cannot be modified because it is owned by the system."

    these entries look like 

    msExchDelegateListBL: CN=Jennifer Eder,OU=Reservation,OU=Al-Qouz,OU=Planet,DC=darling,DC=local

    msExchDelegateListBL: CN=Hani Khamis Hamad,OU=Head Office,OU=Planet,DC=darling,DC=local

    msExchDelegateListBL: CN=Zhou Yun,OU=Chinese Inbound,OU=Head Office,OU=Planet,DC=darling,DC=local

    msExchDelegateListBL: CN=Payroll Head Office,OU=Human Resources,OU=Head Office,OU=Planet,DC=darling,DC=local

    msExchDelegateListBL: CN=Jay Kumar,OU=Head Office,OU=Planet,DC=darling,DC=local

    msExchDelegateListBL: CN=sumith,OU=2010-Remove,DC=darling,DC=local

    any solution .......

     

    Wednesday, October 27, 2010 4:17 PM
  • Hopefully you are still mindfull of this thread and reporting it to the powers that be to get this fixed.  I'm seeing this on a number of sites, and I've seen it in several locations and easily reproducable.  I'm pretty sure the manage permission process isn't code to remove the MSExchDelegateListLink or possibly the msExchDelegateListBL (an issue I haven't seen yet)
    • Proposed as answer by Edbert Thursday, September 06, 2012 12:36 PM
    Thursday, November 18, 2010 5:44 AM
  • I have tried the ADSI edit and removed the entry, but I still see the maibox and cannot remove it!

    www.endace.com
    Tuesday, December 21, 2010 6:45 PM
  • I also have exactly the same problem.

    When I add additional mailboxes to my account, I can not get rid of them again. After removing them from the Outlook 2010 Exchange Profile without any error, they add themselves up the Outlook folder list automatically, yet they don't show up in the "open additional maibox" dialogue anymore.

    The ADSIedit stuff explained in this thread worked, though ...  but that can't be the solution.

     

    Ah yes, we are on Exchange 2010 SP1 and Outlook 2010 aswell.

     

    PLEASE MICROSOFT, FIX THIS.

    Wednesday, December 29, 2010 10:43 PM
  • I found an explanation of this here:

     

    http://www.howexchangeworks.com/2010/09/auto-mapping-mailboxes-with-full-access.html

     

    the bug only seems to be, that the attribute MSExchDelegateListLink is _NOT_ removed from the user when I remove full access from that mailbox. So you get that mailbox mapped over and over, even if full access does not exist anymore. Auto-Mapping Mailboxes I have full access rights for is a nice feature, but they should be auto-removed again when full access is removed.

     

    This is what needs to be fixed by Microsoft in an upcoming patch. Please someone of MS reply to this.

    Wednesday, December 29, 2010 10:52 PM
  • What a crock.. I have the same issue.   Waiting for a fix without having to jump through hoops.   If I did not manually add the accounts, DO NOT add them for me.  Being an admin, I have access to multiple accounts, yet I only actively want to see one or two.   This is NOT a feature Microsoft, this is a FAILURE or PITA
    Friday, December 31, 2010 12:31 AM
  • Im having the same issue as everyone in here but identical to Abdul Jaleel Maliks issue. I have no one in the list but many in the listBL. When I try to remove them, I get the "Cannot be modified because its owned by the system" error message. I have done these tow things to try to get rid of that error:

    ------

    In HKEY_LOCAL_MACHINE\System \CurrentControlSet\Services\NTDS\Parameters, create the following value:
    Value name: Allow System Only Change
    Data type: REG_DWORD
    Value data: 1
    Then close the registry and now you should be able to modify through ADSIEDIT .

    ------

    this did not work. I also tried this:

    ------

    Login as a member of Schema Admins (preferably on the Schema Master FSMO)
    Launch LDP.EXE
    Connect to the Schema Master FSMO using LDP.EXE
    Bind to the Schema Master using an account with Schema Admin permissions.
    From the Browse menu, choose Modify
    In the Modify dialog box, leave the DN field blank, and type schemaUpgradeInProgress in the Attribute field. In the Value field, enter the number 1. Click the Enter button, then click the Run button.
    Close the Modify dialog box.
    Launch ADSIEDIT.MSC and modify the mAPIID values for the necessary attributes . (You may need to wait for the Active Directory to replicate.)
    Run LDP again, and change the value of schemaUpgradeInProgress from 1 to 0.
    From the Active Directory Schema console, right click on the console and choose "Reload the Schema"

    ------

    During this, i tired to edit the values of the ListBL attribute and it gave a database error and the a schema error.

    Any thoughts on this would be greatly appreciated

    Wednesday, January 05, 2011 2:04 PM
  • This worked for me...same problem.

    I was using Outlook 2007 and Exchange 2010 SP1

    Sorry I should be more clear.  Korbyn's solution of editing the MSExchDelegateListLink attribute worked to resolve this issue.

    • Proposed as answer by Gene Lawin Tuesday, January 11, 2011 5:21 AM
    Tuesday, January 11, 2011 5:21 AM
  • I have tried the ADSI edit and removed the entry, but I still see the maibox and cannot remove it!

    www.endace.com

    I too have used ADSIEdit and looked at both the account in question as well as my own account.  Neither account had an entry (both were <NOT SET> for MSExchDelegateListLink)  The mailbox is still listed in Outlook.  I also tried a new Outlook 2010 profile on a new desktop.  This is using all the latest Outlook 2010 patches as of this writing.  Exchange 2010 is running SP1 RU2.  Can a Microsoft Tech please respond and at least let us know that this is acknowledged and being looked into?  Thanks.

    *UPDATE* Korbyn's solution of editing the MSExchDelegateListLink attribute worked to resolve this issue for me as well.  I was not being patient enough with replication.  Just make sure you first remove your FULL permissions from the mailbox first otherwise, the attribute will change and again add you to the list.  

    Thursday, January 20, 2011 4:42 PM
  • This seems to be a serious issue, MS please work on fixing this ........Lot of users in my organization are complaining about this issue.
    Wednesday, March 30, 2011 10:14 PM
  • Yep I have the same thing happening this is completely un-acceptable using adsiedit is only dangerous and makes absolutely no sense to use it to fix something that should simply be addressed properly.

    We just paid alot of money to upgrade to ex 2010 and server 2008 even had someone from microsoft do the installation to be sure nothing was done wrong.  And now i see this.  Seriously? this is terrible. Think about it this is like mounting all shares automatically that each eser has permission to.  Makes no sense at all.  MS YOU NEED TO FIX THIS.  There isn't anyway im hacking a brand new installation of Exchange.  Fix it properly so that when the mailbox is removed from additonal mailboxes ... it goes AWAY.

    Thank you.

     

     

    Thursday, March 31, 2011 5:36 PM
  • What a great answer -- Helps if you read what the actual issue might be. 
    Tuesday, April 05, 2011 3:29 PM
  • I really cant believe this has been going on for this long. The thread dates back to September. Really? Yep, you guessed it, same problem
    Tuesday, April 05, 2011 3:30 PM
  • MS...Is some one listening ..Is ther any solution for this.
    Tuesday, April 12, 2011 3:39 PM
  • Korbyn

    Your solution worked for me, thanks a lot!


    Valeriy Shevtsov, MCT
    Wednesday, April 13, 2011 1:29 PM
  • No problem.  Steve seems to have found a way to disable the feature, though Ihaven't tried it myself.

    http://www.stevieg.org/2011/02/disable-exchange-2010-sp1s-auto-shared-mailbox-mapping/

    And as far as I can tell, no, MS doesn't appear to be listening, this has been a known issue to us non-MS people since 2010 beta, with no signs or indications that it will be resolved... :(

    Wednesday, April 13, 2011 3:06 PM
  • I read this article and reversed the steps on the Exchange sever. By removing myself from the Full Access Permission field and restarting Outlook fixed the issue for me. No need to mess with ADSIEdit.

    http://www.stevieg.org/2010/08/auto-mapping-shared-mailboxes-in-exchange-2010-sp1-with-outlook-2010/


    - Gymmbo
    • Proposed as answer by gymmbo Friday, May 06, 2011 6:52 PM
    Friday, May 06, 2011 6:52 PM
  • Maybe MS should look to add a setting in Outlook to disable the feature if not wanted.  Perhaps the Office team is more responsive than the Exchange team..?  I have switched to OWA coz Outlook is just too bloody messy with this new feature.
    Monday, June 06, 2011 10:06 PM
  • ok folks, I had the same problem and with a little research was able to remove the setting in ADSI Edit as stated above. I also found this to be a life saver, thankfully MS does such a mapping or we would have been in big trouble. Thank you Microsoft!
    Wednesday, July 06, 2011 5:29 PM
  • Now July 8th 2011 and still no resolution for this? ADSIEDIT and/or registry hacks are not resolutions, they're workarounds. Poor show MS!
    • Proposed as answer by SGB_7 Tuesday, October 30, 2012 9:13 AM
    Friday, July 08, 2011 8:17 AM
  • In Exchange 2010 Service Pack 1 (SP1), Outlook 2007 and Outlook 2010 clients automatically map to any mailbox to which a user has Full Access permissions. If a user is granted Full Access permissions to another user's mailbox or to a shared mailbox, Autodiscover automatically loads all mailboxes to which the user has full access. If the user has full access to a large number of mailboxes, performance issues may occur when starting Outlook. For example, in some Exchange organizations, administrators have full access to all the mailboxes in the organization. In this case, upon starting, Outlook attempts to open all mailboxes in the organization. Users can’t control this behavior and have no way to turn it off.

    http://technet.microsoft.com/en-us/library/bb676551.aspx

     

    Monday, July 25, 2011 1:39 PM
  • Thank you, however, the topic of this discussion, is that AFTER you've removed the permissions, you HAVE to go perform additional cleanup steps, like going into ADSIedit, and clear/clean the "MSExchDelegateListLink" OTHERWISE the user STILL has the other mailbox listed in their Outlook profile and STILL has ACCESS to the mailbox for which you believe you have removed said permissions on.

    A slight security hole, and one that unless a security audit is checking all the MSExchDelegateListLink fields and validating against actual assigned permssions.  And I've been waiting since RC1 for them to fix the powershell so that when full permissions are removed, that the MSExchDelegateListLink field is cleaned up too. 

    As per previous posting, the way to the way to add mailbox permissions without the AutoMap feature can be found in the following article:  http://www.stevieg.org/2011/02/disable-exchange-2010-sp1s-auto-shared-mailbox-mapping/ 

    To quote Steve:  "...this isn't a universally-desired feature,..."

    Monday, July 25, 2011 4:41 PM
  • Deleting the permission from Exchange first and then restarting Outlook fixed the problem for me also. One account required about 30 seconds for it to disappear. Has worked on all the users tried so far.
    Best Regards, Mark
    Tuesday, July 26, 2011 10:28 PM
  • We use the following workaround:

    Scheduling a batch script with the following commands to delete the msExchDelegateListLink attribute from every AD object.:

    adfind.exe -b cn=users,dc=domain,dc=com -f "msExchDelegateListLink=*" -dsq | admod.exe msExchDelegateListLink:-: -safety 50

    or if you're sure

    adfind.exe -b cn=users,dc=domain,dc=com -f "msExchDelegateListLink=*" -dsq | admod.exe msExchDelegateListLink:-: -unsafe

     

    The AD tools you find under

    http://www.joeware.net/freetools/tools/admod/

    http://www.joeware.net/freetools/tools/adfind/

     

    Best regards

    Joerg Maletzky

    Wednesday, August 10, 2011 7:48 PM
  • Korbyn,

     

    Thank you, thank you, thank you.  I have been looking for this solution for months off and on and I've never been able to identify it; but your directions above solved it for me.  You are awesome!!!

    Tuesday, September 06, 2011 6:57 PM
  • Thank you this solved my issue first time and worked well for all 11 accounts I have to correct.
    Steve
    Thursday, September 22, 2011 4:05 AM
  • ... So far what I've found to work is having to go into ADSIEdit.msc, Domain context, and drill down to the account you wish to be removed from, and look for the "MSExchDelegateListLink" attribute and remove yourself from that list.  The next time you start Outlook 2010, the ghost "additional" mailbox should disappear after a few minutes...

    Thanks for this Korbyn. Worked a treat for me.

    Outlook 2010
    Exchange 2010 
    Monday, September 26, 2011 8:00 AM
  • ... So far what I've found to work is having to go into ADSIEdit.msc, Domain context, and drill down to the account you wish to be removed from, and look for the "MSExchDelegateListLink" attribute and remove yourself from that list.  The next time you start Outlook 2010, the ghost "additional" mailbox should disappear after a few minutes...

     

    Thanks for this Korbyn. Worked a treat for me.

    Outlook 2010
    Exchange 2010 

    Wednesday, September 28, 2011 2:02 PM
  • Copy cat   :-)
    • Proposed as answer by Stickett Wednesday, October 12, 2011 8:38 PM
    • Unproposed as answer by Stickett Wednesday, October 12, 2011 8:39 PM
    Wednesday, September 28, 2011 11:53 PM
  • In outlook 2007 this is what worked for me. I first went to exchange management console and removed full access permission for the user in question from that mailbox. Then I opened the outlook profile with the mailboxes that could not be removed and CLICKED THE + SIGN TO THE LEFT OF THE NAME. Once the error message came up that the mailbox is not accessable, outlook removed the mailbox entirely from the profile. I tested this on 4 different mailboxes and it has worked every time. I did close outlook everytime by using the file then go down to exit and wait 5 seconds. Then reopen outlook to remove the next mailbox.

    I hope this helps. Note I did not try this on outlook 2010. It shoud work the same way. We have exchange 2010 Sp1 and I was working with outlook 2007.

    Good luck.

     

     

    Wednesday, October 12, 2011 8:46 PM
  • I can remove additional mailboxes from going into my Exchange Server console and removing access, but I still think this is a very long winded way of doing things, we have around 150 users and we are soon going to migrate them to Win7 Office 2010, I can imagine the amount of calls the helpdesk are going to receive about the amount of mailboxes that appear and are not as easily removed as previous versions.  Disappointing MS are not looking at this...
    Tuesday, November 01, 2011 10:28 AM
  • From an Exchange of view, this (enabling or disabling the additional mailbox centrally) makes complete sense.

    What is wrong is the poor and misleading error message in Outlook 2010. The message MAY be correct for POP3/Imap/etc account configurations, but is NEVER correct for an Exchange configuration.

    So MS please make Outlook a bit smarter. Outlook knows that these user mailboxes are configured by Exchange, and not in the local profile, so throw an error message that give the user correct, helpful information.


    • Edited by John Brits Thursday, November 03, 2011 7:28 PM
    Thursday, November 03, 2011 7:27 PM
  • No problem.  Steve seems to have found a way to disable the feature, though Ihaven't tried it myself.

    http://www.stevieg.org/2011/02/disable-exchange-2010-sp1s-auto-shared-mailbox-mapping/

    And as far as I can tell, no, MS doesn't appear to be listening, this has been a known issue to us non-MS people since 2010 beta, with no signs or indications that it will be resolved... :(


    Thanks Korbyn, this worked for me. What I had was another users Inbox showing in my Outlook. When I checked I was on the Full Access Permissions list for this user, so I removed my entry from the list and then I could remove their Inbox from Outlook via the Account Settings dialog.

    igs

    • Edited by IGS_Support Wednesday, November 23, 2011 2:10 PM
    Wednesday, November 23, 2011 2:10 PM
  • I too have experienced this issue too, with a lousy resolution.  So far what I've found to work is having to go into ADSIEdit.msc, Domain context, and drill down to the account you wish to be removed from, and look for the "MSExchDelegateListLink" attribute and remove yourself from that list.  The next time you start Outlook 2010, the ghost "additional" mailbox should disappear after a few minutes.

    Thank you!  That worked perfectly!

    Environment: Exchange 2010 Standard SP1, Outlook 2010.

    • Proposed as answer by SGB_7 Tuesday, October 30, 2012 9:15 AM
    Tuesday, December 06, 2011 3:32 AM
  • works for me. thanks "Korbyn"

    Exch 2010 SP1 and Outlook 2010 32bit as client.


    • Edited by TSO Wednesday, January 04, 2012 11:02 PM
    Friday, December 09, 2011 9:30 PM
  •  

    The issue has been "Finally" solved in Exchange 2010 SP2

     

    http://technet.microsoft.com/en-us/library/hh529943.aspx

    and

    http://technet.microsoft.com/en-us/library/hh529924.aspx

     

    also for reference ...

     

    Remove-MailboxPermission -Identity jaleel -User 'Malik' -AccessRight FullAccess -InheritanceType All 

    or 

    ADD-MailboxPermission -Identity Jaleel -User 'Malik' -AccessRight FullAccess -InheritanceType All -Automapping $false

     

     


    Abdul Jaleel Malik
    Sunday, December 11, 2011 8:54 AM
  • I disagree that it's been solved in SP2 - at least that's what I've experienced with superficial testing.

    I applied Exch SP2 and the client automap function was still hosed. All was verified correct by drilling down in ADSIedit user attributes as well (good info - thanks to the thread contributors!). I tried from EMC to add and then remove the additional account for good measure. Power Shell also was unable to remove additional boxen with an add followed by remove motion.

    I finally smoked the mail profile on the workstation involved. Now automap doesn't work at all for that machine but additional accounts can be added via Outlook client (Backstage -> Account Setting -> Account Setting -> Change -> More Settings -> Advanced tab -> Add -> interesting box name -> ok -> next -> finish.

    Automap is a groovy feature that still works the majority of the time so I'm happy :-) Just have to use the manual workaround (above client side manual mapping) if needed after adding the required user under EMC "Manage Full Access Permission"

    • Proposed as answer by Dale Lewis Monday, January 30, 2012 10:16 PM
    Monday, January 30, 2012 10:16 PM
  • Thanks Korbyn, this solved the problem.
    • Proposed as answer by Bruce Hewer Tuesday, March 20, 2012 5:20 PM
    • Unproposed as answer by Bruce Hewer Tuesday, March 20, 2012 5:20 PM
    Monday, February 13, 2012 1:57 PM
  • SP2 fixed it removing full access permission This clears the (msExchDelegateListLink) attribute

    Log out and back in and mailbox is gone!!


    Bruce Hewer

    • Proposed as answer by Bruce Hewer Wednesday, March 21, 2012 2:42 PM
    Wednesday, March 21, 2012 2:42 PM
  • I too was having the same problem but it worked in Exchange 2003 the problem started when going to Exchange 2010.  To fix mine I had to remove myself from Full permissions to the mailbox I was viewing, went back to Outlook the mailbox was still there then I did an exit from Outlook restarted Outlook the mailbox was still there but when I clicked on the mailbox it opened then my screen refreshed and it magically disappeared.  So that means everytime I need to view a users mailbox I will have to give Full permissions again, add the account and either go through the above or clear the msExchDelegateListLink to remove it???  Whew MS is really not on my good list with all the issues I am going through with this transistion from Exchange 2003 to Exchange 2010.
    Tuesday, April 10, 2012 5:17 PM
  • Korbyns solution works fine... I had the exact same issue, add users (Prof 2 & 3) for admin purposes to my profile (prof1) - attempt to remove and they are not present in the profile view and cannot be closed or removed from your profile... Delete all profiles from the local disk, and registry and they still appear next time you open outlook.. This is because they are assigned to the mailbox in the back end - open the Exch mailbox (prof1) from another computer with MFCMAPI and you still see them...

    However if you do as Korbyn says and look up these accounts in AD (prof 2 & 3) - and use some attribute level editor such as ADSIEdit - you will see the (prof1) user DN present in the (prof 1 & 2) user accounts under MSExchDelegateListLink attribute - clear from here, reopen outlook and wait 5 (to 30) min - the additional profiles should vanish..

    Thanks Korbyn, this was an annoying problem to have in a secure env..

    However - the very fact these accounts clear themselved from the 'open additional Mailboxes' section seems a bug to me! This worked fine in all previous versions of outlook..

    Wednesday, April 18, 2012 6:21 PM
  • I did have the same issue with Office 365 Exchange Online. I was going to follow Korbyn's advice but stumbled on another solution that does not involve ADSIEdit.msc. This is assuming you are using the 'offline' Outlook program installed on your computer. Here is what I did:

    * Exit Outlook.

    * Remove the access rights through powershell, i.e.
      remove-mailboxpermission -identity [EmailBoxToRemove] -user [EmailBoxToRemoveFrom] -accessRight FullAccess -inheritancetype All

    * Start Outlook and go to File ->Info->Cleanup Tools->Archive. Scroll down to the account from which you removed the access rights and click the arrow to drill down the folders. At that point Outlook will freeze for some 10-30 seconds. When it comes back the account is not listed for archiving anymore. After you cancel out of that dialog box it will also be gone from Outlook.

    I am not sure if this works under all circumstances but it did for me in two cases. I guess Outlook realizes that it does not have the access rights and then removes the link without having to manually do it through ADSIEdit.msc.

    • Proposed as answer by BARBRI Tuesday, June 26, 2012 3:50 PM
    Tuesday, May 22, 2012 4:49 PM
  • This worked perfectly.
    Tuesday, June 26, 2012 3:50 PM
  • Korbyn's fix worked for me as well, thanks for the info!

    I am surprised this bug has existed for so long.  Having access after full access is removed is very dangerous IMO.  This means I will now have to audit AD for other instances where people have access they shouldn't.

    Tuesday, June 26, 2012 5:20 PM
  •  Exchange 2010 using Outlook 2007.

    When removing the mailbox from my account it only changed "Mailbox - username" to "username".

    Thanks Tom WH, removing full access permissions cleared it up for me.  It did take 5-10 minutes to sync.

    Korbyn, I know you say this topic is for after removing permissions but my searching brought me to this thread and without Tom WH's post I would still be searching... or using ADSIedit  to clean MSExchDelegaeListLink...for nothing.

    Thursday, August 09, 2012 5:25 PM
  • [quote]

    So far what I've found to work is having to go into ADSIEdit.msc, Domain context, and drill down to the account you wish to be removed from, and look for the "MSExchDelegateListLink" attribute and remove yourself from that list.  The next time you start Outlook 2010, the ghost "additional" mailbox should disappear after a few minutes.

    [/quote]

    This worked for me, proposed as answer. Removing permissions to the mailbox on Exchange 2010 did NOT fix the problem. I saw the same behavior from Outlook 2007 and Outlook 2010, so it seems to be an AD problem not Exchange or Outlook.

    Thursday, September 06, 2012 12:39 PM
  • Make sure you have removed the datafile as your default data file  Go to File>Account Settings>Datafile and add a different data file as your default data file.
    Thursday, September 06, 2012 6:20 PM
  • Great job with this fix!!! This works all the time!

    Troy Kantner

    Thursday, November 01, 2012 3:35 PM
  • I have made easy to follow userguide for myself , but maybe someone can use this to ease his task : 

    www.note.id.lv/2012/12/cannot-remove-additional-mailbox-in.html


    JanisK Blog

    Wednesday, December 05, 2012 1:39 PM
  • Directly using ADSI Edit to try to solve this issue really is not the way to go.

    This is a feature of Exchange 2010 SP1 (and later) called AutoMapping and this is enabled by default for all mailboxes that you enabled Full Access for (for all newly set Full Access permissions since implementing Exchange 2010 SP1 or later). These mailboxes are added/removed automatically to Outlook via AutoDiscover and are not exposed in the Exchange account configuration in Outlook. Therefor, users cannot automatically remove these mailboxes themselves.

    An administrator can set the automapping property for a specific user on a mailbox to "false" to prevent the mailboxes from being mapped automatically in Outlook. Abdul Jaleel Malik already mentioned this in his reply earlier in this thread.

    For additional info, also see: Can’t remove additional Exchange mailboxes



    Robert Sparnaaij [MVP-Outlook]
    Outlook guides and more: HowTo-Outlook.com
    Outlook Quick Tips: MSOutlook.info

    Wednesday, December 05, 2012 2:23 PM
  • This did not work for me because no mailboxes were in the location.

    Bill

    Wednesday, December 19, 2012 4:15 PM
  • This did not work for me because no mailboxes were in the location.

    Which suggestion did you try and which location are you referring to?


    Robert Sparnaaij [MVP-Outlook]
    Outlook guides and more: HowTo-Outlook.com
    Outlook Quick Tips: MSOutlook.info

    Thursday, December 20, 2012 9:48 AM
  • I have this same issue, but a few complications:

    1) I am not an administrator on the domain or in exchange, so

    2) I don't have access to ADSIedit and can't do anything specifically with AD or exchange

    3) I don't have multiple extra mailboxes, I have multiple instances of the SAME mailbox showing

    4) I need access to the one extra mailbox I'm using, so I can't have rw permissions to it revoked

    So basically I have this showing in outlook:

    [My mailbox]

    [Extra mailbox]

    [Extra mailbox]

    [Extra mailbox]

    Like the original poster in this thread, when I right-click on any of the redundant extra mailboxes and click "close", it tells me that the mailbox is associated with an email account.  But the "open these additional mailboxes" dialog is blank - there are zero entries there.  And in any case, I don't want to close them all - I need to access that mailbox... but I would like to have it show up just once instead of multiple times.

    This is most certainly not a "feature".  This is a bug, and an annoying one at that.  Are there any client-side solutions anyone has found that will remedy this issue?

    Thanks so much in advance for your help!

    Tuesday, January 08, 2013 3:16 PM
  • SOLUTION:

    (this is in Outlook 2010)

    Click on your main exchange account.

    Go to File/Info/Account Settings.

    Select your main Exchange account and click Change.

    Click More Settings in the bottom right corner.

    Select Advanced tab.

    Now you can see your added account(s) and remove them as you wish.

    • Proposed as answer by Jerry_D Tuesday, January 29, 2013 11:38 AM
    Tuesday, January 29, 2013 11:37 AM
  • @Jerry_D
    No, it is not. This topic is about automapped mailboxes and not manually mapped ones.

    Also, don't directly propose your own answers as THE answer. That is not what the system is for.



    Robert Sparnaaij [MVP-Outlook]
    Outlook guides and more: HowTo-Outlook.com
    Outlook Quick Tips: MSOutlook.info

    Wednesday, January 30, 2013 3:29 PM
  • I've seen the same issue at atleast 1 of our customers. I'ts been more than 2 years since the start of this thread and still no fix from Microsoft.... I'm currently in the process of fixing this for 1 customer (again!)....

    Come on Microsoft, show us why we pay you so much money to use the products!

    Tuesday, February 19, 2013 7:47 PM
  • Korbyn:

    Thank you so much for this solution.  It worked just as you described.  The other "solutions"  I found refer to a registry entry that isn't in my registry.  I'm using Office 2013 (x64) on Windows 8 Pro with Media Center (x64) with Exchange 2010 via Small Business Server 2011.

    Would you be able to describe your train-of-thought for finding this solution?


    - Michael Faklis

    Wednesday, April 10, 2013 8:06 PM
  • Directly using ADSI Edit to try to solve this issue really is not the way to go.

    This is a feature of Exchange 2010 SP1 (and later) called AutoMapping and this is enabled by default for all mailboxes that you enabled Full Access for (for all newly set Full Access permissions since implementing Exchange 2010 SP1 or later). These mailboxes are added/removed automatically to Outlook via AutoDiscover and are not exposed in the Exchange account configuration in Outlook. Therefor, users cannot automatically remove these mailboxes themselves.

    An administrator can set the automapping property for a specific user on a mailbox to "false" to prevent the mailboxes from being mapped automatically in Outlook. Abdul Jaleel Malik already mentioned this in his reply earlier in this thread.

    For additional info, also see: Can’t remove additional Exchange mailboxes



    Robert Sparnaaij [MVP-Outlook]
    Outlook guides and more: HowTo-Outlook.com
    Outlook Quick Tips: MSOutlook.info

    I disagree.  Its a bogus "feature" that is annoying.  Instead of being default ON for everyone it should be off and we can turn it on per mailbox if we wish.  As much as people chide using ADSIeedit it often is the only way to fix things.

    Powershell and ESM both stalled when i tried to remove myself from a user's mailbox.  I had to resort to ASDIedit

    Thursday, April 11, 2013 9:32 PM
  • I had the same issue with Outlook 2010 and SBS 2011. In the end, to resolve it I:

    - removed the users permissions to the additional mailbox I'd removed from Outlook. 
    - switched off cache mode in Outlook, and restarted Outlook.
    - switched on cache mode again and restarted Outlook.

    Then the mailboxes disappeared. Didn't touch ASDIedit.

    Thursday, June 13, 2013 1:23 PM
  • Not even sure how my accounts got here, but this answer is dead on.  Thanks!

    Friday, June 28, 2013 3:15 PM
  • Perfect.  Thank you so much.


    Mac MacAnanny - Engineer - DoD - Office of the Secretary of Defense - DoD

    Friday, June 28, 2013 3:17 PM
  • Hi,

    I have resolved today, turned off cached mode, checked mailbox access was removed in exchange, deleted .ost file and restarted outlook.

    Thanks

    Friday, July 05, 2013 7:10 AM
  • You don't need to disable and enable cached mode (requiring the index to rebuild).

    Close Outlook, remove access rights on Exchange server, launch Outlook and expand the extra mailbox; it will disappear.

    • Proposed as answer by Kurt Fritz Tuesday, July 16, 2013 5:06 PM
    Tuesday, July 16, 2013 5:06 PM
  • Thank you.  This was precisely the solution.
    Friday, September 06, 2013 7:02 PM
  • I too have experienced this issue too, with a lousy resolution.  So far what I've found to work is having to go into ADSIEdit.msc, Domain context, and drill down to the account you wish to be removed from, and look for the "MSExchDelegateListLink" attribute and remove yourself from that list.  The next time you start Outlook 2010, the ghost "additional" mailbox should disappear after a few minutes.

    I am a little disturbed that I would still have access to this other mailbox AFTER I removed the permissions to it, but because of this MSExchDelegateListLink attribute, that I still did.

    If you go to the location in Outlook to Add addition mailboxes, and add one, it seems that you see the rest.  Doesn't help with removing the one you no long have access to.  So, it's hard to say if it's one bug or two, the mailboxPermission PS command exchange uses, doesn't seem to check/clear the MSExchDelegateListLink attribute, and possibly another bug with Outlook not actually listing "Addition Mailboxes" unless you add one, then you see many.

    Thanks!, this was the only I found I could fix a stuck mailbox for a user where the mailbox they had been given permission to was now disabled!

    • Proposed as answer by BampaJ Thursday, September 19, 2013 2:57 PM
    • Unproposed as answer by BampaJ Thursday, September 19, 2013 2:57 PM
    Thursday, September 19, 2013 5:43 AM
  • Hi there.

    Try this.  It worked for me.

    Add-MailboxPermission -Identity <shared mailbox alias> -User <your mailbox alias> -AccessRights FullAccess -InheritanceType All -Automapping $false

    http://www.msoutlook.info/question/673

    Thursday, September 19, 2013 2:58 PM
  • Maybe some of you already have posted this, but the easiest way I found is to log in to AD with the Exchange module and find the user you want to delete from your Outlook list.

    In properties you find the Attribute editor tab, and delete your name from the "msExchDelegateListLink".

    Worked for me.

    Roger

    • Proposed as answer by sysmangler Sunday, October 13, 2013 6:01 PM
    Friday, October 04, 2013 8:28 AM
  • I was having the same issue Outlook and Exchange 2010 (which brought me here) but in my case removing myself from the 'full access' permissions from the user in EMC which I had given myself in order to verify a mail receipt issue fixed the problem.  After a few minutes and a close/reopen of outlook the 3 users I was testing disappeared. 


    Monday, March 03, 2014 11:08 PM
  • Thank you for the ADSIEdit tip! Worked perfectly.

    As frustrating as this was, for multiple users at multiple sites, it was a good excuse to get our servers all up to date SP and CU wise ;-)

    Friday, May 16, 2014 4:25 PM
  • Log into your EMC console.

    Recipient Configuration --> Mailbox --> Select the mailbox that still shows up on you local Outlook --> Select Action from the menu at the top --> click Manage Full Access Permission and the wizard will open --> your own account should be in the list so select it and hit the red X --> click OK then Finish

    It might take a few minutes to remove itself from Outlook on your local computer. Might have to close/open Outlook.
    • Edited by RockyMtnHi Wednesday, June 11, 2014 1:46 PM Typo...
    Wednesday, June 11, 2014 1:43 PM
  • My situation is a tad bit different.
    May mail server "fatally" crashed and instead of wasting time bringing it back online, I expedited my already in the works decision to host it.  So my mail server is down.  All domain admins have 2 mailboxes we cannot seem to get rid of no matter what I try.  The msExchDelegateListLink holds none of our names in it.

    Where do you suggest I go from here?  It's quite annoying to say the least!

    Wednesday, August 06, 2014 10:29 PM
  • You Rock, I was working on it for ages with no success.
    Just fixed it doing what you said, such a relief. Thank you.
    Thursday, August 14, 2014 6:48 AM
  • Thank You.
    Thursday, August 14, 2014 6:50 AM