none
Link on page in Internet Explorer won't open Excel file but works in FireFox

    Question

  • After updating to Office 2010, when I click on a link in Internet Explorer that points to an Excel file, the file will not open. Excel opens when I click on the link but the file does not open. I tested the same link using Firefox and it works ok. The company does not use Firefox so that isn't a viable workaround.

    Anyone know what is going on or seen this happen? What to do to fix?
    Thank you,
    Sarah

    Monday, December 27, 2010 10:25 PM

All replies

  • I believe below link will help you solve this problem:

    http://support.microsoft.com/kb/162059


    Thanks and regards, SavindraSingh
    Tuesday, December 28, 2010 8:13 AM
  • Thanks for the quick response. I had tried this and it has no impact. After clicking on the link to an Excel file, Excel opens but the file does not load. Internet explorer is not trying to open the file within itself.

    Sarah

    Tuesday, December 28, 2010 1:34 PM
  • Hi,

    What' the version of OS?

    Some components in IE might be corrupted. Try to repair IE or Windows to recover the corruption.

    Best Regards,

    Sally Tang

    Tuesday, January 04, 2011 7:44 AM
  • I don't believe IE is corrupted. We have the same problem on all computers in our company. And I've tested on both IE7 and IE8. (We are on XP so I can't test IE9).

    Sarah

    Tuesday, January 04, 2011 3:59 PM
  • Hi,

    Try this:

    Let’s try to add the following settings into the registry. Please first click Start, in the Search box, type “notepad” and press Enter.

    Copy the following text in the notepad:

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.xls]

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.xls\OpenWithList]

    "a"="EXCEL.EXE"

    "MRUList"="a"

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.xls\OpenWithProgids]

    "Excel.Sheet.8"=hex(0)

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    Then, click File > Save, save it to your desktop with a name, such as reg.

    Go to the desktop, you can see reg.txt. Right click it and choose “Rename”. Rename it to reg.reg. Click on reg,reg. If you are asked if you want to add the information to your computer, click Yes to add.

    Note: If you are unable to see .txt of the file name, please first show file name extension of the file name.

    Show File name extensions:

    =======================

    1.            In Windows XP: Open “My Computer” or “Windows Explorer”. On the Tools menu, click Folder Options.

    In Windows Vista or Windows 7, click the “Start” peal, in the “Search” box, type “Folder Options” and you can open “Folder Options“.

    2.            Click the “View” tab.

    3.            In the “Advanced settings” box, click to clear the “Hide extensions for known file types” check box. 4.            Click OK.

    Check again if we can open Excel files in IE.

    Friday, January 07, 2011 9:23 AM
  • Hi,

    Try this:

    Let’s try to add the following settings into the registry. Please first click Start, in the Search box, type “notepad” and press Enter.

    Copy the following text in the notepad:

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.xls]

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.xls\OpenWithList]

    "a"="EXCEL.EXE"

    "MRUList"="a"

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.xls\OpenWithProgids]

    "Excel.Sheet.8"=hex(0)

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    Then, click File > Save, save it to your desktop with a name, such as reg.

    Go to the desktop, you can see reg.txt. Right click it and choose “Rename”. Rename it to reg.reg. Click on reg,reg. If you are asked if you want to add the information to your computer, click Yes to add.

    Note: If you are unable to see .txt of the file name, please first show file name extension of the file name.

    Show File name extensions:

    =======================

    1.            In Windows XP: Open “My Computer” or “Windows Explorer”. On the Tools menu, click Folder Options.

    In Windows Vista or Windows 7, click the “Start” peal, in the “Search” box, type “Folder Options” and you can open “Folder Options“.

    2.            Click the “View” tab.

    3.            In the “Advanced settings” box, click to clear the “Hide extensions for known file types” check box. 4.            Click OK.

    Check again if we can open Excel files in IE.


    Needless to mention but to be at safer side please remember to read Microsoft's standard notice while following solutions which includes modifying registry:

    Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

    322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows

    Thanks and regards, SavindraSingh
    Friday, January 07, 2011 9:35 AM
  • I tried the registry edit and confirmed the entries in the registry but this has had no impact. (The file setting were already the same.)I believe my only other option is to contact Mirosoft for support. We need to resolve this issue before we roll out Office 2010 in our environment.

    Thank you all,

    Sarah

    Wednesday, January 12, 2011 2:43 PM
  • Hi Sarah, did you ever find a solution to this? I'm having the exact issue at my company with all computers that have upgraded to Office 2010. I have tried every solution out there with no luck. Any suggestions would be welcomed.

    Thanks, Sarah

    Friday, March 25, 2011 4:38 AM
  • I used the following registry change to resolve. This has worked a bit different on different computers in our environment. Some people now have ability to save the file and then can open it after saving and others are able to open the file direct from the link. The only catch is that they have to enter their ID and password to open the linked file each time (or save the password which we don't ever recommend to our users).

    [HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Internet]
    "BasicAuthLevel"=dword:2

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters]
    "UseBasicAuth"=dword:1

    Hope this helps you!
    Sarah

    Friday, March 25, 2011 6:33 PM
  • Stay out of the registry.

    Add the domain where the files are stored to your Trusted Sites in your Internet Options. (http://intranet.domain.com)

    Monday, January 30, 2012 8:34 PM
  • hi Sarah,

    The solution required login two times in my machine, while i am using IIS basic authenitcation.

    Do you know how to solve this problem.

    Rgds

    Andrew

    Wednesday, May 14, 2014 8:16 AM