none
Word 2007 Compatibility Mode

    Question

  • I have a user, who was migrated to Office 2007.

    When he opens Word 2007, it starts in Compatibility Mode - not in any other mode.
    i.e.: Double-click the Word 2007 Icon

    I have tried the following:

    Going to the Circle>Word Options>Save and selecting Word Document(*.docx)
    Deleting the Normal.dot
    Opening the Normal.dot>Converting it and then saving.
    Opening Regedit and creating the DWORD for CompatMode and setting it to "0".

    Nothing has worked, and when I try:
     Run>winword /a
    or
     Run>winword /w

    It still opens in Compatibility mode.

    This only happens with Microsoft Word 2007; all of the other Office apps open normally.

    I should also note, that when I change the default save type to anything, it defaults back to the *.doc file type.
    Is there a registry setting that I can modify, to change this?

    Also, I've tried to use the Office Repair, and that didn't work.
    i.e.: Start>Control Panel>Add or Remove Programs>Office 2007>Change>Repair


    Wednesday, March 18, 2009 10:33 PM

All replies

  • !Bump!

    Anyone have any ideas why it would default to opening/creating a new document in Compatibility mode!?
    Office 2007 was pushed through Marimba, and it appears that this is the only user having this issue.

    Is reinstalling Office 2007 the only option available?

    Wednesday, March 25, 2009 7:52 PM
  • Recreate the user profile.

    BAX L2
    Monday, October 19, 2009 8:26 PM
  • I'm having the exact same problem, tried everything mentioned above with the same results. I'm a little reluctant to recreate the entire user profile for this one issue. Has anyone else seen this or know of anything else that can be tried?
    Wednesday, November 11, 2009 2:20 PM
  • I too am having the same issue. Does anyone have a resolution?

    Thank you for your help!
    Wednesday, November 18, 2009 3:34 PM
  • i know this is a old threat but it frustrates me that there is no solutioin:

    setting the regkey compatmode in hkey currentuser to 0 solved my problem......

     

    Thursday, July 01, 2010 11:02 AM
  • After rereading at the top, look in your Add/Remove programs and see if you have the MS Office Compatibility pack installed because if you do, you don't need it if you already have the Full version of MS Office 2007 to read older documents.  Where I work, alot of people got their MS Office 2007 before our area did, we got the MS Office Compatibility pack, so that, we could view their Office 2007 documents.  After we received our MS Office 2007 installation, I uninstalled the MS Office Compatibility pack.

    This 2nd reply that I have here is when you open a document from Office 2003 or before and it wants to convert to MS Office 2007.

    I found an answer to that problem, while I was looking around somewhere in Microsoft.  I just tried it and it seems to be working for me: Add to the Registry HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common\Security the following

    NoPromptForRC4Encryption    as a  REG_DWORD with value of 1

    I had to create the Security folder. The NoPromptForRC4Encryption is case sensitive, so watch how you add it in.

    I think I closed out MS Word and reopened it to make certain that it started with this new value.

    The credit goes to Microsoft as I am just relaying something that I had found and done a few hours ago.


    Sparky_Maker
    Sunday, February 20, 2011 10:12 PM
  • Has anyone tried

     

    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\<Office application name>\Security\Crypto\CompatMode  to 0


    Raj
    Thursday, April 28, 2011 7:54 PM