none
How do you turn off subtotals in an Excel 2010 pivot table?

    Question

  • Everytime I add a field to the pivot table, I am having to go into 'Field Settings', on the 'Subtotals & Filters' tab I have to select 'None' under Subtotals (always defaults to 'Automatic').  I would love to find a way to default this field setting to 'None' so that I don't have to repeat this same task for every field I put into the pivot.

    Thanks,
    Greg

    Tuesday, March 20, 2012 6:37 PM

Answers

  • Hi

    You could try selecting the Design Tab, then using the "Do not Show Subtotals" option in the SubTotals dropdown as soon as the PivotTable Field list is displayed for you to drag fields in to their required location.

    Hope this helps


    G North MCT

    • Proposed as answer by VivelYano Wednesday, March 21, 2012 12:36 PM
    • Marked as answer by gch330 Wednesday, March 21, 2012 1:04 PM
    Tuesday, March 20, 2012 8:49 PM

All replies

  • AFAIK, there is no way to change the default. You could run a macro to turn off all subtotals....


    HTH, Bernie

    Tuesday, March 20, 2012 8:02 PM
  • Hi

    You could try selecting the Design Tab, then using the "Do not Show Subtotals" option in the SubTotals dropdown as soon as the PivotTable Field list is displayed for you to drag fields in to their required location.

    Hope this helps


    G North MCT

    • Proposed as answer by VivelYano Wednesday, March 21, 2012 12:36 PM
    • Marked as answer by gch330 Wednesday, March 21, 2012 1:04 PM
    Tuesday, March 20, 2012 8:49 PM
  • Hello,

    I agree with G North. I think "Do not Show Subtotals" option in sub total will do your task more easily rather than writing a macro

    Wednesday, March 21, 2012 12:37 PM