none
excel not responding

    Question

  • When I load excel and go to change tab I get not responding for about 45 seconds.  This only happens with a worksheets with data on it.  On occasion this happens in  outlook too.  I uninstall and reinstall office 2010 home and business. and I change my defalt printer I even tried to remove add on with no change.  I had no problem with the beta verision or office 2007

    Thank You

    Michael Van Brunt

    Monday, October 18, 2010 5:51 PM

Answers

All replies

  • Take a look at this article and see if it does you any good:

    http://oca.microsoft.com/en/windiag.asp

    Have you tried launching Excel in Safe Mode and seeing if the problem persists, if not then it may be an add-in that is causing the problem.  In which case you should disable all add-ins (File, Options, Add-ins...) and then test. 

    Try opening Excel in application safe mode and check if the same issue persists. To open Excel in application safe, click on Start > All Programs > Microsoft Office > Press and hold the ‘Ctrl’ key and click ‘Microsoft Office Excel 2007’. If it works fine in Excel safe mode then disable the add-in(s) for it using the steps given here:
    http://office.microsoft.com/en-us/outlook-help/enable-or-disable-add-ins-in-office-programs-HA010034127.aspx

    As far as Outlook is conserned I would recommend the Outlook forums:

    http://social.answers.microsoft.com/Forums/en-US/category/officeoutlook


    If this answer solves your problem, please check Mark as Answered. If this answer helps, please click the Vote as Helpful button. Cheers, Shane Devenshire
    • Marked as answer by Sally Tang Tuesday, October 19, 2010 6:00 AM
    Monday, October 18, 2010 7:20 PM
  • I had a similar issue using Excel 2007 on Windows 7. The application worked fine for years, but just recently starting locking up with everything I did (Microsoft Excel - not responding...). Doing very simple things such as cut, copy, paste, format painter, etc. would cause Excel to lock up for 15-20 seconds at a pop. Basically, it was completely un-usable.

    I contacted Microsoft where they fixed the problem by first starting the application in safe mode. I was originally opening the file in safe mode by navigating to the file, holding down CTRL and then opening the file. This did not work. The MS technician went to a command window (Run from the start button) and then entered "excel /safe". This brought the entire application up in safe mode. This worked. So, the next step was to go to Devices and Printers and set the default printer to Microsoft XPS Document Writer. After doing this, I can open up the file and application normally without issue. The other piece of this as the other person mentioned was to disable any un-needed add-ins. I happened not to have any.

    Apparently, there are some issues between printer drivers and Excel where the printer (HP for me) is set as the default when opening Excel. The next step will be to uninstall the existing printer drivers and reinstall to see if that completely corrects the problem. Either way, the only "hassle" leaving things as is, is that the printer must be selected directly when going to print, as opposed to having the default show up immediately.

    Jimmy

    Wednesday, December 08, 2010 4:26 AM
  • JimmyJoop, you saved me; I had a very important file start doing this tonight, and as soon as I reset the default printer to the Document Writer, problem solved.  I'm assuming its because the default I had in there was a network printer at work, and I'm working at home on my laptop.....

    Sunday, January 02, 2011 7:33 AM
  • Saved me too Jimmy Joop - thanks a million
    Wednesday, April 13, 2011 4:45 PM
  • Hi, I had exactly the same problem with Excel 2003. I do not know why excel in safe mode was needed, it did not change anything.

    But when I set the default printer from HP to a Brother, it immediatly solved the problem.

    Thank you very much Jimmy Joop!

    Wednesday, August 10, 2011 10:40 AM
  • Many thanks for sharing, changing the default printer made it work, so simple. 
    • Edited by Clearpost Wednesday, November 21, 2012 9:13 PM
    Wednesday, November 21, 2012 9:11 PM
  • Thanks alot, it really nice to share this issue with us, i had a user that had the same problem, and you solved not me :)
    Sunday, January 06, 2013 7:42 AM