none
Default account setting in Outlook 2010 does not work when composing new messages?

    Question

  • Hello,

    I am currently using Outlook 2010 (not beta). I have two accounts, a google imap account and a pop3 account.  I have designated my IMAP account as my default account.  As I understand it, this means that when I create a new email, it should default to being sent from my IMAP account.  However, whenever I create a new email, it defaults to the account which I am currently viewing in Outlook.  In other words, if I am currently viewing the pop3 inbox, when I compose an email, it will default send from that account.  Conversely, when I compose an email while viewing the IMAP inbox, it will default send from that account. 

    Any ideas as to what is going on?  This is rather frustrating because I only rarely send with my pop3 account--only when replying/forwarding email received with that account or other unique situations.  Is there a way to make Outlook be true to sending from the default account, without doing something drastic like disabling the secondary account?

    Thanks in advance.

    Rom

    Tuesday, July 20, 2010 5:59 PM

Answers

  • Dear Rom/all,

    When I first noticed this behaviour I found it a well designed solution. I've used OL2010 with two Exchange accounts and depending of the mailbox I was in it choose the right account to send from.

    So you're right with setting the default account, but Outlook is more intelligent and tries to help you!

     

    With kind regards, Arjan Vos - NL


    VosAJM - Woerden (NL)
    Wednesday, July 21, 2010 6:06 AM
  • So is it only SP1 that's required or did you also have to set the "NewItemsUseDefaultSendingAccount" registry entry as well?  Trying to figure out whether I can turn this loose on the relatives or not, if you know what I mean.

    Thanks,

    Rob


    I have SP1 installed, and am not seeing a change in behavior, so am assuming that it requires both SP1 as well as the registry change, per BorisH above.


    If you only have sp1, mailto and send to commands should use the default (imap) account - but you need the reg key to force outlook to use the default account behavior from older versions.

    I have a link to the reg file at http://www.slipstick.com/outlook/ol2010/default_acct.asp - or export your own to give to family.

     



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    • Marked as answer by Tina_Tian Saturday, July 09, 2011 6:38 AM
    Thursday, July 07, 2011 9:59 PM

All replies

  • Dear Rom/all,

    When I first noticed this behaviour I found it a well designed solution. I've used OL2010 with two Exchange accounts and depending of the mailbox I was in it choose the right account to send from.

    So you're right with setting the default account, but Outlook is more intelligent and tries to help you!

     

    With kind regards, Arjan Vos - NL


    VosAJM - Woerden (NL)
    Wednesday, July 21, 2010 6:06 AM
  • HI Arjan,

    Thanks for the response.  I suppose I'll just have to live with it.  But, at least I know that it isn't a bug.

    Best,

    Rom

    Wednesday, July 21, 2010 5:42 PM
  • With Outlook 2010, this is the intended behavior.  If the account has a separate PST designated for the Inbox, then the default account will be determined by the account associated with the PST.  If multiple accounts use the same PST (such as in the case for multiple POP accounts without separate Inboxes), then the mail account chosen as "default" will be the one used in a new mail message.
    Brian Tillman [MVP-Outlook]
    • Marked as answer by Sally Tang Monday, July 26, 2010 4:12 AM
    • Unmarked as answer by Tina_Tian Saturday, July 09, 2011 6:33 AM
    Thursday, July 22, 2010 5:50 PM
  • This "default account" behaviour is driving me mad, and it's a serious bug in my opinion.

     

    My work account is an IMAP folder, and is set to be default. My home account is a POP3 account and is obviously not the default. When I am in a PST folder (which is where I store a lot of my IMAP mail so as not to use up my server space) and hit "New Email" it ignores my default as being work, and uses my home account.

     

    This has caused countless embarrassing follow-ups from me as I've sent business emails from my home account and no-one recognises the address.

     

    Microsoft, PLEASE PLEASE PLEASE fix this and fix it soon. At the very least, if you insist on calling this a "feature", make it optional. The old way of doing things was much more sensible.

     

    Jeremy

    Saturday, July 24, 2010 5:27 PM
  • Agreed with Jeremy.  I use an IMAP account as my primary at work so that I can keep current emails on the server in case I need to access them outside the office. Once emails are no longer current, they are moved to the "office manager" PST file which includes, in this case, emails received by former holders of my position.  Am I going to have to remove all of these historical email accounts? What if someone with an outdated address book attempts to contact "me" via one of these accounts? 

    What Brian Tilman is really saying is that you can't set an IMAP account as the default account.  This is a huge oversight in my opinion. 

    Monday, July 26, 2010 9:47 PM
  • After writing some emails from the wrong address, I created an Outlook macro that composes an email from the default account. I configured a toolbar button for this macro that replaces the default "new email" button.

    Here ist the code of the macro:

     Dim App As Application
     Dim EmailFolder As MAPIFolder
     Dim NewItem As Object
    
     Set App = CreateObject("Outlook.Application")
     Set EmailFolder = App.GetNamespace("MAPI").GetDefaultFolder(olFolderTasks)
     Set NewItem = EmailFolder.Items.Add("IPM.Note")
     NewItem.Display
    
     Set App = Nothing
     Set EmailFolder = Nothing
     Set NewItem = Nothing
    
    

    Andreas

     

    Tuesday, July 27, 2010 8:43 PM
  • Hi Brian,

    The behavior you describe makes a lot of sense for replying from Exchange accounts. For instance, on my work PC I have two Exchange accounts configured in Outlook 2010 and definitely want the "From" account to be defaulted based on what inbox I'm in.

    But on my home PC I have several IMAP and POP accounts. I have a rule that moves copies of my incoming IMAP emails to my main PST inbox, so that I can keep a local copy of all my mail (so it gets backed up, and so I can freely delete old mails from my online accounts). I usually read all my mail from that main PST inbox. So when I hit new email, I want it to use the default account I have configured.

    Since Outlook allows me to select an IMAP account as a default sending account (it even shows "Send from this account by default" in my email account settings window) but actually picks the first available POP account as the default, it's clearly not working as any reasonable user would expect it to, and therefore it is fair to call this a serious design flaw, if not a bug.

    Sunday, August 15, 2010 5:43 AM
  • I also question whether this is intended behavior, and agree that this functionality change in Outlook 2010 is either a bug or a significant design flaw.

    Something not yet mentioned in this thread is that this change is even more problematic when sending IMAP email while using other non-email Outlook features. That is, I have an IMAP account as my default email account, but, by definition I can't have calendar, contacts, or tasks in the same .pst file as my IMAP email, nor can the IMAP .pst file be the default Outlook data file. So, I use a separate .pst file as the default data file to house my calendar, etc., as well as a few POP email accounts I use infrequently. This setup was never a problem in previous versions of Outlook; if I chose to send an email while viewing my calendar, Outlook correctly automatically used my default IMAP email account.

    Now, in Outlook 2010 with this functionality change, if I choose to send an email while viewing my calendar, the email account automatically chosen is one of the POP emails in the same .pst file as the calendar, and not the IMAP email account that is set as default. So, this means that, whenever I send email while using any of the non-email features of Outlook 2010, I now need to pay attention to which email account is chosen automatically, and then manually change the account each time I send an email.

    I've been using Outlook since Office 97 and have been successfully using multiple email accounts since it was first added as a feature. I see this change as a serious problem; functionality that indicates a default email account should override any other automatic means to select email account, and it worked this way in Outlook 2007.

    Is there an effective way to report bugs to MS? Has anyone tried Andreas's workaround? I'd also like to propose that the correct Answer to this thread is that this functionality change is either a bug or a significant oversight.

    Sunday, August 15, 2010 6:21 PM
  • It's not a bug. It could be considered an oversight in how it works with IMAP (I'm guessing no one at MS thought about it since IMAP support isn't as good as it could be) but the change to using the account assigned to the folder set as default was intentional. Believe me, its a really nice feature once you get used to it, at least when imap is not the primary account.

    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Sunday, August 15, 2010 7:59 PM
  • I think the problem ultimately is less with Outlook 2010 automatically selecting the account to send email from based upon the .pst file a user is currently working in and more with the functionality to set a single email account as the default not working as a user would expect it to.

    That is to say that the former functionality should be true unless a user selects a default email account; in such a case the former functionality should then be overridden and the default always used. For me, this is what it would mean to have the ability to choose a default email account. I obviously can only speak for myself, but it certainly appears that I'm not alone in expecting the selection of default email account to work in this way.

    Sunday, August 15, 2010 8:12 PM
  • Once again Microsoft has to 'think' for everyone and something that has worked for years, in their mind, has to change because some pinhead likes it a different way.  They don't stop to think about the consequences that might happen, only their own narrowly focused solution.

    If some people need the email to be sent from a different account, the easiest solution would be to have a setting in the 'DEFAULT' area that states that emails should be sent from the 'active' account.  Click on the checkbox and everyone that has stated that this is a preferable option would be happy as dung beetles in a cow pasture, AND it would leave the rest of uss alone with it working as it has for years.

    In my training as a certified programmer, we had flexibility and testing drilled into our minds.  It seems like the world has turned into, Do It My Way or No Way! 

    Friday, August 20, 2010 3:20 PM
  • I tried the MACRO suggested by Andreas, but do not get the right account as the Default

    I have 4 accounts setup in Outlook, 3 are POP3 accounts, one being a GMAIL personal account.  My Primary account is my university IMAP account.  In the account settings, I have set the DEFAULT to the IMAP Account.  However, when I run this Macro, it ALWAYS returns my Gmail account as the default.  I have started and restarted Outlook, but same issue occurs.  Even rebooted the machine, but same result.

    Anyone have any thoughts as to why this is happening.  PS.  I can be viewing any of the accounts, but the Macro ALWAYS wants to send from the Gmail account, so for some reason, it appears that Outlook is seeing the Gmail account as the default.

    Thanks for any help or suggestions! --Mickey

     

     

    Friday, August 20, 2010 5:37 PM
  • Andreas,

    Your solution seemed like a good idea and I was able to create and sign the macro and create a custom New Email button.  Main problem is:

    • Can't seem to get the new button to do anything but create a new email with the same old problem - it's not using the account I've set as the default in Account Settings.  In this case the account associated with the main pst file is MAPI (Gmail/Google Apps Sync)

    If I could get it to work correctly then I suppose I could hide the built in New Email item and it would be nice if I could use that icon but it's not shown in the list of icons when I try to rename the new one.

    This is not really for me but is for a relative who prefers Outlook to webmail.  I'm moving him from an @gmail.com account to his own domain but he prefers to send email as if it's from his old @gmail.com account instead of the custom domain.  Strange but true.  I want default to the IMAP account, not the MAPI one.

    Any hints you can give me would be appreciated.  I'm pretty technical but not familiar with VBA or Office Macros. 

    Thanks,

    Rob

    Friday, August 20, 2010 8:56 PM
  • I also wish to use an IMAP account as my default for sending new mail, although I am also connected to an Exchange server. This worked fine with previous versions of Outlook but not with 2010. I can quite understand that the new behaviour (to send from the 'active' folder account) would be useful to some users (once they get used to it...) and have absolutely no problem in this additional functionality being added. What I find annoying is that a) the new functionality has REPLACED the old, rather than being added, and b) the 'send from this account by default' message has not been changed - by any standard, this is completely misleading. To add to that, the change does not seem to be documented. MS should realise that only a small minority of users will ever visit forums like this to investigate their problems; most just give up in despair.

    For those of us affected by this intentional change, it is a pain to work around every hour of our working days. It might be better for some, but it is certainly not better for all. I will certainly be avoiding updating the rest of our office to 2010 for this reason. Please can MS return us our original functionality (as an option is fine) at the soonest opportunity?

    Thursday, September 09, 2010 9:22 AM
  • I FOUND A SOLUTION!  I just removed Outlook 2010 from ALL of my machines (30 total) and reinstalled 2007.  Works GREAT!

    MICROSOFT, GET A HINT! You can't think for everybody!

     

    • Proposed as answer by Brian Milnes Wednesday, October 05, 2011 1:01 PM
    Thursday, September 09, 2010 3:25 PM
  • PTJIan - try the macro listed previously or use a reg hack to force asking for the account all the time - http://www.outlook-tips.net/archives/2010/20100830.htm

     



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Thursday, September 09, 2010 4:11 PM
  • I'd like to better understand the account configuration you have that is causing a problem with this behavior change. Do you have your IMAP + POP accounts set up in one of these configurations?

    Setup #1: Separate stores for all accounts

    • Default store PST (IMAP calendar/contacts/tasks/archived mail are here)
    • IMAP Mail store
    • POP account delivery store

    Setup #2: POP delivers to the default store

    • Default store PST, where POP mail is delivered and IMAP mails are archived
    • IMAP mail store

    If you have a different set up, I'd like to understand that as well.

    We spent a lot of time researching the way customers use multiple e-mail accounts in Outlook and the different patterns across different types of customers. The decision to change the behavior to default to the e-mail account that is delivering into a store is consistent with what we heard from the majority of customers with multiple accounts. They wanted to keep mail from different accounts in physical separate containers, so they didn't risk blending personal & work mail together (or two different work accounts). With the mail from separate accounts in separate stores, they wanted Outlook to use the "right" e-mail account for sending mail when they created a new message or replied to a message, and not always use the same account.

    Thursday, September 09, 2010 4:58 PM
  • Ryan – personally, I use three separate data files:

    1. Default store: POP email delivered here, also contains my calendar, tasks, and contacts

    2. Windows Live Hotmail store: Using the Outlook Hotmail connector, stores email, calendar, etc.

    3. IMAP store: IMAP email delivered here

    I have selected in Account Settings to send email from my IMAP account by default, as I primarily receive email via the other accounts and rarely send with them.

    For me the problem is more so that the functionality to set an email account as default does not work as I expect it to. That is, I expect that if I set an email account as default, this setting will override any other means by which to automatically select an email account when sending new email, and therefore the default account will always be automatically selected when sending new email. This is also how it worked in previous versions of Outlook. As it is now, I’m not sure what purpose setting an email account as default serves if it doesn’t work in this manner.

    In practice, the way Outlook 2010 currently handles this is problematic for me because most of the time I am using Outlook for other things besides email, and as everything else is stored in the default .pst, whenever I choose to send a new email while working with my calendar, etc., Outlook defaults to one of my POP accounts and I have to manually change it to use the IMAP account instead. It’s also a problem when I click on any mailto: link, as in this case Outlook 2010 will always default to send from one of my POP accounts, even if I am viewing a folder in my IMAP store at the time.

    Thanks,

    Tad

    Thursday, September 09, 2010 7:21 PM
  • Let me add my 2 cents to this unmitigated screw up of an outlook feature.  This has caused me to send business email from my personal account one too many times.

    Here's the scenario: I have 2 pst files and one imap account.  One pst is my personal email account and one is my business acount.  The imap account is a shared support account.

    If I'm looking at an email in my personal pst and then later hit ctrl-N to send a business email it goes from my personal account.  I have to carefully pay attention to which email account I am sending from every time I create a new email.   Note that if I send a personal email from my business account it is no big deal, my friends can take that, my customers can't.  That is why I have my business account set up as my default account.

    Please microsoft, make the old outlook 2007 method available.  Worst case give me an option to force me to choose the acount every time.

    This is a disaster.  Am I going to take outlook 2010 back to the shop?

    Monday, September 13, 2010 4:39 PM
  • I have to carefully pay attention to which email account I am sending from every time I create a new email.  

    Until there is a resolution (I'm holding out for a registry key to restore previous behavior for those who prefer it), use the ForceAccountSelection registry value.

    Instructions are at http://www.outlook-tips.net/archives/2010/20100830.htm 


     



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Monday, September 13, 2010 5:14 PM
  • I too am calling this a bug.  "Set as Default" does not function as the user expects. 

    I also question anyone who says that this is what a "majority of users" want.

    http://www.outlookforums.com/showthread.php?69015

    PLEASE M$ = give us a registry fix to get things working right!

    My solution is going to be to install another mail client, set that as the default, so at least my wife and kids when right clicking and sending on items from my desktop dont send it from my WORK ACCOUNT!....   >:(

     

    Tuesday, September 14, 2010 1:35 AM
  • Actually, I understand what is happening now...

    Microsoft has a few lines of code in reverse order... :D

    Mail stores "SOMETIMES" have an email account associated with them.  Therefore if a user is looking at a particualr mail store, a particular email account should be used.  I agree with this functionality - in part (I actually have a custom piece of software that sets the default email based on the folder being viewed... this is a perfect solution... - but also doesn't solve the problem at hand!)

    If the user is looking at a standard PST file, the "Default email address" is used.

    The problem is when a call to create a new message from outside outlook.    In this case, Outlook is first looking at the default mail store - to see if that has an email address associated with it, and it uses that.  If not, outlook uses the default email address.

    From outside outlook, outlook should only look at the default email address, not the default store.  This to me is poor coding...

    Tuesday, September 14, 2010 1:46 AM
  • Ok this is driving me mad. I've sent multiple emails meant for business clients from my personal email. There needs to be an option to turn this new feature off. I worked with outlook for years never had an issue until this started happening. FIX it please!

     

     

    Wednesday, September 15, 2010 4:48 PM
  • Just want Brian to know how much I appreciate Microsoft deciding how I should use the software and them programming it that way for me.  I have so many other decisions to make during the day and this is so helpful by removing this heavy burden from me.

    Guys, you really need to take a hint from all of the backlash that this programming screwup has created.  The worse thing is the arrogance that is displayed by the Microsoft people.  WITH OUTLOOK, THIS IS THE INTENDED BEHAVIOR.  You don't think that people have figured that out.  The problem is that it SHOULDN'T BE THE INTENDED BEHAVIOR!

    You may think that you have the only game in town.  That is what the Republicans and Democrats thought, too, until the Tea Party showed up.  Open Office, for all of it's shortcomings, is out there and you are just frustrating people to the point where they will be willing to use a lesser program for free rather than pay for a program that doesn't work properly or give the user flexibility to set it up the way that they want.

    The main thing is that MICROSOFT GIVES THE APPEARANCE THAT IT DOESN'T LISTEN or that it just plain DOESN'T CARE!  To us, it is one and the same. 

    Wednesday, September 15, 2010 5:20 PM
  • MS listens... that's why Ryan posted earlier. Most people who don't like this feature seem to be using an IMAP account - almost everyone else likes it. I'm hopping for a reg hack that will revent to the old behavior but if it comes about, it will be several months.

    There are currently two solutions - use the ForceAccountSelection registry value or a macro posted earlier. Instructions are at http://www.outlook-tips.net/archives/2010/20100830.htm 

     



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Wednesday, September 15, 2010 6:44 PM
  • 1.) I do agree that MS listens. I hope they fix this issue, I can't see it being all that hard to fix, but we'll see. A simple boolean option isn't hard to implement.

    2.) General statements like "Well almost everyone else likes it" are not helpful.You're generalizing and there is no way you can prove that without an extensive usability study.

    3.) These "solutions" are not solutions, they are work arounds. Which do not make my life any easier, it's not a solution to the problem. But another problem to mitigate the damage of a problem introduced by a poorly thought out feature. However, it does help in preventing a mistake at the cost of poorer usability and user frustration.

     

    Unfortunitly being so ingrained with MS office products I'm forced to use 2010. Otherwise I'd downgrade to 07. "Features" like this should always contain a method for going back to the original way of doing things. I was much happier knowing that my "default" mail account was the default always picked. Then when I needed to send an email from my pop account (which is rare) it was easier for me to remember to switch accounts.

     

    John

    Wednesday, September 15, 2010 7:02 PM
  • Ryan

    I have a slightly different setup. We are a small company and most of our work is representing another, larger company. We have accounts on our own Exchange server and also with the larger company, which we access using IMAP. Incoming IMAP messages are moved to our Exchange Inboxes using an Outlook rule so that they get stored centrally (this also makes the IMAP setup more-or-less invisible to end users). By default, we want to also send messages from the IMAP accounts and this used to work fine. Since 2010 this no longer works and we are confusing customers by sending from unfamiliar addresses which is unacceptable.

    I've tried adding the macro which looks like a useable workaround but it still does not send from the default (IMAP) account, choosing the Exchange account instead.  I am not a programmer but wonder if this is due to having the Exchange mailbox instead of POP3.Can anyone help with this?

    The reg key to request a sending account works but seems a retrograde way to deal with it. I'll repeat that this is serious enough to stop me upgrading further users to 2010 until sorted

    Thursday, September 16, 2010 9:12 AM
  • Worse yet, when sending a web page or link by email, or trying to send a file to a mail recipient, it sends from one of the POP accounts, not the default, which is a gmail IMAP account.  So I have unintentionally sent emails from accounts that I don't want to send from.

    Monday, October 04, 2010 1:55 PM
  • I want to thank everyone for bringing this to our attention. I really appricate everyone sharing their configurations and various needs on this thread. It was useful for us to better understand the expectations of POP and IMAP users and how our change was providing an experience inconsistent with what you expected. We're now investigating for SP1 how we can allow you to restore the "always send from the default account" behavior for users who depend on that functionality.
    • Proposed as answer by Darwa Tuesday, November 30, 2010 12:33 PM
    Wednesday, October 20, 2010 11:23 PM
  • Thanks to Ryan for the update, I hope it can be included in SP1, we look forward to it!
    Friday, October 29, 2010 1:07 PM
  • Or worse, be a programming genius with spare time.  Ratz. Sorry I downloaded this.
    Saturday, October 30, 2010 12:18 AM
  • Thank You!  Please send it NOW!  I don't want to send from my POP, I want to send from my IMAP pobox.com account!
    Saturday, October 30, 2010 12:20 AM
  • I am currently experiencing the same problem.  Outside of Outlook, within Contacts, Calender, etc.  is always using my pop3 account.  The "set as default" is not working.  We need a fix.

     

    Thanks,

    Brent

    Sunday, October 31, 2010 3:11 PM
  • I want to thank everyone for bringing this to our attention. I really appricate everyone sharing their configurations and various needs on this thread. It was useful for us to better understand the expectations of POP and IMAP users and how our change was providing an experience inconsistent with what you expected. We're now investigating for SP1 how we can allow you to restore the "always send from the default account" behavior for users who depend on that functionality.

    Thank you. After receiving a final warning from my boss thanks to this dreadful 'feature' I was very nearly ready to go back to 2007 until I read this.

    I don't suppose you have an ETA, do you?

    Tuesday, November 30, 2010 12:32 PM
  • I don't suppose you have an ETA, do you?


    SP1 should be available sometime in the Spring, possibly late Winter (Feb to May).  

    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Tuesday, November 30, 2010 12:39 PM
  • Add me to the list of frustrated users and "Default Account" not working as expected.

    I've got 4 accounts in my client.  1 Exchange, 3 POP.  To be honest, just when I think "ah ha, that's what it's doing", a little later it does something completely different when selecting the "from" address.

    As mentioned by others, this has caused some embarassment in sending emails to folks from "one of my other accounts" instead of the default.

    As someone who's been in IT for 15 years, if this is "how it was designed and supposed to work", then those developers should be canned pronto.  I've never heard of a customer clamour for "this feature"....and this feature doesn't even work.

    Has anyone found a solution through a reghack?

    Dustin
    www.intellivise.net

     

    Saturday, December 04, 2010 1:08 PM
  • Monday, December 06, 2010 10:36 PM
  • I want to thank everyone for bringing this to our attention. I really appricate everyone sharing their configurations and various needs on this thread. It was useful for us to better understand the expectations of POP and IMAP users and how our change was providing an experience inconsistent with what you expected. We're now investigating for SP1 how we can allow you to restore the "always send from the default account" behavior for users who depend on that functionality.

    Any chance we can get a hotfix before SP1? 
    Wednesday, January 19, 2011 11:04 PM
  • I want to add my voice to the chorus of dismayed Outlook 2010 users here. I, too, have sent too many emails out USING THE WRONG account. Why does this not work the same way it did in Outlook 2007? Please, please, please issue a hotfix to resolve this issue! It's simple: if we choose one account as the default account, then that account should actually be the default account!

    Thank you!

    Wednesday, January 26, 2011 4:24 PM
  • Add me to the long & apparently growing list of displeased OL2010 users with the default account BUG -  and it is a BUG.  I right click on a file that I wish to send to "MAIL RECIPIENT" and it no longer is sent via my default email account, (POP),  but rather my secondary, (Exchange), Account.  Unacceptable..  Uninstalled and back to OL2007.
    Thursday, January 27, 2011 10:33 PM
  • Let me add my 2 cents to this unmitigated screw up of an outlook feature.  This has caused me to send business email from my personal account one too many times.

    Here's the scenario: I have 2 pst files and one imap account.  One pst is my personal email account and one is my business acount.  The imap account is a shared support account.

    If I'm looking at an email in my personal pst and then later hit ctrl-N to send a business email it goes from my personal account.  I have to carefully pay attention to which email account I am sending from every time I create a new email.   Note that if I send a personal email from my business account it is no big deal, my friends can take that, my customers can't.  That is why I have my business account set up as my default account.

    Please microsoft, make the old outlook 2007 method available.  Worst case give me an option to force me to choose the acount every time.

    This is a disaster.  Am I going to take outlook 2010 back to the shop?

    this is exactly the same my situation. I hope that with SP1 we will have the option to work as with the 2007
    Friday, February 04, 2011 1:50 PM
  • Is there any word on when we can have a fix for this? This thread has been open for 7 months with no official solution.
    Friday, February 04, 2011 7:15 PM
  • Is there any word on when we can have a fix for this? This thread has been open for 7 months with no official solution.

    None yet, but i sent a reminder to them last night (with a link to this thread).

    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Saturday, February 05, 2011 1:27 AM
  • My main issue with this "bug" is that the "mailto:" protocol is handled incorrectly. So I too am hoping for SP1 to be released soon.

    When I use external programs or websites which contain mailto-links to create a new mail message, Outlook 2010 does not use my default IMAP mail account. Instead, Outlook uses the first POP-account it encounters down the list of my mail accounts.

    In the meantime, here's what I did to work around this problem:

    • I created an extra account, which is nothing more than a POP-version of my default IMAP account. I configured it with a real SMTP-server, so I can send mail via this account. For the POP-server, I entered a dummy name ('mail'). I also checked this extra account uses the default PST data file (outlook.pst in my case), not a new PST file.
    • I ensured that this POP-account is the first POP account which appears in my list of mail accounts (When an account is newly created, it is added to the end of the account list. Therefore, I had to move the account up, using the little up-arrow icon which appears at the top-right of the account list, to make it the very first POP-account in the account list).
    • Then, I went to Define Send/Receive Groups, and configured this POP-account to not receive mail. I did this so that this account would not pull in messages via POP, but only via its IMAP.
    This way, whenever an external program or website wants to send a new mail message, it now uses the POP-version of my default IMAP account.

    This is not a perfect solution however, since the messages sent via the extra POP-account do not auomatically appear in my IMAP sent items folder. Therefore, I still want Microsoft to fix the underlying issue.

     

    • Edited by Vowani Friday, February 11, 2011 9:31 AM
    Thursday, February 10, 2011 11:01 AM
  • I recommend using a fake POP account so it can't download mail accidently (you'll still need to edit the S/R settings so it doesn't try to check the fake server) - use mail as the pop server name. (Instructions and screenshots are at http://www.slipstick.com/outlook/ol2010/default_acct.asp

    At this time, this might be the only solution - I'm not holding my breath that its going to be in SP1 as its not in the version released to external testers.



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Thursday, February 10, 2011 3:29 PM
  • I recommend using a fake POP account so it can't download mail accidently (you'll still need to edit the S/R settings so it doesn't try to check the fake server) - use mail as the pop server name. (Instructions and screenshots are at http://www.slipstick.com/outlook/ol2010/default_acct.asp

    At this time, this might be the only solution - I'm not holding my breath that its going to be in SP1 as its not in the version released to external testers.



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Really Diane?  They aren't even fixing this in SP1??
    Thursday, February 10, 2011 3:37 PM
  • Really Diane?  They aren't even fixing this in SP1??


    I don't know, it may be something that didn't make it into the testers code (it is fairly old code). Because they haven't said it will be fixed, i'm not going to be looking for it. Its better to be pleasantly surprised that they did it than it is to be expecting something they aren't going to deliver. :)  I have meetings with the team at the beginning of March and will find out then - this issue is at the top of my list of things to discuss.

    ETA: if we assume they are fixing it in SP1, people who find this thread think its going to be fixed, so they don't comment then MS thinks its not a big deal and it gets pushed aside. But if we assume its not going to be fixed and keep the issue alive with more people sharing their frustration, we stand a better chance of getting it fixed, if not in sp1, then in a later update.  For this reason, until there is comfirmation from a trusted contact that a fix is in the works and if it will be in SP1 or a later update, I'm going to assume its not being fixed yet.


     


    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Thursday, February 10, 2011 3:53 PM
  • Make it a setting. User must be in charge. I don't like the new 'intended behavior' which many users do not intend.
    Friday, February 11, 2011 3:10 PM
  • Please keep after them, Diane.  The need is not lessening, but rather people are getting disgusted with waiting, and are uninstalling Outlook 2010 and reverting to Outlook 2007.  Our office has a slightly different setup that those listed here.  We have an Exchange Server, but we are not using it for email, which is handled with POP accounts.  We obviously have the POP accounts set as default, but when opening a new email window, the default is the Exchange Server.  We can manually change that, but the problem really comes when sending something from inside another program.  It generates a "mail to", and automatically sends the email, and as there is no chance to change the sending account, the email fails.  We've tried several workarounds, but they are quite burdensome.  This has become a major problem for several people in the office, and I'm reverting them to Outlook 2007.  Until and unless we get a solution that positively allows us to send from the account we've set as the default, they will just remain on Outlook 2007.
    Tuesday, February 15, 2011 7:14 AM
  • I am in agreement with all of the disgruntled Outlook 2010 users. I didn't like the change in Office 2007 that required mail-merge e-mails to be sent from Word rather than from within Outlook, but I've gotten used to it. However, now with this paternalistic feature of Office 2010, the mail-merge e-mails that I've sent in the past couple of weeks have been sent via my personal Yahoo! account (set as POP3) rather than my work e-mail account (an IMAP account).

    Microsoft - please fix this and fix it soon. If I did not want the ability to customize and choose my own preferences and features, I would have bought a MAC... if Microsoft is going to insist on making the PC experience more like the MAC experience, they will lose supporters. If Microsoft thinks for some reason that they are losing market share to Apple and are thus trying to design their programs to be more like Apple's programs, I believe they are sorely mistaken. Most of us who are true to the PC platform do not like the proprietary and paternalistic way Apple approaches its users with a "we know what's best for you" attitude. Granted there are a number of people out there who like to be spoonfed the crap that Apple provides for them, but I'm not one of those people, and there are many more out there who share my views.

    Microsoft - do what's right. Restore user control for this feature in Outlook 2010, and stop trying to think for us! You can add features you think people may like, but make them optional. That's all we ask.

    Thank you!

    Monday, February 21, 2011 8:41 PM
  • I just upgraded to OL 2010 on two machines over the last couple of days and I thought I was going crazy until I saw this thread and other like it.

    I have the same problem. I have two IMAP accounts and two POP accounts, with one of the IMAP accounts set as the "default", although that setting appears meaningless now. The help file says "By default, e-mail is sent by using the account that you designate as the default in the Microsoft Office Backstage view." This is clearly not the case.

    I understand the thinking behind the change, and I can see how it would lead to less need to change the From account. My wife and I share the same profile, so it would probably be a good thing, actually, for the From account to automatically change to hers when she's look at her folders. But, there are two big problems:

    1) "mailto:" entries on web pages and the Send to command in other applications (including Explorer) - these need to resect the default account setting; and

    2) When looking at calendars, contacts, etc. These are associated with a PST out of necessity, but if it's a PST I don't use for mail then new messages initiated when looking at those should respect the default account setting too.

    So, my ideal solution, actually, would not be a complete revertion to the 2007 behavior (though that would be preferable to the current 2010 behaviour). Rather, I would prefer that Outlook retain some of the new behaviour - if I'm looking in a mail folder, by all means send from the account associated with that folder. But if I'm looking at a calendar, in contacts, and especially for mailto links and Send to commands, please, for the love of all that is good, respect the default account setting!

    Chad

    Saturday, February 26, 2011 7:46 AM
  • P.S., I just tried this on my laptop, which has a simpler configuration: It has only two IMAP accounts configured, with no POP accounts. In that case is behaves as you would expect: New emails from within Outlook when looking at the calendar, etc. use the default IMAP account, and Send-to commands from outside Outlook use the default IMAP account also. (And of course if you're looking in the IMAP mailbox that isn't the default one, then clicking New Message uses that non-default account, which, as I indicated above, is fine with me and is actually a sensible change, though perhaps it should be governed by a user-settable option for those people who nearly always want to send from one account only.)

    So it's only when there is a POP account in the mix that Outlook ignores the default selection entirely. The more I look at it, the more this seems like a defect ("bug"), even within the framework of their new design choice.

    On my main machine (with the mix of POP and IMAP accounts) I've implemented the dummy POP account workaround in the meantime so that the default account chosen by Outlook is not an offensive one. This works fine.

    Saturday, February 26, 2011 8:18 AM
  • I think that Microsoft should know better.

    I have the same issue with an exchange setup at my work. No IMAP email is in place. We have a global inbox for our technical support helpdesk (which I have access/visibility on) and I have my own email address. If I send a new email it uses my own email and puts my name/email in the from field. If I send a new email or forward an email from the tech support group inbox it sends from that email address and not mine. Arghhhhh

    Microsoft should allow user choice for something like this as this is a very important feature. How they came to the conclusion that this could be changed and removed entirely is beyond me. Schoolboy stuff IMO

    I am hoping that SP1 does indeed address this issue but I am guessing it will slip the net, Office 2011 will be released and users will be forced to buy that instead, allbeit at a slightly reduced cost or something.

    Please Microsoft sort this out!

    Friday, March 04, 2011 12:47 PM
  • They are working on it...  a big hotfix came out at the end of Feb (http://support.microsoft.com/kb/2475877) - I don't see it in the list (& haven't tested the hotfix yet) so its probably at least one month away. The hotfixes are often released at the end of each month, so just keep an eye out for them. (I have a list of recent articles at http://www.slipstick.com/rss/kbrss.asp#OL2010)

    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Friday, March 04, 2011 2:07 PM
  • Yes, I was recently contacted personally by a member of the Outlook team (gasp!) to inform me that they have "definitely heard feedback about this issue through various channels and [they're] considering it for the 2010 Service Pack which will be in the first half of this year".

    It seems to me that they have to figure out how to please everyone, which is always hard. As I noted above, the new behaviour that ignores the default account setting even for mailto links and Send To commands is clearly problematic. On the other hand, many people (including me) probably like that it defaults to the account associated with the mailbox you're currently working in. But many people in situations like Mr_E_Tech will not like this behaviour. And another grey area is with respect to what to do when the user is looking at a calendar or contacts (or notes or tasks) that are nominally associated with a POP account that may not actually be used for email. I don't want Outlook to use that email account, but some people might.

    So, to me, "we're considering it" means they're not sure the best way to solve it without undue complex configurability.

    My ideal behaviour is this: Send email from the email account associated with the email folder I'm currently working in, but use the default account if I'm looking at a calendar, contacts, etc., and for all mailto and Send To actions. But I know even this won't please everybody, so some new kind of configurability is going to be needed.

    Friday, March 04, 2011 2:33 PM
  • Surely they can just include some additional user preferences. A few tick boxes here and there and voila! Everyone is happy
    Friday, March 04, 2011 3:22 PM
  • My ideal behaviour is this: Send email from the email account associated with the email folder I'm currently working in, but use the default account if I'm looking at a calendar, contacts, etc., and for all mailto and Send To actions. But I know even this won't please everybody, so some new kind of configurability is going to be needed.

    That would be my recommendation too, for the most part. But... i have 3 exchange accounts on 3 servers and i mostly want things in the calendar/contacts of the exchange account I'm viewing. All mailto/sendto actions should use the account identified as default - and this is where most people have problems - so just honoring the default account setting when initiating mail outside of outlook would solve many of the problems.

    My best guess is the option will either be to keep the current behavior or use a 'classic' default behavior. Adding too many options invites more bugs and goofy behavior, so its best to keep it simple.



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Friday, March 04, 2011 5:05 PM
  • As long as they include the "All Mail from this email address" option ... I'll be happy.
    Friday, March 04, 2011 5:32 PM
  • I would have thought an option to set either 'current working folder' account or a fixed account as default for sending should fix it.

    Please keep pressure on though. I was expecting a fix at SP1 and planning future Office 2010 deployment around that. Looks like that will have to be delayed further!

    Tuesday, March 08, 2011 9:08 AM
  • Hi Diane!

    This is an amazingly circular and verbose thread to me! Hope you and other MVPs can point out a clear bug.

    I'm with the rest of the gang here. Mail Merge in Word is now USELESS to me because I can't set which account sends my email. External email default is the issue. We want clear instructions, from Microsoft, on how to send from a specific account in our account list. (i.e. put it in the help system, then we know it is a design feature)

    Let's look at app behavior

    1) I see that default DATA FILE is what is used for sending mail. This is a disaster because we don't want to have to mess up ourcalendars and everything else every time we need to set which account email is sent from

    (worst: changing default DATA FILE destroys my Favorites. Could a "desired feature" be destroying my favorites every time I need to set which account I want to mailmerge from?)

    2) What does DEFAULT in EMAIL account list do? It seems to do nothing.

    So BUG #1 is that one must change their receive data file and calendars to set send mail acct.

    #2 is that a setting in email accounts does nothing.

     

    Sunday, March 13, 2011 8:12 PM
  • I  believe SP1 will address these issues. No ETA for it yet, other than sometime this spring.

    In the meantime, for IMAP accounts, create a fake POP3 account and use the IMAP's SMTP - "deliver" it to the default pst file and set it as the default.

    For Exchange and other accounts - copy the profile and remove the other accounts from the copy, then switch profiles before mail merging.



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Sunday, March 13, 2011 9:54 PM
  • Yep, for IMAP accounts that workaround works well for externally-generated emails.
    Monday, March 14, 2011 1:32 AM
  • This is unbelievable. If I look at this whole thread that started in July 2010 and now we are April 2011 and see that Microsoft has done nothing about this makes me really frustrated.
    I use a PST to manage my work and private email. With 2007 I could receive both work email that comes from exchange and private email that comes from several pop and IMAP accounts to be delivered to the same PST file. (The default PST account in account settings).

    Besides that I could also choose which is my default sending account (which is the exchange - work by choosing the default account).

    In 2010 those both settings still exist, however they are there for esthetics looks and don't do anything anymore.

    Now with 2010 Microsoft has re-invented the square wheel and thinks that is the best invention of the century.

    Now all email from exchange cannot be delivered to a PST file any more and a default send account cannot be chosen anymore. The work-around people suggest really don't make me too excited. 

    So after purchasing 2010 and installing it for less then 1 hour I decide to remove it again and probably wait a couple of years when Microsoft decide that probably the square wheel was not the best choice ...

    Enjoy trying to convince Microsoft .....

    Goegoe

     

    Thursday, April 07, 2011 9:41 PM
  • This sounds like a good solution, but alas I am not familiar with VB for Apps stuff.  I have the VBA editor open now and have punched the code in, but I guess I either need to do some more research on where to go from here, but also I am trying to figure out what this code means so that I may edit it to work in my situation.  Any help on this front would be great.  In the meantime I'm gonna try to read up on these commands.  Thanks for the work.  
    Monday, April 11, 2011 10:05 PM
  • This sounds like a good solution, but alas I am not familiar with VB for Apps stuff.  I have the VBA editor open now and have punched the code in, but I guess I either need to do some more research on where to go from here, but also I am trying to figure out what this code means so that I may edit it to work in my situation.  Any help on this front would be great.  In the meantime I'm gonna try to read up on these commands.  Thanks for the work.  


    is it something that can wait a few weeks - until we see if its in SP1? I'm not sure when its due out or if this will be fixed in it (or in a update later this spring/summer), but i know they are working on a solution.

    Which macro are you using? I have instructions at http://www.slipstick.com/outlook/ol2010/default_acct.asp for two different ones (always use default or always use a specific account) - although there really isn't much configuring to do. The code should "just work".

    What exactly happens when you try? Do you have macros enabled? By default, outlook's macro security blocks unsigned macros.



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Monday, April 11, 2011 10:37 PM
  • Hello,

    i see this discussion in my search for the problem i have since yesterday. My problem is related to this discussion.  I read abouth the fact that this outlook 2010 behaviour is intensional.  But I see some random behaviour.  I explain.  4 weeks ago I set up a new computer with outlook 2010 i used the same setup as on my old outlook 2007. I have 2 accounts: ACCOUNT1, an IMAP/Exchange account which is the default account and ACCOUNT2, which is a POP3 account.  However i have only 1 Data file which is the ost file from the IMAP my POP3 mails also reside in this file. After setup everything worked as expected, New mails, reply's and forward's where al send from my ACCOUNT1/IMAP Default account.  Until Yesterday, i had to change a setting on my POP3 account, (To keep The mail 5 days on the server) and after that change the behaviour of outlook 2010 also changed.  Now a new mail uses the FROM my default ACCOUNT1/IMAP, the reply and forward uses my account2 POP3 which is not the default, and also has not a PST file?  Does anyone know how i can change that again?  Is this the normal behaviour for outlook 2010?

    Kind Regards,

    Pascal

    (Sorry for my English)

     


    Wednesday, April 20, 2011 9:57 AM
  • What folder are you in when you start a new message? Outlook uses the account assigned to that folder as the From account for new mail and replies and forwards always come from the account that downloaded the message. If the mail is downloaded by POP3, POP3 will reply. If you want the Reply address to be another account you either need to change the From account or, if you want all mail to be replied from using a specific address, change the From field and outgoing server on the Account settings.

    Are you using IMAP protocol to Exchange server or the native Exchange format?

    Is the POP3 mail delivered to the Exchange Inbox?



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Wednesday, April 20, 2011 12:07 PM
  • I only have one folder which is the IMAP connected to the exchange server. The incomming POP3 mails are also delivered to that folder.  Therfore i find it strange, when i write a new mail it is send from the IMAP account, and i checked it out: for the incomming mails it doesn's matter how they came in through POP3 or IMAP the reply and forward always use the POP3, unless i change the from field (which shows my PO3 as default)

    Kind regards,

     

    Pascal

     

    Wednesday, April 20, 2011 2:44 PM
  • Are you using any of the solutions listed at http://www.slipstick.com/outlook/ol2010/default_acct.asp to set the sending account?

    Add the E-mail Account field to the view and see which account is actually downloading the message.



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Wednesday, April 20, 2011 4:35 PM
  • I'm glad someone else pointed out this issue.  This thread is mainly focusing on defaults for emails, but the mail-to issue (as well as default from address on calendar invites) are equally problematic!

     

    Thursday, April 28, 2011 7:31 PM
  • I've read most of this thread, but still have a problem.

    I have outlook set up to read mail from three POP3 accounts.  I'll call them A, B  and C.  All three accounts use the same PST file.  A is set as the default, but each time I compose a new e-mail the sending address is set to B.  This is not the way that any older version of Outlook worked, going back at least as far as Outlook 97, and perhaps Outlook 95.  To make this even more strange, A is at the top of the account pick list as it should be because it is the default account, but Outlook chooses the second account in the list, B, instead of the first.

    How can I get this fixed?

    Vic Roberts




    Sunday, May 15, 2011 10:27 PM
  • Here is the fix for most of us.   Worked for me.

     http://support.microsoft.com/kb/2547227/en-us

    Make sure you setup the registry key too.

    -Lee

    Tuesday, June 21, 2011 1:33 PM
  • I am running win 7 64 bit with office 2010 32 bit.

    I get an error from the hotffix that my coomputer does not have the program.

     

    Any ideas?

    Thursday, June 23, 2011 5:09 PM
  • which office suite do you have installed?

    Did you choose the x86 version of the patch?



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    • Proposed as answer by philbill Thursday, June 23, 2011 8:11 PM
    Thursday, June 23, 2011 6:23 PM
  • Ms. Pormsky,

     

    I did miss the fact that the link:

     

    http://support.microsoft.com/hotfix/KBHotfix.aspx?kbnum=2547227&kbln=en-us

     

    has the x64 as the default listing and only it is showing when one first lands on the page.

    One must click on:

    Select hotfix

    http://support.microsoft.com/hotfix/KBHotfix.aspx?kbnum=2547227&kbln=en-us#step1

    or

    Step 1 Show hotfixes for all platforms and languages (2)

    to see the 32 bit version.

    Don't most have 32 bit office?  What a pain.

     

    Thanks for the help

    Thursday, June 23, 2011 8:15 PM
  • it automatically decides what it thinks you need based on your OS, not outlook version, and hides the other choice.

    I'm not sure which is in greater use, but the system should definitely check the office version, not the os.



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Thursday, June 23, 2011 8:48 PM
  • I see in the release notes for Office 2010 SP1 the following:

    "Outlook 2010 SP1 can be set to always use the default sending account."

    Where do I set that? I've looked all over the place...

    Wednesday, June 29, 2011 12:54 PM
  • I believe you need to set a registry key. (I'll check on it)



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Wednesday, June 29, 2011 1:08 PM
  • I see in the release notes for Office 2010 SP1 the following:

    "Outlook 2010 SP1 can be set to always use the default sending account."

    Where do I set that? I've looked all over the place...


    It works if the pop account is delivered to a separate pst (as in not the default pst, meaning you have a min of 3 pst files for 2 accounts) - if you set a pop account to be delivered to the default pst file, then its used as default. No word yet on if this can be changed via a reg key.

    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Thursday, June 30, 2011 4:40 PM
  • The following worked for me:

    • Install Office 2010 SP1
    • Create/Set the following registry entry

    [HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Options\Mail]
    "NewItemsUseDefaultSendingAccount"=dword:00000001

    • Restart Outlook
    Wednesday, July 06, 2011 9:27 AM
  • I just installed Service Pack 1, and it fixed the problem for me!

     

    I'm so excited!  No more emails coming from my non-default POP account!!

    Thursday, July 07, 2011 2:07 PM
  • So is it only SP1 that's required or did you also have to set the "NewItemsUseDefaultSendingAccount" registry entry as well?  Trying to figure out whether I can turn this loose on the relatives or not, if you know what I mean.

    Thanks,

    Rob

    Thursday, July 07, 2011 6:04 PM
  • So is it only SP1 that's required or did you also have to set the "NewItemsUseDefaultSendingAccount" registry entry as well?  Trying to figure out whether I can turn this loose on the relatives or not, if you know what I mean.

    Thanks,

    Rob


    I have SP1 installed, and am not seeing a change in behavior, so am assuming that it requires both SP1 as well as the registry change, per BorisH above.
    Thursday, July 07, 2011 9:43 PM
  • So is it only SP1 that's required or did you also have to set the "NewItemsUseDefaultSendingAccount" registry entry as well?  Trying to figure out whether I can turn this loose on the relatives or not, if you know what I mean.

    Thanks,

    Rob


    I have SP1 installed, and am not seeing a change in behavior, so am assuming that it requires both SP1 as well as the registry change, per BorisH above.


    If you only have sp1, mailto and send to commands should use the default (imap) account - but you need the reg key to force outlook to use the default account behavior from older versions.

    I have a link to the reg file at http://www.slipstick.com/outlook/ol2010/default_acct.asp - or export your own to give to family.

     



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    • Marked as answer by Tina_Tian Saturday, July 09, 2011 6:38 AM
    Thursday, July 07, 2011 9:59 PM
  • I am still having an issue with the default sending address, even after SP1 and the "NewItemsUseDefaultSendingAccount"=dword:00000001 reg.

    Here is my setup and problem.

    4 POP accounts on 1 PST data file.
    When I create a new e-mail it works properly and shows my default sending account.
    When I reply to an e-mail (which was sent to the default sending account) it brings up a different sending account than what I have set as the default.

    This is the same exact behavior before I installed SP1 and before I created that reg key.

    Any suggestions? 


    Roman
    Friday, July 22, 2011 5:26 PM
  • I am still having an issue with the default sending address, even after SP1 and the "NewItemsUseDefaultSendingAccount"=dword:00000001 reg.

    Here is my setup and problem.

    4 POP accounts on 1 PST data file.
    When I create a new e-mail it works properly and shows my default sending account.
    When I reply to an e-mail (which was sent to the default sending account) it brings up a different sending account than what I have set as the default.

    This is the same exact behavior before I installed SP1 and before I created that reg key.

    Any suggestions? 


    Roman
    Does it always use the same sending account?  If so, I would delete that account, close Outlook, and then add that account back in.  That fixed my problem when my copy of Outlook 2010 was sending with the non-default account.   (The account it is using may have been the default account while you were setting up Outlook.)
    Friday, July 22, 2011 5:41 PM
  • POP3 accounts should always work correctly and especially with replies. (The fix was for new messages.)

    Are these 4 distinct accounts with their own mailboxes, usernames and passwords configured in outlook? The behavior sounds more like you have a catchall account and set up accounts for other addresses. In a situation like this, the account that downloaded the message will reply.

    Try this: add the accounts field to the view so you can see which account downloaded the message. That should always be the reply account.



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Friday, July 22, 2011 7:16 PM
  • Diane,

    I recently installed SP1, currently 2 accounts 1 pop and 1 gmail imap. Gmail is my default email. When sending I noticed how the default email address was the pop account, I change the folder when outlook opens and set it to gmail, all is good sending is from gmail. When I click new meeting the default email address is the gmail, HOWEVER when I go into the calendar tab and when Im working from there I click new meeting, it defaults to the pop account and not gmail.

    What can I do?

    Thanks

    Friday, August 05, 2011 5:51 PM
  • Diane,

    I recently installed SP1, currently 2 accounts 1 pop and 1 gmail imap. Gmail is my default email. When sending I noticed how the default email address was the pop account, I change the folder when outlook opens and set it to gmail, all is good sending is from gmail. When I click new meeting the default email address is the gmail, HOWEVER when I go into the calendar tab and when Im working from there I click new meeting, it defaults to the pop account and not gmail.

    What can I do?

    Thanks


    Did you set the NewItemsUseDefaultSendingAccount registry key too? With that set, all meetings will use the default account (which causes issues with meeting tracking).

    As it stands (no key or RTM), with pop3 delivered to the default pst, it owns the calendar in that pst. If the pop3 is delivered to a different pst, then it should use the gmail account.  

    The key is listed at least once a few posts up this thread and i have it at http://www.slipstick.com/outlook/ol2010/default_acct.asp 

     



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Friday, August 05, 2011 7:17 PM
  • Diane,

    I recently installed SP1, currently 2 accounts 1 pop and 1 gmail imap. Gmail is my default email. When sending I noticed how the default email address was the pop account, I change the folder when outlook opens and set it to gmail, all is good sending is from gmail. When I click new meeting the default email address is the gmail, HOWEVER when I go into the calendar tab and when Im working from there I click new meeting, it defaults to the pop account and not gmail.

    What can I do?

    Thanks


    Did you set the NewItemsUseDefaultSendingAccount registry key too? With that set, all meetings will use the default account (which causes issues with meeting tracking).

    As it stands (no key or RTM), with pop3 delivered to the default pst, it owns the calendar in that pst. If the pop3 is delivered to a different pst, then it should use the gmail account.  

    The key is listed at least once a few posts up this thread and i have it at http://www.slipstick.com/outlook/ol2010/default_acct.asp 

     



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Thanks for your reply Diane. I have not made any registry changes. The only change was SP1 and changing the default folder when opening outlook.

    ~Gerard

    Saturday, August 13, 2011 7:22 PM
  • Before last week, I used Outlook to connect to three POP-3 email accounts.  Last week, I converted my default POP-3 account, which is my business account, over to Exchange, using the same email address.  Now, I am having the same problem.  My default email account, which is the Exchange account, is not used if I am currently viewing the POP-3 mail folders.  I too, have sent several emails using a POP-3 address when I meant for them to be the work address.  Please, if an account is set to be "default", then it should be the DEFAULT! No matter what.  On the occasions that I want to send using a different email address, I can select it from the drop-down.  Which email I am currently reading, and which folder it is currently residing in, has NO bearing on which account I wish to use to send my next email.

     


    www.earthpoint.us
    Sunday, August 14, 2011 9:45 PM
  • Did you install SP1 and set the regkey? See http://www.slipstick.com/outlook/ol2010/default_acct.asp#sp1 for instructions.

    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Sunday, August 14, 2011 10:09 PM
  • I can confirn that installing SP1 and making the reg change works perfectly. Still a shame microsoft could not have added a simple tick box for this in Options.

    My reason for needing this behaviour is slightly different to the others. I will try to explain assuming the default Outlook 2010 behaviour prior to applying the fix:

    I have several mail accounts, some with signatures and some without. If I am in a folder belonging to a signatured account (such as my default account) and click to open a new email form, the signature displays just fine. I can then switch between senders using the "From" menu and the signatures change according to the account selected. However if I am in a folder belonging to a non-signatured account and click to open a new email form, I get no signature for that account as you would expect but if I then change to a signatured sender using the "From" menu as before, the signatures to not appear on any of the accounts and I have to add it manually.

    This seems very odd behaviour and I am wondering if it is a bug or if there is anything I can do to correct it.

    Thursday, August 18, 2011 1:31 PM
  • The signature behavior is by design - outlook uses a stlye to set and change the sig and its only added when you assign a sig to an account. If you want it to work for all accounts, create a blank signature to assign to accounts that shouldn't have sigs. I recommend putting -- (two dashes) as the first line so you can see it and avoid typing in the signature block.

    http://www.outlook-tips.net/2010/103/tip-773-accounts-amp-signatures/



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Thursday, August 18, 2011 3:20 PM
  • Thank you very much for the tip Diane. I will follow your advice.

    Now all I need to do is find a way of turning off the unsent emails warning (when closing Outlook) for all my delayed emails? This is quite annoying as I obviously do not want them sent until the set time.

    Friday, August 19, 2011 2:05 PM
  • Can't please everyone LOL. That dialog didn't work in RTM and people didn't like it - I'm pretty sure it was considered a bug, not a 'feature' or 'by design' and it was fixed (restored) in SP1. It's useful to people  who accidently hit the x button - they could keep a message in the outbox and cancel the warning and keep outlook open.

    Also note that messages won't send if outlook isn't open - this isn't a problem if the message is for well into the future but can be a problem if you close outlook before leaving for the day and want the messages sent later in the evening.



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Friday, August 19, 2011 3:17 PM
  • LOL indeed! But once again it is difficult to understand why Microsoft would not have made it an optional feature so that those of us who do not like it could turn it off if required. Getting that message for months on end just because you have a scheduled email sitting in the outbox is somewhat ridiculous.

    It seems that the big M is becoming more and more of the opinion that they know best. Selectable options are surely a better way to please everyone? Or am I being naieve?


    Friday, August 19, 2011 8:00 PM
  • Actually... I know several people who do that specifically to get the dialog. (http://www.slipstick.com/problems/accidentallyclose.asp

    It's also very useful for people who don't use Send Immediately.

    They do allow some dialogs to be dismissed but they also try to protect users from themselves. I work with enough users to know some would disable the dialog than whine because they closed outlook with mail left in the outbox and never discovered it because they turned off the annoying dialog. :) 

    You are aware that having messages on hold for months may result in the recipient not seeing it? Outlook will time stamp the message for the time you sent it to the outbox, not when it sent it to the SMTP server. Some SMTP servers will use the time they picked it up but if the SMTP doesn't update the date, it may sort with mail sent months ago.

    If you need to prepare a message for much later, use Scheduled tasks - you'll need to hit Send (automation security :( ) - so maybe use scheduled tasks to pop it up a few days before you need it sent then let outlook hold it.



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Friday, August 19, 2011 9:57 PM
  •  

    IMAP isn't the problem with the default outgoing setting.

    I have Windows 7, SP1, 64 bit with Office 2010. I had four accounts, one of which was IMAP account and which would not function as the default outgoing account, when designated as the default -- which is the much-discussed anomaly to which much of this thread is dedicated. 

    My solution to the problem was to eliminate the IMAP account by re-doing it account as a POP3. (I started a completely new wizard, rather than change the settings in the formerly IMAP account.) The new account works perfectly as a POP 3, but Outlook still will not allow the account to act as the default outgoing (sending) account, despite the fact that the Outlook dialog indicates that it is the default. 

    Virtually all of the settings on the new POP3 account are the same as the account that erroneously ends up serving as the outgoing default -- except the port settings and the outgoing encryption setting, which is SSL.

    Any idea what the problem is?



    Sunday, August 21, 2011 5:24 AM
  • So I read most of these posts with this irritating problem that many of us our experiencing yet don't see any answers even after all of this time. The one microsoft employee disappears after his "everyone wanted this" crap doesn't fly. I have five pop3 accounts and one microsoft exchange account for my business. I used Hi Impact email to mail out hundreds of emails to my business database at a time. However, they keep going out from the pop3 personal account instead of the hosted exchange account no matter how many times I change it to the default account. Has anyone discovered an answer to this yet? Thanks, Don P
    Tuesday, November 29, 2011 11:06 PM
  • I tried it, and all I got was "Sorry, but we couldn't find the page that you requested." Microsoft strikes again!
    Tuesday, January 03, 2012 8:28 PM
  • Which link did you try and did you try it a second time (just in case the server was being goofy)?

    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Tuesday, January 03, 2012 9:31 PM
  • I had the same problem and solved it with a bit of a workaround. Create another POP account with the same data email address and outgoing server as your IMAP. Also, make sure you use the same data file. Move it up to #2 in the hierarchy after the IMAP, but above the other POP account. Disable the receive, but leave the send function. It won't matter as long as you use the same outgoing server. Then *voila* all your emails will send from the work email regardless of whether it's POP or IMAP.
    Monday, January 09, 2012 5:37 AM
  • While tricks like that work, its no longer necessary as SP1 fixes the problem. See http://www.slipstick.com/outlook/2010/multiple-accounts-and-the-default-account/#sp1 for details.

    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Monday, January 09, 2012 6:26 AM
  • Considering I have been seeing page after page of people complaining about this "feature", either you didn't do enough research or it is time to sack your research department because they are incompetent.  

    People expect their software to work as advertised.  When it expressly "Set as Default: Select which account sending mail defaults from", oddly enough, we expect it to ACTUALLY WORK.  The fact that Microsoft had decided that they know better what I want than *I* do, disgusts me and shows a level of arrogance that really is unbelievable.  

    I am taking a very simple solution to this.  I am moving ALL my clients to Google Apps email and throwing Exchange in the garbage.  It isn't worth the cost, the continual retraining and this situation just highlight how little Microsoft actually cares about the users of their product.


    Thursday, March 15, 2012 8:41 PM
  • Forcing users to select an email address every time is NOT a solution.  Also, it doesn't work.  Outlook STILL sends out on the Exchange account even WHEN you expressly select the other account.  

    Please provide a real solution and not a kludge.

    Thursday, March 15, 2012 8:44 PM
  • You are aware that this was addressed in Outlook 2010 SP1?

    You need to set a reg key after installing Sp1 -

    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Options\Mail
    Create a new DWORD value named NewItemsUseDefaultSendingAccount
    Value: 1

    if you don't want to edit the registry, we have a ready-to-use reg file at outlook 2010 and multiple accounts



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Thursday, March 15, 2012 8:49 PM
  • Diane,

    What is your suggestion for fixing this problem when the Registry contains no such file path as HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Options\Mail   ?

    After ....\Options I only have \Calendar, \Reminders, \ToDoBar. and a Folder called \MSHTML which contains \MSHTML\International

    Windows 7 Home Premium Ver. 6.1.7601 Service Pack 1 Build 7601

    Outlook 2010 (32 bit) ver. 14.0.6109.5005 SP1 MSO 14.0.6112.5000

    Computer was built less than 5 months ago and has no hardware/software issues to date, nor has the registry ever been edited since I received the computer. No "Important Updates" are available through Microsoft updater.

    EDIT: Subsequent searches for that above file path return nothing.


    • Edited by B Holmes Wednesday, March 28, 2012 12:28 AM adding information
    Wednesday, March 28, 2012 12:27 AM
  • The keys are not created until you change settings in options - Iif the key doesn't exist, create it.


    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Wednesday, March 28, 2012 1:13 AM
  • So to make sure I have this right.

    1. Create a key in HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Options called "Mail"

    2. Within that key create a new DWORD value called "NewItemsUseDefaultSendingAccount"  with a Value:1

    3. Win?


    • Proposed as answer by Pedroso74 Tuesday, December 11, 2012 5:27 PM
    • Unproposed as answer by Pedroso74 Tuesday, December 11, 2012 5:27 PM
    Wednesday, March 28, 2012 5:07 PM
  • Correct. Restart Outlook for it to take effect.


    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Wednesday, March 28, 2012 6:37 PM
  • SOLVED?

    I may have stumbled onto a solution.  IMAP is my default, POP for my intranet unix email and ran into the same problem (POP being default for mail merge).

    I FORCED IMAP to be the sending account by creating a new email, specifying my IMAP account and then minimized this email.  I then did my mail merge (Word & Excel 2010) and joy!  IMAP sent the emails, not POP.  Hope that makes sense, and it was reproducible.

    FWIW,

    MarkB

    Wednesday, April 18, 2012 11:38 PM
  • I have the same problem as most others but I do not know how to implement the suggested solution.

    1. How do I determine if SP1 has been installed? I'm running widows 7 and Office 2010. When I look in the update file I don't see it but have updates going back to 2010.

    2. How do I update the registry? I saw the ready to run solution but don't know how to run it.

    A more detailed explanation would help. Thanks

    Monday, April 30, 2012 10:38 PM
  • I think I edited the registry correctly, see below, not sure if the Data value correct. Restarted Outlook but it still selects the wrong account. Not sure about the SP1 install either. Any suggestions?

    Monday, April 30, 2012 11:05 PM
  • The fix started working today. Not sure what changed.

    Thanks for the tips, I guess I was able to stumble through it.

    Tuesday, May 01, 2012 9:23 PM
  • Ryan: I guess I am surprised that you don't hear from more people who are in my situation.

    I am a consultant who works at client sites where Exchange manages the company email and the client on everyone's desk is Outlook. I must receive emails both from Exchange (internal company email) and from multiple external accounts, and I frequently need to reply to those external emails from the workplace. The only way to send a reply to an email (or to send any email at all, actually) from within these environments is to use Exchange, because they all have their networks set up so that I cannot communicate with any external SMTP servers. So yes like most of your focus groups I do want to keep my incoming emails from multiple sources compartmentalized if possible. But when I reply to those emails I have no choice - I must go through the Exchange server, which is not associated with any of those accounts (i.e. there is no way to set up the external accounts to use Exchange as the outgoing mail server rather than some SMTP server).

    So what happens is that I get an email from one of these external accounts and I reply to it. Because I was unable to set up that account with an outgoing server, my reply just sits in my Out Box all day until I realize that it is sitting in there. Then I open up each of the emails and individually (manually) change the outgoing account to the Exchange account (using the dropdown beneath the Send button). Which of course I could have done when I initially sent the reply, if I had remembered to do it.

    Wednesday, May 16, 2012 3:39 PM
  • Of course it's a bug.

    Computing Dictionary

    bug definition

    programming 
     An unwanted and unintended property of a program or piece ofhardware, especially one that causes it to malfunction.

    ** 

    The behaviour itself may be considered a feature by Microsoft, though I disagree, but the fact that one thinks one is specifying a "default" account that is not then used as the default in all cases is clearly a bug.

    It is astonishing to me that in the plethora of options, advanced options and advanced advanced options there is not a checkbox to enable this new behaviour with the default being unchecked.

    Microsoft does it again.

    Monday, July 02, 2012 8:14 PM
  • Thank you so much for the reg edit, it works great.

    I actually had a Microsoft Exchange account, an IMAP account, a POP3 account and a hotmail account and whichever was active, it would send the new email from. VERY VERY ANNOYING, definitely SHOULD BE AN OPTION, you should not make regular people who don't even know what the registry is have to mess with their registry, COME ON MICROSOFT!! It should be a simple check button that shows up in options or even easier, in the "To" box that pops up.

    All new mail now sending from my MEN account, thank you.

    Monday, August 13, 2012 2:45 PM
  • I had the same problem and found the solution here... http ://social.technet.microsoft.com/Forums/en-US/outlook/thread/a648eec8-9b4e-4527-a7b6-345961725164/ (Delete the space after http)

    I just clicked on the registry file in blue for outlook 2010 and BOOM... problem solved!!!

    Very easy...

    • Proposed as answer by Pedroso74 Tuesday, December 11, 2012 5:27 PM
    Tuesday, December 11, 2012 5:26 PM
  • same problem 

    SP1 allrady installed 

    after edit the regedit- work perfect Thanks!!!

    Wednesday, January 09, 2013 9:16 AM
  • This thread needs a "SOLVED" button!

    This was an easy fix, apart from reading though all the extraneous posts.

    For those on Office 2013 you need to add the following registry key (note the "Mail" subfolder vs the older Office version solutions) then restart Outlook.

    [HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Outlook\Options\Mail]
    "NewItemsUseDefaultSendingAccount"=dword:00000001

    Great :)



    Tuesday, April 16, 2013 11:45 AM
  • This only works on new mails. Problem still exists on replies.
    Wednesday, July 24, 2013 3:50 PM
  • It may as well be a bug - it's annoying as hell.  At least provide the option to change this behavior!
    7 hours 53 minutes ago