none
Problem with Microsoft Office 2010 Clipboard (Copy and Paste)

    Question

  • I'm having a problem with Microsoft Office 2010's clipboard feature.  We use Word and Publisher in my office weekly to print a newsletter.  Whenever I try to copy something from a Word document or from an email and then past it into Publisher it doesn't work properly.  For example: I was trying to copy an article that was in an email attachment (Word 2010 docx) and instead of pasting the article it pasted something else I had copied earlier.  I've tried clearing out the clipboard, but it still pasted the line of text from an earlier copy.  Nothing seems to be working.  It's very frustrating.  Any help out there? 

    BTW I'm using a Office 2010 Professional, not beta on a Windows 7 machine.

    Wednesday, October 27, 2010 1:29 PM

Answers

  • Hi,

     

    Can you copy and paste properly in other programs, such as Word to Word, or Word to Outlook?

     

    It might occur as you have not copied successfully. Select the text in Word or an email, right click it and choose Copy. Then in Publisher, right click and choose Paste.

     

    Can you paste now?

     

    Best Regards,

     

    Sally Tang

    • Marked as answer by Sally Tang Thursday, November 04, 2010 8:38 AM
    Friday, October 29, 2010 7:36 AM

All replies

  • Hi,

     

    Can you copy and paste properly in other programs, such as Word to Word, or Word to Outlook?

     

    It might occur as you have not copied successfully. Select the text in Word or an email, right click it and choose Copy. Then in Publisher, right click and choose Paste.

     

    Can you paste now?

     

    Best Regards,

     

    Sally Tang

    • Marked as answer by Sally Tang Thursday, November 04, 2010 8:38 AM
    Friday, October 29, 2010 7:36 AM
  • I'm also having a similar problem with the Office 2010 Clipboard across programs.  When attempting to paste items copied from IE8, or Win XP Calculator, they do not appear on the Clipboard.  They can usually be pasted in my Office 2010 application immediately after copy, but then prevent earlier items in my Office Clipboard from being available for pasting.  I sometimes get an error message (Pasting not available at this time) or the most recent item gets pasted when I click an earlier item.  These operations worked fine in Office 2007. 

    Im on Office 2010 Pro, (NOT BETA), on Win XP SP3.  This is very frustrating indeed (it seems that Office 2010 was prematurely released... still many bugs and conflicts to work out).

    Thursday, March 24, 2011 1:25 AM
  • I have the same issue. Have tried to copy and paste to other office programs and have not issue. If I close out Publisher it asks me if I want to clear the clipboard. If I do then restart, then I can copy and paste once. After that I can only paste the last thing in the clipboard. This really makes the product cumbersome to use! Any assistance would be appreciated!

    Thursday, March 24, 2011 3:20 PM
  • I'm having the exact same problem.  Copy/paste works as it should between any other programs, but Publisher will not paste the most recent clip.  I can copy something in Word that will not paste in Publisher, but WILL paste in another Word or Outlook document.  I had this problem in Office 2007 AND 2010, so obviously a glitch that MS has had trouble either identifying or solving.  In 2007 it was easier to work around with the clipboard manager, but I can't find that feature in 2010.  I'm running Windows 7 32-bit.
    Tuesday, April 12, 2011 3:00 PM
  • Yup, having the same problem. Very frustrating!!!
    Thursday, May 19, 2011 1:09 AM
  • Another "phenomenon" I'm experiencing with the Office 2010 clipboard (Pro!!!).  When I try to copy from Internet Explorer 8, and the Office 2010 clipboard is open, it crashes my IE.  I use the Office clipboard routinely (I need to paste from a variety of "copy" actions on a routine basis).  the Office 2007 clipboard worked fine... 2010 is horrible.
    Tuesday, May 31, 2011 6:43 PM
  • Is there no answer to this?  I am having the same problem.  Office 2010 Pro on Windows 7 Pro with all the updates.  I can copy and place just fine in Excel.  When I go into Word I can paste what I copied previaously in Excel.  Viewing the clipboard shows the copied item fine.  But when I try and copy some text in Word the clipboard never changes.  The only time I can get the clipboard to change is if I do a "Cut" instead of a copy. 

     

    It's a definate MS problem.  We have 45 brand new computers doing the exact same thing.  HELP!

    Thursday, July 21, 2011 2:05 PM
  • Found my own answer.  There is an add-on causing the problem.  The add-on that was my issue is a "Keyboarding Pro add-in".  I disabled it and all is good now.
    • Proposed as answer by RonBarker1 Monday, October 24, 2011 2:37 PM
    • Unproposed as answer by RonBarker1 Monday, October 24, 2011 2:37 PM
    Thursday, July 21, 2011 2:18 PM
  • I am having the same problem w/no Keyboarding Pro add in. I can cut and paste to a variety of MS products but when I try to paste to Pub I cannot. Pub seems to be working in it's own world, I can copy and paste text within the App but cannot bring anything in from the outside. If I copy "XYZ" in Pub then copy "ABC" in Word then try to paste, I paste "XYZ". I cannot find any way to bring text in from other applications, the only workaround is to type the text over - very time consuming.

     

    • Proposed as answer by RonBarker1 Monday, October 24, 2011 2:36 PM
    • Unproposed as answer by RonBarker1 Monday, October 24, 2011 2:36 PM
    Monday, October 24, 2011 2:33 PM
    • Proposed as answer by RonBarker1 Monday, October 24, 2011 2:37 PM
    Monday, October 24, 2011 2:37 PM
  •  

    hiya - no offense, i'm not sure how displaying the clipboard solves the original issue of items not copying to the clipboard in the first place. I have a customer who is experiencing the same types of problems when copying (ctrl-c) a pdf file from an email received to an email to be sent (ctrl-v). it either crashes outlook or copies in the wrong attachment. this is driving us batty.

    Monday, November 21, 2011 6:29 PM
  • hiya - no offense, i'm not sure how displaying the clipboard solves the original issue of items not copying to the clipboard in the first place. I have a customer who is experiencing the same types of problems when copying (ctrl-c) a pdf file from an email received to an email to be sent (ctrl-v). it either crashes outlook or copies in the wrong attachment. this is driving us batty.


    Has anyone had any response that may sort this problem - it's happening to me and I can't paste into Publisher without saving and closing the document first and then re-copying and pasting.  Turning off the Clipboard in Word doesn't work.  Why do they have to mess up programs that used to work perfectly well before!!  Infuriating!
    Tuesday, February 28, 2012 3:15 PM
  • I have had a similar issue. I copy plain text from Mozilla Firefox and try to paste into MS Word 2010 only to get an .jpeg of a black ellipsoid pasted instead of my text. Below are the instructions for a solution I hope works. I just changed the settings now, and have yet to notice a recurrence of my problem. This is for Microsoft Office Professional 2010: Microsoft Word. «««POSSIBLE SOLUTION»»» «1» Click on [File » Options » Advanced] «2» Under "Cut, copy, and paste," I changed all paste options to "Keep Text Only." The key option to change should be the paste style for "Pasting from other programs:" to "Keep Text Only;" however, I chose to just change them all to be safe. I think the issue is that MS Word tries to find the style associated with online text, and the style is identified inconsistently compared to how MS Office identifies it. How MS Office could screw up plain and rich text is beyond me, but I may be making some wrong assumptions. I will post in a week to inform everyone whether or not I have noticed any subsequent problems with pasting into any of my MS products. Until then, I hope this solves your problem. Cheers! |«
    • Edited by Kei2501 Friday, March 23, 2012 2:48 AM
    Friday, March 23, 2012 2:45 AM
  • I read a response to this problem on another user site - he had heard that a recent version of Java inhibited the paste options (other than text-only).  I found that I'd accepted a Java auto-download (v31 I think it was) on 25 Feb 12.  Since then I've had the problem that everyone is complaining about - I couldn't paste into Outlook or Word using any mode other than "text only".

    I've just deleted Java and paste now works as it was meant to and before the 25 Feb Java update appeared. (I'm using Windows 7 Pro and Office 2010).  Of course, deleting Java will no doubt cause a raft of other issues - but that's tomorrow's worry!

    • Proposed as answer by RuthMacD Monday, April 02, 2012 12:14 PM
    Friday, March 23, 2012 8:16 PM
  • I have just done the same and it worked for me too - I've installed an earlier version of Java and Copy & paste still work fine, so it seems to be something to do with the latest version of Java with Office 2010...

    Thanks!

    Monday, April 02, 2012 12:15 PM
  • Just found that the Java change hadn't changed the clipboard functionality, but found another possible solution:

    http://www.excelforum.com/excel-general/806163-formula-copy-problem-only-text-value-paste-allowed.html

    The Skype Click to Call add in has caused a conflict for some users.  I've uninstalled it and Copy and Paste are working again for the moment.

    • Proposed as answer by alanburgess70 Thursday, May 24, 2012 8:27 AM
    Tuesday, April 03, 2012 11:00 AM
  • I am having a similar though not precisely the same problem.  I am using Outlook 2010, IE2010 and Word2010.  I use the HTML format whenever possible and when first booted up I am able to use all the copy/cut/paste options completely and without difficulty, but after some time the only paste option available becomes 'Keep Text Only'.  The only solution I have found is to close down and then boot up again and this seems to resolve the issue for a while until it reverts to the 'Text Only' option.  Is there a simple solution to this extremely annoying glich?  Thank you.


    • Edited by Fearnaught Saturday, April 14, 2012 9:55 AM
    Thursday, April 12, 2012 3:05 PM
  • I'd the same problem with FireFox.

    When Web browser was running I'd problem with paste from memory. Everything I done in Excel was paste as text.

    Solution was to turn off Skype Addin.


    Oskar Shon, Office System MVP

    Press if Helpful; Answer when a problem solved

    Thursday, April 12, 2012 8:47 PM
  • I have now discovered that I am able to use all the paste options in Outook 2010, until I open IE2010.  The paste options are then reduced to Text Only.  Is the solution to use another browser or is Microsoft going to produce a solution.

    Saturday, April 14, 2012 9:54 AM
  • I've got the same problem - in all Office applications. In some circumstances the paste options are reduced to Text Only in Outlook2010, Excel, Word etc.

    I don't know the reason or the solution.

    I've noticed only, that making some manipulations with Internet Options ('security' tab) in IE2010 sometimes solving the problem. But no always. I haven't noticed any rule.

    Tuesday, April 24, 2012 8:35 PM
  • Brilliant! I've just had a user complain about not being able to keep formatting when copying and pasting between Office programs and disabling Skype's Click to Call sorted it straight away.

    Thank you very much RuthMacD!

    Thursday, May 24, 2012 8:27 AM
  • I know this sounds insane, but actually displaying the clipboard solved my issue. I was crashing every time I copied more than just a simple bit of text. But, by displaying the clipboard I can now group a ton of things together, copy them to the clipboard, and paste them into another page or even another document. Crazy!

    Also, by displaying the clipboard I can delete the various other items that have copied to the clipboard that I no longer need - keeping my memory more clean.

    The trick is to display the clipboard in all open publications you are working in, so that you paste from the open clipboard in the document you are working in. The crash must be occurring from some obscure circumstance where the system doesn't know what all you are trying to past and in what format. But, by pasting from the clipboard itself you can past the exact item in the exact format you've copied it.

    Weird!

    So, RonBaker1's post above is actually correct.




    Sunday, June 17, 2012 6:35 AM
  • I have the same problem when copying from Word 2010 to Publisher it would copy images and text that I had deleted infuriating! The only thing i found to work was to delete everything on my clipboard then copy multiple items to clipboard and paste them to Publisher off the clipboard, you can copy a miximum of 24 items, needs to be a fix created for this.
    • Edited by RPWuk Tuesday, July 03, 2012 3:17 PM
    Tuesday, July 03, 2012 3:16 PM
  • is there any resolution to this ??

    It is frustrating to just have Text only copy when you want the entire table/formatting to be copied... what is causing this issue ?


    Ratish

    Friday, July 13, 2012 5:47 PM
  • Same problem, I've lost the option of pasting with formating or without, I only have a single paste option of text only. Very frustrating and no answers when you need them, typical!
    Wednesday, October 03, 2012 4:14 AM
  • Have seen a similar issue in my shop with a variety of users copying from IE, Chrome, RDP, CItrix, Entire suite of Office 2010. The issue is not constant and unpredictable. Primary apps effected have been COPY and PASTE between IE and a thin client published APP. The solution fior most the users has been to close the published app and relaunch it and COPY & PASTE may work for a short while. The best results have been from rebooting the users PC. I'm testing a script that runs a CMD prompt to clear the PC clipboard. It seems to be working no one has complained about COPY & PASTE for a while.
    Wednesday, October 10, 2012 6:33 PM
  • So, 3 years and there still hasn't been a proper solution. :(
    Thursday, October 24, 2013 9:12 PM