none
Office 2010 Professional Plus configures each time I launch - FIXED!

    Question

  • <!-- [if gte mso 10]> <mce:style>

    Every time I start one of the office 2010 programs from the All programs menu, a window opens that says "Please wait while Windows configures Microsoft Office Professional Plus 2010”. (Starts Windows Installer). After about 30 seconds, the program starts and runs OK.  It is affecting the whole suite of MS Office 2010.  Previously, office 2007 was running perfectly.  I have tried:

    ·     Uninstalling and re-installing Office 2010 (using MS Office 2010 cleanup utility in between)

    ·     Uninstalling Office 2007 remnants by using the MS Office 2007 cleanup utility

    ·     Uninstalling MS Works 8

    ·     Uninstalling MS Small Business Accounting 2009 free edition

    ·     Uninstalling MS PowerPoint Viewer 2007

    ·     Created a new Windows user account, and tried running Office 2010 from there

    ·     Running the Win7 compatibility wizard

    ·     Cleaned the registry of Office 12 (2007) keys

    ·     Searched MS Knowledge Base for solutions, but none found that have worked

    ·     Run SFC to check Windows 7 installation


    Nothing has worked so far.  Odd thing is, if I start Word by double clicking on Winword.exe, it starts and runs without running the configuration window. (However, that does not work for Outlook.exe, nor Excel.exe – those still go through the Configuration setup each time)

    I am running Windows 7 32 bit, fully patched.  Office 2010 is 32 bit.

    Any help would be appreciated.


    • Edited by Macflash53 Saturday, August 14, 2010 3:14 PM
    Friday, August 06, 2010 4:56 PM

Answers

  • OMG -  I'VE FIXED IT!

    Looking at the event handler, it was showing an error that HKLM/Software/Classes/.msg could not be accessed.

    This is how I fixed it:

    Using Regedit to locate the key for .msg, when accessing Permissions, I got an error message, but ignored that.  Open the Permissions window, and click on the "Advanced" button.

    Then select the "Owner" tab, and set the owner as "Adminstrators". Click Apply and OK.

    Close Regedit, and Run Outlook, the Configuration process will run.  Then close Outlook.

    Open Regedit again, and locate the same Classes/.msg key.  You should now see a number of sub keys. 

    For each sub key , right click on it to select Permissions.

    Click on the "Advanced" button, and then the "Owner" tab, and set the owner as "Administrators", and click Apply and OK.

    On the security tab, click on the Add button.  Add "SYSTEM" as a new user, and put a tick next to "Full Control".  Click Apply and OK, and you should then see other users added.

    Repeat the above for all sub keys.

    Close Regedit, and reboot.

    I then found that not only Outlook would run without the configuration loop, but all other applications in the Office 2010 suite also ran properly using all the proper shortcuts in All Programs.

     

     

    • Marked as answer by Macflash53 Saturday, August 14, 2010 3:13 PM
    Saturday, August 14, 2010 3:12 PM

All replies

  • Hi,

    Try this:

    hold the start+r key and enter this command into the registry  

    reg add HKCU\Software\Microsoft\Office\14.0\Word\Options /v NoReReg /t REG_DWORD /d 1

    Hope it does help.

    • Proposed as answer by dbawjmiii Tuesday, January 18, 2011 6:35 PM
    Monday, August 09, 2010 6:20 AM
  • Hi Jennifer,

    Many thanks for your reply.  Unfortunately, the reg key you suggested didn't solve the problem.

    I have now installed Office 2010 in a completely different computer (as my licence allows), and I am getting exactly the same problem, so it does not seem to be computer specific.  Note that I purchased Office Pro Plus 2010 as a digital download from an MS Partner.

    Any other suggestions would be appreciated.  Please remember that I have the problem with all applications in Office, not just Word.

    Latest:   I have also noticed that all file associations for Office files are broken, which is odd.  Manually setting them does not overcome the original problem of the Configuration process (Windows Installer) running every time I start any of the Office applications.

    With Outlook, the installer not only runs when it is started, but also runs 5 times when I do a send/receive (there are 5 email accounts configured).  Weird.

    I have noticed another thread with a user experiencing exactly the same problem as me:

    http://social.technet.microsoft.com/Forums/en-US/officesetupdeploy/thread/f1c81929-c194-4e4d-b709-25dba23850e0

     

    Wednesday, August 11, 2010 11:37 AM
  • OMG -  I'VE FIXED IT!

    Looking at the event handler, it was showing an error that HKLM/Software/Classes/.msg could not be accessed.

    This is how I fixed it:

    Using Regedit to locate the key for .msg, when accessing Permissions, I got an error message, but ignored that.  Open the Permissions window, and click on the "Advanced" button.

    Then select the "Owner" tab, and set the owner as "Adminstrators". Click Apply and OK.

    Close Regedit, and Run Outlook, the Configuration process will run.  Then close Outlook.

    Open Regedit again, and locate the same Classes/.msg key.  You should now see a number of sub keys. 

    For each sub key , right click on it to select Permissions.

    Click on the "Advanced" button, and then the "Owner" tab, and set the owner as "Administrators", and click Apply and OK.

    On the security tab, click on the Add button.  Add "SYSTEM" as a new user, and put a tick next to "Full Control".  Click Apply and OK, and you should then see other users added.

    Repeat the above for all sub keys.

    Close Regedit, and reboot.

    I then found that not only Outlook would run without the configuration loop, but all other applications in the Office 2010 suite also ran properly using all the proper shortcuts in All Programs.

     

     

    • Marked as answer by Macflash53 Saturday, August 14, 2010 3:13 PM
    Saturday, August 14, 2010 3:12 PM
  • Thanks for the update. I eventually had to reload the OS after going through many iterations of whack-a-mole for various registry keys, that had permissions problems. I suspect that the office 2007 to 2010 upgrade is poorly coded and the msiinstaller just machine-guns problems throughout the registry. All the entries with broken permissions had mssiinstaller as a user added to the permissions list. A clean install on a virgin OS worked just fine. 20 hours down the tubes - if only I could bill for my time.... John Thoren
    Monday, August 16, 2010 1:52 AM
  • Boy, I hope this works Macflash53, this has been driving me nuts for about 3 weeks.  I will try it tonight. 
    Tuesday, August 17, 2010 10:48 AM
  • Exactly which msg key are we looking for, all applications, like word, publisher etc?
    Tuesday, August 17, 2010 10:56 AM
  • hi,

    try the following,

     

    go to Program Files\Common Files\Microsoft Shared\OFFICE12\Office Setup Controller

    there rename setup.exe.

     

    Hope the problem will be resolved. 

    • Proposed as answer by Nidgy Monday, May 19, 2014 7:31 AM
    Thursday, August 19, 2010 1:28 PM
  • Tried this in Windows 7/MS Office 2010. Didn't work for me.

    For some reason got a huge problem now with start-up - long delay. Event log shows all kinds of cautions and CRITICALs.

    I changed ownership back to "SYSTEM". Hope it fixes star-tup.

    This problem is all over the web since MS Ofc 2007 - I can't find a single note or article on MS Support site.

    I have a laptop with same OS & Office suite and I have no problem - only on desktop - cannot determine if there is some difference in some setting on the two machines that would cause the problem.

    Would appreciate any ideas.

    BTW, I get the configuration problem ONLY when I request "Help", but get it all the time in all Ofc apps plus MS Project and MS VIsio (both also 2010).

     

    Saturday, August 21, 2010 4:15 PM
  • This fixes the problem keys identified in Event Viewer but other problems will likely still exist.  Check other extensions under Classes like .docx or .oft.

    Take a look at your permissions for HKLM/Software/Classes. Mine didn't have an owner so a warning was displayed to communicate the risk.  I added Admins group as the owner then did a remove and install of Office 2010 and it is now working.

    Wednesday, August 25, 2010 6:55 PM
  • Macflash's suggestion is GREAT! And that is how I fixed mine (after many days of annoying "configure" messages).

    The best approach is to check the event handler (I looked that the administrative events but there are other options). It will tell you the source of the problem, i.e., why it goes thru the reconfiguration. In my case (I did not install Outlook), it was .odt (not .msg) that had to be fixed. I added the permissions (I actually had to add different users under the security tab) and did not even had to reboot.

     

     

    Thursday, September 30, 2010 4:34 AM
  • After trying many different things I got my Office 2010 fixed.  My problem was similar to Macflash but a bunch of different registry keys.   I didn't realize it at the time, but I think the registry had other issues, as some other programs were acting a little funky.

    Anyway..  This is a fresh install of Windows 7 Ultimate 64-bit.  It turns out that the Administrators group didn't have permissions to a bunch of registry keys.  This was causing the office issue as well as some other issues.  I'm not sure how this happened, as this was a fresh install last week.

     

    Anyway.. I right-clicked on Command Prompt, under Start Programs, Accessories, and Ran as Administrator, from my admin account.

    Then I did the following command:

    secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose

    Then I rebooted

    I noticed after I rebooted that only my admin account had permissions on the machine.  So I had to go back into Users.  Add my User accounts to the Users Group.   The accounts were still there, they just weren't associated to groups in this pc. 

     

    I think the above command resets permissions in the registry.

     

    • Proposed as answer by mogulman1 Friday, October 15, 2010 8:13 PM
    Friday, October 15, 2010 8:12 PM
  • IT WORKED!!! Finally, this is the only fix that worked for me!! Thank you so much!

    Anyway.. I right-clicked on Command Prompt, under Start Programs, Accessories, and Ran as Administrator, from my admin account.

    Then I did the following command:

    secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose

    Then I rebooted

     

    Sunday, October 31, 2010 4:38 PM
  • Tried secedit  but it did Did not work for me..I have tried everything I have read - what a sad situation with 1000's of people suffering and Microsoft doing absolutely nothing to give a solution..but after the quarter jump in profits why should they care..
    Monday, November 01, 2010 11:08 PM
  • IT WORKED!!! Finally, this is the only fix that worked for me!! Thank you so much!

    Anyway.. I right-clicked on Command Prompt, under Start Programs, Accessories, and Ran as Administrator, from my admin account.

    Then I did the following command:

    secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose

    Then I rebooted

     


    worked for me too... thanks!
    Tuesday, November 02, 2010 3:03 AM
  • Another vote for secedit

     

    Worked after trying everything else.

     

    Tuesday, November 16, 2010 1:10 AM
  • Nothing here worked for me. Why is installing an application so difficult. typical MS BS.
    Tuesday, November 23, 2010 7:13 PM
  • Clearly the issue was that the installer had no read/write access to a bunch of very important Registry keys. I wonder how that happened.

    The SECEDIT stunt seemed to do the trick. Thank you!

     

     

     

     

    Thursday, December 02, 2010 2:45 AM
  • Application Log:

    "Detection of product '{91140000-0011-0000-0000-0000000FF1CE}', feature 'ProductFiles', component '{E5EE9C9D-798D-4D1D-ABF2-32EC15820B2F}' failed.  The resource 'HKEY_CLASSES_ROOT\.aw\' does not exist."

     

    In my case, taking ownership of the HKEY_CLASSES_ROOT\.aw\ key (which did indeed exist) and granting the Owner full permissions resolved the issue.

    OS is Win 7 Ultimate 64-bit. Good luck everyone.

    Saturday, December 04, 2010 8:34 PM
  • THIS worked like a charm. Talk about a frustrating problem. Thanks Jennifer!
    Tuesday, January 18, 2011 6:36 PM
  •  

    "Anyway.. I right-clicked on Command Prompt, under Start Programs, Accessories, and Ran as Administrator, from my admin account.

    Then I did the following command:

    secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose

    Then I rebooted"

     

    YAY it worked for me and I didn't had to reboot. Thanks !!!

    Wednesday, February 23, 2011 5:20 PM
  • mogulman1 - you're a genius! Your solution finally fixed the issue after so many hours of frustration.

    Sunday, March 06, 2011 5:16 PM
  • Thanks Jennifer!,

     

    it works for me!

    Tuesday, April 05, 2011 10:48 AM
  • mogulman1...you sir, are my HERO!!! I've spent HOURS searching for a solution to this problem and that command was the only one that worked! THANK YOU!
    Monday, April 11, 2011 11:50 AM
  • I have the same problem. I tried all suggestions I could find on the net. Got it fixed for all but Excel. Any idea?
    Sunday, April 17, 2011 10:15 AM
  • I too have the same issue with Office 2010 but only on launching Outlook. No errors in the event log but I've tried all the above and still have the same issue.

    Anyone got anything else on this issue?

    Tuesday, April 19, 2011 11:33 AM
  • it worked after logging to admin and cmd

    secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose

    Thank you!

    Thursday, April 21, 2011 6:17 PM
  • Tried the above but still doesn't work.

     

    Saturday, April 23, 2011 4:24 AM
  • Worked for me! Excellent. Where did this come from? Why can'y Microsoft incorporate it in their fixit tools / troubleshooters?
    Monday, April 25, 2011 5:47 AM
  • Marry Me MogulMan1 :)
    Sunday, May 01, 2011 6:00 PM
  • Looks like there is a KB for it but it is not yet a fixit: http://support.microsoft.com/kb/2528748
    Friday, May 27, 2011 2:33 PM
  •  

    Then I did the following command:

    secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose

     

    Did that still had the issue, then I used the kb link down below and used the kb fix:

    http://support.microsoft.com/kb/2528748

     

    Method 1 If you have a previous version of Office installed, such as Office 2003 or Office 2007, follow these steps:

    1. ClickStart, click Run, type the following command, and then press Enter:
      reg add HKCU\Software\Microsoft\Office\14.0\Word\Options /v NoReReg /t REG_DWORD /d 1

    anyhow, just wanted to post that in case the first part didnt fully fix it, thanks again to the original poster(s) with solutions


    Windows 7, SP1 (64 bit professional), Dell XPS L502X Half a Tech
    Saturday, July 23, 2011 7:07 PM
  • OMG -  I'VE FIXED IT!

    Looking at the event handler, it was showing an error that HKLM/Software/Classes/.msg could not be accessed.

    This is how I fixed it:

    Using Regedit to locate the key for .msg, when accessing Permissions, I got an error message, but ignored that.  Open the Permissions window, and click on the "Advanced" button.

    Then select the "Owner" tab, and set the owner as "Adminstrators". Click Apply and OK.

    Close Regedit, and Run Outlook, the Configuration process will run.  Then close Outlook.

    Open Regedit again, and locate the same Classes/.msg key.  You should now see a number of sub keys. 

    For each sub key , right click on it to select Permissions.

    Click on the "Advanced" button, and then the "Owner" tab, and set the owner as "Administrators", and click Apply and OK.

    On the security tab, click on the Add button.  Add "SYSTEM" as a new user, and put a tick next to "Full Control".  Click Apply and OK, and you should then see other users added.

    Repeat the above for all sub keys.

    Close Regedit, and reboot.

    I then found that not only Outlook would run without the configuration loop, but all other applications in the Office 2010 suite also ran properly using all the proper shortcuts in All Programs.

     

     


    What if there is a subkey that says "access is denied"? I'm not an advanced user like many in this forum and I'm having a tough time understanding all the advice.
    Thursday, September 22, 2011 9:58 PM
  • *** FINALLY, ANOTHER FIX! ***

    I've been seeing the Windows Installer / Configuration prompt whenever I launch Outlook 2010 on this one particular machine (XP SP3, Office 2010 Pro Plus).  It has been affecting all users of the machine.  I have tried every suggestion under the sun, and finally found one that worked for me.

    My problem was caused by a corrupted installation of Windows Search 4.0.  When I uninstalled Windows Search 4.0 and rebooted, Outlook started up right away and continued to do so.

    I ended up re-installing Windows Search 4.0 and everything is still working great.  The users needed to be able to search through there Outlook email via the indexing that Windows Search 4.0 provides.

    Here is the link, give it a shot: http://www.msoutlook.info/question/467

     

    - Colon Problems

    Thursday, September 29, 2011 6:17 PM
  • Looks like there is a KB for it but it is not yet a fixit: http://support.microsoft.com/kb/2528748

    Tried the secedit, did nothing.. Worked once but then rebooted and it came back...

     

    Method 3 worked perfectly (I have Visual Studio 2010 Professional installed, and it installed a COM Add-in that was causing the issue).

    Friday, October 28, 2011 5:17 AM
  • Anyway.. I right-clicked on Command Prompt, under Start Programs, Accessories, and Ran as Administrator, from my admin account.

    Then I did the following command:

    secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose

    Then I rebooted

    Hallelujah! Worked for me on my 64-bit Windows 7! Ignored the problem for a long while because it was a relatively minor annoyance, and then today I just couldn't take it anymore. Thank you mogulman1. Genius. 
    Friday, November 18, 2011 3:47 AM
  • This worked like a charm. Thank you Jennifer for the easy fix!
    Thursday, December 22, 2011 4:16 PM
  • Anyway.. I right-clicked on Command Prompt, under Start Programs, Accessories, and Ran as Administrator, from my admin account.

    Then I did the following command:

    secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose

    Then I rebooted

    Thnaks so much

    work amazing 

     

     

    Monday, December 26, 2011 11:19 AM
  • secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose

    Then I rebooted"

     

    I tried this and now I am having problems with multiple programs on my computer. I tried to do a restore but that program isnt working as well. Any suggestions?

    Friday, May 11, 2012 2:30 AM
  • This just worked for me! 

    I installed Visual Studio and the next thing I know, I'm getting a please wait while office configures for EVERY office application.

    Ran the secedit command and issue now gone.

    FYI I'm running Windows 8 consumer evaluation.....
    Tuesday, July 31, 2012 4:03 PM
  • After trying many different things I got my Office 2010 fixed.  My problem was similar to Macflash but a bunch of different registry keys.   I didn't realize it at the time, but I think the registry had other issues, as some other programs were acting a little funky.

    Anyway..  This is a fresh install of Windows 7 Ultimate 64-bit.  It turns out that the Administrators group didn't have permissions to a bunch of registry keys.  This was causing the office issue as well as some other issues.  I'm not sure how this happened, as this was a fresh install last week.

     

    Anyway.. I right-clicked on Command Prompt, under Start Programs, Accessories, and Ran as Administrator, from my admin account.

    Then I did the following command:

    secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose

    Then I rebooted

    I noticed after I rebooted that only my admin account had permissions on the machine.  So I had to go back into Users.  Add my User accounts to the Users Group.   The accounts were still there, they just weren't associated to groups in this pc. 

     

    I think the above command resets permissions in the registry.

     

    It Worked. Finally!! Thanks Mogulman1. For the last 72 hours I tried several installing, uninstalling and reinstalling and tried all sorts of regedits etc.  ... nothing worked until I fond this solution. Kudos.

    • Proposed as answer by adamrogers Thursday, August 16, 2012 10:54 AM
    • Unproposed as answer by adamrogers Thursday, August 16, 2012 10:54 AM
    Thursday, August 16, 2012 10:52 AM
  • "...Anyway.. I right-clicked on Command Prompt, under Start Programs, Accessories, and Ran as Administrator, from my admin account.

    Then I did the following command:

    secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose..."

    Thank you very much.  I had installed fine on 3 other machines (msdn), but one continually prompted me to reconfigure each time I opened an MS Office program.  Coincidentally, I was running Libre Office concurrently (actually LO3.3 was installed first).  Now both work and MS is the default.  Thanks again, this worked without reboot, although I will verify the local user account settings.  Thanks!!
    Sunday, August 19, 2012 8:51 PM
  • Anyway.. I right-clicked on Command Prompt, under Start Programs, Accessories, and Ran as Administrator, from my admin account.

    Then I did the following command:

    secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose

    Then I rebooted

    I noticed after I rebooted that only my admin account had permissions on the machine.  So I had to go back into Users.  Add my User accounts to the Users Group.   The accounts were still there, they just weren't associated to groups in this pc. 

     

    I think the above command resets permissions in the registry.

     


    I cant believe it, it worked!!!I have searched for this solution and finally it work.

    Thanks!!!


    • Edited by Bonjyma Monday, August 20, 2012 11:45 PM
    Monday, August 20, 2012 11:44 PM
  • Ok guys i found a solution!

    For you all that secedit didn´t work, you just have to open regedit and in HKEY_LOCAL_MACHINE/SOFTWARE/MICROSOFT rigth click, choose permisions, then click advanced, çlick add and write creator click ok, click apply, ignore the message, click ok again, add to the permissions and voilá! All your office tools will work without that boring screen again :)

    If this doesn´t work this way by rigth clicking on word icon for example and choosing run as administrator the program should start without the configuring window apearing. 

    Good luck to you all guys, it sure took me 3 good days to resolve this issue ;)

    Tuesday, February 05, 2013 4:48 AM
  • Hi

    I have now tried all these, but still have the problem in Excel and Access. Do anyone have an idea where the problem is?

    All other programs work perfect but thos two.

    Friday, March 01, 2013 6:59 PM
  • Thanks, mogulman1.  This worked like a charm.  If anyone tries this, remember you need to insert spaces in the right places. It is not very clear from the message where they are. Below I have inserted underscore at each place where you need to insert a space.

    secedit_/configure_/cfg_%windir%\inf\defltbase.inf_/db_defltbase.sdb_/verbose

    Sunday, June 09, 2013 2:52 PM
  • I tried this & it worked

    C drive\Program Files (x86)\Common Files\Microsoft
    shared\Office12\OfficeSetupController.

    Change the setup.exe file to something like
    "__setup.exe"
    Try opening ms office - should work
    Rename file back to
    setup.exe & should still work.

    Wednesday, September 18, 2013 5:42 AM
  • worked great!
    Saturday, September 21, 2013 10:33 AM
  • For me it was related to Adobe Acrobat XI and plug-ins, I uninstalled Both (Office 2010 & Acrobat XI) and used a batch file to remove all registry related to Offices installation, installed again Office 2010 after a restart(office working well after installation) then installed Acrobat XI by custom & unselected all plug-ins except AutoCAD & form creation (for safety may be just office one was enough) now both live together peacefully in my PC.
    Sunday, November 10, 2013 7:39 AM
  • Yes!! Finally! Worked for me also! Thank you very much!
    Monday, April 14, 2014 6:30 PM