none
Outlook 2010 Windows 7 - multiple exchange accounts - asking for wrong credentials

    Question

  • Hi guys :D  I work within Windows 7 64bit with Outlook 2010 and have a number of profiles holding single mailbox accounts and one profile holding multiple mailbox accounts.  My issue is that no matter which profile I log into to I get a mixture of credential security windows asking for login details.  So I might get the prompt for one exchange account but with the email address for another exchange account as the username.

    I have to flick between the multiple profile account and the individual ones as some clients work heavily with categories and the public folders take the category list from the main account within the profile.  All very confusing but I've got my head round it except for the annoying login requests.

    I'm pretty much an Office power user but I'm not the server administrator so can't access that.  I've been into Credentials and deleted everything related that is saved under Windows and Generic Credentials but I'm still getting prompted for the wrong accounts. 

    Incidentally, everything was working fine within the multiple profile account until I had to create the accounts as individuals as well.

    Any ideas very much appreciated :D

    Thursday, November 18, 2010 8:57 AM

All replies

  • Hi,

    Are you seeing the credentials prompt when you launch Outlook 2010? And are you saying that the cred dialog box contains the last logged in account you did, which means you have to type in the different username?

    Sorry to make you repeat yourself, but here's what I took from your post:

    1. Open Outlook in Profile #1 for User1@domain.com ---Get prompted for username\password. Enter and go into Outlook.

    2. Close Outlook

    3. Open Outlook in Profile #2 for User2@domain.com --Get prompted for username\password, but noticing that User1's pre-populated in the credentials dialog. You have to type in User2's username\password and then proceed into Outlook.

    Is this what you are asking about?

    What would you like to see happen?

     

    Thanks and take care,

    Jahawk MSFT

    Monday, November 22, 2010 11:06 PM
  • I need to reply to this because it has been driving me nuts.

    First off, to what Jahawk was saying, you can teach each profile to default to the correct username/password. But, what fails, is when you have multiple Exchange mailboxes in one profile.

    I happen to have three exchange mailboxes, each on their own domain, but each served from the same exchange server. That may be the issue with the bug, behind the scenes all three communicate via HTTP/RPC to the same front-end. But internally they are bound to three different domains.

    Each time I open Outlook 2010 on win7 x64, I get prompted for passwords.

    So, I have three accounts: frank@oconnors.org, foconnor@digitalsolutionsllc.net, frank@hydragroup.net. Each of these accounts are tied to their own domain account. I use UPN syntax to log in to each. 

    First account in my inbox is "frank@oconnors.org". I get prompted with the Authentication tiles connect dialog box, it says:

    "Connecting to frank@oconnors.org"

    Two authentication tiles are listed:

    1. frank@hydragroup.net, no password.

    2. Use another account.

    It just so happens "frank@hydragroup.net" is the last one I fill out each time, so it's the first one offered.

    So I fill out "use another account" and put in my frank@oconnors.org credentials, and choose to Remeber Credentials.

    Immediately, after hitting OK, I get a new prompt, its:

    "Connecting to foconnor@digitalsolutionsllc.net"

    It offers:

     

    1. frank@hydragroup.net, no password.

    2. Use another account.

    I choose to 2, and put in my digitalsolutions info. I ask it to remeber my credentials.

    Now, it'll bring up my inbox's. It does not ask me for credentials to my HydraGroup account, because that happens to be the one I entered last time I used outlook. 

    Now, if i close outlook, and re-open it, It will default to "foconnor@digitalsolutionsllc.net" as the default crednetials it stored. Meaning I'll have to fill out the authentication dialog for oconnors.org and now hydragroup.net

    Basically, it remebers the last credential entered as valid for the whole profile. My guess is this is because my exchange server 'name' is the same for all three. It needs to store the credentials indexed by the email address.



    Edit:

    I should point out that the Credentials Manager / Vault, shows each account as three different individual windows credentials. These may have come from access OWA however. It also shows a credential for "hermes.internal.local" which is the internal domain name for the Exhange server. It shows yet another credential for the HTTP/RPC server host name (external DNS resolvable name).

     

     

     

    • Edited by McMalakai Tuesday, December 21, 2010 11:57 PM more info
    Tuesday, December 21, 2010 11:45 PM
  • I need to reply to this because it has been driving me nuts.

    First off, to what Jahawk was saying, you can teach each profile to default to the correct username/password. But, what fails, is when you have multiple Exchange mailboxes in one profile.

    I happen to have three exchange mailboxes, each on their own domain, but each served from the same exchange server. That may be the issue with the bug, behind the scenes all three communicate via HTTP/RPC to the same front-end. But internally they are bound to three different domains.

    Each time I open Outlook 2010 on win7 x64, I get prompted for passwords.

    So, I have three accounts: frank@oconnors.org, foconnor@digitalsolutionsllc.net, frank@hydragroup.net. Each of these accounts are tied to their own domain account. I use UPN syntax to log in to each. 

    First account in my inbox is "frank@oconnors.org". I get prompted with the Authentication tiles connect dialog box, it says:

    "Connecting to frank@oconnors.org"

    Two authentication tiles are listed:

    1. frank@hydragroup.net, no password.

    2. Use another account.

    It just so happens "frank@hydragroup.net" is the last one I fill out each time, so it's the first one offered.

    So I fill out "use another account" and put in my frank@oconnors.org credentials, and choose to Remeber Credentials.

    Immediately, after hitting OK, I get a new prompt, its:

    "Connecting to foconnor@digitalsolutionsllc.net"

    It offers:

     

    1. frank@hydragroup.net, no password.

    2. Use another account.

    I choose to 2, and put in my digitalsolutions info. I ask it to remeber my credentials.

    Now, it'll bring up my inbox's. It does not ask me for credentials to my HydraGroup account, because that happens to be the one I entered last time I used outlook. 

    Now, if i close outlook, and re-open it, It will default to "foconnor@digitalsolutionsllc.net" as the default crednetials it stored. Meaning I'll have to fill out the authentication dialog for oconnors.org and now hydragroup.net

    Basically, it remebers the last credential entered as valid for the whole profile. My guess is this is because my exchange server 'name' is the same for all three. It needs to store the credentials indexed by the email address.



    Edit:

    I should point out that the Credentials Manager / Vault, shows each account as three different individual windows credentials. These may have come from access OWA however. It also shows a credential for "hermes.internal.local" which is the internal domain name for the Exhange server. It shows yet another credential for the HTTP/RPC server host name (external DNS resolvable name).

     

     

     


    It is driving myself crazy to a point where I gave up and use IMAP for the additional accounts myself
    Friday, December 31, 2010 4:32 PM
  • It was driving me nuts as well... thanks for the IMAP tip. :)

    Saturday, January 22, 2011 2:09 AM
  • Yeah, I wish we could get someone to remark this as 'unanswered', maybe we can have it get some attention from the Outlook team.
    Tuesday, January 25, 2011 6:02 PM
  • Hi!

    I didn't mark it as Answered, but I can Unmark it as an Answer.

    To proceed with this issue I would suggest opening a Support Incident with the Outlook team so you can file an incident on it.

    If this proves to be a problem with the product, a bug will be filed and it will be sent up to the Outlook Product team for further investigation.

    If this issue proves to be a "By Design" issue, a Design Change Request can be filed on your behalf.

    For an issue like this, we'd need to set up an Outlook 2010 profile with multiple accounts and reproduce exactly what you are seeing. From there, after we can reproduce the behavior consistently, we'd like need to run an iDNA trace to be able catch what is happening at a code level with Outlook. --Trace the callstack and see what's happening underneath the cred prompts and go from there. --Anyways, that's my opinion of how to approach this issue.

    Please visit the following link for details on the various support options available to you: http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone

    Hope this helps to get us moving toward a resolution for you all.

    Jahawk MSFT

     

     

    Tuesday, January 25, 2011 6:51 PM
  • Definitely reproducible.  It's an annoyance right now, I just try to stay logged in on all my machines ( all four have this bug). If I get free time or feel like saving the world, I'll try and go through your process and help you guys out.

     

     

    Tuesday, January 25, 2011 6:56 PM
  • I have similar issue/bug, Outlook 2010, Windows 7 64bit, I have 1 profile with 3 exchange accounts, all go to different servers/domains and use RPC over HTTP, the first and primary exchange account shows and works correctly, the second one shows up in the left hand outlook tree, however with the third exchange accounts content!

    so only 2 show up in the outlook tree and the email address/name does not match the contents, like the second and third exchange accounts have been put through a blender.

    Public folders also only show 2 sets but this time the 3rd exchange account shows and its contents are correct.

    Seems to be big issues when using 3 (and maybe 2) exchange accounts under the 1 profile in outlook 2010, anyone else having this strange issue? seems like a bug to me but suprised more people are not reporting this.

    Justin.

    Saturday, January 29, 2011 1:34 PM
  • I've got several users with the same issue here. However, all the mailboxes are on the same domain, so I don't think the multiple domains is the issue, it's just multiple mailboxes in a single profile.

    It also doesn't seem to matter whether they're using Windows 7 32 bit or 64 bit. There are all, however, using Outlook 2010 32 bit.

    Monday, January 31, 2011 4:39 PM
  • All it takes for this to happen is 2 mailboxes on one profile. I hope this can be fixed soon, because it's really confusing to the users.
    Monday, January 31, 2011 4:43 PM
  • Is it possible that if the user has administrator privileges on his machine, he doesn't get this annoying problem?

     

    I have noticed that a 'standard user' with 4 mailboxes is having this issue, whereas another user 'administrator' with 2 mailboxes doesn't have any problem. Their machines are identical in terms of hardware and software:

    Windows 7 64 Bit + Office 2010 32 Bit connected to the same Exchange server (all the mailboxes are from the same domain)

    Wednesday, February 02, 2011 10:30 PM
  • I'll try that, but I think most of the users here with multiple mailboxes are administrators on their PCs.
    Wednesday, February 02, 2011 10:40 PM
  • Is it possible that if the user has administrator privileges on his machine, he doesn't get this annoying problem?

     

    I have noticed that a 'standard user' with 4 mailboxes is having this issue, whereas another user 'administrator' with 2 mailboxes doesn't have any problem. Their machines are identical in terms of hardware and software:

    Windows 7 64 Bit + Office 2010 32 Bit connected to the same Exchange server (all the mailboxes are from the same domain)

    I have admin on my boxes ( Win 7 (x32 and x64) + Office 2010 x32 ) and still see this behavior.

     

    Friday, February 04, 2011 5:12 PM
  • I had this same issues, the user was getting a prompt for his credentials everytime he started Outlook. I fixed it by giving the user administrator rights, started Outlook (no prompt) and removed the administrator rights. Now it's fixed.
    Tuesday, March 15, 2011 12:14 PM
  • I had this same issues, the user was getting a prompt for his credentials everytime he started Outlook. I fixed it by giving the user administrator rights, started Outlook (no prompt) and removed the administrator rights. Now it's fixed.


    What a random fix that is :)

    Cheers for updating .. was that a domain user ?

    Tuesday, March 15, 2011 12:16 PM
  • I had this same issues, the user was getting a prompt for his credentials everytime he started Outlook. I fixed it by giving the user administrator rights, started Outlook (no prompt) and removed the administrator rights. Now it's fixed.

    Were they using more than one mailbox?

     

    My users with two mailboxes are administrators on their computers already.

    Tuesday, March 15, 2011 3:18 PM
  • Yeah, this doesn't fix the problem when you have more than one domain account pointing to the same HTTP RPC proxy point.
    Tuesday, March 15, 2011 5:27 PM
  • I am having the same problem, hope we receive an update of this issue any time soon.

     

    Tuesday, March 22, 2011 5:19 AM
  • Hi, I also have this issue.

    I want to connect to two Exchange 2010 mailboxes on the same server or domain with Outlook 2010 and Windows 7 Professional.

    I always have to type the credentials for the two mailboxes when I start Outlook. Is it not possible to link this two mailboxes to one account or username ? It seems that the credentials can only be stored for one mailbox on the client ...

     

     

    Friday, April 01, 2011 6:18 PM
  • This also drove me NUTS, but I think I found a solution. What worked for me (Outlook 2010) was to give the "primary" account (the one that is used to log onto the domain at the PC in question) "Full Access" permissions on the other Exchange mailboxes (in Exchange 2007 Management Console, go to Recipient Configuration, select the other mailbox(es) and click the "Manage Full Access" link. Then add the primary user to the list).

    Example:
    If I log onto the domain at my PC as a user called Primary (email address of primary@somedomain.com), then I would need to give Primary full access permissions to any additional Exchange accounts I want to open within Outlook. If I add a second Exchange account called Secondary (secondary@somedomain.com) I'd need to give Primary "Full Access" rights to Secondary's mailbox.

    Hope this works for others as well...  :-)


    Sal Sorice SoriceConsulting LLC www.soriceconsulting.com
    • Proposed as answer by Scion111 Tuesday, May 03, 2011 5:50 PM
    Tuesday, May 03, 2011 5:50 PM
  • We're actually on Exchange 2010, but I've done as suggested, and will see if it helps.
    Tuesday, May 03, 2011 10:32 PM
  • driving me nutz too
    Ok - have a friend running Win7 Pro x64 and Outlook 2010 32bit with 3 hosted mailboxes on Exchange 2010 with CLOUDBLOCK Hosting... We have all three mailboxes opening in the one profile and EACH TIME she opens Outlook it prompts her for credentials for each mailbox. Credentials are email address (username is email address) and password and it doesn't even ask for the same account credentials each time.... For example user1@domain.com may be prompted for credentials and it will have a guess and may put up user2@domain.com with the curser in the password field.... This means she has to choose another account and type the currect email address and password and do this 3 times every time she opens outlook.

    REALLY THIS IS REDICULOUS. Any help would be great.

    Friday, May 20, 2011 10:23 AM
  • Aaaaargh.....

    Thought my solution cited above worked:
    "I tried to fix this by granting the main Exchange account (the first one setup and the default reply account) Full Access permissions on the other 2 mailboxes. Worked great! No prompts for passwords."

    HOWEVER,
    Whenever you try and send an email using one of the other accounts, the mail gets returned saying you are not allowed to send on behalf of the other user. Kinda makes sense from the credential point of view. I tried to no avail to give send as permissions on the other mailboxes, but the only thing that worked was to remove the full access permissions and go back to the multiple password prompts.

    I'm going to try another solution today and will advise of the outcome.


    Sal Sorice SoriceConsulting LLC www.soriceconsulting.com
    Friday, May 20, 2011 2:32 PM
  • What "seems" to work for my situation:

    1. Give the primary user (the one that belongs to the user who logs onto the PC and is the default Exchange account in Outlook) both Full Access and Manage permissions using Exchange Management Console on the other Exhchange mailboxes that you want to open in Outlook.

    2. Log onto the PC and delete any .OST files that exist.

    3. Logoff/logon and restart the PC a few times (not sure how many it took). I also did a few "gpupdate /force" commands on the PC. This step is a bit quirky, or at least it was for me.

    EVENTUALLY, I was able to logon to the PC as the primary user and was able to send using the other email accounts. The only WEIRD thing I am encountering is that Outlook is prompting for the username/password of the primary account (even though it's already logged onto the domain).

    This is a truly goofy way to get it to work, but I guess we'll have to muddle through until Microsoft realizes what a HUGE hassle this is. I'm not going to even bill my client for all the time its taken me to fiddle with all these "workarounds" - I can't justify it.

    Plesae let me know if this approach helps anyone else - or, better yet - if anyone knows of a patch to fix it for real!!!


    Sal Sorice SoriceConsulting LLC www.soriceconsulting.com
    Friday, May 20, 2011 4:23 PM
  • Typo correction - sorry...

    In step 1

    "both Full Access and Manage permissions using Exchange Management Console" should actually read

    "both Full Access and Send As permissions using Exchange Management Console"


    Sal Sorice SoriceConsulting LLC www.soriceconsulting.com
    Friday, May 20, 2011 6:59 PM
  • Same Issue here since we started delivering Office/Outlook 2010 to our users:

    • Win7, 32 Bit, domain joined, only one main profile, Exchange 2007
    • I still have to check how many and which mailboxes the users open additionally to their own one (we have maiboxes on TWO subdomains)
    • We have gobal security groups to which we grant full access rights in Exchange Management Console (the users added to those groups are able to open additional mailboxes)
    • We never had such issues with Office/Outlook 2003 and still do not have on the clients which were not yet migrated to Win7/Office2010
    • As I had an Exchange MS case open, the engineer offered this registry-key:

      HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\RPC
      UseWindowsUserCredentials[DWORD]:1
    • Unfortunately I was reported that it did not solve the problem either. One of our users may have to type in credentials three times a day and on the other hand she/he may work without typing anything during serveral days, which makes the whole thing very very random
    • Not all of our users seem to be affected. I am testing myself with 10 additional mailboxes open of both domains we have

    We are also considering to open a separate case with Microsoft's Outlook Team.

    I will report back next monday/tuesday.

     


    Friday, May 27, 2011 11:33 AM
  • Outlook 2010 seems to do a lot of autodiscovery, so try installing the main user profile by clicking the MANUAL configuration option.

    When prompted with the user's eMail-Address, try to choose OTHER account and type in correct Domain and username and password.

    In our cases this did not help much, unfortunately and we are still investigating why some users are asked to retype their credentials more than once a day.

    Monday, May 30, 2011 1:32 PM
  • For testing purposes I advised to disable HTTP completely. And it didn't help either. So I am not sure, whether Outlook 2010 does some new RPC over TCP/IP not using the correct credentials all the time.

    Monday, May 30, 2011 1:33 PM
  • Dear all,

    somewhere I read about the Credentials-Manager you can find in the system-settings. In FIVE of our 10 cases (although we have thousands of users), we could solve the problem removing the MS.Outlook entries in the Credentials-Manager. Some of the entries were incorrect anyway. Those users complained about Outlook 2010 asking for credentials when starting up the program.

    But, as I told, we have also some cases where users are asked randomly to retype the credentials more than once a day and on other days they are not.

    I am still investigating whether there could be a relation or whether we are facing different problems/causes.

    I have no clue yet, why some users have entries in the credentials manager and all the rest does not and why some of our users are affected whilst thousands are not.

    Ah, it was here, I read about the Credential Manager: http://answers.microsoft.com/en-us/office/forum/officeversion_other-outlook/windows-7-and-outlook-2010-microsoft-security/209793dd-cbe0-48cc-8936-9bd3ff67966c


    Rosario

    Tuesday, May 31, 2011 1:31 PM
  • Has anyone been able to find a definitive solution to this? The fixes I described above did not work for long. Eventually, the password prompts return (sigh).

    This bug, in my opinion, makes using multiple Exchange accounts with Outlook 2010 completely unusable and a worthless "feature". For example, I have a client with 7 different email addresses. He would NEVER be able to handle having to enter 7 sets of credentials just to get Outlook to open - that's ridiculous.

    Has anyone been in touch with any Micorsoft Outlook personnel that can actually get this problem the serious attention it deserves? Does anyone know the best way to get in touch with the proper Outlook progamming / development team?


    Sal Sorice SoriceConsulting LLC www.soriceconsulting.com
    Friday, June 10, 2011 7:07 PM
  • Last week I could solve another one of our cases. The user complained that Outlook asked to type in the credentials after docking off his  notebook and hence passing to wireless-connection which works only after starting our cisco vpn-client. I feel this correct, but on my test-notebook I can even remove the ethernet cable for 3 days letting Outlook running and when I plug in the cable I can continue to work without retyping my credentials. If Outlook goes offline after this time-out I need only to switch it back online. So I decided to make ONE Entry in the credential manager of the affected user with *.yourdomain.yourcountry and his domain password. This way now he is able to start/stop vpn, to dock in and dock off his notebook as he likes, without having to type in any credentials. Strangely only Outlook asked for credentials, whilst his domain logon persisted.

    So I have only TWO remaining cases to solve. In one of them maybe it is Outlook going randomly offline and when the user clicks to switch it online, the credentials are asked. We are observing during this week and I will report as soon as possible.


    Rosario
    Thursday, June 16, 2011 8:58 AM
  • Two weeks ago I also succeeded in solving our TWO last cases:

    in the first, Outlook went offline for an unknown reason. When I brought it back online, Outlook asked for new credentials als usual. So when I went to check the credential manager again, I found a wrong MS.Outlook-Entry as I already told before. I removed it and from then on, the user was never asked to type in credentials again.

    in the second one, the problem was more complex, but very maddening:

    • the user told me that whenever she left the computer and came back after a while, she had to type in her credentials
    • so I asked whether there was a screen-saver with password protection enabled
    • it was, but without password protection
    • so I asked her to raise the delay to 2 hours
    • when I went to see her computer I deactivated the energy saving option of the NIC in the hardware-manager, but I forgot to check the overall Energy saving options. And I made a correct entry with password in the Credential Manager, only to get her rid (after 3 months!) of nasty behaviour
    • after I arrived back into my office she had already mailed me that this didn't help
    • so I went back next day to observe her computer during the whole day
    • I had already asked her to log into another computer in her office to verfiy that the credentials problem occurred only on her hardware. This proved to be so. She was never asked to type in credentials on the second computer.
    • Observing and checking the global Energy-Saving-Options in the Control-Panel I finally discoverd that this NOTEBOOK computer was set to switch to standby after 30 Minutes even when working docked and with power cord!
    • so I set it to never and lowered the screen-saver to 15 minutes

    Incredible. I must believe, that waking up from standby she not only had to enter her Active-Directory credentials to log into the domain but also again in Outlook.

    Now Energy-Saving Options are turned off and for any case she as a correct entry in the Credential Manager, which solved the problem.


    Rosario
    • Proposed as answer by Fujilives Wednesday, September 21, 2011 7:40 PM
    Wednesday, July 06, 2011 1:22 PM
  • @Rosario2 -- IT WORKED!

    I just went into the windows 7 credential manager and deleted all credentials for the user that was experiencing the issue (we'll call him the root user).  To my suprise, it didn't ask for the password again, and all three exchange accounts on that user's outlook 2010 account worked flawlessly.

    I should point out that I also had given "full access" permissions to the other exchange accounts to the root user, so I'm not sure if that has anything to do with why I was not prompted for passwords after the Credential Manager settings were deleted (IE. the root user's computer login credentials were already being passed to outlook and he had ownership of the other people, so no prompt was necessary).

    Thanks for the tip Ros!

    • Edited by Fujilives Wednesday, September 21, 2011 7:35 PM
    Wednesday, September 21, 2011 7:33 PM
  • I'm having a similar problem to this.  The scenario is:

    1 pc (running win 7 Pro 32bit) joined to a domain with outlook 2010 installed.

    The computer is on the staffdesk in the LRC and is logged on with a generic account.  What i am trying to achieve is to setup multiple profiles on this login.  So the computer is logged on with "LRCstaff"  which is a domain account that has no exchange account connected to it.

    The individual members of staff have created a profile under this logon and are expected to put their credentials in each time they come to log on to Outlook, as soon as they put their correct credentials in a second prompt appears for whoever is the first profile (alphabetically) in the list.

    example:

    user1 profile

    user2 profile

    user3 profile

    user3 loads their profile and provides user3's password, then a second box pops up asking for user1's password.

     

    i tried deleting user1 profile and relogging on as user3 and it then requests the next on the list in this case user2's password.

    i removed any saved credentials in the credential manager and tried again, same issue.  i have been informed by the staff that this didnt happen before when they were on outlook 2007.

     

    Any ideas/thoughts on how to resolve this?  i tried looking for the registry entry rosario2 mentioned but it didnt exist does it need creating?

    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\RPC
     UseWindowsUserCredentials[DWORD]:1

     

    Cheers

     

    Locrieth

     

     

     

    Thursday, November 17, 2011 1:44 PM
  • In your case, you may put it to 0, so as to say DO NOT USE the windows-credentials of the logged in user on the domain, but use the credentials given, when the Outlook-Profile is selected.
    Rosario
    Thursday, November 17, 2011 2:21 PM
  • Hi Rosario2

    Right i looked in the registry but i cant find rpc in that location HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\

    ive got the following dwords/binaries:

    lastuilanguage

    loadmacroprovideronboot

    MTTA

    MTTF

    MTTT

    outlookname

    outlooksessioncount

     

    and ive got the following keys:

    addins

    autodiscover

    display Types

    Journal

    Messages

    office explorer

    options

    ost

    perf

    resiliency

    search

    security

    setup

    sqm

    userinfo

     

    Do i need to create rpc?  if so is it a key or a dword/binary?

     

    Thanks for responding

    Locrieth

    Thursday, November 17, 2011 2:57 PM
  • If it is not there, you would have to create it. But I can not assume any responsibility, as I said, this key was offered by an MS engineer but did not solve our problem. So be careful.

    I hope you set up your mutliple Outlook-Profiles in the control-panel->MAIL so as to be able to choose the profile you want, just when Outlook starts up. If so - and I do it myself to check our students mailboxes if they have problems - then you should not have any problems at all, because every user defined in those profiles has its own credentials which should correctly be asked to enter when you start up Outlook.

    I have TWO profiles set up this way and when starting up Outlook, I choose my own profile, which corresponds to the login user I use to log into the domain, so no credentials are asked for, but choosing the other one, with a students mailbox, I am asked for the credentials of this student.

    Everything should work transparently without any registry-key or other tricks.


    Rosario
    Thursday, November 17, 2011 3:08 PM
  • Hi Rosario,

     

    yeah that is how i created each of the profiles via the mail in control panel.  I have been informed that it worked fine in 2007 logging on as the generic account (which has no exchange account) and setting up each staff members profile.  I expected each profile to request credentials, by default, as the none of the profiles created will log on using the generic user credentials.  But as soon as you enter the users password for the exchange account it just asks for the credentials of the first profile in the list.  Incidentally if you try and authenticate in this second box it fails, but if you just click cancel it then logs in to the correct account.  The LRC staff said its not a major problem, I'm just more interested in why its doing it since we moved to 2010?

     

    Locrieth

    Thursday, November 17, 2011 3:38 PM
  • And you checked the credential manager again? to remove the faulty entries Outlook creates there?
    Rosario
    Thursday, November 17, 2011 3:42 PM
  • I have recently experienced the same symptoms on Win7 64-bit.  I have only one account.  The 'credentials' box keeps coming up when I'm trying to send/receive email; then when I confirm and ask the system to note my email, I get a receive error - it seems to send OK.  I tried to sort this with my ISP (BT) and a change of password seemed to work for an hour, then the symptoms returned.  When I send again (a test message) it seems to work.  Soo frustrating.

    • Edited by sweepling Wednesday, November 23, 2011 5:39 PM
    Wednesday, November 23, 2011 5:34 PM
  • As I wrote, you could remove the faulty entries and put a correct one in the credentials manager:

    >>make ONE Entry in the credential manager of the affected user with *.yourdomain.yourcountry and his domain password.


    Rosario
    Tuesday, November 29, 2011 1:32 PM
  • Dear all,

    as I said, we migrated the clients to windows 7 and Office 2010 during last year. Now, since a couple of months, we are preparing our new Exchange 2010 Servers. To do so we followed the procedures documented by Microsoft and integrated the new EX2010 environment into the existing EX2007. I would suggest not to do it without Assistance from Microsoft, as the whole integration to run both EX2007 and EX2010 is not so trivial as documentation lets suppose. As we had an issue with Free/Busy Times the MS engineer proposed us to move the existing Public Folders from 2007 to 2010 despite documentation saying that Public Folders are no more necessary in 2010 because Free/Busy times are collected right away out of the users' mailboxes. Anyway we did it with MS' assistance and we needed  a whole week to apply again the workarounds I proposed here to make the Outlook Credentials window disappear.

    As I noticed during my tests, disabling the HTTP-Connection also helped to avoid the Credentials window. But unfortunately after every reboot of Outlook the HTPP-Connection Option returned to be active and there was no means to disable it permanently.

    So today the MS Engineer proposed the following powershell commandlet to disable the Option at mailbox level of every user you like:

    Set-CASMailbox MailboxName -MAPIBlockOutlookRpcHTTP:$true

    This is documented here:

    http://technet.microsoft.com/en-us/library/dd439367(EXCHG.80).aspx

    It is not clear, however, why Outlook or Windows is not passing the windows credentials correctly in this situation, where Outlook tries to connect to another Exchange Server, in our case the Public Folder Server where we created the replica of the original PF on 2007.

    In any case, crating a correct entry for the given server or whole domain in the credential manager still corrects the problem too, if a user needs to use HTTP in his Outlook to access his mailbox over internet without a VPN connection.

    I will report back, if we find a better solution to pass those credentials automatically and transparently as it should be.


    Rosario

    • Edited by Rosario2 Monday, January 09, 2012 4:02 PM
    Monday, January 09, 2012 3:58 PM
  • Awful, awful, what we discovered today: one week ago I saw in the Outlook Connections window (CTRL-Right-Click on the Outlook-Icon in the lower right corner of the Task-Bar) that Connection to our new Public Folder server on EX2010 switched to HTTP all the time despite disabling HTTP in the Outlook 2010 client. And I noticed and reported the MS Engineer assisting us to solve this Public Folder issue, that Outlook happened to hang for about 20 seconds in certain cases. On a TMG Server this morning we found an error message saying that one of our CAS-Servers could not be resolved by DNS. This has nothing to do at all, but as I misread the name of the server, thinking it was my Mailbox Server on which we had migrated our Public Folders, I started to ask my network colleagues to have a check on this and on the whole connectivity of the servers among each other.

    And we found it: when migrating the Public Folders the INTERNAL firewall/ rules had been rewritten in analogy to what they were for the previous Public Folder servers on EX2007 and so my colleagues who did the migration forgot to adapt some rules. So this finally was the reason why connection to this server was causing troubles and switching to HTTP all the time and for another unknown reason, maybe because the http protocol routes via Internet to the EXTERNAL Firewall and our ISA or new TMG Servers, this asked CORRECTLY for the users' login credentials.

    On the other side, if the recurring logon prompt is a symptom of bad connectivity, why did I found bad entries in the CredentialManager? I only suppose they were bad, because the users were prompted again and again until I deleted them or in other cases until I made a correct entry to allow login on the whole domain with *.yourDomain.local

    Anyway the connections to the new PF server are now stable, fast and permanent and the connections window in Outlook shows that the preferred connection Method is TCP/IP even if the HTTP-Connection Option is selected by default, as before. And the users are no more prompted for their credentials.

    But I am still confused.


    Rosario
    Wednesday, January 11, 2012 5:03 PM
  • This also drove me NUTS, but I think I found a solution. What worked for me (Outlook 2010) was to give the "primary" account (the one that is used to log onto the domain at the PC in question) "Full Access" permissions on the other Exchange mailboxes (in Exchange 2007 Management Console, go to Recipient Configuration, select the other mailbox(es) and click the "Manage Full Access" link. Then add the primary user to the list).

    Example:
    If I log onto the domain at my PC as a user called Primary (email address of primary@somedomain.com), then I would need to give Primary full access permissions to any additional Exchange accounts I want to open within Outlook. If I add a second Exchange account called Secondary (secondary@somedomain.com) I'd need to give Primary "Full Access" rights to Secondary's mailbox.

    Hope this works for others as well...  :-)


    Sal Sorice SoriceConsulting LLC www.soriceconsulting.com

    This solution worked for me! (Exchange 2007, Outlook 2010)

    After that I deleted all credentials from credential manager (on workstation) and if prompt I entered same username and pass (Primary) for all additional mail accounts (I added two additional as stated above).

    I've also added send as permissions to same user, however on one workstation that didn't work from beggining and I have to waited hour or two to be able to successfully send emails from additional account (before that I got error "user doesn't have permissions to send from this email address").

    Friday, April 13, 2012 11:04 AM
  • Wireless connections in the Building will cause problems as well. We found that if the wireless client did not connect via VPN or to the domain and forced Outlook to connect Via HTTP it would prompt for a password.

    We found an executive that was connected via Network in his office, went to a meeting using wireless, the Outlook client would prompt because it was connecting via HTTP over OWA, but it was coming from the Outlook regular Client so the culprit was actually the way the Wireless connection was set up. If you set it up to connect to the Domain this problem goes away.


    GuitarPlayer40years

    Monday, August 20, 2012 4:10 PM
  • I  noticed the same issue here also. When Outook takes HTTP for ANY reason, i.e. apparently despite having a fast TCP/IP connection, Outlook decides to switch to HTTP, then the outlook login prompt appears.

    So I never found a solution to this. Apparently you can not force Outlook to never use HTTP. If you remove the option, next time you start up, Outlook reconfigures itself and sets the option to enabled. The servers are apparently taken from Autodiscovery, and as we still have a mixed Environment of EX07 and EX10 due to our upgrade-path, as suggested by Microsoft, we get also the wrong server-settings depending on where the user's mailbox resides, either on EX10 or EX07 Mailbox-Server.

    During the last months I discovered, if you CTL-right-click the Outlook icon on the lower right corner of the task-bar and popUp the CONNECTIONS Window, that the login window appears when you have bad connectivity with the Active-Directory-Servers, i.e. Domain-Controllers. I get connection times of 500 to more than 1000 whilst in normal cases these values remain below 10.

    So now I am not sure - it is more than a year since we began to struggle with that nasty login prompt - if it was ever since a bad connectivity to one of the AD-Servers, and nothing else. Maybe not even the Public-Folder issue I reported here.

    I am still confused, but we can reproduce the situtation by clicking RECONNECT in the outlook-connections window. If the AD-servers respond quickly, everything works well. If one doesn't answer, Outlook switches to the next, and next again, until it gives up, probably after a specified number of attempts or time-out, and then it presents the login-prompt, as if to say "I could not get/reach any DC, so please try to retype your credentials". Sometimes this doesn't help and the prompt comes up again and again. Until you restart Outlook or you click RECONNECT in the mentioned connections window.

    Any hints would really be appreciated, unless we have to open a case not with Exchange-Engineers but with Outlook-Engineers at Microsoft to explain and analyze our Outlook-Connectivity issues.


    Rosario

    Monday, August 20, 2012 4:34 PM
  • In case there are people still battling with Outlook 2010 continually asking for credentials while connecting across domains etc to a Exchange environment, this may help you.

    Our environment is set up something like as follows.

    Exchange2010.Domain1 (New Domain been set up, resources being migrated from domain1 & 2)
    Users.Domain2 (Trusted by Domain1, Existing Domain, to be migrated to Domain1)
    Users.Domain3 (Not Trusted, Existing Domain, to be migratd to Domain1)

    We found that with the migration of email to Domain1 all our users on Domain2 were functioning correctly, but pretty much all our users on Domain3 were getting continually prompted with for Outlook credentials / locking accounts out etc.

    Anyway, as it turns out the EX2010 environment was configured with NTLMv2 (this may even be the default setting), which was the underlying cause of the issue.

    We adjusted the Group Policy settings for Domain3 (a mix of Windows XP/7 machines) and have not had an issue since.

    At a machine level, try the following:

    In the Group Policies Editor (gpedit.msc), open each of the following items in turn:
    Computer Configuration
    Windows Settings
    Security Settings
    Local Policies
    Security Options

    Now, right-click on the “Network security: LAN Manager authentication level” policy item, and then, from the context (pop-up) menu, select “Properties”.
    Now select the “Local Security Settings” tab, and then, in the dropdown box, locate and select “Send LM & NTLM – user NTLMv2 session security if negotiated”

    I hope this helps!


    • Edited by anchor_m Wednesday, September 19, 2012 6:55 AM
    Wednesday, September 19, 2012 4:25 AM
  • anchor_m, I tried your GPO setting on one of our affected Hardware but without success. I mean on the CLIENT machine. Did you mean to do it on all Exchange and Active Directory Servers?? Our actual situation is still, that we have some computers, i.e. hardware, affected because I suppose it is the hardware that tries to contact the Active-Directory DCs in a special given order, rather than the user. The affected users still have one or more mailboxes open besides their own one. As I said they have full access through an Active Directory Group which in turn I have given full access rights in the Exchange Management Console. Please note: we even did internal DNS-Splitting now to force Outlook to never use HTTP (over the TMGs) when the clients work in our internal network. But it didn't help either. We still have the outlook-credentials-window popping up. We tried even switching off the IP6 protocol on all of our AD controllers and Exchange 2007 and 2010 servers, with no avail.

    So if I can not get any other solution/advice, I will try these steps on the affected computers:

    - switch off IP6 on the client-side
    - switch off all network discovery
    - recreate the access permissions on the second mailbox


    Rosario


    • Edited by Rosario2 Tuesday, November 06, 2012 10:49 AM
    Tuesday, November 06, 2012 10:43 AM
  • Dear all, reviewing this thread and checking in the EMC showed me another phenomenon: there are some entries with a question mark in the SEND-AS and in the FULL-ACCESS permission windows, even my own user account I use to access the mailboxes when there is a problem, appears with a question mark. But my account has never been deleted. Nor did we migrate from Exchange 2003 as I found similar cases in these forums. But in one of those forums

    http://social.technet.microsoft.com/Forums/en/exchangesvrdeploylegacy/thread/50a94a45-903e-409e-ba5c-116d84bed7ff

    I found the advice to MOVE the mailbox to another database as this would automatically cleanup some logical problems. Unfortunately the question marks did not disappear nor did the error when I tried to delete them:

    Cannot remove ACE on object "CN=..." because it is not present

    So the corrupted or orphaned AD-Entries remained even after moving the mailbox from a 2007 Database to an Exchange 2010 database and back again.

    BUT IT DID solve something: the users reported that the login-credentials-window did not appear at startup of their Outlook 2010. I still have to check whether it was moving only or whether it was rather removing the AD-Group from the SEND-AS and FULL-ACCESS permissions and adding them again or a combination of both measures. We have a lot of Resource- and other unpersonal mailboxes our users keep open in their Outlook. So I am really wondering if our logon-credentials-window was simply a matter of corrupt Mailbox-Permissions. Weird is that after typing the correct credentials users could access the mailboxes without problems. We never had users complaining not being able to access one of those supplementary mailboxes. So access and credentials worked. But as I told, one or more of the AD domain controllers might have failed at Outlook startup to accept the windows-AD-logon-credentials (typed in to log onto the domain) or to send back data/informations Outlook expected leading to a timeout which in turn made the logon-window popup. I will report back as soon as I have inspected another couple of those mailboxes.


    Rosario

    • Edited by Rosario2 Thursday, November 08, 2012 3:56 PM
    Thursday, November 08, 2012 3:50 PM
  • Unfortunately, after a couple of days, the logon-credentials-window appeared again. So I checked in the Outlook Connections-Window and it still behaves as I reported previously: i.e. it works fine with certain DCs and it hangs with a couple of other DCs making the logon-window pop-up. If you click CANCEL and recreate the connections, it might succeed without logon-window and repeating again may make it appear again. So at least I can now reproduce the bad behaviour. I must investigate now what those DCs have in common. It might be that these DCs are already Windows 2008 Servers whilst the original AD Servers were set up as 2003 Servers. I know this was done for transitioning our AD from 2003 to 2008. Any Ideas are still very appreciated.

    Rosario

    Friday, November 09, 2012 2:12 PM
  • Independently from the DCs I suppose not behaving correctly, I moved all the user mailboxes and the calendar/resource mailboxes they access to EX2010 servers. Since then the users did not report any logon-window. It seems to do the trick. So lets hope it was sort of side-effect of the coexistence. In the next weeks we will start to move the user mailboxes to EX10 servers definitely and the try to decommission Public-Folders and EX07 Servers after another couple of weeks.

    Rosario


    • Edited by Rosario2 Thursday, December 06, 2012 1:14 PM
    Thursday, December 06, 2012 1:12 PM
  • I've literally just come across this issue with Outlook 2010 using 2 x hosted exchange accounts and I'll be trying out the permissions and credentials deletion trick. However, bearing in mind that this issue was raised on here several years ago, and to my knowledge still continues to be an issue, it's a disgrace that Microsoft have not addressed it. The whole point to upgrading from Outlook 2007 to 2010 was to use multiple exchange accounts so how have MS managed to completely overlook this problem. Shame on you MS for allowing this issue to leak through and furthermore so for not pulling your fingers out and addressing a unique selling point for Outlook 2010.....
    Monday, March 04, 2013 9:30 PM
  • The solution below does not work to put multiple exchange accounts within the one profile. What it does do is allow you to access multiple exchange accounts from within the one profile, without having to re-enter credentials all the time.

    It's a simple 23 or 25 step process (oh joy!) but it produces a workable solution if you put in the initial effort. I'm still annoyed that the whole process can't be more straight forward. I know it's not the exact the answer to the problem that people are seeking (myself included), but hopefully it helps, at least while something better is found or developed.

    http://support.microsoft.com/kb/291626

    To log on to one e-mail account (account A) and to have access to the mailbox for a different e-mail account (account B), follow these steps, as appropriate for the version of Outlook that you are running. Note These steps assume that both accounts are on the same Exchange server.

    Microsoft Outlook 2002 and Microsoft Office Outlook 2003 Start Outlook with a profile that is configured for the Exchange Server mailbox for account B. You may have to log on to the network as the user of account B for proper validation. On the Tools menu, click Options. On the Delegates tab, click Add. Type or select the name for the user of account A, click Add, and then click OK. In all lists, in the Delegate Permissions dialog box, click to select Editor (can read, create, and modify items). Click OK two times. If the Folder list is not visible, click Folder List on the View menu. Right-click Mailbox - user name, and then click Properties for 'Mailbox - user name on the shortcut menu. On the Permissions tab, click Add. Type or select the name for the user of account A, click Add, and then click OK. In the Name box, click the newly added entry for account A. In the Roles box, click Owner, and then click OK. Repeat steps 8 through 12 for all the other folders in the mailbox. On the File menu, click Exit and Log Off. Restart Microsoft Windows, and then log on as the user of account A. Start Outlook with a profile that is configured for the Exchange Server mailbox for account A. On the Tools menu, click E-mail Accounts. Click View or change existing e-mail accounts. Click to select Microsoft Exchange Server, and then click Change. Click the More Settings button. Click the Advanced tab. Click Add to add an account to the Open these additional mailboxes: list. Type the name for the user of account B, and then click OK three times. The mailbox for account B appears in your Folder List.

    Microsoft Office Outlook 2007 Start Outlook with a profile that is configured for the Exchange Server mailbox for account B. You may have to log on to the network as the user of account B for proper validation. On the Tools menu, click Options. On the Delegates tab, click Add. Type or select the name for the user of account A, click Add, and then click OK. In all lists, click to select Editor (can read, create, and modify items) in the Delegate Permissions dialog box. Click OK two times. If the Folder list is not visible, click Folder List on the View menu. Right-click Mailbox - user name, and then click Properties for 'Mailbox - user name on the shortcut menu. On the Permissions tab, click Add. Type or select the name for the user of account A, click Add, and then click OK. In the Name box, click the newly added entry for account A. In the Permission Level box, click Owner, and then click OK. Repeat steps 8 through 12 for all the other folders in the mailbox. On the File menu, click Exit and Log Off. Restart Windows, and then log on as the user of account A. Start Outlook with a profile that is configured for the Exchange Server mailbox for account A. On the Tools menu, click Account Settings. On the E-mail tab, click the name of the account, and then click the Change icon. Click the More Settings button. Click the Advanced tab. Click Add to add an account to the Open these additional mailboxes: list. Type the name for the user of account B, and then click OK three times. Click Next, click Finish, and then click Close. The mailbox for account B appears in your Folder List. The user for account A can send messages and meeting requests on behalf of the user of account B by entering the name of the user for account B in the From Field. These messages contain the names of the users for both account A and account B.

    Microsoft Office Outlook 2010 Start Outlook with a profile that is configured for the Exchange Server mailbox for account B. You may have to log on to the network as the user of account B for proper validation. On the Files menu, click Info. Click Account Settings, and then click Delegate Access. On the Delegates tab, click Add. Type or select the name for the user of account A, click Add, and then click OK. In all lists, click to select Editor (can read, create, and modify items) in the Delegate Permissions dialog box. Click OK two times. If the Folder list is not visible, click Folder List on the View menu. Right-click Mailbox - user name, and then click Properties for 'Mailbox - user name on the shortcut menu. On the Permissions tab, click Add. Type or select the name for the user of account A, click Add, and then click OK. In the Name box, click the newly added entry for account A. In the Permission Level box, click Owner, and then click OK. Repeat steps 8 through 12 for all the other folders in the mailbox. On the File menu, click Exit and Log Off. Restart Windows, and then log on as the user of account A. Start Outlook with a profile that is configured for the Exchange Server mailbox for account A. On the Files menu, click Info. Click Account Settings, and then click Account Settings. On the E-mail tab, click the name of the account, and then click the Change icon. Click the More Settings button. Click the Advanced tab. Click Add to add an account to the Open these additional mailboxes: list. Type the name for the user of account B, and then click OK three times. Click Next, click Finish, and then click Close. he mailbox for account B appears in your Folder List. The user for account A can send messages and meeting requests on behalf of the user of account B by entering the name of the user for account B in the From Field. These messages contain the names of the users for both account A and account B.



    • Edited by Simple_One Tuesday, March 12, 2013 8:13 AM Spelling
    Tuesday, March 12, 2013 8:08 AM
  • The issue with the two "bad" DCs is still under investigation. But we deleted the EX07 Public-Folders completely and hence Outlook 2003 Clients and similar are not supported any more. I had to switch to Outlook 2010 myself now.

    No Outlook-Logon-Window was reported since my last post. So we keep our fingers crossed and are going to look if we can keep at least one of the EX07 Mailbox-Servers alive and in coexistence for another year or so, only to be able to restore old backups from tapes to this one EX07 Mailbox server.


    Rosario

    Tuesday, March 12, 2013 10:26 AM
  • I think you would be much more comfortable if you use AD Security-Groups to grant full-access and send-on-behalf directly to those groups in Exchange Management Console. This results in one single point of administration.

    Rosario

    Tuesday, March 12, 2013 10:32 AM
  • Here's a solution to try to remove the password requests:

    1. In Outlook remove all accounts except the default account - should be the same account that the user uses to log on to the PC. Close Outlook

    2. On your Exchange server, open Exchange Management Console, go to Recipient Configuration, Mailboxes and select/highlight the next account you want to add. On the right, select "Manage Full Access Permission" and then add the default account from Outlook. Click on Manage to apply the new settings and close the dialogue box.

    3. Open Outlook and it should automatically add the new account and might not even ask for the password. This is similar to giving someone permission to manage a "Room Account" and not needing to add credentials.

    I did this and didn't even have an issue sending emails from the second account using the default account.

    Tuesday, January 14, 2014 12:41 PM
  • Yes, you are right in what concerns giving full access permissions. As I wrote earlier in this thread, I am used to grant full access and send as permissions directly on the Exchange Servers rather than via Outlook delegates. But pay attention with automapping, this could interfere with the list of mailboxes added on the Client side through Outlook. To disable automapping refer to Technet article here:

    http://technet.microsoft.com/en-us/library/hh529943(v=exchg.141).aspx


    Rosario


    • Edited by Rosario2 Tuesday, January 14, 2014 2:11 PM
    Tuesday, January 14, 2014 2:10 PM
  • I fixed this problem pretty simply, without having to change permissions on the mailboxes or make changes to the registry.

    I have clients on a hosted Exchange provider, using Exchange 2010 and Outlook 2010.  The host has autodiscover set up properly (this is important: if your servers' URLs and DNS aren't configured properly, you might be spinning your wheels here).  They use NTLM to authenticate with their proxy server to use RPC/HTTPS.  There is no synchronization with Active Directory or anything.  Anyway, I could always add two separate Exchange accounts just fine, but the third gave me problems.  Usually, when opening Outlook, it would just prompt me endlessly for the password for the new account.

    With this particular hosted Exchange provider, you have to have the public name of their proxy, and the internal name of their Exchange server (something like *.exch029.domain.local) in your Credential Manager to avoid getting prompted for a password when opening Outlook.  I noticed that when Outlook saves your password during setup from the Mail icon in Control Panel (that is, doing autodiscover while Outlook is closed to set up a new Exchange account), it does not necessarily put anything for your e-mail account itself into Credential Manager.  That is, even if you have two mailboxes on the same server that you access by having set them up separately and entered each box's password, everything works, but you won't see the password for one of the two accounts anywhere in Credential Manager.  You will only see one of the e-mail addresses and its password being used to authenticate to the proxy server (the two credentials mentioned above).

    So, try this.  Add the third account using the Mail icon and autodiscover.  It should complete successfully.  Then, open Outlook, and when it starts prompting repeatedly, just cancel and close it.  Then, delete the entries in Credential Manager for the proxy server.  If you see any other entries for MS.Outlook or Windows Identity for your mail accounts, delete those too.

    Then, open Outlook again.  It should prompt you four times; once for each of your e-mail accounts, and a fourth because one of them was for the proxy server, not for the mailbox itself.  Then it should work just fine.  If you go into Credential Manager, you will see there is now an MS.Outlook entry and Windows Identity for all three of your e-mail accounts.

    In Credential Manager, if any of the required entries for the proxy server (such as, in my case, the domain.local one) didn't get saved, then manually enter it.

    I think the problem is related to the fact we have two different storage locations for saved Exchange account passwords: the Windows Vista/7/8 Credential Manager, and the old-style password storage of Windows XP.  Since Outlook 2010 can run on Windows XP, it supports both.  If you don't see your e-mail account in MS.Outlook/Windows Identity entries in Credential Manager, then the password must be in the Windows XP credentials file.  I think the Mail icon saves them in there.  Outlook can use this for two accounts, but somehow when Outlook tries to handle a third Exchange account with that old file in play, it just falls apart.  By having Outlook start over from scratch by making it prompt you for everything again while Outlook is running, it puts everything in the new Credential Manager as proper entries (one MS.Outlook and one Windows Identity entry for each e-mail address), and it doesn't have problems finding the passwords any more.

    I type all this based on a limited, one-time experience on four computers.  Hopefully the general conclusions can help someone whose parameters are not exactly the same as mine.  Please leave feedback on how this works for you.

    Jeffrey Fox


    • Edited by beakt Thursday, February 27, 2014 6:10 PM
    Thursday, February 27, 2014 6:07 PM
  • Jeffrey's information looks good and makes sense. But I believe I have come across a solution to stop this occurring in the first place when setting up new accounts.

    I was trying to run multiple exchange accounts in Outlook for my clients (using Intermedia hosted exchange), and sometimes the password would ask every time, and as the original poster mentions, the credentials would also seem to get mixed up between the accounts, with one account prompting but using the other accounts email address as the username.

    The issue also seemed to occur on XP or Windows 7, and Outlook 2007 and Outlook 2010. So it did not seem to be software version or OS related. Autodiscover was setup and fine. So..... through trial and error I believe the issue is caused during initial account setup.

    Even if you have Autodiscover, you must not let Autodiscover find the server details or do auto setup, these must be all set manually. After account setup, when starting Outlook and letting the mailbox configure, it is then okay to check the box and say yes to the Autodiscover popup.

    My solution below works everytime for me on a clean OS install. But if accounts have already been setup using autoconfigure, I found that even following every registry and credential cleaning procedure found on this thread and others could not get the problem to totally go away. I'm sure there is a way to do that, I just have not found it.

    1. Close Outlook, setup mail account in control panel using 'Mail' icon.

    2. Choose 'Manually Configure Server Settings'

    3. Enter exchange server and username, but do not 'Check Name' or test account.

    4. Go into 'More Settings' > Connection TAB > Check box and go into 'Exchange Proxy Settings'

    5. Here you enter all your exchange settings manually.

    (For Intermedia, Fast and Slow networks is checked, while in the dropdown choose 'Basic Authentication')

    6. Click apply/ok whatever to get back to the screen with exchange server name and username. Then click Next (not check or test)

    7. At this point, the account will try and connect with the exchange and a popup will appear, enter your details and check box to remember your password.

    8. Now open Outlook for first time configuration. If you have autodiscover that will popup at some point, and you can check the box and allow it to configure.

    I have had up to 3 exchange mailboxes on a single Outlook 2010 account, with no more issues as discussed.

    Tuesday, May 27, 2014 10:59 AM