none
Outlook Search is not working for some text in some HTML emails...

    Question

  • We are sending a number of generated MHTML (Web Archive) emails from SSRS. In the attached message, it will find  the word Auth, but not City/St/Zip. Example from customer was that it would find Oakwood Rd, but it would not Find 1234 Oakwood Rd.

    If I forward the message, (I assume) outlook does some editing to it and the resulting message can be searched regularly.

    Search: from folder, not within message

    Click here for Attachment (also added c# code to generate the email to yourself): https://sites.google.com/site/tempoutlookerror/home

    Issue occurring in Outlook 2010. I haven't tested other versions. Indexing complete, and it does index outlook. Occurs in regular search as well as advanced search.

    You should be able to pull the message from the above attachment into Outlook and see the same issue. If you can't reproduce, let me know. 

    Thanks,
    Colin


    Friday, June 22, 2012 2:48 PM

All replies

  • Hi,

    I have test the pull the message into Draft folder (other folder seem can’t keep it retain), then I use Search(also advanced search), search City/St/Zip noting list, just like your description.

    Then I rebuild the index(Start – Control Panes – Indexing Options – Advanced – Rebuild), the search seem work, Both City/St/ZIP or Address something else could find the result in the list. Note: rebuild windows index cost a lot of time.

    Feel free to post back. Thanks.

    Cheers,

    Tony Chen

    Tuesday, June 26, 2012 4:55 PM
    Moderator
  • Tried this. It doesn't seem to help.

    Did you try putting it into an empty folder? Otherwise, I have code here that well send the email. (c#)

         https://sites.google.com/site/tempoutlookerror/home

    Tuesday, June 26, 2012 6:41 PM