none
Unable to Sort Task Lists by "Assigned To" Column

    Question

  • Hi everybody,

     

    My users make great use of task lists.  While users can use the "My Tasks" view to see what tasks are theirs, their managers are unable to sort the "Assigned To" column to determine who to assign new tasks to.

    When they attempt to apply any sort to this column, the error that pops up in a dialog is:

    "Cannot show the value of the filter. The field may not be filterable, or the number of items returned exceeds the list view threshold enforced by the administrator."

    Not even the farm admin account is able to do this.  This is a new farm on a 2010 Enterprise license.  The farm consists of a WFE and SQL server, and the February CU has been applied.

    Thanks for your help!


    David Caudill IT Manager
    Monday, May 09, 2011 6:21 PM

Answers

  • This problem was found to be because of a couple of default settings that happen on the "Assigned To" column on the "Project Tasks" template.  I editted these settings in "List Settings" by clicking the column name to edit it.

    "Allow multiple selections:" was set to Yes.  I changed it to No.

    "Allow Selection of:" was set to "People and Groups".  I changed it to "People only."

     

    After applying these settings, the column sorts normally.  I hope this helps somebody else- it doesn't appear that other list templates are set this way.  This was a surprisingly simple fix for a problem that was so hard to find in search results.


    David Caudill IT Manager
    Wednesday, May 11, 2011 6:40 PM

All replies

  • I should add here that I AM able to sort by other columns of the type "User or Groups."

     


    David Caudill IT Manager
    Tuesday, May 10, 2011 6:50 PM
  • This problem was found to be because of a couple of default settings that happen on the "Assigned To" column on the "Project Tasks" template.  I editted these settings in "List Settings" by clicking the column name to edit it.

    "Allow multiple selections:" was set to Yes.  I changed it to No.

    "Allow Selection of:" was set to "People and Groups".  I changed it to "People only."

     

    After applying these settings, the column sorts normally.  I hope this helps somebody else- it doesn't appear that other list templates are set this way.  This was a surprisingly simple fix for a problem that was so hard to find in search results.


    David Caudill IT Manager
    Wednesday, May 11, 2011 6:40 PM
  • Hi,

     

    Just to give more information, I also had the error message on a User or Group column (not Assigned To) in a list that is below the Sharepoint threshold (< 5000 items). I changed it to user only, but I still had the issue. It only worked after I changed the Display with "Name (with presence)" instead of "Name".

    Thanks,

    Fabien Henriques

    IT & QA Manager

    Thursday, December 29, 2011 10:00 AM
  • You are correct that if you change those settings you can then filter the column.   However you are no longer able to have more than one persons name listed.  This worked well in 2007 but is no longer working since our upgrade - any other ideas?

    Thanks much!

    Robin Mickler

    Friday, February 10, 2012 1:54 PM
  • To fix the Filter Issue on Assigned To Column. We need to run the following scripts.

    The field which allows more than one values or which allows multiple selections. The multi-valued fileds are non-sortable, non-filterable. Multi-valued fields cannot be indexed

    $web=Get-SPWeb

    $list=$web.Lists[]
    $field=$list.Fields[]
    $strSchema=$field.SchemaXml
    $str=Schema$strSchema.Replace("Sortable=`"FALSE`"","Sortable=`"true`"")
    $field.SchemaXml = $strSchema


    Krishana Kumar http://www.mosstechnet-kk.com


    Friday, April 27, 2012 12:16 PM
  • Hello,

    We encountered the same problem today.
    After reading the reply from David here above, we checked our configuration.

    We also had "allow multiple values" set to "yes", and "people and groups".
    Since we needed the multiple values, we only changed "people and groups" to "only people".

    After that we were able to filter on the Assigned To column.

    So it seems to be related to the "people and groups" setting that you cannot filter anymore.
    It makes sense, when you would have a username and a groupname that have the same value.
    In that case it would be impossible to filter on either the username or the groupname.

    Wednesday, July 18, 2012 7:56 AM
  • I am experiencing the same issue with SharePoint 2010.  Changing from "people and groups" to "only people" did not fix this issue.

    Have others tried this solution?  And if yes, did it work for you as well?

    Has anyone tried the solution from Krishana Kumar?  Did that work?

    Thursday, October 03, 2013 7:42 PM
  • Where and how do you run this script?  I am power user and not an SP administrator.
    Thursday, October 03, 2013 7:43 PM
  • Hi Robin,

      Did you see the reply from Krishana Kumar about running a script?  Has this been tried?

    Raffi

    Thursday, October 03, 2013 7:45 PM
  • Hi,

    apologize for late reply, you no need to be an administrator to run the above script, you can write simple Power shell script using script simply get the SPSite, spweb, the list where this issue is and change the value according to your  column name and execute the script from your sharepoint server.

    Regards

    Krishana


    Krishana Kumar http://www.mosstechnet-kk.com

    Wednesday, October 23, 2013 4:06 AM