none
IMAP bugs in Outlook 2013

    Question

  • These issues moved from previous post and expanded.

    I know a lot of work has gone on with IMAP changes behind the scenes to make everything more responsive but some of these changes have adversely affected usability.

    1. If you delete, edit or create IMAP folders to your account outside of Outlook you really have to fight to get Outlook to see the changes. Sometimes you have to remove the IMAP account completely and add it again just to get a proper view of the changes. This is definitely something to do with the new caching regime. As an example Outlook does not seem to want to let go of folders deleted outside of Outlook (orphaned folders) and insists they still exist. For instance I can still move messages into these orphans and Outlook accepts them and agrees they are there even though the folder no longer exists on the server. In some cases you can even unsubscribe from the folder and it remains displayed. In fact the whole subscribe/unsubscribe process seems extremely buggy as well.

    2. This is a bug. If I delete a group of unread messages, usually, all except the top one show as deleted and ready to purge (grey with a line through). The top one remains not deleted and unread. As soon as I mark it as read it will then show as deleted and ready to purge (grey with a line through).

    Jason

    Wednesday, December 19, 2012 8:11 AM

All replies

  • Hello Jason,

    Thank you for your post again. This is a quick note to let you know that we are performing research on this issue.

    Cheers,
    Tony Chen
    Forum Support
    ________________________________________
    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com.

    Friday, December 21, 2012 5:42 AM
    Moderator
  • Do you run RTM build of Outlook 2013? Can you reproduce these hebaviors in Gmail IMAP account?

    If you have your own IMAP server, please also test it and see these issues with Outlook 2013.

    Thanks.

    Cheers,
    Tony Chen
    Forum Support
    ________________________________________
    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com.

    Thursday, December 27, 2012 3:09 AM
    Moderator
  • Yes released version fully patched.

    Previously running Outlook 2010 against the same accounts with none of these issues.

    I will test Gmail later

    Thursday, December 27, 2012 9:02 AM
  • I'be also noted that my when my IMAP inbox is included in Favorites the count of unread items does not get displayed.

    Paul

    Sunday, February 03, 2013 1:33 PM
  • Hi,

    I tested this issue with AOL and Gmail IMAP accounts. I don’t see the same issue as you are seeing. Can you please test with these and let me know if the issue duplicates here.

    Thanks and Best Regards,

    Nitish Karmakar [MSFT]

    Thursday, February 07, 2013 10:11 PM
  • The two IMAP accounts I use are both gmail.

    Paul

    Thursday, February 07, 2013 10:41 PM
  • Hi Bunkermentality,

    Based on you description of your issue I have the following steps that I would like you to try.


    1) Disable Outlook add-ins and then review the issue.
    Enable or disable add-ins in Office programs
    http://office.microsoft.com/en-us/outlook-help/enable-or-disable-add-ins-in-office-programs-HA010034127.aspx

    2) Review the mailbox folder properties using mfcmapi tool.

     Please Download MFCMapi Tool from: www.codeplex.com/mfcmapi
    o Note: If you are using 64 bit version of outlook (Outlook 2010 64Bit) then you will have to download the 64 bit version of the Mfcmapi tool from the downloads tab of the above website.
     Extract and Launch MFCMAPI Mapi profile for the mailbox owner.Select Session Logon and select your user profile
     Now Expand the Mailbox-Username. Expand the “Root-Mailbox”.
     Expand the IPM_SUBTREE (Cached mode Profile) and Locate the “Mail-Folder” Folder.
    o Note: Online mode profile with have Top of Information Store.
     Now Click on the  “Mail-Folder”  folder and review the following props
    o PR_Content_Unread
    o PR_Content_Count

    o The PR_Content_Unread refers to the unread items refers to unread items in that folder.
    o The Content PR_Content_Count refers to total number of items.

    3) Run the following command switch against your mapi profile.
    CleanViews
    Safe
    Resetnavpane

    The following article explains the command switches and how to run them.
    http://office.microsoft.com/en-us/outlook-help/command-line-switches-HP001003110.aspx

    4) Create a new mapi profile.
    How to create a new Mapi profile
    http://office.microsoft.com/en-us/outlook-help/create-a-profile-HA010354939.aspx

    Does the issue duplicate here in the new profile?
    5) Please remove the mail folders that you added in favorites and then add them back.

    In case the above failes to correct the issue then we would need to investigate the issue in detail. It would be best that you open a support incident with us to discuss the issue. Please visit the following link to see the various support options that are available to you:  http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone . This will help us address your issue more efficiently.

    Please note that if the issue you are reporting is due to a code defect in Outlook, you will not be charged for support.

    Best Regards,
    Nitish Karmakar [MSFT]

    Thursday, February 28, 2013 6:17 PM
  • Thanks for your reply.

    I successfully followed all steps down 4) and the new profile does display message counts correctly. The original profile also displays message counts but the count is static; it does not increment as new messages are received. However in the new profile the count is dynamic and does increase with new messages.

    I then deleted and recreated the IMAP account in the old profile. This caused things to work correctly.

    Finally I re-enabled the Add-Ins and deleted the temp profile. All OK. Good result. Thanks for your help.

    Tuesday, March 12, 2013 3:35 PM