none
Office 2010 Upload Center will not allow me to connect to a non ms webdav server.

    Question

  • I have a non ms  webdav server that I can no longer upload to after installing office 2010.  The webdav share is mounted on a windows 7 client as a shared drive.  I can open the files in Word, Excel, etc. but can't save them back to the server.  I get the alert bar in Word requiring me to sign in to the server but I never get any kind of login window.  Everything works fine using Office 2007.

    I also tried adding it to the Trusted Locations in Word but it would not allow me to ass the site.  It gave me an error message saying "The remote or network path you have entered is not allowed by your current security settings."  What settings and where are they?

    Webdav server is running on Apache 2 using SSL for access.  Server is set as a trusted site in Internet options.  SSL certificates are installed correctly. Client is Windows 7 Ultimate 64 bit,  MS Office 2010 Professional Plus.  Apache server is a Mac OS X server.

    Does Office 2010 only work with Sharepoint or Skydrive and not other brands of servers?  Is there a method for setting server access / connectivity in Office 2010.  I don't seem to be able to find any options / preferences for changing  login / security  access in Upload Center.

     

    Update: 04/12/2011 @ 0956 EST - Was able to set Trusted Location in Word. Still getting the alert bar requiring me to sign in to the server. Also tried this with another non ms server ( Solaris ), still does not work.

    On another note: mounting the webdav directory as a SMB share on the client workstation works fine, no errors. Whatever this is it appears to be related to how word treats webdav shares / folders and non ms servers.

    Update: 04/13/2011 @ 1621 EST - Ok the problem is the Digest Authentication.  Works ok to mount the resource using  net use z: "\\server.my.dom\uploads" /USER:zz * command but subsequent access from within Word or Excel fails to use the authentication method.   I know it is possible to do this as WebDrive and NetDrive accomplish this without any problems.  Word / Excel work fine using NetDrive to connect to the webdav server.  Does anyone have any ideas how to resolve this?
    Monday, April 11, 2011 8:10 PM

All replies

  • Hi

     

    Thank you for using Microsoft Office for IT Professionals Forums.

     

    From your description, I understand that  you can’t add Trusted Locations in Word 2010. If there is any misunderstanding, please feel free to let me know.

     

    Please follow these steps to troubleshoot this issue:

    1. Start Microsoft word
    2. Click File , and then click  Options.
    3. Click Trust Center, click Trust Center Settings, and then click Trusted Locations.
    4. If you want to create a trusted location that is not local to your computer, select the Allow trusted locations on my network (not recommended) check box.
    5. Click Add new location.

     IMPORTANT   We recommended that you don't make your entire Documents or My Documents folder a trusted location. Doing so creates a larger target for a hacker to potentially exploit and increases your security risk. Create a subfolder within Documents or My Documents, and make only that folder a trusted location.

    1. In the Path box, type the name of the folder that you want to use as a trusted location, or click Browse to locate the folder.
    2. If you want to include subfolders as trusted locations, select the Subfolders of this location are also trusted check box.
    3. In the Description box, type what you want to describe the purpose of the trusted location.
    4. Click OK.

     

    More detailed information Add, remove, or modify a trusted location for your files you can refer to this link:

    http://office.microsoft.com/en-us/infopath-help/add-remove-or-modify-a-trusted-location-for-your-files-HA010354311.aspx?CTT=1

     

    You can refer to this article Plan Trusted Locations settings for Office 2010 from Microsoft|Technet library

    http://technet.microsoft.com/en-us/library/cc179039.aspx

     

    Please take your time to try the suggestions and let me know the results at your earliest convenience. If anything is unclear or if there is anything I can do for you, please feel free to let me know.

     

    Hope that helps.

     

    Sincerely

    William Zhou CHN
    Thursday, April 14, 2011 8:35 AM
  • Thanks for your reply. I was able to add the webdav server as a trusted site as I noted in my first update. I have subsequently identified the problem as an windows authentication issue between the Windows 7 client and the server.

    See the second update on 04/13/2011. I can mount the share using the < net use z: "\\server.my.dom\uploads" /USER:zz * > command. I can open documents in Word or Excel fine but every time I try to save a change I get an alert bar telling me I am required to sign in to the server to make the update. I never get the usual Windows Authentication window for me to enter my credentials. I have no way to sign in to the server. Windows 7 doesn't seem to remember that I already authenticated when I mounted the resource earlier.

    However there is a software product called NetDrive that works to mount the resource as a shared drive just like the "net use" command that apparently establishes the necessary information in Windows 7 to allow authentication from Word or Excel. It works fine.

    What I need to know is what got changed from the earlier versions of Office that broke the ability to do this and how do I fix it? It works fine from earlier versions of Office but not since Microsoft added the Upload Center to Office.

    Thursday, April 14, 2011 12:17 PM
  • I am have the exact same issue, and I attempted the solutions mentioned here, to NO avail.

    Were you ever able to get this to work. I cannot get rid of the upload center! I keep getting the "Need to Sign In" message, but no dialogue box to do so.

    Saturday, August 27, 2011 4:42 PM
  • I'm having the same problem. Are there any real solutions?
    Saturday, October 15, 2011 11:59 PM
  • I am also experiencing this issue. I can mount the drive in Windows and everything works fine except office 2010 becuase of the upload center, with no way to disable that piece of sh*t from Microsoft.

     

    Any solutions?

    Friday, October 28, 2011 3:00 AM
  • If you don't like it go to apple
    FFalcon1961
    Friday, October 28, 2011 1:54 PM
  • I also have this same issue. Has anyone found a resolution?
    Wednesday, March 27, 2013 10:02 PM
  • This seems to address the issue of Microsoft Office 2010 not TrustING  the WebDAV server that it wants to upload to, but has anyone ever addressed the problem when the WebDAV server doesn't Trust MS Office 2010?

    Specifically the problem I keep having is that the server (apache TomCat 6) authenticates the user as logged in, but the server is in control of the WebDAV from the beginning and will only allow an upload of a document that it originated and first downloaded to the client within the CURRENT active Session.  Therefore, in this case, having a cache mechanism for uploading the edited document back to the originating server after it has been edited is a BAD THING, because the cache can't verify that the Session is still current.  Therefore, if the session has timed out or been disconnected, that file can NEVER be uploaded to the server, and should not be kept, since the user now has to first start by download a new copy of the master from the server again.  When the cache is still trying to upload that old copy back to the server it causes errors in the web application.

    Microsoft needs to address this by enabling a setting to identify sites that should bypass  the caching provided by Office Upload Center.

    Wednesday, August 14, 2013 8:21 PM