none
Cannot enable conversation view in Outlook 2010

    Question

  • Outlook Experts:  I'm having a strange problem with the RTM version of Outlook 2010 - I can't enable the "Show as conversations" option from the View tab of the menu.  I can click the checkbox, but whenever I click on anything (e.g., another mail message), the setting disappears.  The "Conversation Settings" menu is disabled.  Some details:

       1. The problem appears to be machine-specific.  I tried another user account on the same computer, and had the same issue.  I also tried creating a new mail profile and have the same issue.

       2. Using the same PST file on another computer works fine, and three other machines that are running Outlook 2010 seem to have no problem with this view.

       3. I had a post-beta/pre-RTM build of Office 2010 installed on this machine for test purposes.  I did not uninstall it before installing the RTM version of Office 2010.  I understand that this is a big red flag, but I've done the same on three other machines and don't have any problems at all.

       4. I'm running the 32-bit version of MS Office Premium Plus (MSDN) on Windows 7 Ultimate x64.

    So far, I have tried the following:

       1. Comparing both the HKCU and HKLM keys for Outlook between this computer and one on which the conversation view works.  I can't see any differences and can't immediately see any relevant portions of the settings.

       2. Started Outlook using numerous startup switches, including /safe, /nocustomize, and /noextensions and /regserver.

       3. Ran ScanPST on the Outlook file (errors found and fixed); I doubt this is relevant, but I thought I'd mention it.

    I haven't yet uninstalled Office 2010, but that's an option.  I would probably delete all relevant Registry keys, but I'm not sure if there are some that I'm missing.

    Does anyone have any idea what I can do to troubleshoot this further?  Any help or suggestions would be greatly appreciated!


        * Anil Desai

    Note: I also posted this question to the Microsoft Technical Communities "Outlook Install and Configure" group.  Apologies if I'm breaking etiquette. :)
    • Edited by Anil DesaiMVP Wednesday, May 05, 2010 1:25 PM Removed formatting
    Wednesday, May 05, 2010 1:23 PM

Answers

  • All: Just a quick update on this issue.  I finally bit the bullet and decided to remove Office 2010.  I ran into numerous issues with reinstalling it, but was finally able to resolve them by deleting the Office 14 machine-specific Registry keys and by running the Windows Installer Clean-Up Utility.  I think re-installed and re-activated my MSDN version of Office, and all seems to be working well now.

    Thanks again to everyone for their suggestions.

    - Anil
    • Marked as answer by Anil DesaiMVP Tuesday, August 24, 2010 5:49 PM
    Friday, May 14, 2010 4:27 PM

All replies

  • Have you tried rebuilding your search index? I believe that Conversation View relies heavily on the index in order to work.
    Simon Jones http://pcpro.co.uk
    Wednesday, May 05, 2010 5:32 PM
  • Simon: Thanks for the suggestion - I hadn't thought of that.  I just removed Outlook from the index and re-included it.  It looks like everything rebuilt properly and instance search is working well.  However, conversation view is still broken.  I'd appreciate any other suggestions! - Anil
    Wednesday, May 05, 2010 8:59 PM
  • You mentioned a number of startup switches but I didn't see /cleanviews listed there.  Did you try that one?
    -B-
    http://www.officeforlawyers.com
    Author: The Lawyer's Guide to Microsoft Outlook
    Wednesday, May 05, 2010 9:17 PM
  • Ben: Yes, I did try that switch as well - thanks for the suggestion.  I also tried resetting the views from within Outlook.  What seems strange to me is that the problem is machine-specific.  I'm tempted to copy the relevant Registry keys from a machine that works properly, but that could cause other problems.  It seems like the fact that the "Conversation Settings" drop-down list in the View ribbon tab is disabled would be a big clue, but I just can't find out where that setting might be stored.  Perhaps I should try to remove and reinstall Office 2010, though I think I'll need to manually delete all of the application-specific Registry keys.

    Any other suggestions? 

    Thursday, May 06, 2010 1:20 PM
  • What type of email account do you have configured?

    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Thursday, May 06, 2010 1:50 PM
  • Diane: I'm currently connecting to a Gmail account via POP3, and I'm using the Hotmail Connector to connect to my Hotmail account.  I have tried opening the same PST file with a new Mail profile, and I still had the same problem.  Does this help at all?  And, thanks to everyone for their support! - Anil
    Thursday, May 06, 2010 4:20 PM
  • All: Just a quick update on this issue.  I finally bit the bullet and decided to remove Office 2010.  I ran into numerous issues with reinstalling it, but was finally able to resolve them by deleting the Office 14 machine-specific Registry keys and by running the Windows Installer Clean-Up Utility.  I think re-installed and re-activated my MSDN version of Office, and all seems to be working well now.

    Thanks again to everyone for their suggestions.

    - Anil
    • Marked as answer by Anil DesaiMVP Tuesday, August 24, 2010 5:49 PM
    Friday, May 14, 2010 4:27 PM
  • Anil, All,

    I was having the same problem and I was unable to fix it by reinstalling. After much research I learned a registry key setting that caused the problem.

    HKEY_CURRENT_USER\Software\Policies\Microsoft\office\14.0\Outlook\Setup” key name is “UpgradeToConversations” if it is set to “0” you will not see show conversation you need to change the value to “1”

    I hope this helps others.

    Shaun

    • Proposed as answer by Andy_T_80 Monday, February 07, 2011 10:48 AM
    Wednesday, December 22, 2010 6:48 PM
  • This post just saved me from throwing my laptop out of the window. Thank you, Shaun! For any other novices trying to fix this problem,

    Step 1. Go to Start.

    Step 2. Click Run.

    Step 3. Type “regedit” and click on OK

    Step 4. Follow the path HKEY_CURRENT_USER\Software\Policies\Microsoft\office\14.0\Outlook\Setup\UpgradeToConversations and change Value data entry from 0 to 1.

    • Proposed as answer by Makapav Tuesday, February 22, 2011 10:41 PM
    Monday, February 07, 2011 10:48 AM
  • This worked perfectly, thank you very much!
    Tuesday, February 08, 2011 9:17 PM
  • First of all...I upgraded to the version20 of Office 2010 today ...and started facing the issue of not being able to see the Conversations sub-tab on the View tab....Using the above help on the registry settings I am able to get the Conversations sub-tab to show...but it still is greyed out.... Any additional clue will be helpful.

    Thanks

    • Proposed as answer by Jeiyaraj Thursday, July 05, 2012 7:15 AM
    • Unproposed as answer by Jeiyaraj Thursday, July 05, 2012 7:15 AM
    Wednesday, February 09, 2011 9:00 AM
  • I figured it out...I had to go to view mode...arrange by date and then i was able to select the "show as conversations" option
    • Proposed as answer by SandiMarks Wednesday, January 29, 2014 12:25 PM
    Wednesday, February 09, 2011 9:08 AM
  • This post just saved me from throwing my laptop out of the window. Thank you, Shaun! For any other novices trying to fix this problem,

    Step 1. Go to Start.

    Step 2. Click Run.

    Step 3. Type “regedit” and click on OK

    Step 4. Follow the path HKEY_CURRENT_USER\Software\Policies\Microsoft\office\14.0\Outlook\Setup\UpgradeToConversations and change Value data entry from 0 to 1.

    This solution works like a Charm. I tried clicking on date first, but still Show as Conversation was disabled. Thanks Andy !
    Wednesday, August 17, 2011 6:18 PM
  • Hey...  I have been having a similar issue only, all the conversations upgraded fine from the Outlook 2007 installation but now Outlook 2010 won't group any new messages into conversations.  Any ideas, I read someone here mention the Search Index, how do I rebuild that?
    Thursday, October 27, 2011 1:24 AM
  • What type of email account? Are the messages part of a real conversation? (As opposed to being individual messages with the same subject)?

    Are the messages in different data files? You definitely need indexing enabled for it to work across diferent pst files. Press Ctrl+E to open the search ribbon, go to Search tools, locations to search. All of your pst files should be checked.

    Do you have conversations enabled? Look on the View ribbon.



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Thursday, October 27, 2011 2:22 AM
  • I have 2 IMAP accounts, I don't care if the conversations display messages between accounts, just the same account will do fine.  All my PST files are checked and they are apart of the same conversation back and forth between myself and a friend of mine and they also have the same subject line.

    It should also be noted that Outlook 2007 displayed the conversational links properly and when I upgraded all the mail contained in Outlook already when I upgraded displays correctly in conversations, only mail arriving since I upgraded has the issue.

    Conversations is enabled.

    Also, to note, when I select a message I have replied to in the message list and hit the right arrow to expand it, it finds the message I replied with as if just those two items are in that conversation.  It does that with every individual message I have replied to, even if two of the messages should display in the same conversation.

    Thursday, October 27, 2011 4:17 AM
  • The registry editor fix WORKED!! ... thank you !!
    Tuesday, January 10, 2012 8:26 AM
  • I figured it out...I had to go to view mode...arrange by date and then i was able to select the "show as conversations" option

    Thanks to Shelly_Kohli for supplying the missing link as quoted above, I've managed to solve the 'Mystery of the Greyed-out "Show Conversations" Tick Box', without messing around with the Registry.Don't edit the Registry unless you know what you are doing, or you could just screw up your PC!

    This is the problem I was facing:

    I wanted to group all my mail in the Inbox according to conversations. Somehow, the Backup Inbox had the mail arranged according to conversations as I wanted, but never the main Inbox, no matter what I tried. I followed Outlook's Help on Conversations but without any illustration, I couldn't find out what & where to click. Reading through this thread ( and by a stroke of luck!), I finally located the 'Show as Conversations' box, but it was still greyed out. 

    This is what I did:

    1. Click 'View' on the main toolbar.
    2. In the 'Arrangement' group, highlight the 'Date'. This will sort out all mail in your inbox according to the the date.
    3. Voila! The 'Show as Conversations' box is open! Tick on the box.
    4. A pop-up window with the message "Show messages arranged by conversations in : All Folders, This Folder & Cancel". Click on whichever choice you please.
    5. All done !
    • Proposed as answer by Jeiyaraj Thursday, July 05, 2012 7:33 AM
    • Edited by Jeiyaraj Thursday, July 05, 2012 7:34 AM
    Thursday, July 05, 2012 7:33 AM
  • Hi,

    I am nor having office folder at all, I can browse up to HKEY_CURRENT_USER\Software\Policies\Microsoft\

    HKEY_CURRENT_USER\Software\Policies\Microsoft\office\14.0\Outlook\Setup\UpgradeToConversations-----> this is not available.


    Thursday, August 16, 2012 3:09 AM
  • Are you on a work computer where group policies are used? If not, you won't have the keys. Check in HKEY_CURRENT_USER\Software\Microsoft\office\14.0\Outlook\Setup\UpgradeToConversations

    Are you using a view that supports conversations?



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Thursday, August 16, 2012 3:15 AM
  • Brilliant Shelly. I spent hours trying to find the regedit solution. gtried yours and it worked instantly. THANK YOU.
    Wednesday, January 29, 2014 12:25 PM