none
outlook 2010 attachment previewer problem

    General discussion

  • Dear All,

    I recently upgraded to the office 2010 beta, and have been quite pleased with the new system, until i tried to view an image that was attached to an email. I keep getting on any type of image or pdf that the previewer is not available ad to double click to open the file. I then get photo viewer telling me it can't open the file. So i saved the file to my desktop and try to open the jpg in any program such a photshop, illustrator or fireworks and it tells me there is an unknown or invalid JPEG marker type is found."

    I can't open any files that are attached to emails, which is getting really annoying now. I have tried everything i can think of, running outlook as an admin, turning off image previewers, checking image previewers are enabled, i've tried the protection settings, and disabling it for Outlook.

    Nothing will work. I've searched google and found a few solutions where they say this is caused by google desktop search causing problems and that uninstalling it solves the issue, however I don't have google desktop search installed, just google toolbar.

    Its starting to drive me round the bend, i've even ran and repaired the pst file which didn't make any difference either.

    Have reported it as a frown but not holding my breath for a response.

    System:
    Windows 7 64 bit
    Office 2010 32 bit beta version

    The laptop is 2 weeks old from Dell and all updates are applied.

    Can anyone shed any light?

    Thanks

    Tom
    Thursday, January 14, 2010 3:37 PM

All replies

  • So any jpg or pdf attachment you get won't open even if you save it to the hard drive befre opening? Are you using antivirus software to scan your incoming email? (Scanning incoming email can corrupt the attachments.)

    Diane Poremsky [MVP - Outlook]
    Outlook Tips: http://www.outlook-tips.net/
    Outlook & Exchange Solutions Center: http://www.slipstick.com
    Saturday, January 16, 2010 4:12 AM
  • Looking in to this further, it is only affecting certain folders. Other folders with jpgs are fine, but 2 folders in particular are effected. In the one folder no jpg, gifs of photoshop files will work at all going back 3 years.

    I had an email this morning with 2 photoshop files on it and neither of them will open. I've saved to desktop and done the unblock option. I've tried forwarding them to another email account but they are corrupted as well. I've tried to double click them in the email

    I've tried the option to remote protection. but nothing seems to be working on this particular folder.

    I'm using Mcaffee to scan my incoming email, but it strange taht it wouold effect some and not all of the images.

    In fact some of the images that aren't working were delviered before I started using McAffee.

    I've ran an PST repair as well.

    I'm getting very worried now that outlook has mucked up that folder which wouldn't be good!

    Anybody that can help it would be greatly appreciated!

    T
    Monday, January 18, 2010 12:20 PM
  • Is it a local or network folder?

    I don't think Outlook mucked it up - either mcafee did or there is a problem with photoshop's installation or association with the file types.


    Diane Poremsky [MVP - Outlook]
    Outlook Tips: http://www.outlook-tips.net/
    Outlook & Exchange Solutions Center: http://www.slipstick.com
    Monday, January 18, 2010 3:49 PM
  • Its a folder within outlook that all my emails from one person are moved to by a rule.

    Photoshop works fine and the file assosciation are correct as well.

    i can open old photoshop files that haven't been emailed without any problem.

    I just can't open any type of image attachement in this folder, so jpg's, gif's, tiff, eps, ai, psd or png are all being corrupted.

    I get told by outlook there is an error with the previewer. I also get told whe ni save a jpg to my desktop it can't be opened due to a incorrect flag in the file.

    Its strikes me as strange that Mcafee would much up just image files on this particular folder, especailly images that were received long before it was installed on my computer. Even so just ot be sure. I stopped all Mcaffee services running, and send from an external webmail account, one jpg, one gif and one psd file.

    I set up a rule to move it to the folder in question to be sure that all steps of the process were covered that way if the same error happens then its definetly outlook creating the problem and not the anti-virus.

    i'll post back when the email is received
    Monday, January 18, 2010 10:57 PM
  • I have a similar problem also using outlook 2010 beta. Received jpg and png attachments (exchange 2007 account) which were korrupt. Logged in with outlook web access and downloaded the attachments with no problem. I have no antivirus scanner on my client machine.. The file size is substantially smaller when downloaded with outlook 2010.

    Sunday, April 18, 2010 9:23 PM
  • I have exactly the same problem as mentioned above.

    If I take the attachment to another computer on a USB stick, save it in an Office 2007 application, then reopen back on the Office 2010 computer I still receive the corruption message.

    Does anyone have a work around or know how to run a repair on Word 2010?

    Wednesday, April 21, 2010 5:23 PM
  • I have experienced this bug too. It seems that Outlook 2010 does not identify the attached files correctly. I have tried opening the mailbox from a Outlook 2003, which worked fine. I have also tried forwarding the same message to other people, and all of them could open the jpg's.

    Looking forward to see a bugfix from microsoft.

    Thursday, April 22, 2010 11:53 AM
  • I am having a similar problem -- only I've been using Outlook 2010 for several months now with no problems whatsoever until today.  To my knowledge I have not changed anything recently on my computer -- particularly any anti-virus software (other than the automatic updates of definitions that it does regularly).  Any attachment I try to preview says that it cannot find the PDF (or JPG or whatever) previewer for Vista, and if I download the attachment I get similar corruption messages from Photoshop or Acrobat etc.  The really strange part about all of this is that I am not running Vista... I've been running Windows 7 for quite some time now (since long before I switched to Office 2010).  Everything has been working wonderfully and I have enjoyed using many of the new features in Office 2010 until now.  I have no idea what on earth could have possibly caused this issue all of a sudden.  I can pinpoint the e-mail that caused the problem this morning in fact.  There were 2 attachments -- one PDF and one JPG.  I was (and still am) able to both preview and open the PDF attachment in that e-mail, but when I went to then subsequently open (or preview) the JPG in the same e-mail the problem started.  Now with any other e-mail I have received the problem has persisted -- I cannot preview the file nor can I save it to my hard-drive to open it because the file will be corrupt.  I can still go back and view that original PDF attachment but anything I have received after that today will not open.  I am running Microsoft Exchange Server for e-mail, and if I log-on to webmail, I have no problems opening the very same attachments that are giving me problems when I access them that way.  Anyone have any idea how to fix this?  I will have to look into downgrading Office from the 2010 Beta very soon if this is going to continue.
    Tuesday, June 01, 2010 8:32 PM
  • I am having a problem which is a variation on the same theme.  What is even more odd is that I have a laptop and desktop which I installed Outlook 2010 on and they behave very differently.  On my laptop, I can easily view all doc and docx attachments, while on my desktop, these very same attachments are not recognized or are considered as corrupt documents.  I have been fiddling around with trusted locations on my desktop (e.g., trusting my server folders etc.) but so far no success - even after reinstallation of 2010 on the desktop.  My laptop's Outlook works fine without having to trust any particular location.  I installed Outlook on my desktop after doing a fresh install of the XP OS while the Outlook installation was an upgrade of Office 2007 with a fairly weather beaten XP registry.  So currently, I see no rhyme or reason except that it appears that the 2010 installation is highly highly sensitive.  Hopefully there is a quick fix to this or I might also have to roll back to an earlier version of Outlook.
    Saturday, June 19, 2010 10:43 PM
  • As an addendum, on my desktop, any folder which I listed as a trusted location and download a file previously classified as corrupt, I could now open.  Using this logic, I tried to list the Outlook temporary folder as a trusted location, but I was not permitted to do this.  Again, none of this is necessary with my laptop Outlook which seems to work fine.

    A potentially important issue, which I have not figured out is that the first time I launched a preview on the laptop's Outlook, an installer for Microsoft Office Single Image 2010 also launched and the install was successful.  I saw no more of Office Single Image on the laptop.

    However, on my desktop, an installation of Microsoft Office Single Image 2010 begins EACH time I either try to open or try to preview an attachment.  After 60 seconds of an attempted installation, the installation appears to quit and that is when I get the message implying that the file is corrupt.

    Once again, the inconvenient fix is to save this file to a hard drive folder that you have listed as a Trusted location and then you can open this formally corrupt file.

     

     

    Saturday, June 19, 2010 10:59 PM
  • It's definitely the Outlook app. I'm using the Beta of Office 2010 suite in our company and we use SBS 2003 server with Exchange 2003. I tried to open some images right from the Outlook itself and no luck with this! BUT... I tried to do the same through OWA and it WORKED. Now, I know it is only a Beta and it has the right for flaws. Just downloading trial of Office Pro Plus 2010 RTM TN - I hope the problem will be gone...

     

    David

    Monday, July 05, 2010 1:38 PM
  • Just finished installing it and tried to open some of the affected images. And it works - the problem's gone! :) D.
    Monday, July 05, 2010 2:51 PM
  • I am having a problem which is a variation on the same theme.  What is even more odd is that I have a laptop and desktop which I installed Outlook 2010 on and they behave very differently.  On my laptop, I can easily view all doc and docx attachments, while on my desktop, these very same attachments are not recognized or are considered as corrupt documents.  I have been fiddling around with trusted locations on my desktop (e.g., trusting my server folders etc.) but so far no success - even after reinstallation of 2010 on the desktop.  My laptop's Outlook works fine without having to trust any particular location.  I installed Outlook on my desktop after doing a fresh install of the XP OS while the Outlook installation was an upgrade of Office 2007 with a fairly weather beaten XP registry.  So currently, I see no rhyme or reason except that it appears that the 2010 installation is highly highly sensitive.  Hopefully there is a quick fix to this or I might also have to roll back to an earlier version of Outlook.

     

    Had the same issue.

    Here is the fix

    Hello,

    I finally found out what the issue is with this.  It actually isn't a "Protected view" issue, but a DCOM issue.

    Somehow the DCOM permission got changed, so it wouldn't allow certain applications access to simple things like Preview mode on Outlook 2010 / 2007, or opening up attachments without it saying file corrupt.  I also was having an issue with Pop ups in IE8, where javascript messages about security tokens were not authenticated.

    The solution is as follows, and then you can turn on your protected mode back on in word, excel, and your "Preview mode" in outlook will start working again.

    Go to start, then run.  Type dcomcnfg and push o.k. Component Services should come up.

    Expand Component Services, click on Computers, then "Right click" on My Computer and go to "properties".

    Click on Default Properties tab, and make sure the following is set:

    Default Authentication Level: Should say Connect, not "None"

    And Default Impersonation Level: SHould say Identify.

    When those are set properly, hit o.k and turn on your protected mode back on your Office applications.  Everything works as expected :)

    Cheers :)

    Tuesday, November 30, 2010 12:43 AM
  • Actually, i found that Default Authenticaion Level can also be set to "Default".  Just make sure it isn't set to None, or else you will have this issue.
    Tuesday, November 30, 2010 1:01 AM
  • mka101 whoever you are you are a complete hero. The fix works. I spent something like 4 days trying to find something which would and my only regret is that your solution is well buried whereas it out to be out there right at the front.

    I hope that Microsoft takes up what you have posted. I also hope that in future Microsoft will do something as sensible as enable users to search for a solution on the exact wording of the error message thrown up by Outlook and, where it creates an error message as it did in Word concerning permissions it again shows the whole message and allows a search on it.

    You have effectively saved me from having to rebuild my whole PC. If I knew who you were I would buy you a large drink.

    Now, do you reckon that the problem was caused by some helpful "update" from Microsoft? Otherwise I cannot see how what worked one day stopped working the next when there is no way that I would be able to do anything as esoteric as change the setting that you discovered.

    Sunday, December 05, 2010 7:32 PM
  • Excellent analysis...thank you so much!
    Monday, December 20, 2010 11:33 PM
  • Also works and is probably the safest choice.
    Monday, December 20, 2010 11:34 PM
  • I tried mka101's suggestions, but that was the way my computer was already set.  Outlook 2010 was opening jpg's just fine earlier and now won't open or save any from attachments, including ones it opened earlier.  There are no error codes on the error message.  It just says check the folder permissions where you are trying to save the attachment.

    Also this computer has Norton not McAfee as mentioned in some of the earlier comments. 

    Any response or advice would be greatly appreciated.

    Monday, January 17, 2011 10:53 PM
  • Try Disabling Protected View for Outlook Attachments.

    Open the relevant Office Program (I had to do it in Word and Excel)

    Go to File.. Options...Trust Center...Trust Center Settings...Protected View...

    Deselect Enable Protected View for Outlook Attachments.

     

     

    Monday, January 24, 2011 2:21 PM
  • I have the same issues, PDF attachments unable to view or open, unless I use a different PC with office 2007 and vista. I have tried all of the above without success.

    Windows 7 Ulitimate, 32 bit; Office 2010; Nortons 360

    Any suggestions very welcome. Many thanks!

     

    PROBLEM RESOLVED
    Thursday, January 27, 2011 10:01 AM
  • On Thu, 27 Jan 2011 10:01:16 +0000, tttdcs wrote:

    I have the same issues, PDF attachments unable to view or open, unless I use a different PC with office 2007 and vista. I have tried all of the above without success.

    I'm not sure what you mean by "all of the above," but have you
    installed a pdf reading program?

    Adobe Reader is the most commonly used such program, but I think Foxit
    Reader (also free) is much faster and much better. I highly recommend
    it. You can download it at http://www.foxitsoftware.com/pdf/reader/


    Ken Blake
    Thursday, January 27, 2011 8:41 PM
  • please let me know how you resolved your problem as I still have the same problem after doing all the above.  I specifically strugle with a pdf doc with a specific name????  all the other PDF docs with different names open and preview without any hassles.....

     

    thanks,

     

    I got the fix for those who did not come right with the above suggestions:

    When you try to open a file attachment in Outlook, you get an error:

    Can’t create file: filename . Right-click the folder you want to create the file in, and then click Properties on the shortcut menu to check your permissions for the folder.

    This problem occurs usually when Outlook cannot access the temp file the file is linked to. To resolve this problem, try the following steps:

    1. Click Start > Run and type regedit .

    2. Click Edit > Find and type OutlookSecureTempFolder .

    3. When regedit has found the entry, it will tell you where your Outlook temporary files are stored. It will look similar to:

    C:\Documents and Settings\username \Local Settings\Temporary Internet Files\OLKrandomnumber

    4. Open My Computer and navigate to this location on your hard drive.

    5. Delete all of the files in this folder.

    6. Restart Microsoft Outlook and you should be able to open your attachment.

     

    I actually did not have a folder in Temporary Internet files so I changed the location to

    C:\Documents and Settings\username \Local Settings\Temporary Internet Files\

    it worked perfectly after that!

    Thursday, February 10, 2011 6:53 PM
  • You are the man, or woman!  Thank you so much.  This solution actually fixed another issue I was having.  I am Director of Operations for a healcare provider company and we utilize computers in the o.r.  We were ordering laptops with Windows 7 on them, but none of the hyperlinks were working.  I looked for a solution online and this one was very similar. 

    In any case, thank you so much

    Tuesday, May 17, 2011 8:38 PM
  • jtwoodfield - I had the same issue.  It was working for months and then one day it just stopped working.  I could still preview jpg and pdf, but no Office documents i.e. Work, Excel, PP.  The only thing I know I did was install a VPN client.  Of course, it could have been an update and I just didn't realize it.  In any case, I'm so glad for these forums.

    Thanks!

    Tuesday, May 17, 2011 8:41 PM
  • This worked for me perfectly ...
    Sunday, June 19, 2011 9:45 PM
  • I tried what you said and as you saw on your pc I too did not have the correct url in the registry. I can now open pdfs, but still cannot open images that are attachments in an outlook 2010 email. Any suggestions, I did read all of the above and did all but still no luck.
    Tuesday, June 21, 2011 6:57 PM
  • Finally.. I couldn't figure out why some people kept not being able to open attachments anymore. The name of the attachment being the major problem when it locked up for them. I was just deleting profiles because it takes less than a min to set them back up.. Anyway used OutlookTempCleaner and just put it in startup for them. http://www.howto-outlook.com/products/outlooktempcleaner.htm

    Makes life easy :)

    Wednesday, July 06, 2011 8:29 PM
  • This is what fixed the problem I was having.
    Friday, February 03, 2012 8:30 PM
  • I have had the following issue. Upgrading to Office Professional 2010 from either Office 2003 or Office 2007 broke the ability to preview CSV files or in some cases Excel files as well. I have found the following fix:

    1st - Download and install J#.net from http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=4712

    2nd - Download and install the Previewer Handler Pack from MSDN http://techie-buzz.com/featured/preview-zip-pdf-files-in-outlook.html . it adds support for several popular files formats including ZIP, PDF, XML, MSI, BIN, CSV, XPS, and XAML files. Download sample previewers from MSDN.

    After I did both steps outlined above it fixed my issues. I hope this helps..

    Tuesday, April 17, 2012 12:56 PM
  • http://social.technet.microsoft.com/Forums/en-US/outlook/thread/6b248e2d-a586-468a-8e87-356977b62d6e

    Select the windows button (bottom left corner) to the right you will see deffault programs - click on that

    Then select Associate a file or protocol with program

    For myself my pdf's were opening with picture viewer - I found the extension .pdf and changed the program to adobe

    Posted by dracinelli on August 10th in a different thread. Worked perfectly!

    Wednesday, September 19, 2012 8:03 PM
  • I have problem di same with office 2010 and cant open file excel it try to remove temp with free CCleaner and it work.

    Thxs

    Dody

    Friday, November 01, 2013 2:42 AM
  • Thanks this worked great for me. I could not view .jpg attachments in Outlook 2010. For some reason the Default program got changed.
    Tuesday, January 28, 2014 6:08 PM