none
Word2007 in windows 7 -There was a problem sending the command to the program!

    Question

  • I just bought my new HP laptop with windows 7 Home premier edition, and then I installed windows office 2007 suite. It's ok if I only open the word without any existing word file. But if I open word with a word file, it says " there was a problem sending the command to the program". I try this action under safe mode, it's no problem, I can open an existing word file. If I open the winword.exe and use menu "file-open" to open a word file, it's alright. But If I double click a word file, it shows that error.

    I tried to change the registry information according to the solution on internet, but it doesn't work.  I checked the compatibility mode, it says run in "windows XP sp3", and it is grey, I can't uncheck it.

    Anyone got any idea to fix this problem?

     

    Thanks a lot.


    Sunday, May 29, 2011 6:25 AM

Answers

  • Hi

     

    Thank you for using Microsoft Office for IT Professionals Forums.

     

    From your description, This sounds like a problem with the file associations in Windows.. If there is any misunderstanding, please feel free to let me know.

     

    The first thing to check is to make sure that the file extensions are correctly associated with Word.

    1.       Click Start > type or copy following command to the Search box
    "C:\Program Files\Microsoft Office\Office12\winword.exe" /unregserver

    2.       You should then, immediately, use the following command:
    "C:\Program Files\Microsoft Office\Office12\winword.exe" /regserver

     

    Re-associate the Word file  manually:

    1. Please go to Start \Control Panel\Programs\Default Programs\Set Associations.
    2. Locate the files .doc, .docm,.docx, .dot, .dotm, check if there are associated with Microsoft Word. If not, highlight the file and click the Change Program button. Choose Microsoft Word from the list. If you are unable to see Microsoft Word from the list, click the Browse button. Browse to the folder: C:\Program Files\Microsoft Office\Office12, and choose WINWORD.EXE.
    3. Click OK to save the settings.

     

    Please take your time to try the suggestions and let me know the results at your earliest convenience. If anything is unclear or if there is anything I can do for you, please feel free to let me know.

     

    Hope that helps.

     

    Sincerely

    William Zhou CHN
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Tuesday, May 31, 2011 8:59 AM
  • Hi,

    My problem in Word 2007/ Windows 7 is solved by unchecking by Unchecking the comptibility mode, u can reach there by C:\Program Files\Microsoft Office\Office12  --> Right Click on WINWORD --> Properties --> Compatibilty Tab --> Uncheck the 'Run this program in compatibility Mode for' checkbox, if ticked.

     

    Regards,

    Rubin

    Thursday, November 24, 2011 3:18 AM

All replies

  • Hi

     

    Thank you for using Microsoft Office for IT Professionals Forums.

     

    From your description, This sounds like a problem with the file associations in Windows.. If there is any misunderstanding, please feel free to let me know.

     

    The first thing to check is to make sure that the file extensions are correctly associated with Word.

    1.       Click Start > type or copy following command to the Search box
    "C:\Program Files\Microsoft Office\Office12\winword.exe" /unregserver

    2.       You should then, immediately, use the following command:
    "C:\Program Files\Microsoft Office\Office12\winword.exe" /regserver

     

    Re-associate the Word file  manually:

    1. Please go to Start \Control Panel\Programs\Default Programs\Set Associations.
    2. Locate the files .doc, .docm,.docx, .dot, .dotm, check if there are associated with Microsoft Word. If not, highlight the file and click the Change Program button. Choose Microsoft Word from the list. If you are unable to see Microsoft Word from the list, click the Browse button. Browse to the folder: C:\Program Files\Microsoft Office\Office12, and choose WINWORD.EXE.
    3. Click OK to save the settings.

     

    Please take your time to try the suggestions and let me know the results at your earliest convenience. If anything is unclear or if there is anything I can do for you, please feel free to let me know.

     

    Hope that helps.

     

    Sincerely

    William Zhou CHN
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Tuesday, May 31, 2011 8:59 AM
  • Hi,

    My problem in Word 2007/ Windows 7 is solved by unchecking by Unchecking the comptibility mode, u can reach there by C:\Program Files\Microsoft Office\Office12  --> Right Click on WINWORD --> Properties --> Compatibilty Tab --> Uncheck the 'Run this program in compatibility Mode for' checkbox, if ticked.

     

    Regards,

    Rubin

    Thursday, November 24, 2011 3:18 AM
  • I was going to try unchecking the compatibility mode box, but it was already unchecked. The problem finally went away for me by checking the compatibility mode box and choosing Windows 7 from the dropdown.

    Good luck,

    Chris

    • Proposed as answer by abhishekcap Wednesday, March 21, 2012 4:04 PM
    • Unproposed as answer by abhishekcap Wednesday, March 21, 2012 4:04 PM
    Tuesday, February 21, 2012 3:20 PM
  • It sounds as though the DDE setting for the .doc and/or .docx extensions are broken. 

    You might want to "re-register" Word's file extensions, which simply involves using the /r startup switch. This article provides more than anyone really needs to know: How to use startup command line switches to start Word 2010, Word 2007, Word 2003, Word 2002, and Word 2000. In brief:

    Close Word
    Start > Run > winword.exe /r {ENTER}

    Does that fix it?
    Wednesday, March 21, 2012 4:04 PM
  • Hi,

    I have the same problem. I have followed the steps you suggested but unfortunately I haven't found neither the 'WINWORD.EXE' in the folder Office12.

    Any suggestions for this?

    Regard,

    Kchr

    Sunday, March 25, 2012 6:25 AM
  • Press shift and Right click the file(docx or xlsx), choose "open with" and select the software you want to open the file with (Ms Word or Ms Excel).

    Try opening the file again and you won't get this message.

    This worked for me.

    Sunday, April 01, 2012 3:49 PM
  • I have tried all those. I have also tried the following:

    • Changing (after backing up): HKEY_CLASSES_ROOT\Word.Document.12\shell\Open\command\(Default)
      from: "C:\Program Files (x86)\Microsoft Office\Office12\WINWORD.EXE" /n  /dde
      to: "C:\Program Files (x86)\Microsoft Office\Office12\WINWORD.EXE" /n  "%1"
    • Deleting (after backing up)
      HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\User Settings\Word_Core
      HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\User Settings\Word_Intl
      HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Word\Options
      HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Word\Data
      HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Word
    • Verifying the following:
      "Ignore other applications that use DDE" - unchecked
      "Run as an administrator" - unchecked
      "Run this program in in compatibility mode for:" - unchecked
    • Changing the default printer to Microsoft XPS Document Writer
    • Uninstalling and reinstalling Office 2007 as the administrator
    • Deleting Normal.dotm
    • Verifying that I have no other versions of Office installed.

    There may be more but I can't keep track of all the things I've tried. I'm running Windows 7 Professional 64-bit and Office 2007. If the application is open, I can double-click the file to open, otherwise, no joy, I get the error message and Word opens but no file. Happens for both Word and Excel but not other office programs (that I've seen so far).

    Monday, August 04, 2014 1:10 AM