none
Outlook 2010 Conditional Formatting Issues

    Question

  • I have added conditional formatting rules in Outlook 2010 but they do not seem to work as I expect.

    I want to have messages that I am not on the To line, but am on the CC line to show up in a different color.  I would like the unread version of these messages to be in bold (in the new color) and the read versions of these messages to be in nonbold but the new color.  I have been successful in getting the read messages to change color, but the unread messages seem to stay in the default bold color.

    Iterestingly, I changed the rule for the unread cc message to be a different size font with bold and a new color and the message in the inbox showed up in the default color with the default bold, but the new font size.

    I think I am creating the rules correctly as I have read how to create conditional formatting rules many places, but it seems like the Unread group headers rule is overriding the new rules.

    Thanks in advance for any help.

    Tuesday, March 22, 2011 4:53 PM

Answers

  • I was able to get what I wanted.  It may not be the "best" way, but it seems to work.

    1.  Changed the Unread messages font to Arial.

    2.  Added a rule to change the font to Arial, Purple when on More Choices tab the Only items that are is checked and set to unread, and on the Advanced tab set a criteria for cc contains my last name and To doesn't contain my last name.

    3.  Added a rule to change the font to Arial, Purple when on More Choices tab the Only items that are is checked and set to read, and on the Advanced tab set a criteria for cc contains my last name and To doesn't contain my last name.

    4.  Added a rule to change the font to Arial, Blue when on More Choices tab the Only items that are is checked and set to unread, and on the Advanced tab set a criteria for To contains my last name.

    Now I have unread items that I am on the cc line and not on the To line showing up as Bold, Purple; items that have been read that I am on the cc line and not on the To line showing up in Regular, Purple; and unread items that have me on the To line showing up in Bold, Blue.

    Like I said, it may not be as efficient as it could be, but it seems to work.

     

    Thanks for all of you help.

    Ken

    • Marked as answer by Ken6432 Wednesday, March 23, 2011 5:35 PM
    Wednesday, March 23, 2011 5:34 PM

All replies

  • Hi

    When you create the rule are you specifically setting the read/unread option under more choices?

    I have just created a formatting rule that changes the colour without setting read or unread.  The colour applies correctly and when marking mail as unread the relevant information switches to bold.

    I tried it with the read option and only the read mails changed colour.  So added a second identical rule but for unread and the colour appeared on both types of message.

    Hope this helps


    G North MMI
    Tuesday, March 22, 2011 8:02 PM
  • Thanks for the input.

    For the cc'd unread, I have the Only Items that are Unread checked on the More Choices tab.  For the cc'd and read, I did not have anything on the More Choices tab selected.

    I will look to see if there is another way to determine if it has been read that will work.  Maybe on the Advanced tab.

     

    Ken

    Tuesday, March 22, 2011 8:40 PM
  • Still does not work.  I cannot find any other way besides the More Choices tab to tell it to set the unread messages to the new color, in bold.

    It seems like a bug to me.  I tried setting the cc'd unread to be a totally different font (Wingdings) and that did not show up either.  Though if I tell it to be Italic that does show up, just in the normal color as the Unread Messages rule.

    Has anyone else seen this issue?

     

    Ken

    Tuesday, March 22, 2011 8:50 PM
  • Hi

    Just to clarify.  You only need one rule setup as follows:

    In the Filter dialog after clicking Condition..., select Where I am and change the option to "on the CC line with other people"

    Click OK

    On the Font button set the colour you want to assign to this type of message.

    Click OK

    Click OK, to complete the rule.

    This single rule will change the colour of messages where you are in the CC box.

    The existing Unread messages rule will control the bold or not when the message is read/unread.

     


    G North MMI
    • Marked as answer by Ken6432 Wednesday, March 23, 2011 1:06 PM
    • Unmarked as answer by Ken6432 Wednesday, March 23, 2011 1:06 PM
    Wednesday, March 23, 2011 9:59 AM
  • I took out all of my other rules and set up a rule exactly as you described.  It still does not work for me.  The color change only takes effect after the message is read.  Before the message is read, the color is still the same as the standard color.

    I have changed the original font and color of the standard Unread message rule.  I don't know if that would make a difference.  I have all of the standard rules set to Arial with the standard colors, except I have the Unread Messages set to Blue Arial.

    Ken

    Wednesday, March 23, 2011 12:45 PM
  • When I change the Unread messages rule back to Auto, it works as you described.  The font of the Unread message rule still overides the cc line rule.  If I change the font of the cc rule to be Wingdings (no I don't plan to keep it on Wingdings, this is just for testing) the font only changes to Wingdings after the message is read.  Unread messages are still in Arial, but the color of the cc rule does work.

    Still seems like a bug to me, but maybe I am missing something.

    Thanks for your help.

    Ken

    Wednesday, March 23, 2011 12:50 PM
  • You can remove the font change from the rules.  If you want your view to display in Arial change the Font in Other Settings and set the Row Font to Arial. 

    This should mean that your Unread is only applying Bold and your CC rule only the colour. All the other font settings are controlled elsewhere, maybe this will give you better results.


    G North MMI
    Wednesday, March 23, 2011 2:54 PM
  • I was able to get what I wanted.  It may not be the "best" way, but it seems to work.

    1.  Changed the Unread messages font to Arial.

    2.  Added a rule to change the font to Arial, Purple when on More Choices tab the Only items that are is checked and set to unread, and on the Advanced tab set a criteria for cc contains my last name and To doesn't contain my last name.

    3.  Added a rule to change the font to Arial, Purple when on More Choices tab the Only items that are is checked and set to read, and on the Advanced tab set a criteria for cc contains my last name and To doesn't contain my last name.

    4.  Added a rule to change the font to Arial, Blue when on More Choices tab the Only items that are is checked and set to unread, and on the Advanced tab set a criteria for To contains my last name.

    Now I have unread items that I am on the cc line and not on the To line showing up as Bold, Purple; items that have been read that I am on the cc line and not on the To line showing up in Regular, Purple; and unread items that have me on the To line showing up in Bold, Blue.

    Like I said, it may not be as efficient as it could be, but it seems to work.

     

    Thanks for all of you help.

    Ken

    • Marked as answer by Ken6432 Wednesday, March 23, 2011 5:35 PM
    Wednesday, March 23, 2011 5:34 PM
  • Ken's 4 steps worked for me to have my unread Inbox mails in Bold and read Inbox mails in nonBold, for mails that met the specific criteria.  Thank you.

    regards

    Kums

    Tuesday, June 19, 2012 5:32 AM