none
“There was a problem sending the command to the program.”

    Question

  • Two environments:

    2. New text Citrix upgrade Xenapp 6.5 on Windows 2008 R2 X64 servers

    Windows 7 64bit

    Office 2007 32bit

    eDocs 5.3.1. patch 3

    One user account – standard user test account.  same rights on both environments

    Issue only occurs on new citrix server 64 bit.

    2. On a windows 7 64bit laptop the issue doesn’t occur.

    The sys admins tell me it’s the same build.

    Scenario:

    1. Log onto citrix 64x

    2. Word document on desktop

    3. Word isn’t open.

    4. Double click on word document to launch

    The results:

    Error message displays ‘There was a problem sending the command to the program.’

    Click OK the document opens

    Can work fine in Word

    Same steps on the laptop 64bit

    1. Log onto laptop 64x

    2. Word document on desktop

    3. Word isn’t open

    4. Double click on word document to launch

    The results:

    Document opens successfully in Word – no error messages.

    I’ve done a web search. people report this issue however on different applications and environments.
    So far the recommendations aren’t applicable to me. 
    These are the fixes I’ve applied so far without success.

    • Re-register Words file extensions:

    Close Word
    Start > Run or press [WIN Key]+R
    In the Run dialog type: winword.exe /r
    Press OK

    • Check settings for Run this program as administrator

    In Start menu, select Word 2007, right mouse click, select Properties, select Compatibility un tick checkbox ‘Run this Program as an administrator.’

    This wasn’t ticked in the first place

    • Excel settings

    Excel behaves correctly. I can replicate the same message if I change a setting in Excel Options, Advanced
    Tick the checkbox ‘Ignore other applications that use Dynamic Data Exchange (DDE)’

    However the same settings aren’t available in Word options. Which makes me think it’s a registry setting that needs updating for Word.

    • Registry hack to turn off /dde

    HKEY_CLASSES\ROOT\Applications\Winword.exe\Shell\Edit\Command

    C:\Program Files\Microsoft Office\Office12\WINWORD.EXE" /n /dde

    The result this works. Opens successfully no errors. However the document management system eDocs requires DDE to open files.

    With the /dde switch removed it also launches multiple winword.exe sessions. Instead of the document being launched in the one winword.exe session.

    Note: the laptop has the same registry value switches set and it works ie

    C:\Program Files\Microsoft Office\Office12\WINWORD.EXE" /n /dde

    • Run "Microsoft Office Diagnostics”

    There must be a difference in the settings or configurations.

    Any other suggestions I can implement.

    dd

    Wednesday, August 28, 2013 1:40 AM

Answers

  • If this is a configuration issue, and best I can tell from your long description no programming code is involved, then you're asking in the wrong place. MSDN forums target programming using Microsoft software, in the case of this forum, the Word APIs.

    Possibly, the TechNet forums for IT Pros would be the right place? Shall I move this for you?


    Cindy Meister, VSTO/Word MVP, my blog

    Wednesday, August 28, 2013 6:03 AM

All replies

  • If this is a configuration issue, and best I can tell from your long description no programming code is involved, then you're asking in the wrong place. MSDN forums target programming using Microsoft software, in the case of this forum, the Word APIs.

    Possibly, the TechNet forums for IT Pros would be the right place? Shall I move this for you?


    Cindy Meister, VSTO/Word MVP, my blog

    Wednesday, August 28, 2013 6:03 AM
  • hi Cindy

    sorry was away on training, & just got back.

    yes you can move to a more suitable forum.

    many thanks Cindy

    dd

    Wednesday, September 04, 2013 11:46 PM