none
"Did you mean" suggests same keyword

    Question

  • When I search for "test" and then refine by result type "Web Page" - it asks did I mean the same "test" keyword? A click on suggestion doesn't change anything.

    Does anyone have an idea of possible reasons for such behavior?

    Thursday, December 27, 2012 11:47 AM

Answers

  • Hi Alexey,

    Query Spelling Correction:
    This function is hosted in the Termstore. We can now easy configure “Exclusion” and “Inclusion” Terms. Another big benefit is, that Terms configured in the “Inclusion” Termset also used for “Did you mean” functionality.
    So this example showing in the Pic would result in searching for ”EI” and didn’t get any results the system will suggest “Did you mean ExpertsInside

    Thanks,

    Jack


    Jack Gao
    TechNet Community Support


    Wednesday, January 02, 2013 5:44 AM
    Moderator

All replies

  • Hi Alexey,

    Query Spelling Correction:
    This function is hosted in the Termstore. We can now easy configure “Exclusion” and “Inclusion” Terms. Another big benefit is, that Terms configured in the “Inclusion” Termset also used for “Did you mean” functionality.
    So this example showing in the Pic would result in searching for ”EI” and didn’t get any results the system will suggest “Did you mean ExpertsInside

    Thanks,

    Jack


    Jack Gao
    TechNet Community Support


    Wednesday, January 02, 2013 5:44 AM
    Moderator
  • Hello Jack, 

    thanks for pointing to Query Spelling Correction, but I believe it's not the case here.

    Let me add more details.

    1. Search for "test" => get multiple results, no spelling correction (as expected)
    2. Refine by Result Type - WebPage => get multiple web pages but with spelling correction "test"->"test". (not expected)
    3. get back and Refine by Result Type Excel => get multiple excel results, no spelling correction (as expected)
    4. works well with refining by other result types except Web Page

    Tuesday, January 15, 2013 8:53 AM
  • This item has been marked as "answered" incorrectly. Response isn't an answer but explanation of the functionality, however I am having the very same issue both on-premises and O365 environments. Can we get more visibility to this issue?

    Same behavior as described. Regardless of the query keyword, SharePoint suggests the same keyword like you have typed incorrectly, but that's not the case.

    Thanks!


    • Edited by alisalih Monday, March 31, 2014 7:10 PM clarification
    Monday, March 31, 2014 7:03 PM
  • Yes, it does look like an issue. I will try to follow up on it, thanks for reporting.

    Lucian Baciu

    Monday, March 31, 2014 7:59 PM
  • Hi Alexey,

    I had exactly the same issue as you in SharePoint 2013 and I have managed to resolve the issue. Firstly I checked that the 'SpellingDictionary' was set to dynamic by using the following PowerShell:

    $ssa = Get-SPEnterpriseSearchServiceApplication
    Get-SPEnterpriseSearchQuerySpellingCorrection -SearchApplication $ssa

    This showed that the 'SpellingDictionary' was set to Dynamic.

    Next, I simply went to my search results page and entered edit mode. I then edited the 'Search Results' web part and unticked the 'Show "Did You Mean?"' box and clicked OK and checked in the page.

    Finally, I edited the results page again and this time ticked the 'Show "Did You Mean?"' box and clicked OK and checked in and published the page.

    For reasons I cannot explain, once I had done this, the 'Did You Mean?' suggestion began to work ok. The only thing I can think is that the steps above effectively reset the settings. This may or may not work for you too. Hope it does. As I say, I don't know why this worked for me but I thought it was worth sharing any way.

    Good luck.

    Joe

    Friday, August 01, 2014 2:40 AM