none
WSS 3.0 file upload problem

    Question

  • Hi,

    I have an itermitent upload problem with WSS 3.0.  I noticed today that the size of the databse in my SQL express 2005 x64 DB is at 4gb so I cleared the log files by I still get the same error.

    The errors ae slightly strnag in that uploading a file from the web using wither Explorer View or normal sharepoint upload fails by either timing out or but saying that the file cannot be found.  I have flushed the logs on the DB and now it is around 2gb.

    Internally, on the LAN it seems that file upload and download without a problem.44I am running sp2 and really hope that sp3 will fix the problem as  have run out of other things to try.

    I've looked at all the usual things like IIS and Web Application timeouts, database size.  Uploads used to work without issue but now they don't

    Some general direction where to look now would be good, or if you have had the same problems then some help is also good.

    Thanks, james

    Sunday, March 11, 2012 8:36 PM

Answers

  • Hi,

    I have found the problem.  It looks like the SQL Express version is 2005 and the database limit has been exceeded and is now 4GB.

    I downloaded the SQL Express Manager, attached to the Sharepoint instance using the following connection string \\.\pipe\MSSQL$MICROSOFT##SSEE\sql\queryIn the Database properties in Options I have set the Recovery mode to Simple and performed a full DB backup (Which I was doing anyway) and then shrink logs.   I did this on both the Content and the Config databases.

    The majority of size was the logs which was 3gb and this has resolved my issue.

    Thanks

    James

    Wednesday, March 14, 2012 9:28 AM

All replies

  • Hi James,

    Maybe your external network speed is slow, and the passed file is relatively large, resulting in timeout.
    Below are the steps to be performed on windows 2003 or window 2008 server
     

    1. Increase the maximum upload size
    a. By default Maximum upload size is set to 50 mb
    b. Click Start, point to All Programs, point to Administrative Tools, and then click SharePoint Central Administration. 
    c. Under Virtual Server Configuration, click Configure virtual server settings. On the Virtual Server List page, click the virtual server that you want to change. 
    d. On the Virtual Server Settings page, under Virtual Server Management, click Virtual server general settings. Select the web application 
    e. Under Maximum upload size, type the maximum file size in megabytes that you want, and then click OK. 
    Note : Maximum file size is 2,047 megabytes

    2. Increase the connection time-
    out setting 
    perform the below steps for IIS 6.0
    a. By default, the IIS connection time-out setting is 120 seconds. To increase the connection time-outsetting, follow these steps: 
    b. Click Start, point to All Programs, point to Administrative Tools, and then click Internet Information Services (IIS) Manager. 
    c. Right-click the virtual server that you want to configure, and then click Properties. 
    d. Click the Web Site tab. Under Connections, type the number of seconds that you want in the Connection time-out box, and then click OK.
    perform the below steps for IIS 7.0
    a. Click Start, point to All Programs, point to Administrative Tools, and then click Internet Information Services (IIS) Manager. 
    b. Select the the virtual server that you want to configure, and then click on Advance settings 
    c. Under Connection Limits ,type the number of seconds that you want in the Connection time-out box, and then click OK.

    3. Increase the maximum upload size in web.config file of web application 

    perform the below steps for IIS 6.0

    1、a. open the web.config of the web application on which we want to increase the size 
    b. Replace the following line:
    <httpRuntime maxRequestLength="51200" />
    with
    <httpRuntime maxRequestLength="153600" />
    2. Do the IIS reset /noforce
    Perform the below steps on IIS 7.0 with administrator pack of IIS 7.0 installed 
    a. On the taskbar, click Start, point to Administrative Tools, and then click Server Manager. 
    b. In the Server Manager hierarchy pane, expand Roles, and then click Web Server (IIS). 
    c. In the Web Server (IIS) pane, scroll to the Role Services section, and then click Add Role Services. On the Select Role Services page of the Add Role Services Wizard, select Request Filtering, and then click Next.
    d. On the Confirm Installation Selections page, click Install. On the Results page, click Close. 
    e. open your SharePoint Web Application in IIS Manager and find the "Request Filtering" option that appears 
    f. choose 'Edit Feature Settings' in the task pane on the right 
    g. set the value on "Maximum allowed content length" as per your requirement 

    Perform the below steps on IIS 7.0 
    a. On the taskbar, click Start, point to Administrative Tools, and then click Server Manager. 
    b. In the Server Manager hierarchy pane, expand Roles, and then click Web Server (IIS). 
    c. In the Web Server (IIS) pane, scroll to the Role Services section, and then click Add Role Services. On the Select Role Services page of the Add Role Services Wizard, select Request Filtering, and then click Next.
    d. On the Confirm Installation Selections page, click Install. On the Results page, click Close. 
    e. open your SharePoint Web Application in IIS Manager and 
    f. Use Notepad to open the Web application Web.config file
    g. Add the following settings under the <configuration> section of the Web.config file: 
    <system.webServer>
    <security>
    <requestFiltering>
    <requestLimits maxAllowedContentLength="52428800"/>
    </requestFiltering>
    </security>
    </system.webServer>

    The following links are about how to troubleshooting the issue:
    http://www.toddklindt.com/blog/Lists/Posts/Post.aspx?ID=152
    http://blog.fpweb.net/troubleshooting-sharepoint-file-not-found-error/

    Thanks,
    Lhan Han
    Tuesday, March 13, 2012 3:09 AM
  • Hi,

    I have found the problem.  It looks like the SQL Express version is 2005 and the database limit has been exceeded and is now 4GB.

    I downloaded the SQL Express Manager, attached to the Sharepoint instance using the following connection string \\.\pipe\MSSQL$MICROSOFT##SSEE\sql\queryIn the Database properties in Options I have set the Recovery mode to Simple and performed a full DB backup (Which I was doing anyway) and then shrink logs.   I did this on both the Content and the Config databases.

    The majority of size was the logs which was 3gb and this has resolved my issue.

    Thanks

    James

    Wednesday, March 14, 2012 9:28 AM