none
Outlook 2010 Hangs at Loading Profile

    Question

  • We just updated our network with all Server 2008 R2 servers, Exchange 2010, and Office 2010 Pro. We have isntalled Office 2010 on all machines and all has been working fine for the last 2 weeks. Over the last 3 days, we now are having some problems with when Outlook is launched, it hangs on "Loading Profile" and does not go any further. I have tried killing the "Agent" process that this creates as suggested in other forums. I have run repairs, and un-install/re-installs which seems to temporaily fix the problem. Most the clients are up-to-date with the Office updates. I have also un-installed SP1 on a couple machines which again works for a bit then the next time the user restarts the computer Outlook hangs again.

     

    This is getting extremely frustrating as I have another thread with some other Office problems. Thanks for the help in advance.

    Friday, January 20, 2012 6:20 PM

Answers

  • Option 1.

    Try deleting outlook profile and delete and re create profile to see that if it loads properly.

     

    Option 2.

    Open task manager > Process do these steps.

    1) Right click the agent.exe process and click properties.

    2) Change the compatibility mode to Windows XP SP3.

    3) Terminate agent.exe as above and restart Outlook or reboot your computer

    For more info refer the link: http://www.interworks.com/blogs/lmcfarlin/2010/07/30/outlook-2010-stuck-loading-profile-window


    With best regards Siddarth Sajjan : Disclaimer: This posting is provided "as is" with no warranties, and confers no rights.
    • Proposed as answer by Siddarth Sajjan Saturday, January 21, 2012 9:25 AM
    • Marked as answer by C_J_GO Tuesday, January 24, 2012 4:05 PM
    Saturday, January 21, 2012 9:19 AM

All replies

  • Option 1.

    Try deleting outlook profile and delete and re create profile to see that if it loads properly.

     

    Option 2.

    Open task manager > Process do these steps.

    1) Right click the agent.exe process and click properties.

    2) Change the compatibility mode to Windows XP SP3.

    3) Terminate agent.exe as above and restart Outlook or reboot your computer

    For more info refer the link: http://www.interworks.com/blogs/lmcfarlin/2010/07/30/outlook-2010-stuck-loading-profile-window


    With best regards Siddarth Sajjan : Disclaimer: This posting is provided "as is" with no warranties, and confers no rights.
    • Proposed as answer by Siddarth Sajjan Saturday, January 21, 2012 9:25 AM
    • Marked as answer by C_J_GO Tuesday, January 24, 2012 4:05 PM
    Saturday, January 21, 2012 9:19 AM
  • Thanks for your help Siddarth!

    With running the agent.exe in XP SP3 mode seemed to have cured the issue. One thing that I do want to note for whoever is also having this issue, is to restart any service that pulls from Outlook as well. For example, we have a Shoretel phone system and use the Shoretel Communicator which pulls its address book from Outlook. I recommend stopping these types of programs from starting up before Outlook does...it appears some of these programs do not like when Outlook is not already running when it tries to pull data from it and perhaps stalls Outlook.

    Tuesday, January 24, 2012 4:10 PM
  • I too had this issue, and it had nothing to do with recreating profiles or going into the registry.  I'm running Win7 x64 with Office 2010.


    I’ve had this happen to me all too often, had 3 different solution options that I was trying, and found one that works every time (so far). The issue for me is with Shortel Call Manager and the “Agent.exe” process.

    For those who use the Shortel contact or voicemail integration, it can sometimes break Outlook if you close it. When you try to re-open Outlook, it can hang on loading profiles until you reboot or kill off the "agent.exe" process. Of course uninstalling voicemail integration solves this problem, but most of us like that feature (listening to voicemail from an email message).

    In short, kill the Agent.exe process if you get stuck. If you want to try a more permanent solution you could try modifying the Agent.exe process to run in XP compatibility mode, but no guarantee.

    There are other programs that use Agent.exe (Macromedia, Roxio, etc.) and this solution may work for that scenario as well.

    • Proposed as answer by Pr0x1 Wednesday, January 25, 2012 5:03 PM
    Wednesday, January 25, 2012 5:03 PM
  • We have been running into the same issue and aslo recently switched to a ShoreTel phone system and are running Office 2010 Pro Plus and Exchange 2010 and ShoreTel 12.1. I have changed 2 of the deault options in my ShoreTel Communicator (professional access) software that have seemed to clear up the problem though I can't say for sure which one of them helped eliminate the problem or if it was the combination. I did not have to uninstall the VM integration. I changed to import contacts manually instead of on startup and I drilled down (import configurator tab) to disable the import of the GAL (ours is several thousand entries which I thought may be problematic). Good luck!

    This fix has worked on both Windows 7 OS and Windows XP SP3.

      
    Wednesday, February 22, 2012 4:36 PM
  • ShoreTel version 12 doesn't work with Office 2010. When you upgrade to ShoreTel version 13 this is fixed.
    Monday, July 09, 2012 5:53 PM
  • I had the same problem.  I tried all the posted solutions without success...new profile, reinstall, reset nav pane, safe mode, killing processes, stopping add-ons, etc.  I found the same solutions repeated ad nauseum on website after website.  Finally after much experimentation I found this solution.

    1.  Export the registry key containing your profiles at HKCU>Software>Microsoft>WindowsNT>CurrentVersion>Windows Messaging Subsystem>Profiles.  This is just a precautionary measure.
    2.  Stop all optional start-up programs from running on boot.
    3.  Kill and uninstall all search programs, such as Google desktop and Copernic.
    4.  Delete the registry key above.
    5.  Create a new profile using the Control Panel>Mail tool.  Include an email address.  I had to do this twice before it would save the new profile...it only works if there are no profiles in the registry.
    6.  Start Outlook in safe mode.
    7.  Manually move your old messages from the old pst file(s) to the new one.  I had 1.5 gigs of mail to move, so it took a while.
    8.  With your messages backed up, delete the old pst file(s).  Move any other old pst files out of the Outlook files folder.  Don't ask me why this worked, but it made the difference.
    9.  Start Outlook with the new profile.  At this point, Outlook started very quickly and without problems.  I hope it works for you.
    10.  Update the programs with the relevant add-ons.  iTunes, McAfee, Sugar Sync, etc. all had add-ons in the Outlook start-up list.  My Sugar Sync add-on was causing problems.
    11.  With Outlook running, reinstall your search program if you had one, using the latest update.  For me it was Copernic that was the problem.  It was set to index Outlook messages, but it was corrupted and had to be reinstalled.
    11.  Use msconfig to selectively reboot.  I did this several times to make sure that no other programs were conflicting with Outlook.  It took forever, and the results were negative, but it seems prudent.

    This solution took me many boring and frustrating hours to work out.  In the end, it was an outside program that was the problem.  I hope this helps you.
    Friday, November 02, 2012 4:37 PM
  • I had the same problem.  Outlook 2010 on Windows 7 Ultimate Service Pack 1 would start the first time but not subsequent times.  It would hang on the splash screen.  We use the ShorTel phone system.  Killing the agent.exe as others mentioned above did work but obviously I didn't want to have to keep doing that.  So I opened the ShorTel settings and went to the Outlook section.  All the boxes were unchecked but I noticed it said that the voice mail integration was installed.  I clicked the uninstall button and that fixed everything.  I can close Outlook and reopen it without having to kill the Agent.exe process.  Hope this helps someone.
    Monday, January 07, 2013 5:02 PM
  • Really easy fix..... Turn off use cached exchange mode.

    Georgio
    Microsoft Answers Support Engineer
    Visit our Microsoft Answers Feedback Forum and let us know what you think



    Friday, February 08, 2013 5:13 PM
  • And how do you turn that off without running Outlook?  
    Tuesday, July 02, 2013 6:03 PM
  • Thanks a lot Adam !

    I tried a lot of things before, with no success.

    Finally, thanks your post, I killed this :  HKCU>Software>Microsoft>WindowsNT>CurrentVersion>Windows Messaging Subsystem>Profiles

    And then recreate profile (Exchange connection for me) with mail icon in control panel.

    Now Outlook 2010 opens the mail database immediately (before it took about 20 seconds!)

    • Proposed as answer by JamesBrewer6 Thursday, September 12, 2013 10:46 AM
    • Unproposed as answer by JamesBrewer6 Thursday, September 12, 2013 10:46 AM
    Thursday, July 25, 2013 2:51 PM
  • This did the trick. Thanks Georgio.   

    I tried recreating the profile, deleted the OST folder, repaired office, uninstalling Shoretel but same issue.

    Friday, December 20, 2013 5:13 PM
  • Mail in Control Panel

    Monday, March 17, 2014 5:54 PM