none
Excel 2010 not enough system resources to display completely

    Question

  • I have searched the web high and low for an answer to this issue we are having with one user who uses Excel 2010 quite extensively and I have not been able to find an answer that resolves the issue.

    She keeps getting the error message "Not enough system resources to display completely."  The spreadsheet in question is a simple two worksheet file that she does simple calculations on.  Her PC is an HP Elitebook 8560w (only 1 month old) with an i7 Intel processor, 8GB RAM, 500GB HDD with over 300GB free, Windows 7 Professional (64-bit) with all the latest patches and updates & Office 2010 Professional (32-bit).  The video and printer drivers are all update to the latest versions. 

    The spreadsheet is one she has used before on her older Windows XP Pro SP3 desktop with no problems.   We have tried the "set the Zoom to 100% or less" resolution that has been mentioned all over the web and it does not work. 

    We are still having this issue.  Does anyone know how to resolve this in Excel 2010.  I have seen the "solutions" for Excel XP, 7, 2000, 2003 and 2007 and they don't seem to work, or at least the ones I have tried!  :-)

    Would welcome all serious suggestions.  Mahalo Nui Loa!

    Monday, May 21, 2012 9:29 PM

Answers

  • Hello Rex,

    Thanks for the quick reply. I checked the visual range and all seems to be fine there.  These two spreadsheets don't really have a lot of data or any major calculations in them. One spreadsheet has two worksheets and the larger of the two has only about 50 rows with about 15 columns and simple SUM calculations.  The other has about 6 worksheets and the other spreadsheet has about 5 worksheets with the larger worksheet having 50 rows with about a dozen columns and only one SUM calculation.  They are not complicated spreadsheets to say the least.  Plus, I think I may have mentioned that this happens intermittently.... sigh!

    I really appreciate the suggestion and the link.  I may just tell the user to recreate the spreadsheets from scratch (no copy/pasting) and see how that goes. 

    Mahalos for the help!


    Wednesday, May 23, 2012 8:08 PM

All replies

  • Hi,

    I would suggest you test minimizing the used range in these spreadsheets, see the following:

    To save memory and reduce file size, Excel tries to store information about the area only on a worksheet that was used. This is called the used range. Sometimes various editing and formatting operations extend the used range significantly beyond the range that you would currently consider used. This can cause performance obstructions and file-size obstructions.

    You can check the visible used range on a worksheet by using CTRL+END. Where this is excessive, you should consider deleting all the rows and columns below and to the right of your real last used cell and then saving the workbook. Create a backup copy first. If you have formulas with ranges that extend into or refer to the deleted area, these ranges will be reduced in size or changed to #N/A.

    More information:
    http://msdn.microsoft.com/en-us/library/ff726673.aspx

    Sincerely
    Rex Zhang


    Rex Zhang

    TechNet Community Support

    Wednesday, May 23, 2012 8:35 AM
    Moderator
  • Hello Rex,

    Thanks for the quick reply. I checked the visual range and all seems to be fine there.  These two spreadsheets don't really have a lot of data or any major calculations in them. One spreadsheet has two worksheets and the larger of the two has only about 50 rows with about 15 columns and simple SUM calculations.  The other has about 6 worksheets and the other spreadsheet has about 5 worksheets with the larger worksheet having 50 rows with about a dozen columns and only one SUM calculation.  They are not complicated spreadsheets to say the least.  Plus, I think I may have mentioned that this happens intermittently.... sigh!

    I really appreciate the suggestion and the link.  I may just tell the user to recreate the spreadsheets from scratch (no copy/pasting) and see how that goes. 

    Mahalos for the help!


    Wednesday, May 23, 2012 8:08 PM
  • I've had this problem on several computers on our network.  I found various recommendations, but no solid answers.  I have resolved this problem on two computers with just the first steps performed.  The third computer require also following the step highlighted in yellow below:

    Deleted all temp files by:

    Start > Run > enter %temp% in the search box and press Enter

    Delete everything from this folder

    Cleared Recent Docs List & Lower Number Displaying:

    File > Options > Advanced > Scroll to Display category > change number of recent documents.  To clear the list, set this to 0 and save.  You can adjust up after that if you choose.

    Delete files from the following folders: (may have to view hidden files – top corner drop down > folder options > view tab > Hidden files and folders > select Show hidden files, folders and drives.

    Local Service:

    %windir%\ServicesProfiles\LocalService\AppData\LocalLow\Microsoft\CryptnetUrlCache\Content

    %windir%\ServicesProfiles\LocalService\AppData\LocalLow\Microsoft\CryptnetUrlCache\MetaData

    Network Service:

    %windir%\ServicesProfiles\NetworkService\AppData\LocalLow\Microsoft\CryptnetUrlCache\Content

    %windir%\ServicesProfiles\NetworkService\AppData\LocalLow\Microsoft\CryptnetUrlCache\MetaData

    LocalSystem:

    %windir%\System32\config\systemprofile\AppData\LocalLow\Microsoft\CryptnetUrlCache\Content

    %windir%\System32\config\systemprofile\AppData\LocalLow\Microsoft\CryptnetUrlCache\MetaData

    The above process worked to prevent this problem on two machines, but not another.  On the one that this didn’t work, I also

    Start > Programs > Windows Update > View Update History.  Look for KB# 2597166 If it exists, click it and uninstall. 

    Can also try, though I didn’t.  I may do this first, but I didn’t feel this was my issue.

    Control Panel > Add/Remove Programs > Select Office > Change > Run Repair


    • Proposed as answer by jhewpoo Monday, June 25, 2012 6:10 PM
    Monday, June 25, 2012 6:09 PM
  • This seemed to work for me. Reducing the amount of recent items displayed (I took it down from 25 to 10), clearing out all temp files and thumbnails, and then just to be thorough I deleted the suggested KB# 2597166 and none of the issues seem to be appearing again. Many many thanks for posting all of these suggestions. I wonder what's up with that security update that it could contribute to this issue?
    • Edited by DKizzy Friday, June 29, 2012 1:59 PM
    Friday, June 29, 2012 1:59 PM
  • Also try disabling autorecover for that workbook. I have had a recent problem with an excel 2010 network shared monthly spreadsheet with hidden cells and macros, that crashed, displayed system resources message and was generally being a pain in the 'derriere'. Previously we worked in Office 2003 with a similar spreadsheet and no problems. Came across the Autorecover solution elswhere on the great helpline that is a famous search engine, but it took some time. I have had no dropouts for 24 hrs now which is remarkable as it would happen several times in a day on 2-3 different machines.

    Regards

    Friday, November 30, 2012 1:04 PM
  • This worked for me. I changed the recent items to 5 and deleted the %temp% folder contents, although, it did not let me delete them all it got the client working.
    Wednesday, December 05, 2012 10:40 PM
  • try lower your display zoom to 95% or 100%.  This error message will disappear.
    Thursday, February 14, 2013 8:50 AM
  • When i am clear all temp file this Problem is Resolve 

    DushYant'

    Wednesday, October 09, 2013 7:56 AM
  • this problem is not low resource is server and file access right to users computer
    Thursday, October 10, 2013 4:02 AM
  • This helped me with this annoying message. Changing the zoom from 80% to 90% did it.

    Never had that problem before, but got it after one of Microsoft's unwanted updates! (It overrides my settings of NOT wanting updates).

    And let me tell you, after getting a new computer with Windows8 :-( , I'm seriously thinking of going to Mac after 30 years on PC. 

    Friday, March 07, 2014 1:33 PM
  • Try to check the zoom on both worksheets to make sure they are equal. I was consistently getting this error recently, and one worksheet was zoomed in and the other was not.
    Tuesday, March 11, 2014 7:09 PM
  • I get this error after I open several huge worksheets.  Even if you close all of your Excel windows the program is still running in the background so you have to Ctrl-Alt-Delete>Start Task Manager>Under Processes Find Microsoft Excel>Right Click and Select "End Process Tree".  After Excel is actually closed you will be able to open files again.  
    Wednesday, July 23, 2014 11:45 PM
  • I know this is an old topic but I had this error today.

    I simply changed my display settings to the optimal and it solved the issue. The user had changed the display settings and didn't realize they were not the optimal settings, they thought it was a bad display.

    Monday, August 25, 2014 1:05 PM