none
Disable spell check word 2010

    Question

  • From a standard user account when I am un-installing spell check in proofing tools - from add remove programs - the change is not staying. Once I restart or log off/login the spell checker is coming up again. Next time i go to add remove programs no change. If I login with an admin account it only does it for the current session next time I login with any user no change. Not sure what exactly is wrong. I am basically trying to disable spell checker - I also have tried classic templates which is applying too. However even this works the standard user will be able to go to word option and re-enable those settings anyway. What is the best work around for this scenario? thanks (btw it is office 2010 pro in win 7 32 bit)

    Thursday, March 31, 2011 10:01 PM

Answers

  • Hi,
     
    To turn off automatic spelling checking and automatic grammar checking for all documents that you create from now on, do the following:
     
    File -> Help -> Options -> Proofing
    Under Exceptions for, click All New Documents.

    Clear the Hide spelling errors in this document only and Hide grammar errors in this document only check boxes.
      
    Sincerely,
    Max Meng


    Tuesday, April 05, 2011 1:55 PM

All replies

  • Hi,
     
    To turn off automatic spelling checking and automatic grammar checking for all documents that you create from now on, do the following:
     
    File -> Help -> Options -> Proofing
    Under Exceptions for, click All New Documents.

    Clear the Hide spelling errors in this document only and Hide grammar errors in this document only check boxes.
      
    Sincerely,
    Max Meng


    Tuesday, April 05, 2011 1:55 PM
  • Thank you
    Friday, April 22, 2011 2:58 PM
  • Hi there.

    I had a try at the above, but it only disables the "auto spell check". Is there a way in Word 2010 to disable / remove the spellcheck functionality? As mentioned in the problem description, trying to disable / remove the spell checker from Add/remove programs doesnt work. I even tried re-naming the %Program Files%\Microsoft Office\Office14\PROOF folder, however Word just re-installed the folder on next-run.

    The issue is that a student can hit F7 and run the spell checker anyway.

    I have also, for the time being, found it useful to remove the proofing section from the Word 2010 ribbon, so <as far as I know> the student will need to know to press F7 to do any spell checking, but obviously to meet the requirements for the Education big-wigs, students can't be allowed to access spell check at all.

    Regards,

    Nathan

    Tuesday, August 30, 2011 10:46 PM
  • Hi Nathan

    Did you find a solution to this issue

    Like you the rules say disable spell check and I have not yet found a way to do so

    Just hiding the function does not fit the bill I suspect

    Regards

     

    Parky29

    Saturday, October 29, 2011 7:59 PM
  • I think I found a way, Open word or any desired application, ie Outlook - go to File -> Options -> Proofing -> deselect Mark grammar as you type, deselect Check spelling as you type (in Word also deselect Check grammar and spelling) and then click on Custom Dictionaries and deselect the Custom.DIC. Restart Word (Outlook) and voila, no spelling correction, no auto correction ..
    • Edited by JakubWz Thursday, November 10, 2011 2:13 PM
    Thursday, November 10, 2011 1:45 PM
  • JakubWz's suggestion is good for Office 2007, but not Office 2010 as the "check spelling as you type" option has been removed in 2010. There is a fix, however, which I've put in another thread on this forum at http://social.technet.microsoft.com/Forums/en-US/officeitpro/thread/f1e95b7e-3eca-4048-9d11-10e1249758a7
    Friday, November 18, 2011 2:57 PM
  • HI all,

    I have written a blog post about this issue. If its of any help.

    http://chronicbit.blogspot.co.uk/2014/03/disabling-proofing-tools-and-related.html

    Matt

    Thursday, March 06, 2014 11:43 AM