none
Outlook 2010 and Communicator 2007 R2 integration: Conversation History

    Question

  • Hi!

    I have an issue with Office 2010 32bit and Communicator 2007 R2 integration on Windows 7 x64. I have two Exchange accounts added to Outlook, and the issue is that Communicator stores conversation history in my other (not default) mailbox. My default Outlook Exchange account is the same as the sign-in account for Office Communicator. It seems to me that there is a bug in Office Communicator. It somehow doesn’t know witch account to use to store conversation history in. I already installed the latest updates for both, Office and Communicator, as well as the latest operating system updates. Does somebody have a hack to resolve this issue? :)

    regards!

    Thursday, May 13, 2010 7:59 PM

Answers

  • First, I would like to confirm if there is a Conversation History folder under each of the two Exchange accounts. If any one of them is lost, please let me know.

     

    Second, I suggest checking the options in your communicator.

    =========

    1.       Open your Office communicator, and click the status button at the top left of OCS and choose options from the list.

    2.       Click Personal from the left panel, after Sign-in address, check if the sing-in address is the default account address. You can also click the Advanced.. button to change the account settings.

    If the settings are not right, please change it to the default account address, and check the options to save the conversation history from the options window. Then, the conversation history should be saved in the default account’s conversation history folder.

     

    If the settings are right, I suggest creating a new Outlook profile to test this issue.

     

    Here are the detailed steps on how to create a new Outlook profile

    ==============

    1.    Exit Outlook.

    2.    Go to Start > Control Panel, click or double-click Mail.

     

    Mail appears in different Control Panel locations depending upon the version of the Microsoft Windows operating system, Control Panel view selected, and whether a 32- or 64-bit operating system or version of Outlook is installed.

     

    The easiest way to locate Mail is to open Control Panel in Windows, and then in the Search box at the top of window, type Mail. In Control Panel for Windows XP, type Mail in the Address box.

     

    Note    The Mail icon appears after Outlook starts for the first time.

     

    The title bar of the Mail Setup dialog box contains the name of the current profile. To select a different existing profile, click Show Profiles, select the profile name, and then click Properties.

     

    3.    Click Show Profiles. Choose Prompt for a profile to be used.

    4.    Click Add.

    5.    Type a name for the profile, and then click OK.

    6.    Start Outlook, and choose this new profile.

     

    If the problem does not occur in the new profile, the old profile is corrupted and we can use the new profile.

    • Marked as answer by Sally Tang Monday, May 24, 2010 6:26 AM
    Monday, May 17, 2010 3:08 AM

All replies

  • First, I would like to confirm if there is a Conversation History folder under each of the two Exchange accounts. If any one of them is lost, please let me know.

     

    Second, I suggest checking the options in your communicator.

    =========

    1.       Open your Office communicator, and click the status button at the top left of OCS and choose options from the list.

    2.       Click Personal from the left panel, after Sign-in address, check if the sing-in address is the default account address. You can also click the Advanced.. button to change the account settings.

    If the settings are not right, please change it to the default account address, and check the options to save the conversation history from the options window. Then, the conversation history should be saved in the default account’s conversation history folder.

     

    If the settings are right, I suggest creating a new Outlook profile to test this issue.

     

    Here are the detailed steps on how to create a new Outlook profile

    ==============

    1.    Exit Outlook.

    2.    Go to Start > Control Panel, click or double-click Mail.

     

    Mail appears in different Control Panel locations depending upon the version of the Microsoft Windows operating system, Control Panel view selected, and whether a 32- or 64-bit operating system or version of Outlook is installed.

     

    The easiest way to locate Mail is to open Control Panel in Windows, and then in the Search box at the top of window, type Mail. In Control Panel for Windows XP, type Mail in the Address box.

     

    Note    The Mail icon appears after Outlook starts for the first time.

     

    The title bar of the Mail Setup dialog box contains the name of the current profile. To select a different existing profile, click Show Profiles, select the profile name, and then click Properties.

     

    3.    Click Show Profiles. Choose Prompt for a profile to be used.

    4.    Click Add.

    5.    Type a name for the profile, and then click OK.

    6.    Start Outlook, and choose this new profile.

     

    If the problem does not occur in the new profile, the old profile is corrupted and we can use the new profile.

    • Marked as answer by Sally Tang Monday, May 24, 2010 6:26 AM
    Monday, May 17, 2010 3:08 AM
  • Hi Sally

    I also suffer from the same issue.  I have Windows 7 (x64), with Office 2010 (x64) and I am using Communicator 2007 R2. 

    I have followed all your steps above but to no avail.  Is there an issue with Communicator being x86 and Office being x64? Or could you possibly suggest other courses of action?

    Regards

    Peter

    Wednesday, June 02, 2010 9:40 AM
  • Actually, same issue here.  Outlook 2010 (64), Win 7 (64), Exchange 07 (SP2) and until a few weeks ago... OC was rocking and even forwarding unread msgs to me.  Now, no missed messages in my inbox and no conversation history.

    Guess we aren't deploying Office 2010... Intuit wasn't ready with Quickbooks and Communicator wasn't ready either.

    I'll check back, but clearly Office 2010 is not ready for deployment yet

    Thursday, June 03, 2010 3:54 AM
  • I also have the same issue.  Windows 7 (x64), with Office 2010 (x32) and I am using Communicator 2007 R2. 

    Have followed steps above to no avail.  Is there an fix for this issue?

    Regards

    Steve

    Tuesday, June 08, 2010 10:39 PM
  • We have the same issue on every machine with a secondary Exchange mailbox too. Windows 7 (32), Office 2010 (32), Communicator 3.5.6907.206.

    Communicator hotfix from July did not solve the problem.

     

     

     

    Tuesday, July 27, 2010 1:22 PM
  • I had this issue and the following has fixed it for me. Go into Office Communicator Options and turn off the two history options in Personal. Sign out of Communicator.

    In Outlook, make a note of the details of the account which is being wrongly used for conversation history and then delete it. Close Outlook and log off the computer (to clear any cached credentials).

    Log back onto the PC, open Outlook and sign into Communicator (if not automatic). Go to Options in Communicator and turn on the history options. Use communicator and check the conversation history is being saved in the correct account.

    Add the second account back into Outlook.

    Good luck with this!

    Tim

    • Proposed as answer by Tim Butterworth Thursday, November 18, 2010 11:27 AM
    Thursday, November 18, 2010 11:26 AM
  • I think it is a bug with both products. I did exactly the same as Tim Butterworth proposed and the problem went away.

    But now it seems to have come back. not sure what exactly I done wrong but the problem seems to be coming back.

    Anyone listening from Microsoft.


    Manishg
    Tuesday, May 31, 2011 12:08 PM
  • Could you please check "Delegates" for all accounts?
    Monday, July 18, 2011 1:23 PM