none
Can't open Excel 2010 file from desktop

    Question

  • I have Excel 2010 on an XP computer.

    When I click "domains.xlsx" from my desktop Excel 2010 will open but not my file. The only way to open it is from inside the File tab.  

    This happens with all my Excel files including my .xls files.

    Could I get some help here.

    Thanks

    Thursday, August 05, 2010 8:49 PM

Answers

All replies

  • File > Options > Advanced > General: uncheck Ignore other applications that use Dynamic Data Exchange (DDE).
    Bill Manville. Excel MVP, Oxford, England. www.manville.org.uk
    • Proposed as answer by BernieTech Tuesday, June 03, 2014 10:47 PM
    • Unproposed as answer by BernieTech Tuesday, June 03, 2014 10:47 PM
    • Proposed as answer by BernieTech Tuesday, June 03, 2014 10:47 PM
    Friday, August 06, 2010 7:05 AM
  • Hi,

    I think maybe this problem caused by the reason. You can try the method below.

     

    ================

     

    First, the problem maybe caused by settings in Excel 2010.

     

    Step 1: Open Excel 2010 and Click File -> Advanced -> General, then delete the “√” before "Ignore other applications that use Dynamic Data Exchange (DDE)"

     

    Step 2: Exit Excel and try to open it from desktop by double click.

     

    If it still don not work, please tell me.

     

    Regards,

     

    Harry

    • Proposed as answer by AKA LIZ Thursday, September 13, 2012 11:59 PM
    • Unproposed as answer by AKA LIZ Thursday, September 13, 2012 11:59 PM
    Friday, August 06, 2010 9:34 AM
  • Thanks guys, but unchecking "Ignore other applications that use Dynamic Data Exchange (DDE)" did not work.

    I don't know if this helps. If excel is open and I click on an excel file on my desktop another separate excel program opens up, again without loading the file.

     

     

     

     

     

     

     

    Saturday, August 07, 2010 6:06 PM
  • In Windows Explorer > Tools > Folder Options > File Types > XLS > Advanced > Open (which should be bold, as the default action) > Edit:
    You should have Use DDE: checked, DDE Message: [Open(%1)]

    Check for other filetypes also, e.g. XLSX

    If incorrect, try repairing the install of Office 2010 via Control Panel > Add / Remove Programs.

     

     

     


    Bill Manville. Excel MVP, Oxford, England. www.manville.org.uk
    Saturday, August 07, 2010 10:49 PM
  • When I highlight Open and click the Edit... button nothing happens. I see the Edit... button being depressed but no new dialogue box appears? If if I highlight Open in Protected View from the Actions: list then click Edit.. I do get a dialogue box to pop open.

     

    Open in Protected &View

    "C:\Program Files\Microsoft Application Virtualization Client\sftdde.exe" "Microsoft Excel 2010 9014006204090000" Excel /dde

    Use DDE is checked

    [open("%1",,,,,,,,,,,,,,,,,1)]

     

    I reinstalled Office but got the same results. I am not sure why I can't click Edit... when Open is highlighted?

     

     

     

     

     

     

     

     

    Monday, August 09, 2010 4:31 AM
  • Sorry, I know nothing about "Microsoft Application Virtualization Client" (App-V) but clearly your Excel is being run by an unusual means, presumably controlled by some IT department?  The following is therefore a shot in the dark...

    If you are able to Start > Run "C:\Program Files\Microsoft Office\Office14\Excel.exe" then you do have a local instance of Excel as well as the means of running it via App-V.  Of you don't need App-V for any other uses of the machine, and you have admin rights on the machine you could try removing App-V and then repairing Office 2010.

     


    Bill Manville. Excel MVP, Oxford, England. www.manville.org.uk
    Monday, August 09, 2010 6:42 AM
  • I am using my person computer with full admin rights.  I can't find excel.exe here - C:\Program Files\Microsoft Office\Office14\  ? I like ms 2010 but the way it's installed/configured is a little bit wacky. I'm going to leave it alone for now.

    Thanks for all your help.

     

    Thursday, August 12, 2010 3:00 AM
  • >I am using my person computer with full admin rights.  I can't find excel.exe here - C:\Program Files\Microsoft Office\Office14\

    I am intrigued to know how Excel came to be installed so that it is run using "Microsoft Application Virtualization Client" (App-V).  It doesn't sound like something that you would do and not know about it, so I assume someone must have done it for you.  Best talk to them about why they did it rather than using a standard desktop install.


    Bill Manville. Excel MVP, Oxford, England. www.manville.org.uk
    Thursday, August 12, 2010 6:28 AM
  • I have the same problem as Harry Potter with Office 2010 - started today.  Just installed on July 20th.  No office files can be opened unless I am in Word or Excel etc. and click on the file from there - which is real inconvenient when trying to open email attachments especially.  There are no programs associated with Word, Excel, PPT etc.  Personal computer with full admin rights.  Same thing Program Files\Microsoft Office\office 14\

    There are no office files to be found???  DDE is unchecked.

    No ability to select default programs because no Office Suite software shows up.  Only the stock windows 7 programs.

    PLEASE HELP ASAP.  THIS IS A RIDICULOUS PROBLEM to be having in the first place.  Is it related to an office update???

     

     

    Friday, August 13, 2010 6:02 AM
  • I'm not fluent with Windows 7 and can't find where to tell you to look to see if you are also using a command line like Terry is to run Excel:
    "C:\Program Files\Microsoft Application Virtualization Client\sftdde.exe" "Microsoft Excel 2010 9014006204090000" Excel /dde

    If you did not install Office on the computer yourself, I suggest you talk to the people who did, in order to understand what version was installed and why it uses App-V.

    I am out of my depth here.


    Bill Manville. Excel MVP, Oxford, England. www.manville.org.uk
    Friday, August 13, 2010 6:57 AM
  • Well, I also faced same problem when someone sent me an .xlsx file, and I was not able to open it by using excel 2003.

    The only way to open your file is by using open office.
    Hope, it helps

    Friday, August 13, 2010 9:42 AM
  • Hi Davebr07

    You should be able to open xlsx files in 2003 once you have installed the compatibility pack:

    http://www.microsoft.com/downloads/details.aspx?FamilyId=941B3470-3AE9-4AEE-8F43-C6BB74CD1466&displaylang=en


    Bill Manville. Excel MVP, Oxford, England. www.manville.org.uk
    • Marked as answer by Sally Tang Tuesday, August 17, 2010 5:10 AM
    Saturday, August 14, 2010 7:00 AM
  • I'm having a similar problem.

    Couldn't open anything saved 2007 or 2010 from icon, had tech try to correct Office 2010 then I couldn't open ANY excel files from icon (only file>open). I unchecked the dde thing and am able to open older than 2007 again, but still not able to open '07 & '10 from icons.

    I'm running windows 7.

    Any ideas?

    Thanks!

    Tuesday, January 11, 2011 8:42 PM
  • To others who are having this problem, Bill's solution worked for me. Since this thread was the first hit on Google when I searched on "excel 2010 doesn't open files when clicked on" I thought I'd add my comment.

    Bill suggested:

    File > Options > Advanced > General: uncheck Ignore other applications that use Dynamic Data Exchange (DDE).

    However, I found the box already unchecked .  I checked it,  closed the window and then re-opened the window and rechecked it.

    This fixed the problem for me. 

    Note that some of the responses in this thread assume that the original poster was having problems opening an Excel 2010 file in a previous version of Excel. That's not the problem he was having!   His problem was that double-clicking a file on the desktop would open Excel, but Excel would not open automatically open the file.

     


    Tom
    Wednesday, March 16, 2011 3:58 PM
  • I am having the same issue as tfield98x. I'm running Excel 2010 on a Windows 7 Ultimate computer. When I click on an .xlsx file directly from the desktop, it will not open. It can only be opened from inside Excel 2010.

     

    Bill's suggestion has not worked for me. Do you know of any other solutions? I cannot find a solution on the Microsoft website.

    Wednesday, May 25, 2011 3:54 PM
  • Dear Guys

    I also faced the same issue and, thanks guys but after digging through the registry i found the key under xlsx was wrong. The openwithprogid was wrong it was something like exel_auto_fil rather than excel.sheet.12.

    Dont know how much $ we need to spend before microsoft tech support will help but $25,000 on office alone isnt enough :-(

    +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

    Follow the steps to resolve it

    run: regedit

    go to : HKEY_CURRENT_USER ==>Software ==>Microsoft ==>Windows ==>

    CurrentVersion ==> Explorer ==> FileExts ==> .xlsx ==> OpenWithProgrids

    cick right mouse
    add New ==> Binary Value ==> name the binary value as ===> Excel.Sheet.12

    click ok

    Same you can do it for docx ==> Word.Document.12 if its not opening properly with Office 2010

    ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

    Good luck
    Gee

     

    Monday, November 07, 2011 8:27 AM
  • Dear Guys

    I also faced the same issue and, thanks guys but after digging through the registry i found the key under xlsx was wrong. The openwithprogid was wrong it was something like exel_auto_fil rather than excel.sheet.12.

    Dont know how much $ we need to spend before microsoft tech support will help but $25,000 on office alone isnt enough :-(

    +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

    Follow the steps to resolve it

    run: regedit

    go to : HKEY_CURRENT_USER ==>Software ==>Microsoft ==>Windows ==>

    CurrentVersion ==> Explorer ==> FileExts ==> .xlsx ==> OpenWithProgrids


    click right mouse
    add New ==> Binary Value ==> name the binary value as ===> Excel.Sheet.12

    click ok

    Same you can do it for docx ==> Word.Document.12 if its not opening properly with Office 2010

    ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

    Good luck
    Gee

    Monday, November 07, 2011 8:30 AM
  • Has anyone still been able to solve this?  

    I tried all of these steps and still cannot directly open .xlsx files from my desktop.

    It's slowly driving me insane.


    Thursday, May 03, 2012 1:56 PM
  • New to this and regedit - a first ever - but - this worked on Windows7 prof 32bit with Office2010
    Mine had been trying to use Windows Media player of all things.  I had tried forcing from File association window or rightclicking file and using Open with - this messed up reg by the look of it creating unneeded entries.

    Work as Geekoshy with BACKUP and ADDITIONS as below

    BACKUP
    Right click xlsx key and Export to docs as xlsx, if you need to restore to original state simply double click it will put itself back automatically.

    As from Geekoshy
    Follow the steps to resolve it
    run: regedit
    go to : HKEY_CURRENT_USER ==>Software ==>Microsoft ==>Windows ==>
    CurrentVersion ==> Explorer ==> FileExts ==> .xlsx ==> OpenWithProgrids
    click right mouse
    add New ==> Binary Value ==> name the binary value as ===> Excel.Sheet.12
    click ok

    ADDITIONS
    If there is a key in xlsx called user choice or other such - Delete it
    If there is an entry within Progids other than Default - Delete it

    NOW

    When you double click the xlsx file to open you get a program list including in my case Windows Media Player (its own old choices)- choose or select Excel and tick the Always use this box underneath - it all works.

    Hope it works for you.

    Friday, June 22, 2012 7:24 AM
  • I have EXECL 2010 and I had the same problem opening .xlsx attachments with a double click on the desktop.  I solved my problem this way:

    Go to Control Panel

    Open Programs

    Go to Defaul Programs

    Choose Associate a protocol or file type with a program

    Scroll down to .xlsx and select

    Click Change Program

    Associate this extension with Excel 2010

    You can now open files from desktop and attachments as well.

    Friday, September 14, 2012 12:05 AM
  • This solution worked to me.
    Tuesday, February 11, 2014 8:26 PM
  • After running down all possibilities stated here and none of them working, I made some adjustments to AKA LIZ's suggestion.

    My Office is the Starter 2010 edition, which came with the laptop. However, after some update or something, I can no longer find any Office 2010 folder, only Office14, which of course is empty.

    Taking AKA LIZ's lead, I went to Control Panel > Default Programs > Associate a protocol or file type and searched (in vain) for Excel / Word (problem was the same).

    I noticed that other file extensions on the list had the correct icon, and the program associated with them was NOT "Microsoft Office", but "Microsoft Application Virtualization DDE Handler" for Excel extensions or "Microsoft Application Virtualization Handler" for Word ones (Please note I have no idea what this is or what DDE might even stand for).

    I then decided to check the shortcuts for Excel/Word on my quick launch and noticed that the programs used were precisely those, so I proceeded to associate the extensions with those programs... and it worked!

    So, summarizing (sorry if too long a post):

    Go to Control Panel > Default Programs > Associate a protocol or file type with a program

    Then find the extensions you want (usually .xls and .xlsx for Excel and .doc and .docx for Word), and choose the programs that whatever shortcuts you have open to. Excel pointed to the same program, which didn't work, but the actual program was already on the available programs list. For reference, mine were in "C:\Program Files (x86)\Microsoft Application Virtualization Client\sftdde.exe" for Excel and "C:\Program Files (x86)\Common Files\microsoft shared\Virtualization Handler\CVH.exe" for Word.

    Tuesday, February 18, 2014 5:26 PM
  • Thanks a lot!!! This

    File > Options > Advanced > General: uncheck Ignore other applications that use Dynamic Data Exchange (DDE).

    worked just fine for me. I bought a new Satellite Toshiba on november 2012. It has Windows 7 and had Office 7 also. Everything was fine but one day Word started to use humongous CPU resources, to the point where the fan turned on (Some kind of CPU consuming loop maybe?). Anyways, I found this was happening with other users and I also found a fix and downloaded it. The only problem then is I couldn't directly open Word anymore and later Excel followed in. I upgraded to Office 13 and Word stopped doing that but not Excel. I was thinking of reinstalling or upgrading Windows. Anyways, I tried this fix here mentioned by Bill Manville and it worked!!!! (Maybe I could have fixed it without upgrading Office).

    Tuesday, June 03, 2014 10:45 PM