none
Cannot Change Programmatic Access Security

    Question

  • Hello All,

    I am having an issue when creating an email mailmerge in Word 2010.  I have a document that I want to attach to each email for over 100 recipients.  The problem is that when you use the attachment mode you are warned for each person - very annoying.  When I go to the Trust Center and try to change the Programmatic Access Security it is all greyed out and the first option to always warn is set.  I have gone into the registry and created a key to change the dword to 3 for do not warn.  I can see that it is changed in Outlook but my merge still warns me for every email.  I am not using Exchange and my A/V program shows valid in Outlook - I am using Norman Data Defense.  Not sure what to try at this point.  Any suggestions would be greatly appreciated.  I have a friend that is using AVG for A/V and their systems say that the A/V is invalid.

    Regards,

    Rob


    Rob Battaglia
    Tuesday, November 01, 2011 9:15 PM

Answers

  • Hi Bob,

    The issue you are experiencing is because of the enhanced security features of Outlook 2010.

    To resolve the issue, please create the following registry key and Dword values:

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\Outlook\Security
    Dword: PromptOOMSend
    Value: 2
    Dword: PromptOOMAddressBookAccess
    value: 2
    Dword : PromptOOMAddressInformationAccess
    Value:2
    Dword: PromptOOMMeetingTaskRequestResponse
    Value: 2
    Dword: PromptOOMSaveAs
    Value: 2
    Dword: PromptOOMFormulaAccess
    Value: 2
    Dword: PromptSimpleMAPISend
    Value: 2
    Dword: PromptSimpleMAPINameResolve
    Value: 2
    Dword: PromptSimpleMAPIOpenMessage
    Value : 2

    You can also refer to http://support.microsoft.com/kb/953806.

    FYI - Although the KB refers to Outlook 2007, it is applicable to Outlook 2010 as well.

    Hope this Helps.

    Regards,

    HARVEYY - [MSFT]

    Friday, November 11, 2011 8:49 PM

All replies

  • Hi Rob,

    Judging from what you said, I'd suggest you to get contact with your IT/Domain/Exchange administrator, cause this setting could be controlled by the Globle Group Policy, and it won't be allowed to be modified by your own.

    If you are not in the Enterprise environment, you can try to check the settings by your own.

    The policy setting is under ''Microsoft Outlook 2010\Security\Security Form Settings\Programmatic Security", set the value to Not configured or Disabled. And restart your Office.



    Sincerely,

    Max Meng
    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com.

    Thursday, November 03, 2011 7:29 AM
  • Hello Max,

    Where do I find the policy settings on my local machine?  I am not on an Exchange Server.

    Regards,

    Rob


    Rob Battaglia
    Thursday, November 03, 2011 1:03 PM
  • Can  you also respond to the issue of the A/V software not being valid - I have a customer that uses AVG and Outlook states that it is not valid in the Programmatic Security settings.  Does MS not support AVG as a secure A/V software?

    Thanks,

    Rob


    Rob Battaglia
    Thursday, November 03, 2011 1:41 PM
  • Hello Max,

    It has been a few days and I have not heard back from you.  I was able to install the snap-in for Office 2010 in my local group policy.  I changed the Security mode in the security form settings to enabled with use outlook security group policy.  I also enabled the configure outlook object model prompt when sending mail and set it to automatically approve.

    The Programmatic Access Security is still grayed out in Outlook but now none of the options are selected because I am using the local group policy to control it.  Unfortunately the warning still appears when I perform a mail merge email with attachment.  My antivirus is Norman Security Suite and in Outlook under the Programmatic Access Security it does say that it is valid.

    What else should I try?

    Regards,

    Rob


    Rob Battaglia
    Wednesday, November 09, 2011 4:13 PM
  • Hi Bob,

    I'm trying to invovle someone familar with this issue to further look.

    Besides that, could you try to install the Forefront to check if it will work?

    Download the trial here:

    http://www.microsoft.com/en-us/server-cloud/forefront/default.aspx



    Sincerely,

    Max Meng
    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com.

    Thursday, November 10, 2011 6:02 AM
  • Hi Bob,

    The issue you are experiencing is because of the enhanced security features of Outlook 2010.

    To resolve the issue, please create the following registry key and Dword values:

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\Outlook\Security
    Dword: PromptOOMSend
    Value: 2
    Dword: PromptOOMAddressBookAccess
    value: 2
    Dword : PromptOOMAddressInformationAccess
    Value:2
    Dword: PromptOOMMeetingTaskRequestResponse
    Value: 2
    Dword: PromptOOMSaveAs
    Value: 2
    Dword: PromptOOMFormulaAccess
    Value: 2
    Dword: PromptSimpleMAPISend
    Value: 2
    Dword: PromptSimpleMAPINameResolve
    Value: 2
    Dword: PromptSimpleMAPIOpenMessage
    Value : 2

    You can also refer to http://support.microsoft.com/kb/953806.

    FYI - Although the KB refers to Outlook 2007, it is applicable to Outlook 2010 as well.

    Hope this Helps.

    Regards,

    HARVEYY - [MSFT]

    Friday, November 11, 2011 8:49 PM

  • Worked for me.  Thanks.

    • Edited by JPAUMC Tuesday, May 22, 2012 4:56 PM spelling errors
    Tuesday, May 22, 2012 4:54 PM
  • These warnings started popping up on my system after installing a utility which synchronizes my Outlook Contacts with Google Contacts.

    Fortunately, I found a safe way to eliminate the warnings from Outlook, while keeping it protected from malware. It turned out the warnings were not caused by that utility itself. They occurred because Outlook, for some reason, was not (yet) recognizing my anti-virus program as valid.

    Here's how I solved it.

    1) Open Outlook 2010, go to "File/Options/Trust Center" menu item, and then click on the "Trust Center Settings" button at the right side of the dialog box.

    2) From there, select the "Programmatic Access" menu item. At the bottom of this dialog, note what your "Antivirus status" is. If it is "Invalid" then close Outlook, navigate to where its "OUTLOOK" program icon is on your disk (typically it sits in the "Program Files (x86)/Microsoft Office" folder), and then right-click this icon and select "Run as administrator" from the pop-up-menu. If you get a warning, then select "allow" or "yes" to continue.

    3) Then in Outlook, go back to Programmatic Access as described above, and you should see your antivirus status updated to "Valid" (assuming you have an up-to-date antivirus program on your computer).

    4) Exit Outlook. Then open it the way you usually do. The warnings should now be gone.

    This way, your Outlook application will be protected from malware, and you should no longer see warnings when other applications try to access Outlook.

    Wednesday, December 05, 2012 7:34 AM
  • Thanks for that: worked fine, but I had to change the access to "Never warn. . ."

    NB: this is the first time I've seen this solution after a lot of searching. All mailmerge guides just assume that it works.

    Tuesday, January 21, 2014 6:52 AM
  • If the problem persists, despite having tried the solution given, then try my solution : 

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\(Your outlook version)\Outlook\Security

    Inside Security you must add or modify :
    o PromptSimpleMAPISend
    o PromptSimpleMAPINameResolve
    o PromptSimpleMAPIOpenMessage

    All of them must are DWORD and have value 2 hex.

    After this you must check the following path :

    HKEY_LOCAL_MACHINE/SOFTWARE /Microsoft/Office/(here you choose your outlook version)/Outlook/Security

    IF the path doesn't exist then create it.

    Inside security must be a DWORD named "ObjectModelGuard" with value 2 hex.

    then restart and try again if the problem persists.

    I have tried this on W.XP & W7.

    Best Regars,

    E.Fernandez


    • Edited by EFernandezV Friday, January 24, 2014 7:23 PM
    Friday, January 24, 2014 7:21 PM
  • I thought my answer was correct but it didn't work on my work PC (which was where it was needed).

    In the end I discovered setting

    HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\default

    to Microsoft Outlook (it was set on Eudora) did the trick.

    The normal Windows GUI was showing the default mail client as Microsoft Outlook, but apparently some programs (eg Word) don't take any notice of that, just what is showing in the above key.

    Aargh!

    • Proposed as answer by anahr Tuesday, January 28, 2014 8:56 PM
    • Unproposed as answer by anahr Tuesday, January 28, 2014 8:56 PM
    Saturday, January 25, 2014 4:34 AM
  • Right click on the Outlook shortcut and 'run as administrator'

    Then the programmatic access options will no longer be greyed out.


    • Edited by anahr Tuesday, January 28, 2014 9:00 PM typo
    Tuesday, January 28, 2014 8:57 PM
  • WOW, I wish I had skipped to the bottom first. This one works great for me. I was thinking to try that anyway but unfortunately searched the web, stumbled on this article and tried all the registry suggestions above first.
    Wednesday, March 05, 2014 3:29 PM