none
Automatic replies (out of office) says server unavailable in Outlook 2010

    Question

  • I had been using Office 2010 Beta for several months and did not have a problem with the out of office assistant until I upgraded to the official version of Office 2010 last week.  Now when I try to access Automatic Replies, it says the server is currently unavailable.  Can anyone help. I don't think this is an Exchange issue since it just started happening after I installed the official version.

    I'm using Vista, office 2010 and my email is hosted with GoDaddy Exchange servers.

    Thanks in advance!

     

     

    Thursday, June 24, 2010 9:37 PM

Answers

  • Hi,

     

    This issue may occur when one or more of the conditions are true:

    1.       You’re trying to open the OOF settings of different Exchange-account

    2.       Incorrect Auto-discover Service settings

    3.       Wrong certificate

    4.       “Enable Anonymous Access” is enabled in IIS on the EWS virtual directory.

     

    1) In most cases, the reason for this error is that you try to adjust the Out of Office settings of User A, while you’re logged on as User B. As an Exchange administrator, you probably need to modify colleague Out of Office settings on occasional basis. Unfortunately, this is not possible since we have migrated from Outlook 2007 to Outlook 2010, you couldn’t modify Out of Office settings any more. Editing OOF settings by logging in with an administrator account resulted in the following error:
    Your Out of Office settings cannot be displayed, because the server is currently unavailable. Try again later

     

    Solution: Log in as user X, but then you will have to reset the users’ password.

     

    If the problem persists, you can also check if this article helps: http://www.proexchange.be/blogs/exchange2007/archive/2009/07/14/your-out-of-office-settings-cannot-be-displayed-because-the-server-is-currently-unavailable-try-again-later.aspx

     

    Please take your time to try the suggestions and let me know the results at your earliest convenience. If anything is unclear or if there is anything I can do for you, please feel free to let me know.

     

    Best Regards,

     

    Sally Tang

    • Marked as answer by Sally Tang Monday, June 28, 2010 2:36 AM
    Friday, June 25, 2010 7:35 AM

All replies

  • Hi,

     

    This issue may occur when one or more of the conditions are true:

    1.       You’re trying to open the OOF settings of different Exchange-account

    2.       Incorrect Auto-discover Service settings

    3.       Wrong certificate

    4.       “Enable Anonymous Access” is enabled in IIS on the EWS virtual directory.

     

    1) In most cases, the reason for this error is that you try to adjust the Out of Office settings of User A, while you’re logged on as User B. As an Exchange administrator, you probably need to modify colleague Out of Office settings on occasional basis. Unfortunately, this is not possible since we have migrated from Outlook 2007 to Outlook 2010, you couldn’t modify Out of Office settings any more. Editing OOF settings by logging in with an administrator account resulted in the following error:
    Your Out of Office settings cannot be displayed, because the server is currently unavailable. Try again later

     

    Solution: Log in as user X, but then you will have to reset the users’ password.

     

    If the problem persists, you can also check if this article helps: http://www.proexchange.be/blogs/exchange2007/archive/2009/07/14/your-out-of-office-settings-cannot-be-displayed-because-the-server-is-currently-unavailable-try-again-later.aspx

     

    Please take your time to try the suggestions and let me know the results at your earliest convenience. If anything is unclear or if there is anything I can do for you, please feel free to let me know.

     

    Best Regards,

     

    Sally Tang

    • Marked as answer by Sally Tang Monday, June 28, 2010 2:36 AM
    Friday, June 25, 2010 7:35 AM
  • Sally,

    Thank you for your reply. I'm not an Exchange admin.  My email is hosted with Godaddy's exchange server. The issue I'm experiencing is on the client side. I have followed the instructions in the proexchange blog link you have. I am able to connect to the https link that shows for the OOF when I do test autoconfig. I only have one exchange email setup on my laptop, so I've checked 1 and 2 of your conditions. Do you know how I can check 3 & 4?

    Thank you.

     

     

    Wednesday, June 30, 2010 1:37 PM
  • Sally,

    After messing with this for a few days, I have learned something new. When I am connected to one of my customer's systems through Microsoft VPN, Out of Office works! So, this leads me to believe it is in my network settings, but I don't know which setting to change.  With this new information, I'm hoping you or someone can help me.  I've read in other threads about a dns setting, but I'm not sure what to add or change in the DNS settings.  The out of office says server is currently unavailable when I am connected through my wired and wireless connections.

    Thanks in advance.

    Kim

     

     

    Thursday, July 01, 2010 3:05 AM
  • Try to flush DNS:

    ipconfig /flushdns

    Best Regards,

    Sally Tang

    Tuesday, August 31, 2010 1:27 AM
  • If someone else has this problem try this:

    go to control panel> mail.

    Create a new profile. (you don't have to use cached mode for this one, we're just testing)

    Open outlook using the new profile and test the Automatic reply.

    If it works, just kill off the old profile and use the new one (and you can switch it to cached.)

    i don't know exactly what it fixed, my testing showed the wrong url in the registry settings for the old one, but it worked and was faster than trying a million other things that didn't work. :P

    hope this helps someone.

    Cheers!

    Wednesday, July 20, 2011 1:05 AM
  • Hi Sally,

    I tried a flushdns and I got a "program not responding" message for about 30 seconds then the same error came up again. "Your automatic reply settings cannot be displayed because the server is currently unavailable. Try again later."

    My situation is  little different because we are in a large company that is mostly migrated to EX2010 using Outlook 2010. This problem is specific to just one user that we know of. This particular user's OOF works fine in OWA but not from his client. Also, no mater where (machine) you recreate his profile the problem follows his profile. When we moved his mailbox to a 2007 EX server. the problem went away but we moved him back to 2010 thinking that the bugs worked themselves out but the error still persisted. The user wanted to go back to 2010 because of his iPhone functionality.

    Besides teh flushdns, i also tried gpupdate /force

    Thanks and please let me know if you have other solutions.

     

    • Proposed as answer by drew-man-chu Monday, October 03, 2011 2:59 PM
    • Unproposed as answer by drew-man-chu Friday, October 14, 2011 5:02 PM
    Tuesday, September 27, 2011 8:04 PM
  • Hi Sally,

    As a simple user I upgraded from 2003 to 2010 a few months ago. Tried all these suggestions, even our support team are confused, I have reverted back to 2003 and hey ho out of office is working again! Why should an upgrade cause so much grief?


    Thursday, October 27, 2011 9:42 AM
  • I know this is a old post but I thought I would drop a comment since it seems to hit high on the search results.  I hopes this helps someone.  

    I experienced this same Out of Office error message stating, "Your automatic reply settings cannot be displayed because the server is currently unavailable. Try again later."  

    This was noticed after a Exchange 2007 to 2010 migration with clients all using Outlook 2010. Once the users had a mailbox on the new 2010 server they got this error.  I'm pretty sure the EWS directory was the default created by Exchange 2010 SP1 setup.com /p.  I tried all the suggestions in http://www.proexchange.be/blogs/exchange2007/archive/2009/07/14/your-out-of-office-settings-cannot-be-displayed-because-the-server-is-currently-unavailable-try-again-later.aspx and nothing in it worked or was relevant to my software versions. 

    MY FIX:

    IIS Manager --> Open the EWS virtual directory --> SSL Settings --> Require SSL = enabled/checked , Client Certificates = Ignore.  Click Apply.

    I dont think I even had to restart Outlook or do a iisreset. This simple change fixed my Out of Office error.    


    • Proposed as answer by Geekasso Tuesday, January 31, 2012 10:09 PM
    Tuesday, November 01, 2011 7:56 AM
  • Cyrus847, that worked for me!  Thanks!  Yes, worked right off the bat, no service restarts or IISReset.
    Wednesday, December 14, 2011 9:05 PM
  • MY FIX:

    IIS Manager --> Open the EWS virtual directory --> SSL Settings --> Require SSL = enabled/checked , Client Certificates = Ignore.  Click Apply.

    I dont think I even had to restart Outlook or do a iisreset. This simple change fixed my Out of Office error.    


    That worked for me too. Thank you.
    • Proposed as answer by MLRSwansea Monday, September 17, 2012 3:57 PM
    • Unproposed as answer by MLRSwansea Monday, September 17, 2012 3:57 PM
    Tuesday, January 31, 2012 10:09 PM
  • yes. that did it for mee too.

     

    strange behaviour that I noticed: When the user was logged in with his own account, on his own computer, i got the 'your automatic reply etc...' When I logged in as ad admin on another computer, and opened the users mailbox, it all worked fine. (this in contrast to what others are experiencing)

     

    n.e.how: your fix did it.

    Friday, February 03, 2012 1:30 PM
  • Hi guys been looking at all the info on here. How do I get into the IIS in the first place? I am completely useless on a PC (so forgive the dull question). I have found how to check the IIS is on - it wasn't and now is but only showing IIS 6?? Everything I am reading is IIS 7...Help!!
    Monday, February 20, 2012 11:29 AM
  • I found a different way to fix this issue. We have Exchange 2007, and had an Outlook 2010 client that could not access her out of office settings because the server was unavailble. I tried almost all of the solutions on this page to no avail. What worked was to go into the Outlook user's account settings (under the "file tab.) Highlight the user's acct->Click the "repair" button->Manually configure settings->leave the settings as is, but click the "more settings" button->click the "security" tab->check the box for "always prompt for credentials". See if that works after exiting and going back in. It worked after this, and after several Outlook logins with the password, I was able to go back in and uncheck the credentials box and still have it work.

    Interestlingly, we only had this problem with her computer and account only. Different combinations worked fine. (My email on her computer worked ok, and her email worked on my computer)

    Marky, I believe the previous poster was referring to their Exchange server for the IIS manager. I found it under Server Manager->Roles. I didn't want to mess with mine because I don't want hundreds of users to lose email to try and fix one account :) My box was unchecked, btw.

    • Proposed as answer by h3ctiic Thursday, August 01, 2013 9:01 AM
    Monday, February 20, 2012 7:51 PM
  • on 2007 i did a repair to the email account and it worked .. under the mail icon in control panel ..
    Wednesday, August 15, 2012 1:48 PM
  • After trying many potential solutions, benji's solution also worked for me - thanks for sharing benji
    • Edited by Pauly68 Friday, June 21, 2013 9:25 AM cause
    Friday, June 21, 2013 9:21 AM
  • Solution from benji_b1980 worked for me as well. (outlook/exchange 2010) - Problem started when user changed AD password.
    Thursday, August 01, 2013 9:02 AM
  • I had a similar issue with 2 of our users.  We are running Exchange 2010 on Windows Server 2008 R2 & Outlook 2010 on Windows 7 clients.  Servers are Service Pack 1, clients all have the latest patches from Microsoft Update.  We never ran a beta version of anything.  Everyone uses Cached Exchange Mode.  The two users in question were migrated from Exchange 2003 to Exchange 2010 a few years ago, but there were no problems with Out Of Office until just recently.  When they tried to set an Out Of Office reply from within Outlook, they got a message saying the server is currently unavailable.  Setting the Out Of Office reply through OWA worked fine.  Deleting & recreating their profile did nothing.  To resolve the issue, on both client machines I did the following:

    • Make sure Outlook is closed
    • Open Control Panel
    • Open User Accounts
    • In the left-hand column, click Manage your credentials
    • Find the credentials that say MS.Outlook:email@servername.com.  On these two client PCs, it was under "Generic Credentials."
    • Click the down arrow on the right
    • Click Edit
    • Erase the password & have the user type in their current Windows Active Directory password.
    • Click Save
    • Reopen Outlook

    After that, everything worked as it should.  I didn't make any modifications on the server at all.

    • Proposed as answer by Hal'sNemesis Thursday, August 08, 2013 3:33 PM
    Thursday, August 08, 2013 3:32 PM
  • I did the "on 2007 i did a repair to the email account and it worked .. under the mail icon in control panel " except I have Outlook 2013 and auto reply works for me now.
    Thursday, November 21, 2013 9:42 PM
  • This solution by beni_b1980 worked for us we had one user with Outlook 2010 after migrating from SBS 2003 to SBS 2011 the user was unable to access OOF settings.  After following the instructions everything was restored.

    Thanks!

    Wednesday, January 15, 2014 8:51 PM
  • There is a another way to set OOF, I thought in 2013 this disappeared. But it was simple, make sure you have a domain account i used our main domain admin account that has access to all mailboxes on the server, setup a test box with outlook 2010 or 2013 installed, do not create any default profile, go to Control Panel > Mail > Show Profiles, use the option Prompt for a Profile to be Used.

    Create / Add / Remove profile, I set the profiles with online access only to not impact the disk usage, else for each profile it will download the mailbox locally. 

    When you click on Add under the E-Mail account (you need your autodiscovery to be working properly on the domain) just change the email address for this domain admin account to the users email address and click next do not need to change any other fields or even enter password (if domain account you are using has full access to end users mailboxes). 

    Launch outlook and choose the profile you want to use. You can setup OOF and do anything with that account as if you were logged in as that particular user, example setup the shared calendar's etc. 

    It will even work with OWA if you login as the domain account with full access to all the mailboxes, you just switch to different mailboxes on the browser. 

    I do not know if you really need to change anything on IIS for this to work. It worked out of the box for us.


    • Edited by IamPK Tuesday, March 18, 2014 5:29 PM
    Tuesday, March 18, 2014 5:27 PM