none
Configuration of Gmail accounts in Outlook 2013

    Question

  • Like many Outlook 2013 users, I am having problems with  IMAP accounts in Outlook 2013.

    This case is about my Gmail account.  I was able to set it up so that mails are being received in and sent from Outlook, but the Gmail folder "All Mail" was not shown in outlook, even though I had enabled all Gmail folders for IMAP and also subscribed to them.

    One post I found (in German) suggested limiting Outlook's hierarchy display to subscribed folders, but that didn't help in my case.

    Several posts on MS and other websites suggest setting the root folder path in Outlook.  This brought some improvement, as I can now see the Gmail "All Mails" folder and no longer need to expand [Gmail] to see the folders previously hidden under it.

    However, some Gmail folders now appear twice in Outlook:

    • All Mail
    • Chats
    • Important

    Furthermore, the synchronization does not work as I would expect:
    Most Gmail folders are simply filtered views of "All Mail".  In particular, incoming mail marked "Important" appears both in the inbox and in the "Important" folder.  I would expect that a message deleted in Outlook from one of these folders would also be removed from the other, but this isn't happening in my installation.

    Some posts on both MS and other websites suggest that IMAP synchronization can be improved by renaming folders on the provider side using the web interface.  However, I don't want to do this for fear of the possible impact on other IMAP clients (e.g. my smartphone) which also access the Gmail account.

    Surely there are enough Outlook 2013 users with Gmail accounts to justify publishing a detailed article on how best to configure it, but I haven't yet found one

    What is the "Best Practice" for configuring a Gmail account in Outlook 2013?

    Thanks in advance for responding!

    Tuesday, October 29, 2013 9:27 AM

Answers

  • Hi,

    Have you tried John's suggestion? Just create a new mail profile for test, it will not affect your existing profile.

    http://office.microsoft.com/en-in/outlook-help/create-an-outlook-profile-HA102749460.aspx

    If Gmail works file in the new mail profile, we can refer to the article below and follow the steps listed in it to get All Mail folder show in Outlook 2013.

    http://community.spiceworks.com/how_to/show/22277-show-google-apps-or-gmail-all-mail-folder-in-outlook-2013

    1. Open the IMAP Folders Window

    In the left pane in Outlook 2013, locate and click the GMail folder then right-click the GMail folder, and click IMAP Folders.

    2. Query for All to find All Mail folder

    Type All in the "Display folders whose names contain:" field and click Query. This should display [GMail]/All Mail in the All list area.

    3. Subscribe to All Mail

    Click the [GMail]/All Mail listing and click Subscribe.

    4. Turn on Show Only Subscribed Folders

    Check the option "When displaying hierarchy in Outlook, show only subscribed folders." Finally click "Apply" and "OK".

    Hope this helps.

    Best Regards,

    Steve Fan

    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.

    If you have any feedback on our support, please click here

    Tuesday, November 12, 2013 1:38 AM

All replies

  • Hi,

    First, I’d recommend you check this issue using Gmail Web-mail. Please login your Gmail and check if you can reproduce this issue there.

    I've tested this in my environment, when I deleted an email in Important folder, it was also deleted from Inbox. Then, I tried setting the root folder path in Outlook, after finishing that, I got the same issue with you. So, I guess this issue was cused by setting the root folder path.

    If you don’t want the Important folder, as a work around, we can set it not Show in IMAP. To do this, please follow the steps below:

    1. Exit Outlook.

    2. Login to Gmail web-mail and go to Settings.

    3. Click on Labels tab, under System Labels group, uncheck the option Show in IMAP for the Important folder.

    4. Save the settings on Gmail. Open Outlook and check if it helps.

    If you don’t want to hide it, please try to create a new mail profile and set up the Gmail in the new mail profile to check the result. Please refer to the following article to create new mail profile:

    http://office.microsoft.com/en-in/outlook-help/create-an-outlook-profile-HA102749460.aspx

    Hope this helps.

    Regards,

    Steve Fan

    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.

    If you have any feedback on our support, please click here




    Thursday, October 31, 2013 4:47 AM
  • Dear Steve,

    Thanks for your response.

    Unfortunately, after following your instructions above, I see no change in Outlook.

    Specifically, I removed the "Show in IMAP" checkmark from both the "Chats" and the "Important" folders on the Gmail website, but still see 2 copies of each under my Gmail account in Outlook.

    I am quite reluctant to start all over again with a new mail profile, or even with a new account.  A post at the end of this thread warns of losing history, and numerous posts in this thread report no (lasting) improvement from such measures.


    • Edited by rsbrux Friday, November 01, 2013 5:43 PM
    Friday, November 01, 2013 5:43 PM
  • what is your reservation about creating a new profile? what if you just delete the account from your existing profile and re-add it since you've unchecked those boxes on gmail.com?

    I have gmail imap configured on three instances of outlook 2013 with no issues, but I am not using any labels in gmail at all. if I mark something read or delete it in my gmail inbox in outlook, it gets marked read or deleted on my phone.

    originally I had my "all mail" set to not show in imap on gmail.com, but then I signed up for attachments.me, which requires it. so I unsubscribed from that folder in outlook's imap settings.

    if you go into the IMAP Folders settings in Outlook (right click any of your gmail folders in the navigation pane and choose "imap folders") and explicitly unsubscribe from the "extra" folders you don't want to see, do they still appear in outlook? if so I would recommend trying a new outlook profile, since you've made those imap changes on gmail.com.


    Friday, November 01, 2013 6:46 PM
  • Hi,

    How is everything going? Is the problem resolved?

    If you need further support on this question, please do not hesitate to let me know and I will be happy to
    help.

    I'm standing by for your reply.

    Best Regards,

    Steve Fan

    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.

    If you have any feedback on our support, please click here

    Thursday, November 07, 2013 3:19 AM
  • Hi Steve,

    Sorry, I have more urgent matters to attend to and haven't had much time for experimentation with this.

    Please see the discussions referenced in my previous reply for detailed explanations of why I would prefer not to create a new profile.

    I have unsubscribed to the Gmail "All Mail" folder in the "IMAP folders" dialog you show above, but it still appears (twice!) in my Outlook folder hierarchy, even though I have checked the box limiting Outlook's hierarchy display to subscribed folders.  The folders "Chats" and "Important", which also appear twice in my Outlook folder hierarchy, do not show up in the "IMAP folders" dialog, presumably because I disabled them on the Gmail side, as described in my previous reply.

    Thanks for your support.

    Thursday, November 07, 2013 1:21 PM
  • I have created new outlook profiles many times on many machines, and with all due respect to 'a Microsoft phone support person,' the only time I've seen any "history" disappear was when I was using pop3 *and* not leaving copies of messages on the server.  I have never seen a new imap, exchange, or activesync outlook profile somehow wipe the mail server clean.

    you don't even have to delete your existing outlook profile. just create a new one in control panel, and see what happens if you start outlook with the new profile. your local mail history will remain safe in the other profile's data file. if you're still concerned, you could even back up your gmail mailbox to a pst before you start, just to be extra safe.

    if you right-click the "chats" folder in the outlook hierarchy, is "delete folder" an option? does it work?

    Thursday, November 07, 2013 8:21 PM
  • Hi,

    Have you tried John's suggestion? Just create a new mail profile for test, it will not affect your existing profile.

    http://office.microsoft.com/en-in/outlook-help/create-an-outlook-profile-HA102749460.aspx

    If Gmail works file in the new mail profile, we can refer to the article below and follow the steps listed in it to get All Mail folder show in Outlook 2013.

    http://community.spiceworks.com/how_to/show/22277-show-google-apps-or-gmail-all-mail-folder-in-outlook-2013

    1. Open the IMAP Folders Window

    In the left pane in Outlook 2013, locate and click the GMail folder then right-click the GMail folder, and click IMAP Folders.

    2. Query for All to find All Mail folder

    Type All in the "Display folders whose names contain:" field and click Query. This should display [GMail]/All Mail in the All list area.

    3. Subscribe to All Mail

    Click the [GMail]/All Mail listing and click Subscribe.

    4. Turn on Show Only Subscribed Folders

    Check the option "When displaying hierarchy in Outlook, show only subscribed folders." Finally click "Apply" and "OK".

    Hope this helps.

    Best Regards,

    Steve Fan

    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.

    If you have any feedback on our support, please click here

    Tuesday, November 12, 2013 1:38 AM
  • Hi,

    Just wanted to say hi and check if there is anything that I can do for you on this problem. If so, please do not hesitate to let me know and I will be happy to help.

    I'm standing by for your reply.

    Best Regards,

    Steve Fan

    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.

    If you have any feedback on our support, please click here

    Friday, November 15, 2013 1:58 AM
  • Hi,

    I'm marking the reply as answer as there has been no update for a couple of days.

    If you come back to find it doesn't work for you, please reply to us and unmark the answer.

    Best Regards,

    Steve Fan

    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.

    If you have any feedback on our support, please click here

    Monday, November 18, 2013 1:40 PM