none
Error: There is a problem sending the command to the program in Excel 2010

    Question

  • I'm using Windows 7 and Office Home & Student 2010. This error just started today. The solution in previous versions of Excel is not solving the issue in the 2010 version.
    Tuesday, April 12, 2011 9:31 AM

Answers

  • Try this from another site I came across - it worked for me...

     

     

    Go to the Office Button / Excel Options / Advanced, and scroll all the way down to the General section.  There you will see the “Ignore other applications that use Dynamic Data Exchange (DDE)” setting checked.  Uncheck the box, click OK to apply, and you’re good to go

    • Proposed as answer by El Chefe Thursday, August 11, 2011 3:47 PM
    • Unproposed as answer by El Chefe Thursday, August 11, 2011 3:47 PM
    • Proposed as answer by El Chefe Thursday, August 11, 2011 3:47 PM
    • Marked as answer by David Wolters Tuesday, September 06, 2011 3:23 PM
    Sunday, July 24, 2011 8:56 PM
  • Try this then (which worked for me--none of the previous ideas worked).

     

    I;m using excel 2002 and win 7. So when you right click on the excel.exe file in the office 10 folder, go to properties and then run in compatibilty mode tab, click on 'windows 7' and exit.

     

    My excel files now open properly with NO

    There is a problem sending the command to the program

     

    error.

    • Proposed as answer by Gus Sanchez Monday, January 02, 2012 4:46 AM
    • Marked as answer by David Wolters Wednesday, February 08, 2012 3:59 PM
    Saturday, December 10, 2011 3:57 PM

All replies

  • Hi,

    Try the following steps:

    Right click on Excel (.exe) > Properties > Compatibility > uncheck all the boxes

    To access Excel (.exe), open the following location:

    Windows 7 32bit: C:\Program Files\Microsoft Office\Office14

    Windows 7 64bit: C:\Program Files(x86)\Microsoft Office\Office14

    Sincerely

    • Proposed as answer by Harry Yuan Monday, April 18, 2011 2:47 AM
    • Marked as answer by Harry Yuan Monday, April 18, 2011 2:47 AM
    • Unmarked as answer by David Wolters Tuesday, April 19, 2011 1:59 PM
    Thursday, April 14, 2011 2:12 AM
  • Hi thanks, I tried that but it didn't work.
    Monday, April 18, 2011 6:04 PM
  • Hi had the same problem with Excel 2007, on Win7-64bit OS. I did the following to resolve

    To access Excel (.exe), open the following location:

    Windows 7 32bit: C:\Program Files\Microsoft Office\Office14

    Windows 7 64bit: C:\Program Files(x86)\Microsoft Office\Office14

    Right click on Excel (.exe) > Properties > Compatibility >

    1.  Check the box Run this program in compatability mode for > Windows XP (SP3)

    2. Settings > UNCHECK all the boxes

    3.  Privilege level> CHECK run as administrator.

    This seems to work fine now.

    • Proposed as answer by Tero R Tuesday, September 27, 2011 9:27 AM
    Wednesday, July 20, 2011 9:26 AM
  • I run Excel 2010 Win 64 bit.  Solution did not work for me.
    Saturday, July 23, 2011 9:07 AM
  • Try this from another site I came across - it worked for me...

     

     

    Go to the Office Button / Excel Options / Advanced, and scroll all the way down to the General section.  There you will see the “Ignore other applications that use Dynamic Data Exchange (DDE)” setting checked.  Uncheck the box, click OK to apply, and you’re good to go

    • Proposed as answer by El Chefe Thursday, August 11, 2011 3:47 PM
    • Unproposed as answer by El Chefe Thursday, August 11, 2011 3:47 PM
    • Proposed as answer by El Chefe Thursday, August 11, 2011 3:47 PM
    • Marked as answer by David Wolters Tuesday, September 06, 2011 3:23 PM
    Sunday, July 24, 2011 8:56 PM
  • This solution works for me. Thank you very much!!!
    Tuesday, July 26, 2011 10:19 PM
  • I have recently discovered the following:

    There seems to be an issue with the WinZip Office add-on. When Office 2007 applications (I have tested with Word and Excel) are configured to use the wzofc.dll add-on, documents can not be opened by double clicking in Windows Explorer.  When trying to open a document by double clicking the following message is given: "There was a problem sending the command to the program". Disabling the Winzip add-in fixes the problem in the office application.  I am using Winzip version 15.5 on Windows 7 64bit Home Premium with MS Office 2007.

    I have fixed this for me by running Word as an Administrator and disabling the WinZip Courier add-in using the Options, Add-ins menu.

    Monday, August 15, 2011 2:53 AM
  • Harry,

     

    I did what you suggested and it did work for me.  What I do NOT understand is WHY?  The only box that was checked was "run as administrator"...why would having that checked cause this issue?

    Thanks again for the fix!

    C. Brown / NOLACHEF

    Tuesday, August 30, 2011 6:55 PM
  • I tried all the other fixes from this board and others, and this is the one that worked for me, thank you!

     

    Thursday, September 01, 2011 11:53 AM
  • dazbc's solution worked for me..

     

    Thanks!

     

    Friday, September 02, 2011 3:08 PM
  • That worked.  Thanks

    Devon

    Tuesday, September 06, 2011 9:38 PM
  • Dazbc, your solutin worked for me!

     

    Thanks!

    Tuesday, September 13, 2011 5:24 PM
  • That's so helpful... thanks for all...  
    Thursday, September 29, 2011 5:24 PM
  • The error even happened after reinstalling Office 2007 base install from CD.

    I thought it happened due to some Office updates but it could have been some Windows updates that caused this problem.

    This worked for me as well the DDE

    Thanks


    ArkieV
    Friday, September 30, 2011 4:32 AM
  •  

    MS Office - arrrrrrrhhhhhhgggggggg!

    dazbc's tip worked like a champ. Like.




    Friday, October 07, 2011 1:03 AM
  • Superrrrrrrrrrrr. This thing has been annoying me for 2 weeks now and thanks to your guidelines it's finally fixed. A big THANKS!
    Thursday, October 13, 2011 11:57 AM
  • Dear Dazbc

    i appreciate your brilliant work and it helped solve the issue.

    thanks

    Wednesday, October 19, 2011 6:54 AM
  • I have this issue with Excel 2010  and have unchecked the "Ignore other applications that use Dynamic Data Exchange (DDE)". I even uninstalled and reinstalled.  Any time i double click an xlsx file I get "There was a problem sending the command to the program". I can open excel and then open the file manually.  Would really appreciate getting this fixed.
    KC
    Tuesday, October 25, 2011 4:19 PM
  • When you get the error, on the error window, open details and see why its hanging. In the list you see it is waiting on something, that will indicate your problem.

    For my computer, it was waiting on spool, which is printing, so I unplugged the printer, and all is fixed.

    Tuesday, October 25, 2011 9:34 PM
  • THe error dialog just has a red X in a circle, the title is the name o fthe spreadsheet, the text is "There was a problem sending the command to the program.", there's an X to close the dialog and an OK button. That's it, no pull down list or other informaiton in the dialog. Nothing if i right click in the dialog area, Move or Close if I right click in the title. I can click on Excel while the dialog is open.

    Using process explorer I see the command line for the excel app is the normal path to excel and "excel.exe /dde".
    And the error dialog is explorer.


    KC
    Tuesday, October 25, 2011 11:42 PM
  • I see. Mine was diff.

    My problem is gone for the time being, but I had seen a list.

    Just wondering if: unplug all ports, usb, firewires, network, etc... then restart comp, run program, and then plug everything back in.

    Wednesday, October 26, 2011 12:40 AM
  • This solution worked on the first attempt. I have Excel2007 (12.0....5003) SP2. Thanks!
    Friday, October 28, 2011 4:07 PM
  • This was the solution for me! Thanks very much!
    Tuesday, November 15, 2011 11:02 AM
  • My solution, after trying everything else, was to remove Office, spend 2 hours deleting every reference to "excel" or "xls" in the registry and then reinstalling.  :(

    Amazing how many entries are left in the registry after doing an uninstall.


    KC
    Tuesday, November 15, 2011 3:58 PM
  • This solution fixes the problem, but it creates another problem.  

    With this option checked every Excel file I open, creates a new Excel instance, so I can have different Excel files open on different monitors.  

    With this option unchecked all of my open Excel files are in one instance, so I can't place them in different monitors.  

    Can I have the problem fixed and enable the ability to place open Excel files in different monitors?

    Tuesday, November 29, 2011 10:27 PM
  • This was driving one of our users crazy. Fixed it easily with this solution, thanks! Now to investigate what caused the problem...
    Monday, December 05, 2011 10:04 PM
  • Try this then (which worked for me--none of the previous ideas worked).

     

    I;m using excel 2002 and win 7. So when you right click on the excel.exe file in the office 10 folder, go to properties and then run in compatibilty mode tab, click on 'windows 7' and exit.

     

    My excel files now open properly with NO

    There is a problem sending the command to the program

     

    error.

    • Proposed as answer by Gus Sanchez Monday, January 02, 2012 4:46 AM
    • Marked as answer by David Wolters Wednesday, February 08, 2012 3:59 PM
    Saturday, December 10, 2011 3:57 PM
  • It works for me. Great!!! I was pulling my hair this morning. Thanks!!!
    • Proposed as answer by Ndugwa Monday, January 09, 2012 2:44 PM
    • Unproposed as answer by David Wolters Monday, January 09, 2012 6:23 PM
    Saturday, January 07, 2012 3:52 PM
  • Thanks Dazbc.

    This works

    Monday, January 09, 2012 2:46 PM
  • Try this from another site I came across - it worked for me...

     

     

    Go to the Office Button / Excel Options / Advanced, and scroll all the way down to the General section.  There you will see the “Ignore other applications that use Dynamic Data Exchange (DDE)” setting checked.  Uncheck the box, click OK to apply, and you’re good to go

    This works! :) Many Thanks!
    Friday, January 13, 2012 2:41 AM
  • The problem with the solution is that by unchecking Ignore other applications that use DDE, if you want to open up different spreadsheets in multiple instances of Excel, you cant. They will open in the same instance. So if you are using dual screens for example, and you want one spreadsheet open on each monitor you cant do it. This is the answer I am looking for in case anyone knows. Thanks.
    • Edited by banndito Monday, January 16, 2012 10:13 PM
    Monday, January 16, 2012 10:12 PM
  • Dazbc!

     

    Thanks, worked for me first time.

     

    Forever

    Saturday, February 04, 2012 4:10 AM
  • As with most software issues, one size doesn't fit all despite what is marked as the correct answer, which is actually "one answer".  The Fixit Man's solution worked for me on Windows 7 x64, setting the exe to run in Windows 7 compatability mode worked like a charm.

    I tried to mark up The Fixit Man's solution but a javascript pop up appeared informing me of an 'unexpected error'.  Looks like MS have two things to fix now.

    Tuesday, February 07, 2012 8:59 AM
  • This resolved my issue. Thanks!

    Wednesday, February 08, 2012 12:42 AM
  • I know Project 2007 isn't part of the standard Office suite - but I have multiple users in a corporate environment that are having this issue as well... but I don't see any way to disable DDE from within Project.  Any Ideas?

    Wednesday, February 08, 2012 5:12 PM
  • Worked for me too.

    Any technical explanation why this happened suddenly ?

    Wednesday, February 15, 2012 10:13 AM
  • I had the issue and the Ignore DDE trick didn't work. I identified the solution eveneutally related to a recent install of Visual Studio. It had added two new COM Add-ons into Excel. I went to the Excel options and disabled the add-ons and it works fine now.

    So if the DDE option doesn't work, I suggest you check for add-ons that relate to any recent software you've installed and try disabling them!

    • Edited by Ed Solman Wednesday, February 15, 2012 10:50 PM
    Wednesday, February 15, 2012 10:50 PM
  • If you have Word viewer installed - just uninstall it. It solved my problem. Because, the file association it had before with the .docx to the Word viewer does not get re-associated properly with the full version of Word.
    Thursday, February 16, 2012 2:58 AM
  • HI , I tried with Excel 2007 with Win7 64 bit. Its solved my problem. Thanks

    Andiappan

    Wednesday, February 22, 2012 5:43 AM
  • Thanks My excel is now working.

    Thursday, February 23, 2012 1:14 PM
  • Thank you so much, it worked for me
    Sunday, March 04, 2012 6:49 AM
  • Thank you very much.  It works!  Question is, Why should this happen? 

    Sunday, March 18, 2012 1:43 AM
  • MS release a tool to fix that problem. It works well to me.

    http://support.microsoft.com/kb/211494

    Wednesday, March 21, 2012 7:36 AM
  • I recently had the same problem running Excel 2007 with Windows 7 and this solution worked for me!  Thanks.
    Tuesday, March 27, 2012 5:21 PM
  • Thanks. Its easly solved my problem. DDE option was already unckecked in my Excel but compatibility was set to XP which I changed to Win7 and it works. Thank you.

    CA. Bhola Kumar

    Thursday, April 12, 2012 7:07 PM
  • This worked for me with Excel 2007. 
    Wednesday, April 18, 2012 9:52 PM
  • Problem unresolved:

    I am using MS Office 2010 Professional Plus (service pack 1) 64 bit with Windows 7 Home premium 64 bit (service pack 1).

    When ever I double click any .xls file: "There was a problem...." error message is displayed. But if i first open excel and then open the file, in that case no problem.

    I have unchecked 'Ignore other applications that use DDE'. As a precaution, I checked the DDE option, closed excel, opened excel a 2nd time to uncheck the DDE option.
    I have disabled and removed all COM add-ins
    I have unchecked all compatibility options.

    I have also changed the default printer to XPS writer.


    But still I get the error. I have also reinstalled office 2010 and applied all updates.

    Sunday, April 22, 2012 12:23 AM
  • Thanks alot. I checked all the previous solutions and none of these worked for me.

    Follow the below steps to solve the issue:

          Step(1): find the Excel.EXE  (mostly: C:\Program Files (x86)\Microsoft Office\Office12\)

          Step(2): Goto the Excel Properties and then Identify Compatibility Tab

          Step(3): Select Windows7 value available under compatibility dropdown.

          Step(4): Finally Click OK button and Exit.

    Thanks,



    • Edited by Suresh Kambham Wednesday, April 25, 2012 9:58 AM just alignment
    Wednesday, April 25, 2012 9:55 AM
  • I too would love to know how to disable DDE within Project 2010!?
    Saturday, May 05, 2012 5:40 AM
  • This is not a fix. This is disabling enhanced functionality that was part of the product to make the rest of the product work correctly. I need to open separate instances of excel in their own windows and i'm tired of having to open new spreadsheets every time I want to open a file in a different window. Excel 2010 does that through the "ignore other applications/DDE" setting.

    This is a bug, period and needs to be addressed. Nothing I've found addresses this and neither does modifying or adding registry keys.

    Wednesday, May 09, 2012 10:26 PM
  • This solution fixes the problem, but it creates another problem.  

    With this option checked every Excel file I open, creates a new Excel instance, so I can have different Excel files open on different monitors.  

    With this option unchecked all of my open Excel files are in one instance, so I can't place them in different monitors.  

    Can I have the problem fixed and enable the ability to place open Excel files in different monitors?


    Exactly. This is not a fix. This is a half effort and really only somewhat of a solution for previous versions of Excel.
    Wednesday, May 09, 2012 10:29 PM
  • MS release a tool to fix that problem. It works well to me.

    http://support.microsoft.com/kb/211494


    All this tool does is turn the DDE setting off for you. If you don't want to use that feature or is you have a previous version that's fine, but otherwise this is not a fix.
    Wednesday, May 09, 2012 10:42 PM
  • Strange I am having the exact same problem as you are starting on the same day.  Bug or function?
    Friday, May 11, 2012 1:30 PM
  • This "solution" solves the "problem sending the command to the program" (which just started a few days ago) but now the original problem that checking “Ignore other applications that use Dynamic Data Exchange (DDE)” was "fixing" has returned - namely the incredibly annoying default of Excel to open all spreadsheets in the same window. What are the Microsoft folks smoking (or not smoking as the case may be)?

    Thursday, May 24, 2012 11:29 AM
  • Thanks!!!!!
    Thursday, June 14, 2012 9:53 PM
  • Yes! I will go along with that tthe fixit man, the same problem happened to me the other day.  It took me ages to try and figure it out until i opened up the replies to this problem, as yourself i tried the many solutions and it was only this solution that worked.  So thank you for that, you have made a tired pensioner very happy.  By the way i am running Office 2010 with Windows 7 home premium.

    Gordon bigfella.



    Sunday, June 24, 2012 2:49 PM
  • Thanks :)
    Wednesday, July 04, 2012 10:12 AM
  • I am running Office 2007 x86 (with Excel) on Win7 x64 SP1.

    I had this checkbox already cleared.  Problem still exists even after a reboot.  Any other ideas?


    If this post is helpful, please mark it as such!
    Dave Black, MCPD, MCTS
    http://dave-black.blogspot.com

    Friday, July 06, 2012 3:10 PM
  • Perfect answer.
    Sunday, July 08, 2012 8:30 PM
  • Tried this - it doesn't help anything.  Turned of the option.  Didn't fix anything. Turn on option. Didn't fix anyhing. Turn option back off. Didn't fix anything.  ANYBODY?
    Monday, July 09, 2012 6:30 PM
  • I am running windows 7 64bit office 2003.  I still recieved the error after running in compatibilty mode.  I checked the properties of the file itself.  I found it was trying to open itself with what I think was an XML converter.  I changed it to excel and it works fine know.  This would explain why the file opened correctly when using excel/open and not by double clicking onthe file itself

    Tuesday, July 10, 2012 3:14 PM
  • thanks a lot... searched a lot online for any helpful answer..but only your answer prooved to be helpful and saved my lots of work n time. 
    Saturday, September 01, 2012 7:51 PM
  • This worked fine. Thank you.
    Thursday, September 27, 2012 5:44 AM
  • Deosn't work on my W7 64b. MSOF2010.
    Friday, October 05, 2012 1:39 PM
  • Works!  Thx.  W7 64b. MSOF2010
    Friday, October 05, 2012 1:40 PM
  • Thank you !
    Wednesday, October 31, 2012 2:37 AM
  • It is working.. thank you so much... 
    Wednesday, January 02, 2013 5:19 AM
  • In my case, it hangs and starts slowly (and then gets this problem) because I have a couple of network printers that are unavailable.  So when I work at home, my office domain printers are not accessible.   But if I am connected to the Internet, Excel takes a long time to figure this out when it starts up. 

    I work around the problem by disconnecting from the internet before starting Excel: the timeout searching for unavailable printers is then quick, and Excel starts without problems.  Then I reconnect.  

    If anyone can recommend an easy way to switch between  "work" and "home" profiles so that the work printers are automatically disabled when I am on some other network, I'd appreciate it.  

    My default printer is not a work one - it is the "Send to OneNote 2010" printer.  I'm running Windows 7 Pro SP1 32-bit, with Office 2010, for the record, and my machine is a member of my workplace domain.



    • Edited by cspwcspw-pete Friday, March 22, 2013 7:40 AM
    • Proposed as answer by cspwcspw-pete Saturday, April 20, 2013 5:25 AM
    • Unproposed as answer by cspwcspw-pete Saturday, April 20, 2013 5:25 AM
    Friday, March 22, 2013 7:38 AM
  • I finally solved this!    

    The problem was my workplace shares not available, but not related to printers!   I had somehow got the Excel Default File Save location pointing to a share location on my workplace domain.  

    The clue: when the splash screen for Excel 2010 started up, it says Contacting: \\server...     

    The fix: I cleared the setting in Excel at     File | Options | Save | Default file location, and I made sure all my other file locations were not on remote shares.

    Pete

    • Proposed as answer by cspwcspw-pete Saturday, April 20, 2013 5:32 AM
    Saturday, April 20, 2013 5:32 AM
  • YES!!  This is the one that worked for me after I tired the DDE and a couple of others !  Thanks!

    Wednesday, July 17, 2013 10:26 PM
  • This solution worked for me as well. My guess is that it was related to me uninstalling 7z software. Probably hosed the DDEs the built-in unzip functionality was doing or left a plug-in in excel that fails since it no longer exists.
    Friday, July 26, 2013 1:03 AM
  • This worked for me.   I was having this error in Excel and Word.  Did not test PowerPoint.  Interesting test though.  

    1. Made sure Excel was not running. I went to the EXE properties and I set compatibility mode to Windows7.  I applied the change. Then opened excel via document double click in Windows Explorer.  Worked as expected, problem solved.  
    2. THEN...  I closed Excel and made sure it was not running. Cleared Compatibility Mode to it's state before step 1. Applied the change.  Proceeded to double click the document in Windows Explorer and it still works perfectly.
    3. Not only was my Excel problem resolved.  Word now works fine too.  I did not have to modify anything in the Word.EXE properties.

    I have no explanation as to why this "fix" worked after returning it to it's previous state or why it resolved the problem with another application.  It must have resolved a different conflict in the OS not just within the application.  I am now happy, just a little confused.

    Tuesday, August 13, 2013 2:48 PM
  • This one worked for me.  Thank you!
    Tuesday, August 27, 2013 5:16 PM
  • Hi!

    OMG I spent hours & hours trying to fix this... I have Win7 Ultimate -64b, office pro 2007 SP3 with FileFormatConverter installed (for Office 2007). I tried every single possible solution (uncheck this, delete this file, modify keys in registry, de-install, re-install, run diagnostic, etc..., name them all!).

    Only 1, 1 single 1 thing worked for me:

    1) Follow this link: http://support.microsoft.com/kb/211494

    2) Under the resolution section, choose (and ONLY choose) the "Fix it for me" solution, depending on your OS

    I tried the "Let me fix it myself" solution, following every single step, but obviously the MSI package provided by Microsoft does something different that is obviously not described anywhere.

    Good luck!

    Thursday, September 26, 2013 11:39 PM
  • Thx mate, your fix worked for me :)
    Monday, October 07, 2013 2:27 AM
  • This post helped me find our solution. The GroupWise integraded add-in was causing our issue. It had to be disabled then it started working.

    Go to file, options, add-ins, Com Add-ins and remove the Groupwise add-in.

    Stephen

    Tuesday, October 08, 2013 3:57 PM
  • Hi,

    It works ..good..

    thanks

    Nilesh

    Saturday, October 26, 2013 6:35 AM
  • It worked perfectly, thank you
    Monday, October 28, 2013 7:58 AM
  • Great!!! that helps me too. :) Thanks guys.
    Thursday, November 21, 2013 9:44 PM
  • I was suffering with this problem in excel from very long time “There is a problem sending the command” but the above solution resolve this issue in less than a minute, thanks

    Wednesday, November 27, 2013 12:30 PM
  • We were experiencing this error, and verified the box was unchecked.  Upon closer inspection, our Host Intrusion Protection System was blocking the UDP ports which allow for queries to update.  Please verify the ports are open if the popular answer was not able to resolve your issue.


    Noelle Marchbanks SharePoint Developer and Business Process Analyst Joint Communications Support Element

    Tuesday, December 10, 2013 5:05 PM
  • Hi there

    I have this problem on Excel 2013 (all other applications in office work ok)  I would like to have a go at fixing it, but (and this might be a dumb question) but where is the "office button"?

    Thursday, December 12, 2013 12:13 PM
  • This may make me look like an idiot.  Running Windows 7 and office 365 home.  The only time the problem arose in excel and in word was when I went to explorer and clicked on a file to open it I got the error.

    The answer desk fixed it in 3 minutes.  The file association was still set to open with excel 2007.  One needs to check that first and not last.   And maybe it never came up before is because all of you hundred people knew to check it first.

    Just like one of life's natural laws or is it Murphy's?  'You always find lost things in the last place you look'.

    Bill


    • Proposed as answer by Billmc2014 Tuesday, February 04, 2014 1:36 AM
    • Edited by Billmc2014 Tuesday, February 04, 2014 1:37 AM
    Tuesday, February 04, 2014 1:35 AM