none
Blocked Senders feature in Outlook 2010 does not work

    Question

  • I have a specific blocked sender admin@domain.net listed in my Blocked Senders list, but emails from that email address still go to my Inbox instead of the Junk E-mail folder.  We use Exchange for email, and Outlook 2010 as the client.

     

    Note: this sender is blocked for a specific sender that he configured through Junk E-mail Options in Outlook 2010, and this sender is not blocked at the server level.

     

    I only have one account set up in Outlook.  What do I need to do to get Blocked Senders / Junk E-mail working in Outlook?

     

    Thanks,

    Elizabeth

    Tuesday, May 10, 2011 9:26 PM

Answers

  • Hello,

    From issue description it says you are unable to block specific email in Outlook. We would like to have some more information.

     1. Does it happen with specific email address only?
     2. What happens when you try with any other email address ?
     3. Is it specific to machine/user/Outlook profile that is used currently?
     
    Lets follow below plan and update if it works

     1. If it is happening with only one email check what happens if you create a notepad file and enter email address and import it from junk mail options.
     2. If it is happening with any email address we enter try to create a new outlook profile and see if issue occurs on new outlook profile as well.
     
    Regards,


    RKeith - [MSFT]
    Wednesday, May 25, 2011 9:45 PM
    Moderator

All replies

  • Hi,

     

    From your description, I suggest you try to check the total size of blocked sender list. As total size of all lists combined cannot exceed 512K. Once the 512K limit is reached, Outlook alerts you and additional addresses aren't saved until you remove some from the list.

    If your issue is caused by the limited size, you can add a new registry key value to the following registry key:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\

    Add a new DWORD value of Type Max Extended Rule Size and edit the Value Data, entering the maximum size (in bytes) you want to allow.

    If your issue is not related to limited size, try to keep your junk e-mail filter updated. Each version of Microsoft Outlook that contains a junk e-mail filter receives updates to the data file (outlfltr.dat) as part of the Microsoft-wide monthly update released on the second Tuesday of each month. The updated outlfltr.dat is the result of the evaluation of hundreds of thousands of spam messages and constantly increases the filter “catch” rate for incoming junk email.

    The recommended way to obtain updates to the Outlook Junk E-mail filter is by turning on the Automatic Updates option in the Windows Security Center.

    If you have done all above but it still not work, try to create a new outlook profile to test this issue.

    ·          Go to Start > Control Panel, click Mail. The title bar of the Mail Setup dialog box contains the name of the current profile. To select a different existing profile, click Show Profiles, select the profile name, and then click Properties.

    ·          Click Show Profiles. Choose Prompt for a profile to be used.

    ·          Click Add.

    ·          Type a name for the profile, and then click OK.

    ·          Start Outlook, and choose this new profile.

    Sincerely,

     

    Harry 

    Thursday, May 12, 2011 7:16 AM
    Moderator
  • We haven't reached the size limit since we have not recieved any Outlook alerts that we cannot add the address.

    The address is indeed listed in the Junk Mail options > Blocked Senders, no problem.  The user just keeps getting messages from that email address, even though it is expicitly listed in the Blocked Senders list.

    Are there any other possible causes? I'd rather not have to create a new profile for them if I can help it..

    Friday, May 13, 2011 3:41 PM
  • Hi,

    Thank you for your question.

    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.

    Thank you for your understanding and support.

    Sincerely

    Harry

    Thursday, May 19, 2011 1:39 AM
    Moderator
  • Hello,

    From issue description it says you are unable to block specific email in Outlook. We would like to have some more information.

     1. Does it happen with specific email address only?
     2. What happens when you try with any other email address ?
     3. Is it specific to machine/user/Outlook profile that is used currently?
     
    Lets follow below plan and update if it works

     1. If it is happening with only one email check what happens if you create a notepad file and enter email address and import it from junk mail options.
     2. If it is happening with any email address we enter try to create a new outlook profile and see if issue occurs on new outlook profile as well.
     
    Regards,


    RKeith - [MSFT]
    Wednesday, May 25, 2011 9:45 PM
    Moderator
  • Did you verify the address or doamin is not also on one of the Safe lists? They override the blocked list.

    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    • Proposed as answer by viper96 Friday, July 26, 2013 12:46 PM
    Thursday, May 26, 2011 5:11 AM
  • I'm having the same problem and it is not specific to an email address.  I've tried blocking from my gmail and hotmail accounts addresseses and both came through even when adding the email addresses to the Blcokd Senders.  also, this is not only me so the profile change option is not correct for me.  I've tested this with another user within my company.

    Appreciate your help.  Thank you!

     

    Thursday, July 07, 2011 5:57 PM
  • I'd like to confirm the issue. It is not related to any specific sender domains, users or machines. We are using the latest Outlook version 14.0.6106.5005.

    Please mark the thread as "not solved".


    Edit:

    One possible solution is documented in this article:

    http://support.microsoft.com/kb/2276432

    Outlook's "Blocks Sender" functionality and Exchange's IMF stop working after installing Forefront Protection for Exchange

    The following PowerShell command should resolve it:

    New-FseExtendedOption –Name CFAllowBlockedSenders –Value true

     

    When the SCL rating is -1, then Outlook sends the e-mail directly to the inbox. The "Block Sender" list only works for SCL 0 to 9.

     

    Tuesday, October 18, 2011 2:55 PM
  • I still have the same problem but your answer has to do with Forefront and Exchange. I do not use this. Only POP and IMAP accounts and the Blocked senders list simply does not work.

    I've checked. The email is in the list and I still get the junk in my inbox.

     


    RealPommy
    Monday, December 19, 2011 4:55 AM
  • I am having having a similar problem. If I right click on the message and select Junk > Block Sender, it does not get added to my blocked senders list. The only way for me to get it added to the list successfully is to do it manually: Junk Options > Add > and then enter the email addy. This is way time consuming. Why doesn't the right click Junk > Block Sender add the email address to my Junk senders list?
    • Edited by mickapoo Wednesday, December 28, 2011 6:29 PM
    Wednesday, December 28, 2011 1:04 PM
  • Do you get the confirmation that that address was added to the list?

    What type of email account is affected and how many email accounts do you have configured in Outlook? Each account has its own list - to view the list for a specific account, open a message downloaded by the account and access the junk options from the open message.



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Wednesday, December 28, 2011 1:13 PM
  • No, I don't get any confirmation when I right click and select Junk > Block Sender.

     

    I have one email account, it's POP3.

    Wednesday, December 28, 2011 1:49 PM
  • No, I don't get any confirmation when I right click and select Junk > Block Sender.

     

    I have one email account, it's POP3.


    I have one IMAP account and 4 aliases for this one. I have 3320 emails in my blocked account list and none seems to work. I still get my inbox swamped with spam, even if the email address is in the blocked list.
    RealPommy
    Thursday, December 29, 2011 2:04 AM
  • Oh, your lists are problably full. There is a limit to the number of addresses that can be on all of the safe and blocked lists combined and you probably hit it. Outlook is supposd to pop up a warning that the list is full. The limit used to be about 2000 total addresses across all 3 lists in Outlook 2003, but was increased a little, although i forget the exact limit now.

    FWIW, blocking addresses is a poor way to filter spam as most addresses are only used once or twice then the spammer gets a new address. Set Outlook in high filtering and add names to the safe list. We recommend a short blocked list and a long safe list - only block addresses that never change, like for newsetters that you can't get unsubscribed from or annoying former co-workers who won't stop forwarding junk.



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Thursday, December 29, 2011 2:49 AM
  • This is not a solution. I have the same problem with recurrent bypass of the blocked senders list. Sometimes it is the same sender id from a different domain, sometimes the same domain. I have tried blocking all senders from domains and filtering at the mail host server level, the latter still in trial. Outlook 2010 is set to high filtering. My accounts are MAPI hotmail and IMAP/SMTP using my own domain.

    How do I find the size of the blocked sender file and the number of senders supposedly blocked? Without actually counting, that is?

    Also, I have been trying to block by using a *@domain.com format in addition to the @domain.com format. Is there any point to doing this?

    Monday, January 16, 2012 2:40 PM
  • Re: using *@doamin format - no, there is no point in doing that as it does not support wildcards.

    Re: counting entries. Export the list then open it in notepad. With the status bar enabled, you can click in the last row and get the # of lines for that list.

    Note that outlook 2010 uses different safe and blocked lists for each account - verify that the names you are blocking are on the list for the correct account. To view the setting per account, open a message downloaded by an account and click it's ribbon.  http://slipstick.me/jing/junk-options.png 

    Also, junk filters don't work as well with imap - messages won't be filtered until the entire message is downloaded.



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Monday, January 16, 2012 8:08 PM
  • Thanks. Too bad about wildcards. It would help to be able to block all the junk that comes as *.info.
    Wednesday, January 18, 2012 2:44 PM
  • In the case of info, how about a rule that looks for .info in the sender's address? 

    The junk filter has an option for TLD but its limited to by country, which leaves info and any of the other new TLD out of that option.



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter
    Wednesday, January 18, 2012 11:04 PM
  • I'm suffering the same issue of "Blocked Senders" not functioning at all.  I continue to receive emails from addresses listed in my "Blocked Senders" listing.  I've got a POP3 email account.  Is there any hope of it working?
    Saturday, June 09, 2012 5:37 PM
  • I run Outlook 2010 stand-alone to pop3 accounts.  I also have side-pop3 accounts on my client at work - even though work is a 2010 Exchange Server topology.

    In BOTH cases (home/stand-alone Outlook 2010 and work/corpate Outlook 2010 topology) - the pop3 incoming SPAM is overwhelming me.  Seems like the last few months there has been a huge jump - e.g. I'm getting 100spams / day and only 1-2 are going to Junk folder.    I've spent a few weeks now doing Junk Sender but its not making any noticeable difference.

    I also see Blocked Senders in my list that are simply coming on thru.    My Blocked Sender's list is 444 items.   My Sensativity is "High: Most junk e-mailis caught..".  And I only have a handful of entries in my Safe Senders / Safe Recipients - so I know that this is NOT the cuase of Blocked Sender's failure.

    Something is seriously broken and I suspect it started about 4? months ago...      I've been using Outlook 2010 for year or 2 without change and I don't recall this being a problem till a few months ago.

    Wednesday, June 27, 2012 5:16 PM
  • How many accounts are in your profile? Open an email message sent to the affected account and open the Junk options dialog from the Junk button on the open message. Are the settings correct?


    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Thursday, June 28, 2012 2:04 AM
  • Re: using *@doamin format - no, there is no point in doing that as it does not support wildcards.

    If that is the case, Why is it in the examples in Outlook 2010?  If you click edit on an entry in your blocked senders list the Examples: shows  someone@example.com, @example.com and example.com as the options. Is this incorrect? If so, why isnt it changed? Its been thay way in the last couple of versions of outlook and it used to work. While @example.com  is not using wildcards I believe the intent is the same, block all email from the domain @example.com.

      I have the same issue as everybody else The full address I am trying to block is in the list. As well as @domain.ext. I still recieve dozens of email every day from this sender. My blocked senders list ony contains about 100 items. I am using Outlook 2010 in an corporate exchage environment. Forefront is not used. There is only one account in my profile and it has been rebuilt.  My laptop uses Windows 7 Enterprise.

    Friday, July 13, 2012 2:45 PM
  • wildcards in this discussion refer to the use of the * in the entry and only in respect to the question I was replying to.  Outlook does not support using the wildcard character.

    You can use just the domain name, which will get all mail sent to (or from) that domain. However, it is my understanding that example.com is the same as @example.com and does not include mail from addresses in the form of @mail.example.com.

    Do you have a contact for that address? Are you trusting all mail sent to the address it is sending to? The safe list overrides the blocked list, so if you have your own address on a safe list, mail sent to you by blocked senders will always come through.



    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Friday, July 13, 2012 3:00 PM
  • i have the same issue also, i have one exchange account configured on the Outlook 2010. we are not using fore front protection. also i've recreted the profile but nothing changed.
    Monday, August 06, 2012 8:59 AM
  • I have 4 pop accounts. I have been trying for a year or more to block senders emails. my list is not full

    and I have tried to block from all accounts. Nothing works. Outlook express blocked anyone and everyone that was listed. too bad we can get those kinda of filters.  I'm using Windows 7 . 37 emails a day with way too many that I don't want. I can't just get rid of all my addresses......

    Help

    KustomMerc


    • Edited by KustomMerc Tuesday, August 21, 2012 2:55 PM
    Tuesday, August 21, 2012 2:54 PM
  • I totally agree, the items continually appear in the INBOX. As shown below, when I right-click and AGAIN report as Junk and Block Sender, I get this message that, the sender is ALREADY in the list. Well, if it is already IN the list, how can we get Outlook to RESPECT THE LIST?

    Thank you for researching this.

    Tuesday, August 21, 2012 6:32 PM
  • Is the address the message is sent to on the Safe list (or in the address book, if you trust the address book). Safe lists always trump the blocked list - and almost everyone I know puts their own contact in Contacts.  


    Diane Poremsky [MVP - Outlook]
    Outlook Daily Tips | Outlook & Exchange Solutions Center
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Tuesday, August 21, 2012 8:36 PM
  • It's very dissapointing Microsoft won't allow wildcards.  I have to control my spam and I just can't do it.  Also, they should add Block Sender's Domail to the right click, junk menu for a message.  I can opt to never block a sender's domaim but I can't do the opposite.
    Thursday, October 25, 2012 3:39 PM
  • I have exactly the same problem as mickapoo.  On a junk email, I right-click, select "Block Sender", I get the attached confirmation message (mickapoo may have clicked "never show this") and the email is moved to Junk E-mail, but there is absolutely no change to the Blocked Senders list.

    I am using Office Professional Plus, with all updates.  My Blocked Senders List is only ~12 entries.  My computer is an Asus B43S business laptop operating standalone - there is no server or MS Exchange.  My accounts are POP with SSL.  My OS is Windows7 Professional.

    Thursday, December 20, 2012 5:02 PM
  • Same problem here, blocked sender is in the blocked list but I do still get junk mail from the same mail. This is a bug, no doubt.

    If it is not, then there should be a dialog that explains why the mail is not redirected to junk folder.

    Friday, December 21, 2012 6:17 PM
  • I am still suffering from this issue.  I have one email account in Outlook 2010 using Exchange 365 and Windows 7.  There is only one entry in my block sender list.  If anyone has the answer to this I am sure everyone would appreciate it being posted.

    Tuesday, March 05, 2013 8:34 PM
  • Me too
    Tuesday, March 05, 2013 8:36 PM
  • I've resigned myself to the fact that there is no resolution and that Outlook 2010 Junk Folder /spam config is non-functional.

    The workaround I've implemented is to make an Outlook Rule to mark the emails as Read and move them to the Deleted Items folder.  It's not really a solution to the issue, just a workaround.

    Wednesday, March 06, 2013 6:32 PM
  • The same ptoblem. It used to work before, but now our administrator has installed new version of Exchange Server (or smth) - and it stopped working.
    Monday, March 11, 2013 6:52 AM
  • I too gave up on Outlook 2010 blocked senders function, so I got Office 2013 and guess what?  It's still broken.

    Once again:

    1. Right-click an email,
    2. Click Junk > Block Sender
    3. email is moved to Junk E-mail folder
    4. nothing is added to my blocked senders list

    This has to be a flat-out bug.  Why has this been ignored for years??

    Thursday, April 25, 2013 7:20 PM
  • How many accounts are in your profile? Each account has its own junk list.


    Diane Poremsky [MVP - Outlook]
    Outlook & Exchange Solutions Center
    Outlook Tips
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Thursday, April 25, 2013 7:44 PM
  • To see the blocked senders list, I

    1. right-click the same email in the same inbox in the same account,
    2. select Junk > Junk E-mail options ...
    3. Dialog box header says  Junk E-mail options - correct account name
    4. Blocked Senders tab - new blocked sender does not appear.  In fact none that I have ever marked as blocked appear.
    Thursday, April 25, 2013 8:07 PM
  • As with others, I believe Outlook has a defect.  It just flat out no longer "blocks" emails.  It will put them in the junk folder...  But I end up having to look through hundreds of known "junK" to make sure nothing valid was accidentally filtered, which foils the purpose of BLOCKING.  As noted by others, I do not have addresses listed in both SAFE and BLOCKED.  I have imported the exact same BLOCKED list into each of the email address files in my Outlook configuration.  Is Microsoft going to resolve this issue?

    Sunday, May 19, 2013 3:00 PM
  • Um. Blocked senders automatically treats messages from addresses on the blocked senders list as junk email (regardless of the content of the message) and puts it in the junk folder. It does not block the messages from being downloaded (outlook needs to download to run the filter) or automatically delete them - it just guarantees the message is treated as junk email. See Understanding the safe and blocked lists.

    You should use Safe lists almost exclusively to reduce false positives and blocked list only for a few names-  like from annoying people or mailing lists you can't get unsubscribed from.

    Also note that if you are using Exchange mailboxes, you need to use cached mode.



    Diane Poremsky [MVP - Outlook]
    Outlook & Exchange Solutions Center
    Outlook Tips
    Subscribe to Exchange Messaging Outlook weekly newsletter



    Sunday, May 19, 2013 3:33 PM
  • By default when Forefront's anti-spam agent deems a piece of mail as non-spam (clean) it sets the SCL rating of that specific message to -1. This has a negative effect on the Outlook "Block Sender" functionality, and Exchange's IMF, because mail that receives a rating of SCL -1 will be exempt from Outlook's Block Sender rule as well as Exchange's IMF functionality.

    The workaround is to edit the SCL value that Forefront Protection for Exchange applies to "clean messages".

    The following work around will change the Forefront Protection for Exchange SCL clean value to zero (0). This is done in Forefront's Power Shell by creating a new extended option:
    PS> New-FseExtendedOption –Name CFAllowBlockedSenders –Value true
    PS> Get-FseExtendedOption –Name CFAllowBlockedSenders

    This should return the following: CFAllowBlockedSenders   True


    Monday, May 27, 2013 8:42 PM
  • Thanks very much Mahmood,

    This is a very precise and detailed answer. You're obviously a true expert.

    It would be great for me if you can answer this, or know of someone else who can:

         I am not using Exchange or a Corporate Network, just Outlook on a standalone PC (Win 7).  I'm experiencing exactly the same problem.  Is there a similar fix for my situation?  Perhaps a registry change?

    Tuesday, May 28, 2013 1:03 AM
  • your welcome,

    Regarding to your issue is your mail account working based on Exchange mail system?

    Tuesday, May 28, 2013 7:10 AM
  • No, just Outlook with POP mail.

    Tuesday, May 28, 2013 3:08 PM
  • I have had this problem for a long time and used the workaround above to set up actual filter rules. I know... what a pain. But I think I might have found out what is going on. Under the junk mail options/Options tab I had selected "high". Now I noticed that it says it catches "Most junk email" and that it implies it might catch good ones as well which means to me that it must have some of that famous hi-tech AI("artificial ignorance") built into it. This implies  to me that it knows better than what we put in the lists perhaps? I have selected "Safe lists only" instead of "high" and will used my contacts and what I add to it and see if that does not fix the problem. I just did this so I do not know if it works yet and I have high hopes. It might be something else for you all to try.

    Good Luck.

    • Proposed as answer by b101 Saturday, July 06, 2013 2:11 AM
    Saturday, July 06, 2013 2:04 AM
  • I can see that this problem has been around for two years now with no effective/intelligent answer. I have only one account/profile in my Outlook/mail configuration. Have kept adding just ONE address to the blocked senders list and it keeps disappearing from the list, and its mail keeps being delivered to my Inbox. We need someone competent to provide us with a working solution for what is obviously a bug.

    Wednesday, August 07, 2013 12:23 AM
  • What type of email account are you using? If Outlook.com, use a rule to move it to the deleted items folder instead.


    Diane Poremsky [MVP - Outlook]
    Outlook & Exchange Solutions Center
    Outlook Tips
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Wednesday, August 07, 2013 3:10 PM
  • The junk filter has anything with the blocked senders list to do?
    Monday, November 25, 2013 9:13 PM
  • No, it seems like the spammers actually reuses mail addresses. But Outlook 2010 is not able to block on them anyway. Not with the blocked senders list.
    Monday, November 25, 2013 9:18 PM
  • They seem to be permitted on the safe list only
    Monday, November 25, 2013 9:20 PM
  • It is also annoying that the number one email client cannot perform address blocking
    Monday, November 25, 2013 9:31 PM
  • The junk filter uses the blocked and safe senders lists. What type of email account do you use?



    Diane Poremsky [MVP - Outlook]
    Outlook & Exchange Solutions Center
    Outlook Tips
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Monday, November 25, 2013 9:58 PM
  • I have the same problem with Outlook, the Junk Mail filter simply does not work and Microsoft appears to continually ignore the problem. I get lots of emails from people using the outlook.com domain which I have added to my blocked senders list as @outlook.com but I still get emails from that domain. I also get emails from people pretending to be from paypal so block the user email name which is service @ paypal  and .co.uk but those emails still come through as well. When is Microsoft going to address this issue?
    Monday, January 06, 2014 5:00 PM
  • What type of email account do you have configured in Outlook? The junk filter doesn't work with Outlook.com accounts (filtering is server-side). It should work with POP3, IMAP, and Exchange.

    If you use multiple accounts, you need to verify you are adding the domain to the correct account's list - each account has their own safe and blocked lists, they don't share the list. More information and screenshots: http://slipstick.com/outlook/rules/outlook-junk-filter-multiple-accounts/



    Diane Poremsky [MVP - Outlook]
    Outlook & Exchange Solutions Center
    Outlook Tips
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Tuesday, January 07, 2014 5:09 AM
  • I had the same problem with the blocked sender emails not going to the Junk Email folder in Outlook 2010.  Looking at the Safe Senders tab on the Junk E-mail Options, I noticed that the "Also trust e-mail from my Contacts" option was checked.  I went to my Contacts and found out that the email address I was trying to block was in there.  I deleted the unwanted contact from my Outlook Contacts.  This fixed the problem.
    Tuesday, January 21, 2014 1:08 AM
  • Ì have exactly the same issue.

    Outlook doesn't filter the spam from a sender whose both address and domain ARE on my "blocked senders" list. But it doesn't do anything, I receive around 5 mails every day from these address

    I work on Outlook 2010, MS Windows 8.1. My account is IMAP, one single account. I have only 6 blocked senders. My safe senders list is empty so obviously this sender is not a safe one.

    It is clear that this is a bug of Outlook. Why it doesn't work after such a long time and on different outlook versions? Are some senders paying to Microsoft for us to keep on suffering with their messages or what? How is it possible that after 3 years the issue couldn't be solved?? Why Outlook superusers are asking always the same recurrent questions ("do you use multiple accounts?", "is the sender on your safe senders list?", "is your blocked sender list full?", etc.) instead of giving a proper answer which could solve the problem?

    Thanks

    Wednesday, February 12, 2014 9:48 AM
  • Ì have exactly the same issue.

    Outlook doesn't filter the spam from a sender whose both address and domain ARE on my "blocked senders" list. But it doesn't do anything, I receive around 5 mails every day from these address

    I work on Outlook 2010, MS Windows 8.1. My account is IMAP, one single account. I have only 6 blocked senders. My safe senders list is empty so obviously this sender is not a safe one.

    It is clear that this is a bug of Outlook. Why it doesn't work after such a long time and on different outlook versions? Are some senders paying to Microsoft for us to keep on suffering with their messages or what? How is it possible that after 3 years the issue couldn't be solved?? Why Outlook superusers are asking always the same recurrent questions ("do you use multiple accounts?", "is the sender on your safe senders list?", "is your blocked sender list full?", etc.) instead of giving a proper answer which could solve the problem?

    Thanks


    I have the exact same issue. One hosted IMAP account, one Outlook profile, Windows 8.1 Pro / Outlook 2010. No corporate Exchange involved at all - just a standalone PC on a network. People repeating the same thing about making sure you have not filled up junk folder entries or making sure the sender is not on the trusted list is just plain annoying. Read the posts! Saying the same thing over and over doesn't help. It just does not work, never has on my PC, never worked with Windows 7 Pro /Outlook 2010 and now I have upgraded to 8.1 it still doesn't work. I don't understand why some answers are so complex with registry entries and all that stuff, this should be simple, it is a simple feature, configured on a single click of a mouse to block an individual user - it just plain doesn't work.
    Friday, March 07, 2014 11:22 AM
  • yah! you're right! perfectly solving my prob.
    • Edited by Leocyril Thursday, April 03, 2014 8:53 AM
    Thursday, April 03, 2014 8:53 AM
  • For me I tried all the above steps and some additional - and finally it worked because of the following:

    I removed my email address from the "Junk Email Options - Safe Recipients"

    That's all. I don't know why my email address added in Safe Recipients.

    Thanks,

    APK


    • Edited by anvis99 Thursday, April 10, 2014 7:49 AM
    Thursday, April 10, 2014 7:47 AM