none
Change Published Ports for Web services (Reverse Proxy)

    Question

  • I'm working in a testing environment with only one public IP. Because I also need to publish OWA and exchange services on port 443, I want to move the Lync web services to other ports than the default 443 and 80.

    I found this guide how to configure TMG to do it, and in that guide on the second screenshot there are two fields "Published Ports" which I don't have in my topology builder. I'm using a single consolidated edge with one public IP and moved my access edge port to 5061.

    I managed to move the ports by editing the topology builder XML file and publishing it. Afterwards I re-ran step 2 of the Lync installation and now everything is working on the non-default ports.

    I have two questions regarding this setup:

    1. Why are the published ports fields missing in my topology builder?
    2. Is this a supported configuration for production use? I already have a customer who only has 1 public IP and want to use Exch + Lync externally.

    Best regards

     

     


    Technical Specialist Microsoft OCS & UC Voice Specialisation - http://www.uwictpartner.be
    If you think my post is the answer to your question, please mark it as answer so future visitors can easily find it.
    Monday, December 13, 2010 2:37 PM

All replies

  • Ruben,

    To answer your 1st question: the 2nd screen shot is not from LYNC, if you go into the Topology builder, select your Edge Pools.  Then on the General setting, under External Settings is where you configure your external ports for Lync to use.

    2nd question: yes its supported but i would recommend doing this via the Topology builder instead of editing the XML file.

     

    thanks

    Mike

    • Proposed as answer by MSFT-Hef Tuesday, January 04, 2011 6:20 PM
    • Unproposed as answer by Ruben Nauwelaers Tuesday, January 04, 2011 6:37 PM
    Tuesday, January 04, 2011 6:20 PM
  • Hi,

    Thanks for your reply.

    1/ The screenshot IS from topology builder. I have the same screen in topology builder but I only have the fields "Listening Ports", not the fields "Published Ports"

    2/ I meant the ports used for the web services like Address Book Service, the ones that will be published by the reverse proxy. The ports you mention, Below External Settings on the Edge Pool, are the external port numbers for A/V-, Access- and Web Conferencing Edge.

    Best regards


    Technical Specialist Microsoft OCS & UC Voice Specialisation - http://www.uwictpartner.be
    If you think my post is the answer to your question, please mark it as answer so future visitors can easily find it.

    Tuesday, January 04, 2011 6:34 PM
  • "Published Ports" of External Web Services does exist in the Topology Builder on my both RC and RTM edition, would you please check it again?
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, January 05, 2011 3:12 AM
  • It's not there as you can see:

    Image of Topology Builder missing the Published Ports for external Web Services

    I'm using the RTM version of the product. I have a Standard Edition environment


    Technical Specialist Microsoft OCS/Lync & UC Voice Specialisation - http://www.uwictpartner.be
    If you think my post is the answer to your question, please mark it as answer so future visitors can easily find it.
    Wednesday, January 05, 2011 7:14 AM
  • ok sorry for the confusion. 

    Under my installation I can get properties for External Web Services and under "listening ports" i have "published ports" for internal and external web services.

    The only difference is my lab setup is enterprise edition.

    I just setup another lab with standard edtion and got the same results as your picture above.

    Let me see what i can find out about why this is different and since modifying the xml is a big NO NO, i'll see if i can find out what the required steps would be to modify this setting in standard edition.

    Wednesday, January 12, 2011 11:19 PM
  • Ruben,

    this is what I have been able to find out.  Basically to do this with Standard Edition server you should use LYNC server management shell command to modify the port.

    and yes this is supported if done using the management shell.

    the command is:

    Set-CsWebServer [-Identity <XdsGlobalRelativeIdentity>] [-AppSharingPortCount <UInt16>] [-AppSharingPortStart <UInt16>] [-Confirm [<SwitchParameter>]] [-ExternalFqdn <Fqdn>] [-ExternalHttpPort <UInt16>] [-ExternalHttpsPort <UInt16>] [-Force <SwitchParameter>] [-InternalFqdn <Fqdn>] [-PrimaryHttpPort <UInt16>] [-PrimaryHttpsPort <UInt16>] [-PublishedExternalHttpPort <UInt16>] [-PublishedExternalHttpsPort <UInt16>] [-PublishedPrimaryHttpPort <UInt16>] [-PublishedPrimaryHttpsPort <UInt16>] ReachExternalPsomServerPort <UInt16>] [-ReachPrimaryPsomServerPort <UInt16>] [-UserServer <String>] [-WhatIf [<SwitchParameter>]]

    more info here:

    http://technet.microsoft.com/en-us/library/gg398759.aspx

    thanks

    Mike

     

    • Proposed as answer by MSFT-Hef Thursday, January 13, 2011 5:23 PM
    Thursday, January 13, 2011 5:17 PM