none
"An error occurred sending the command to the application" When trying to open excel document from outlook 2007

    Question

  • Error message "An error occurred sending the command to the application" When trying to open excel document from outlook 2007.

    OS: Windows Server 2008 R2

    If I save the document then it opens fine, messing with default file associations does not resolve this problem, I've googled for ir it and some suggest unticking compatibility mode or "run as admin" for excel application, neither is selected in my case.

    Outlook is configured to run as remote application from remoteApp server, this error is only occurring for one user, for others excel documents open just fine.

    Thursday, June 30, 2011 11:49 AM

Answers

  • Thanks for the reply, but I was able to solve this. Essentially this was an Excel problem not outlook, I was not aware that when opening documents from outlook which works as Remote Application, the program is launched from the outlook remoteApp server and not the local program where user is working, that is why I could open saved files fine, but could not open files directly from outlook.

    So what I did is logged to application server with the problematic user credentials and followed these steps:

    1. Start Excel

    2. Click on the Excel logo on the top left

    3. Choose Excel Options

    4. Select Advanced tab on the left menu

    5. Scroll down to the “General” section

    6. Uncheck Ignore other application that use Dynamic Data Exchange (DDE) option

    7. Click OK, and try opening excel files again.

    • Marked as answer by Aurimas N Thursday, July 07, 2011 10:40 AM
    Thursday, July 07, 2011 10:40 AM

All replies

  • any ideas?
    Friday, July 01, 2011 9:05 AM
  • Hi

     

    Thank you for using Microsoft Office for IT Professionals Forums.

     

    From your description, we can Create a trusted location follow these steps

    1. Click the Microsoft Office Button , and then click Excel Options.
    2. Click Trust Center, click Trust Center Settings, and then click Trusted Locations.
    3. If you want to create a trusted location that is not local to your computer, select the Allow trusted locations on my network (not recommended) check box.
    4. Click Add new location.

     IMPORTANT   We recommended that you don't make your entire Documents or My Documents folder a trusted location. Doing so creates a larger target for a hacker to potentially exploit and increases your security risk. Create a subfolder within Documents or My Documents, and make only that folder a trusted location.

    1. In the Path box, type the name of the folder that you want to use as a trusted location, or click Browse to locate the folder.
    2. If you want to include subfolders as trusted locations, select the Subfolders of this location are also trusted check box.
    3. In the Description box, type what you want to describe the purpose of the trusted location.
    4. Click OK.

     

    More detailed information you can refer to this link:

    http://office.microsoft.com/en-us/word-help/create-remove-or-change-a-trusted-location-for-your-files-HA010031999.aspx?CTT=1#BM12

     

    Please take your time to try the suggestions and let me know the results at your earliest convenience. If anything is unclear or if there is anything I can do for you, please feel free to let me know.

     

    Hope that helps.

     

    Sincerely

    William Zhou CHN

    --------------------------------------------------------------------------------

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Thursday, July 07, 2011 8:54 AM
  • Thanks for the reply, but I was able to solve this. Essentially this was an Excel problem not outlook, I was not aware that when opening documents from outlook which works as Remote Application, the program is launched from the outlook remoteApp server and not the local program where user is working, that is why I could open saved files fine, but could not open files directly from outlook.

    So what I did is logged to application server with the problematic user credentials and followed these steps:

    1. Start Excel

    2. Click on the Excel logo on the top left

    3. Choose Excel Options

    4. Select Advanced tab on the left menu

    5. Scroll down to the “General” section

    6. Uncheck Ignore other application that use Dynamic Data Exchange (DDE) option

    7. Click OK, and try opening excel files again.

    • Marked as answer by Aurimas N Thursday, July 07, 2011 10:40 AM
    Thursday, July 07, 2011 10:40 AM
  • Thanks - this worked for me also.  Just wanted to let you know the help was greatly appreciated.
    Monday, November 28, 2011 6:52 PM
  • Worked for me too. Thanks a lot
    Thursday, October 18, 2012 11:35 AM