none
Protected View Error "The file is corrupt and cannot be opened"

    Question

  • All 

     

    I have a problem with Protected View in Office 2010 on Windows 7.

    Symptom:  When downloading a file from the Internet, the file will not open if launched directly from the source location, or saved locally and then opened.  This is impacting both Word and Excel.  I haven’t tested other applications.  The user gets the error "The file is corrupt and cannot be opened.".

    Expected behaviour:  Documents should open in Protected View because they are coming from an untrusted zone (Internet Zone).

    Troubleshooting Results:

     -      If I turn off Protected View the error goes away and the documents open without issue (but not in Protected View obviously)

    -      If I save the file locally, then copy it to a network drive, the problem goes away (because the zone information is changed?).

    -      If I save the file directly to a network location, then open it, the problem does not impact me (also doesn’t open in Protected View)

    -      If I repair Office the problem is NOT fixed

    -      If I reinstall Office the problem is NOT fixed

    The problem doesn't impact all machines, but any new machine I build suffers the problem.  All Protected View options are set by group policy and all machines are getting the correct settings.

    -       The setting “Enable Protected View for files originating from the Internet” is enabled

    -       The setting “Enable Protected View for files located in potentially unsafe locations” is enabled

    -      The setting “Enable Protected View for Outlook attachments” is enabled

    -      Enable Data Execution Prevention mode is enabled

    Has anyone seen this problem or can anyone offer suggestions of where to start looking for the root cause?  There are lots of postings on this around the various Internet forums, but most just suggest turning off Protected View, that is not a valid solution to my mind, Protected View is there for a very sound reason and it is not something I'm willing to turn off, especially when it is working on some machines as expected.

    Thanks.

    James.

    • Edited by jsc.19 Thursday, September 09, 2010 12:31 AM
    Friday, September 03, 2010 8:18 AM

Answers

  • Will, thanks for taking the time to post some suggestions.  I understand Protected View perfectly well and my post is because Protected View is not behaving as it should.  I think my dot points above show this, still, thanks for taking the time to post.  I think Tony is more on track with his questions around what has changed in my build, and this is the area I've focused on over the few days since posting.

    I've pulled my build apart and put it back together and found the issue.  This was tedious to say the least, but turned out worthwhile.  A program we used called Trim Context Desktop (http://h71028.www7.hp.com/enterprise/w1/en/software/information-management-trim.html) is part of our SOE.  This is a records management tool, but we only use a small feature set, and all the Office integration options that can be configured during install are turned off, but it turns out that the application still impacts Office.  If I uninstall the Trim client from our SOE, Office Protected View starts working as expected.  We knew the full Trim suite wasn't ready for Office 2010, but assumed, wrongly, that since we didn't use the Office integration features we were OK.  All our testing was around the application and it works fine, I just didn't connect it to the Office issues until systematically eliminating changes from the SOE build.  Keep a log of your changes!!!  It helped me reverse things until I found the problem.

    Uninstalling Trim also fixes and issue I had in Outlook where the previewers wouldn't display Office documents, reporting that the previewers were not installed. 

    We will go to HP to get some support and advice around this before putting Trim back in to the SOE.

    Anyone - if you have similar problems, can I suggest you look at all your Office add-ins and also any applications that may potentially hook in to Office.

    Cheers all.

    James.

     

    • Marked as answer by jsc.19 Thursday, September 09, 2010 12:28 AM
    Thursday, September 09, 2010 12:28 AM

All replies

  • Hello James,

    Please check out the following blog entry about Protected View. What you are seeing is not a bug, but by design. Protected View is a new feature of Office 2010 that detects when an Office 2010 document is opened from the internet zone and then opens that document in a "sandboxed" application that is read only. You should be seeing a prompt that looks like the one below:

    Clicking to 'Enable Editing' should allow you to edit the document. If you are now seeing this prompt and are opening the document in a browser other than Internet Explorer, try opening the document in IE and let me know if you see the prompt.

    (Link to the blog from Microsoft Trustworthy Computing on protected view: http://blogs.technet.com/b/office2010/archive/2009/08/13/protected-view-in-office-2010.aspx)

    Will Buffington
    Microsoft Excel Support

    Tuesday, September 07, 2010 10:37 PM
  • I don't know the answer to the question but ..
     
    Either a file is corrupt or it is not - there isn't any half way house,
    although it may be that some processes detect corruption that others miss.
     
    You are saying it is *by design* that the process of opening a file in
    Protected View will sometimes (on some machines) report corruption that
    opening the same file without using Protected View will not. Please provide
    some details of this design.
     
     
    As to the problem itself, in the case where the problem goes away when the
    file is saved locally, what process is being used to save the file? Most
    Microsoft processes should add or maintain the Zone Information as the fact
    the the file has come from the internet has not changed. Is the local folder
    perhaps a Trusted Location?
     
    --
    Enjoy,
    Tony
     
    www.WordArticles.com
     
    "Will Buffington" wrote in message
    news:906e92bf-9541-4493-8b28-6623a342e659...
    > Hello James,
    >
    > Please check out the following blog entry about Protected View. What you
    > are seeing is not a bug, but by design. Protected View is a new feature of
    > Office 2010 that detects when an Office 2010 document is opened from the
    > internet zone and then opens that document in a "sandboxed" application
    > that is read only. You should be seeing a prompt that looks like the one
    > below:
    >
    >
    >
    > Clicking to 'Enable Editing' should allow you to edit the document. If you
    > are now seeing this prompt and are opening the document in a browser other
    > than Internet Explorer, try opening the document in IE and let me know if
    > you see the prompt.
    >
    > (Link to the blog from Microsoft Trustworthy Computing on protected view:
    > http://blogs.technet.com/b/office2010/archive/2009/08/13/protected-view-in-office-2010.aspx)
    >
    > Will Buffington
    > Microsoft Excel Support
    >
     
     

    Enjoy,
    Tony
    www.WordArticles.com
    Wednesday, September 08, 2010 9:08 AM
  • With regard to the question of corruption, in my view the error message is bogus. What I think may be happening is Excel is unable to modify the file (For example, Excel 2007 and 2010 do some checks when a file is opened for consistency when a pivot table is detected in the document) and throws the generic error about the file being corrupt. When I say this is by design, I mean the file opening in protected view is by design, per the blog cited in my last post. What I'm wondering is whether the user is seeing the prompt to enable the Excel file. If not then it could be because they may be using a non-Internet Explorer browser like Chrome or Firefox.

    Will
    Wednesday, September 08, 2010 5:07 PM
  • Will,
     
    OK. Thanks for clearing that up.
     
    The questioner wants to use Protected View, so presumably knows that it is
    by design, and also says that this affects both Word and Excel, so it seems
    to me as though there is some more general effect at play than consistency
    checks in Excel.
     
    If the user is getting the internet file using software that does not invoke
    AES then Protected View would not be fired and there would, presumably, be
    no difference in behaviour whether it was enabled or not.
     
    James,
     
    You say you get this on any new build you do but not on machines built prior
    to ... when? There must be some difference; have you changed your build
    process, or applied some updates? Is it possible that you have different
    trusted locations, or that the documents have been previously opened and are
    marked as trusted on the 'old' machines?
     
    I would be interested to see any file that causes the problem, if not
    confidential.
     
    --
    Enjoy,
    Tony
     
    www.WordArticles.com
     
    "Will Buffington" wrote in message
    news:95708bf2-20f9-4d8e-8958-e06d179bc01f...
    > With regard to the question of corruption, in my view the error message is
    > bogus. What I think may be happening is Excel is unable to modify the file
    > (For example, Excel 2007 and 2010 do some checks when a file is opened for
    > consistency when a pivot table is detected in the document) and throws the
    > generic error about the file being corrupt. When I say this is by design,
    > I mean the file opening in protected view is by design, per the blog cited
    > in my last post. What I'm wondering is whether the user is seeing the
    > prompt to enable the Excel file. If not then it could be because they may
    > be using a non-Internet Explorer browser like Chrome or Firefox.
    >
    > Will
     
     

    Enjoy,
    Tony
    www.WordArticles.com
    Wednesday, September 08, 2010 7:58 PM
  • Will, thanks for taking the time to post some suggestions.  I understand Protected View perfectly well and my post is because Protected View is not behaving as it should.  I think my dot points above show this, still, thanks for taking the time to post.  I think Tony is more on track with his questions around what has changed in my build, and this is the area I've focused on over the few days since posting.

    I've pulled my build apart and put it back together and found the issue.  This was tedious to say the least, but turned out worthwhile.  A program we used called Trim Context Desktop (http://h71028.www7.hp.com/enterprise/w1/en/software/information-management-trim.html) is part of our SOE.  This is a records management tool, but we only use a small feature set, and all the Office integration options that can be configured during install are turned off, but it turns out that the application still impacts Office.  If I uninstall the Trim client from our SOE, Office Protected View starts working as expected.  We knew the full Trim suite wasn't ready for Office 2010, but assumed, wrongly, that since we didn't use the Office integration features we were OK.  All our testing was around the application and it works fine, I just didn't connect it to the Office issues until systematically eliminating changes from the SOE build.  Keep a log of your changes!!!  It helped me reverse things until I found the problem.

    Uninstalling Trim also fixes and issue I had in Outlook where the previewers wouldn't display Office documents, reporting that the previewers were not installed. 

    We will go to HP to get some support and advice around this before putting Trim back in to the SOE.

    Anyone - if you have similar problems, can I suggest you look at all your Office add-ins and also any applications that may potentially hook in to Office.

    Cheers all.

    James.

     

    • Marked as answer by jsc.19 Thursday, September 09, 2010 12:28 AM
    Thursday, September 09, 2010 12:28 AM
  • Thanks for coming back, James, and I'm glad you've found the source of your
    problem.
     
    As an aside, I had no idea HP made software like that and will take a look
    at it - or would if I could. Personally, although I love their hardware, I
    wouldn't touch HP software, and the fact that their web page doesn't load
    (in IE8) just reinforces my feeling.
     
    --
    Enjoy,
    Tony
     
    www.WordArticles.com
     
    "jsc.19" wrote in message news:f9aaa05d-ad62-4f0e-96e1-6bbeb4c7098d...
    > Will, thanks for taking the time to post some suggestions. I understand
    > Protected View perfectly well and my post is because Protected View is not
    > behaving as it should. I think my dot points above show this, still,
    > thanks for taking the time to post. I think Tony is more on track with
    > his questions around what has changed in my build, and this is the area
    > I've focused on over the few days since posting.
    >
    > I've pulled my build apart and put it back together and found the issue.
    > This was tedious to say the least, but turned out worthwhile. A program
    > we used called Trim Context Desktop
    > (http://h71028.www7.hp.com/enterprise/w1/en/software/information-management-trim.html)
    > is part of our SOE. This is a records management tool, but we only use a
    > small feature set, and all the Office integration options that can be
    > configured during install are turned off, but it turns out that the
    > application still impacts Office. If I uninstall the Trim client from our
    > SOE, Office Protected View starts working as expected. We knew the full
    > Trim suite wasn't ready for Office 2010, but assumed, wrongly, that since
    > we didn't use the Office integration features we were OK. All our testing
    > was around the application and it works fine, I just didn't connect it to
    > the Office issues until systematically eliminating changes from the SOE
    > build. Keep a log of your changes!!! It helped me reverse things until I
    > found the problem.
    >
    > Uninstalling Trim also fixes and issue I had in Outlook where the
    > previewers wouldn't display Office documents, reporting that the
    > previewers were not installed.
    >
    > We will go to HP to get some support and advice around this before putting
    > Trim back in to the SOE.
    >
    > Anyone - if you have similar problems, can I suggest you look at all your
    > Office add-ins and also any applications that may potentially hook in to
    > Office.
    >
    > Cheers all.
    >
    > James.
    >
    >
    >
     
     

    Enjoy,
    Tony
    www.WordArticles.com
    Thursday, September 09, 2010 7:35 AM
  • Fixed this issue.  It was due to DCOM settings being changed.

    Hello,

    I finally found out what the issue is with this.  It actually isn't a "Protected view" issue, but a DCOM issue.

    Somehow the DCOM permission got changed, so it wouldn't allow certain applications access to simple things like Preview mode on Outlook 2010 / 2007, or opening up attachments without it saying file corrupt.  I also was having an issue with Pop ups in IE8, where javascript messages about security tokens were not authenticated.

    The solution is as follows, and then you can turn on your protected mode back on in word, excel, and your "Preview mode" in outlook will start working again.

    Go to start, then run.  Type dcomcnfg and push o.k. Component Services should come up.

    Expand Component Services, click on Computers, then "Right click" on My Computer and go to "properties".

    Click on Default Properties tab, and make sure the following is set:

    Default Authentication Level: Should say Default, not "None"

    And Default Impersonation Level: SHould say Identify.

    When those are set properly, hit o.k and turn on your protected mode back on your Office applications.  Everything works as expected :)

    Cheers :)

    Tuesday, November 30, 2010 12:57 AM
  • Fixed this issue.  It was due to DCOM settings being changed.

    Hello,

    I finally found out what the issue is with this.  It actually isn't a "Protected view" issue, but a DCOM issue.

    Somehow the DCOM permission got changed, so it wouldn't allow certain applications access to simple things like Preview mode on Outlook 2010 / 2007, or opening up attachments without it saying file corrupt.  I also was having an issue with Pop ups in IE8, where javascript messages about security tokens were not authenticated.

    The solution is as follows, and then you can turn on your protected mode back on in word, excel, and your "Preview mode" in outlook will start working again.

    Go to start, then run.  Type dcomcnfg and push o.k. Component Services should come up.

    Expand Component Services, click on Computers, then "Right click" on My Computer and go to "properties".

    Click on Default Properties tab, and make sure the following is set:

    Default Authentication Level: Should say Default, not "None"

    And Default Impersonation Level: SHould say Identify.

    When those are set properly, hit o.k and turn on your protected mode back on your Office applications.  Everything works as expected :)

    Cheers :)

    Excellent!! I was having similar problem and this fixed it. When I tried to open a office file (work or excel docs) from a network share I was getting the ".. corrupt file.." error in excel and a similar list of errors in Word. Applying the fix above sorted the problem out. Nice one!
    Monday, January 31, 2011 10:17 AM
  • Based on my googling, there's a lot of us out here with this problem.  When we try to open a file from a network location in Excel 2010, we get an error: "The file is corrupt and cannot be opened."

    The dcomcnfg solution did not work for me, although I haven't messed around with other Default Authentication Level settings yet.

    Of course, turning off Protected Mode settings works, but that's not what I want.  Protected Mode is a good thing, and it works just fine on my other Office 2010 installations.  The only thing different about this particular installation, is that it's on a terminal server running Windows Server 2008 R2.  Maybe it's something about the security settings on the server...

    ***UPDATE***

    Adding my network drive to the Trust Locations of Office 2010 did NOT work.

    I ended up resolving this problem using my domain group policy.  I added my network share IP address to the Trusted Sites zone under User Configuration > Policies > Administrative Templates > Windows Components > Internet Explorer > Internet Control Panel > Security Page > Site to Zone Assignment List.  In the same folder, under Trust Sites Zone Template, I set security to Medium Low (I'm not sure whether that is necessary or not).

    • Edited by Baodad Friday, April 01, 2011 5:41 AM Found solution
    Friday, April 01, 2011 4:51 AM
  • This is correct for the most part, but I compared the Default Authentication Level on a known working machine and it was set to Connect instead of Default and this resolved my issue.

    Thanks though was a huge help.

    Thursday, May 19, 2011 1:25 AM
  • i am a tech for a financial company and had the issue on one of our computers.  the fix did not work for me either and i also added the web address of the holder of the spreadsheet to the trusted sites in the excel security center which also did not work.  the issue has been escalated to level 3 for almost 2 weeks now with no solution in sight.  if anyone at microsoft can help me out on this, it would be great as i have an advisor not being able to perform her duties due to this bug.  it has to be a setting on her system as the other 2 people in her office using the same form have no issues, and i logged in as administrator on her box and had the same errors.  any additional troubleshooting is appreciated, i would love to be the level 2 tech that solved a problem that level 3 could not.  and i just can't let this one go, it's a pride thing...
    Wednesday, January 18, 2012 2:13 PM
  • tony,

    i'm tim, a level 2 tech at a call center.  i have the same problem on one of my boxes, workbook is stored online, needs to be modified and saved.  i found several fixes on this forum and tried them all and then some.  not an account issue, repairing office or excel don't work, reinstall, added website to trusted sites, changed settings on dcom, don't have trim installed, nothing works.  box is running xp sp3, 2 others in office work fine, one win 7, one xp.  it has been escalated to level 3 for 2 weeks, she can't do part of her job, can you help me out with this?

    Wednesday, January 18, 2012 4:56 PM
  • I struggled with this issue for a long time as well, trying all the solutions proposed in this thread.  Eventually, the only workaround I've found (I'm almost certain this is an MS bug) involved tweaking our domain's group policy settings - making sure that both Office group policy settings allowed certain locations, and also that the trusted sites in IE included our local network.  I apologize for not having more details right now, but I had to do something to disengage the "protected view" functionality from triggering when users opened documents on the network.  It's unfortunate because I like the idea of "protected view," but this bug in its implementation persists (until someone with enough tech savvy can convince Microsoft to address it).
    • Edited by Baodad Thursday, January 19, 2012 2:00 AM
    Thursday, January 19, 2012 1:57 AM
  • unfortunately, this would not help as she is not on a domain.  i would really like to be able to help her out, but am running out of options, ready to do a reimage
    Tuesday, January 24, 2012 1:42 PM
  • I found if the userid was in the local Administrators group, but _NOT_ in the local Users group, then Protected View would not run properly.  Add this to another of the items to check on when this problem happens...
    • Edited by Shangrila1 Tuesday, April 10, 2012 8:20 PM
    Tuesday, April 10, 2012 8:19 PM
  • Finally - i used above and solved my issue too.

    The problem was my PCs on my domain thought the files saved on my "server" came over the internet and were not a trusted site.  The issue i had was going around ALL pcs to ensure that my server was added as a trusted site.

    i used Group Policy as described above - recap -

    User Configuration > Policies > Administrative Templates > Windows Components > Internet Explorer > Internet Control Panel > Security Page > Site to Zone Assignment List.

    enabled and added in first column file://servername and second column 2

    In the same folder, under Trust Sites Zone Template, I set security to Medium Low.

    If you don't have group policy or wish to do manually

    go to control panel, internet options, security tab, select trusted sites zone, press sites button, add file://servername and click add and also if you like add 10.22.22.22 (ip number) of server, or http://www.enteraddresshere.com for example.

    Good Luck everyone, this took me two weeks to sort - but finally!

    • Proposed as answer by 72wilko Thursday, May 10, 2012 2:54 PM
    Thursday, May 10, 2012 2:54 PM
  • I just wanted to add to this that I have recently come across this problem. An XLS file received from an external email address was producing a 'file is corrupt' message when Excel was trying to open it in Protected View.

    For me the solution was Office 2010 Service Pack 1.

    Once installed this fixed the problem.

    Thanks,

    Jay

    Tuesday, September 18, 2012 10:30 AM
  • I just wanted to add to this old thread. None of the solutions worked for me. I was also getting "The file is corrupt and cannot be opened" message when I try to open an Excel (*.xls) email attachment from a co-worker. My box has Office 2010, and my co-worker has Office 2007. At first I made sure it wasn't the file by forwarding it to another co-worker.  Walla! No problem opening the file.

    So while reading this thread and trying out all the suggestions, I accidentally came upon a work around.

    In Excel go to > File > Options > Trust Center > Trust Center Settings > Trusted Locations > Add New Location ... then I added my desktop as a "trusted location".

    Now I can save the Excel file on my desktop and I'm able to open it from there, no problem.

    Friday, August 15, 2014 5:15 PM
  • Hi, Also like the previous reply I too wanted to add my input as i searched tirelessly and tried everything and nothing worked... Our setup: office 2k13 fresh install on a xenapp 6.5 build which had office 2007 removed. Key point: we use Appsense Personalization to handle profiles.. First thing of note, with all our existing GPOS in place I was getting the corrupt message straight off the bat in Excel and a slightly different message in Word but along the same lines. What took me a very long time to discover was if I accessed a UNC via the FQDN I was getting these errors. If the UNC was just simple \\server\share then it worked fine *note* it didn't go into Protected view - which isn't what me and the OP were looking for - i.e. we wanted protected view to work. In my GPO I was mapping drives using the FQDN which was part of the puzzle. So now I could open files at last but still not right... Know what Appsense was like I then figured out that with the Personalization service stopped I could indeed use (from the File Open dialog) protected view. I narrowed it down to the actual 'personalization' part of the environment manager config causing the issue... reading on My Appsense documents I found the example settings for office 2013 and split them out from my 2007 settings (so I now have both seperately). as soon as I did this it then worked, I can use protected view no problem. Obviously not everyone uses Appsense but essentially I guess my issue was within the profile (since that is what it's for) so maybe a similar issue using citrix or roaming profiles could be giving the same problems.. Last thing - when the issue was happening to me I noticed that no OICE_xxxxxx folder was being created under the c:\users\un\appdata (seems odd it not being in local or roaming etc) Thanks Chris
    Friday, September 12, 2014 7:11 PM