none
disable proofing, spell checker, using GPO.

    Question

  • Hi, i need to remove the spell check and autocorrect feature in office 2010 for certain users in my domain using a gpo. Situation is we have exams and the students will log in using an exam account and this account needs to have a gpo applied to it that removes all proofing tooles.  Thanks.
    Sunday, October 16, 2011 7:29 PM

All replies

  • Hi,

     

    Thank you for using Microsoft Office for IT Professionals Forums.

     

    From your description, you can try the following method:

     

    1.Disable autocorrect and other unwanted features.
    Microsoft Office Word 2010 > Word Options > Proofing

     

    2. Remove these items from the UI
    Microsoft Office Word 2010 > Disable Items from User Interface > Custom > Disable Commands

     

    Control Name |Policy ID

    Spelling |2
    Grammar |329
    SetLanguage |790
    SpellingRecheckDocument |2349
    GrammarSettingsDialog |2469
    SpellingAndGrammar |2566
    ProofingOptions |2788
    SpellingHideErrors |3217
    GrammarHideErrors |3218
    Dictionary |3219
    TranslationPane |6111
    ResearchPane |7343
    ReadingViewResearchPane |7387
    Thesaurus |9056
    (greys out Word Options)* |11323
    TranslationToolTip |12842
    EnglishWritingAssistant |14453
    SpellingMenu |15780

    More information about this can be found here:
    Disable user interface items and shortcut keys

     

    3.Disable to the keyboard shortcuts
    Microsoft Office Word 2010 > Disable Items from User Interface > Custom > Disable shortcut keys

    F7 | 118
    Shift + F7 | 118,16
    Ctrl + Shift + o | 79,12
    Alt – T | 254

     

    Please take your time to try the suggestions and let me know the results at your earliest convenience. If anything is unclear or if there is anything I can do for you, please feel free to let me know.

     

     

    Sincerely

    Rex Zhang

    --------------------------------------------------------------------------------

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    • Proposed as answer by B.G. Arets Tuesday, January 31, 2012 8:38 AM
    Tuesday, October 18, 2011 3:02 AM
  • Hi Rex,

    I've just tried that, and while it does grey out all the toolbar options, the squiggly red line still appears under spelling errors, and the correct spelling is available via a right-click.

    Thursday, October 20, 2011 3:31 PM
  • Hi Rex,

    Thanks for the reply however auto capitalisation is applied underlining and right click spell check is still avaliable.

    Any help on removing these musch appreciated.

     

     

    Sunday, November 06, 2011 11:52 AM
  • Okay, I've finally got this.

    Follow Rex Zhang's instructions above to disable the toolbars, and then add the following registry key to the restricted users:

    [HKEY_CURRENT_USER\Software\Microsoft\Shared Tools\Proofing Tools\1.0\Office]
    "WordSpellingOptions"=dword:0

     

    You will also need to add the following reg key to everyone else, otherwise they won't get the spell check if they use a computer after a restricted user.

    [HKEY_CURRENT_USER\Software\Microsoft\Shared Tools\Proofing Tools\1.0\Office]
    "WordSpellingOptions"=dword:5

     

    • Proposed as answer by enjay_enjay Friday, November 18, 2011 2:52 PM
    Friday, November 18, 2011 2:46 PM
  • Nice one Enjay, the last issue i have remaining is auto capitalisation of the first letter of each paragraph? no matter what i do it still keeps auto correcting to a capital could really do with a gpo setting to remove it. Well done for your find as i have been overwriting the mssp7en.dll dictionary file with a blank file your method is cleaner.
    Sunday, November 20, 2011 10:51 AM
  • Auto capitalization can't be turned off with a simple key, unless Microsoft forgot to document it. I spent too much time trying to figure this all out and I had missed some of this stuff. Regardless, the only way to switch off that capitalization is through messing with a huge binary key (Software\Microsoft\Office\Office14\Word\Data in registry I believe, under HKCU).

    Anyway, this tool I recently put up might help.

    http://www.migee.com/2011/12/06/disable-grammar-spell-check-thesaurus-proofing-in-office-2010/


    http://www.migee.com
    • Edited by MikeMorawski Tuesday, December 06, 2011 10:23 PM
    Tuesday, December 06, 2011 10:23 PM
  • The above settings combined with the registry settings work.

    However I found 5 more settings you should disable. These options take a user to word options and the user can turn Spell Check on again.

    (greys out Word Options)* |11323

    ·         MarginsCustomMargins | 12795

    ·         PageSetupDialog | 247

    ·         PageSizeMorePaperSizesDialog | 15048

    ·         LineNumbersOptionsDialog | 15049

    ·         LanguagePreferences | 22145

    Sincerely

    B. Arets

    • Edited by B.G. Arets Tuesday, January 31, 2012 8:39 AM
    • Proposed as answer by B.G. Arets Tuesday, January 31, 2012 8:39 AM
    Tuesday, January 31, 2012 8:38 AM
  • Just want to say thanks B.G Arets. I've updated the code and added credit where needed!

    http://www.migee.com

    Tuesday, July 17, 2012 12:49 AM
  • Im having the same problem, i need to Turn off all spelling and grammar checking for an exam. Everything has been turned off apart from the spellchecker as you type. I set up the GPO to change the registry key when the exam user logs in, but it didn't work. A GPresult showed everything had applied correctly, my problem is, that registry key doesn't exist in our x86 Win XP student build. Any help is appreciated
    Tuesday, January 08, 2013 1:30 PM