none
When selecting one cell, multiple cells highlight

    Question

  • When I am working with Excel 2010, I try to select a single cell however multiple cells get highlighted. It will highlight usually the next 5-6 cells in the same row. It occurs randomly on random cells, but happens about 25% of the time. If I click the cell and it does its highlighting thing, I usually have to click away in another cell and then re-click the first one to get it to go away. Also, if I just try to ignore the highlighted cells and try to work as normal, when I try to tab to the next cell in the row, it will only let me tab between the cells in the column that are highlighted. It is not a mouse problem, I am not accidentally selecting multiple cells, and it happens on documents I created as well as documents others have created. It will also happens on a new, blank document or others completely stripped of any kind of potentially hidden formatting. I have not tried to re-install Office yet, but that will be next step if no one has a solution. Thanks
    Tuesday, November 23, 2010 5:57 PM

Answers

All replies

  • Sounds like the Extended Selection feature which is toggled on/off by pressing the F8 key.
    '---
    Jim Cone
    Portland, Oregon USA
    http://www.contextures.com/excel-sort-addin.html
    (30 + ways to sort)
    • Marked as answer by Sally Tang Thursday, December 02, 2010 5:33 AM
    Wednesday, November 24, 2010 3:52 AM
  • This issue is already being discussed in another thread:

    http://social.answers.microsoft.com/Forums/en-US/excslcreate/thread/e77e5d4b-ff27-4bd2-9538-842e01a53497

    I would suggest we stick to that thread.

    Monday, December 06, 2010 2:33 PM
  • This issue is already being discussed in another thread:

    http://social.answers.microsoft.com/Forums/en-US/excslcreate/thread/e77e5d4b-ff27-4bd2-9538-842e01a53497

    I would suggest we stick to that thread.

    That forwards to another site.

     

    A user of mine had this problem on 2007. 

    It would select 2 cells in the same column.

    I emailed the excel doc to myself and a co-worker.  It only selects one cell on my excel 2010.
    It selects 2 cells in the same row on my co-workers excel 2010.

    Changing the view zoom to something other than 100% solves the problem.  Changing it back to 100% brings the problem back.

    This seems to be a bug.

    Wednesday, May 25, 2011 4:12 PM
  • I just want to thank the person who wrote about this issue and the person(s) that had the answer. It's been driving me crazy, but the F8 toggle did the trick!
    Wednesday, September 14, 2011 8:30 PM
  • The F8 toggle doesn't always work.  This is a bug with Excel and Microsoft is aware of it but doesn't seem to know how to fix it.
    Friday, February 10, 2012 1:15 PM
  • Doesn't work for mine either (2010). Tried the f8, same results... Any updates on this yet???
    Monday, April 09, 2012 3:31 PM
  • I am having the same problem in MS Excel 2007 and F8 does not solve it.
    Thursday, April 26, 2012 2:28 PM
  • I

    I first came across this problem today and it would appear that the only other potential fix is to use the zoom feature in the bottom rhs of the screen and zoom out and then back in to your original size and this seems to cure the problem.  It may reoccur but repeating this process will remedy the problem again.  Very frustrating but atleast the limited fix is not to longwinded.

    Good luck.

    • Proposed as answer by Ade Tamworth Thursday, May 31, 2012 1:52 PM
    Thursday, May 31, 2012 1:52 PM
  • I was having the same trouble. I switched from Normal View to Page and then to Print view and back to Normal. That seemed to work because the f8 was not. I'm using 2010. 

    Good Luck!

    Monday, July 02, 2012 8:31 PM
  • I never had this problem before, but I got a new HP EliteBook and now I have this happen all the time.  It seems to happen when I scroll to a part of the sheet that was previously off-screen.  Zooming seems to fix it for now
    Tuesday, July 03, 2012 12:34 PM
  • I have this same issue.  I get around it by changing the zoom level to anything that is NOT 100%.  F8 has nothing to do with it.
    Thursday, October 18, 2012 12:31 AM
  • F8 did not help me at all. It only made the two highlighted cells go to 6 cells. Making it anything other than 100% zoom is what did work. And I thank the people who suggested that!! I made it a custom 105%. Whew! That was driving me crazy.
    • Proposed as answer by laufenba Thursday, December 20, 2012 3:26 PM
    • Unproposed as answer by laufenba Thursday, December 20, 2012 3:26 PM
    Wednesday, November 07, 2012 4:27 PM
  • I've been dealing with this also.  The only thing I've found is that there is a correlation when I added headers/footers to my worksheet.  As soon as I do that I started getting random multiple cells being highlighted.  When I remove the headers/footers it goes away.  I see in other replys that decreasing the zoom seems to help some people with this issue.  Maybe when adding headers/footers has something to do with the zoom feature also, but I would definitely give this a try and see what happens.  It is just annoying anyway you look at it. 
    Thursday, December 20, 2012 3:31 PM
  • I've been getting the same random problem in 2010 - but this last message struck a chord with me because I just added a header and it started occurring again!

    Microsoft take note that this is the way to reproduce it.

    Wednesday, March 06, 2013 9:55 AM
  • I have been experiencing the same problem, but I seem to have figured out the method to the madness. If you click in the direct center or at the right of the cell box, it will select the adjacent box as well. But, if you click to the left of the cell, it will only select the one box. 

    Hope this helps. 

    Wednesday, June 26, 2013 9:08 PM
  • I ran into this problem today working in Excel 2010 at 90% zoom.

    First I tried F8 and Shift+F8 but neither of them worked.

    Next I changed the zoom levels up and down and this worked while I was at a different zoom level than the document was saved in but went back to the same problem when I tried working at 90% zoom again.

    Finally I came across the fix mentioned below from July 2, 2012 that suggested switching from Normal View to Page and then to Print view and back to Normal and this worked!!! Thanks to all for your input below, you saved my Monday morning!

    LIST OF POSSIBLE FIXES:

    1. Try using the F8 and/or Shift+F8 [extend selection] to toggle back and forth.

    2. Change zoom level of your document up or down [this was only a temporary fix for me].

    3. Change page layout between Normal, Page Layout, and Page Break Preview (the 3 boxes at the bottom right hand corner of excel spreadsheet) then back to Normal.

    • Proposed as answer by Squintz221 Monday, September 09, 2013 5:49 PM
    Monday, September 09, 2013 5:48 PM
  • I ran into the same problem using MS Excel 2007. My file was .xlsx extension and I saved the spreadsheet as .xls. Problem solved. 
    Thursday, November 14, 2013 9:10 PM
  • Using the latest iteration of EXCEL, this happens only when working in "Page Layout" mode (bug).  If this happens, I select VIEW>Workbook Views>(anything but "Page Layout").  Since discovering this, I only work in "Normal" or "Page Break Preview".  Note: f8 and switching back to Page Layout did nothing for me. 

    Tuesday, November 26, 2013 4:04 PM
  • I have been experiencing the same problem, but I seem to have figured out the method to the madness. If you click in the direct center or at the right of the cell box, it will select the adjacent box as well. But, if you click to the left of the cell, it will only select the one box. 

    Hope this helps. 

    This occurs in my case as well.  I'll be using this as my short term fix, but the issue is still puzzling.
    Friday, December 06, 2013 2:48 PM
  • Changing the view zoom to something other than 100% solves the problem.  Changing it back to 100% brings the problem back.

    This seems to be a bug.

    Using the Custom Zoom option and changing to <90% solves the problem. If you want to use 100% zoom then use the Custom Zoom option to change back to 100% (Do Not use the 100% Icon). I am now using 100% Zoom without a problem.
    Wednesday, December 11, 2013 9:10 PM
  • Thank you!

    Wednesday, January 22, 2014 3:47 PM
  • In our Excel 2010 case we found that a user had changed the file's "view" from Normal to Page Layout. Setting the view back to Normal and saving the file resolved it (See below).

    • Proposed as answer by Specboy Thursday, March 20, 2014 3:37 PM
    Wednesday, March 05, 2014 4:02 PM
  • I am using 2010 also.  Same resolution here F8 did not work.  NumLock- or NumLock+ did not work.  Changing the zoom from 100% worked.  Very annoying when working in large workbooks.  Very annoying period!
    Wednesday, April 02, 2014 3:23 PM
  • Using Windows 8.1 - Excel 2013

    Like many others F8 did not work for me; changing zoom back to 100% did not work either.

    Changing to Normal View - nope, problem still exists.

    What worked was - continuously hit Shift key; when asked to enable Sticky Keys - hit cancel.

    Tuesday, June 03, 2014 1:04 PM
  • I tried the F8 and escape keys and nothing seemed to help but changing the view size did. It's definitely a defect within excel itself.  

    Monday, June 23, 2014 3:30 PM
  • I'm not sure why it does it but I found an easy fix that has worked every time for me.  Click on the box you want and while holding the left mouse button scroll up however many times you need to to get it to the one box.  I hope that's clear. :-)
    • Proposed as answer by impatches Friday, July 04, 2014 9:00 PM
    Friday, July 04, 2014 8:59 PM