none
Gmail folder "All Mail" is not showing up in Outlook 2013 using IMAP

    Question

  • For some reason the "All Mail" folder is not showing up in Outlook. 

    I tried deleting and adding the account but no luck, also tried it with another account and same problem. Every folder (Inbox, Sent, Bin, Spam and all Labels) show up but no "All Mail". 

    Anyone else had this problem?  I have version 15.0.4420.1017 64Bbit.

    Can't find the link to submit a bug also.. 

    Saturday, November 10, 2012 2:11 PM

All replies

  • Hi there, based on what you are experiencing I would say the issue is with your gmail account. Do any of your email folders show up? Do you have a folder called "Inbox"?

    Mark D. Albin IT Master Services www.itmasterservice.com (775) 229-4254

    Sunday, November 11, 2012 3:54 AM
  • The issue is not Gmail. It happens to me, too, on ALL THREE of my gmail accounts. 
    Monday, November 12, 2012 1:45 AM
  • So if it is not GMAIL then please explain what it is.


    Mark D. Albin IT Master Services www.itmasterservice.com (775) 229-4254

    Monday, November 12, 2012 2:41 AM
  • I believe that it is not GMail because I always saw this folder in Outlook 2007 and 2010, but now I do not see the folder in 2013. I do still see the folder in Outlook 2010 on another system.

    Under an IMAP Folder query I see [GMail]/All Mail listed along with all of the other folders that are available in 2013.

    I'm not sure what the problem is, but I do feel that it is Outlook not GMail.

    Wednesday, November 14, 2012 4:59 AM
  • Hi everyone,

    I'm experiencing the same issue with my two gmail accounts. All OK in outlook 2010 but in outlook 2013 the folder ALL MAIL does not appear.

    Any fix to that ?

    Thanks in advance for sharing.

    Thursday, November 15, 2012 8:44 AM
  • Hi Amar,

    Did you solve this issue ? And if yes can you explain how?

    Many thanks!

    Sunday, November 18, 2012 3:42 PM
  • +1. Same problem. "All Mail" folder shows up in Outlook 2007 but not in Outlook 2013.
    Sunday, November 18, 2012 4:57 PM
  • I was having the same problem i.e. "All Mail" was visible in Outlook 2012 but not visible after upgrade to Outlook 2013. To resolve, I "subscribed" to the folder:

    1. In the left nav folder list, click on "[Gmail]"

    2. Right click on [Gmail] .. IMAP folders

    3. Query for folders containing "All"

    4. Subscribe to "[Gmail]/All Mail"

    5. Restart Outlook 2013

    • Proposed as answer by suprsonic Thursday, January 17, 2013 11:52 PM
    Monday, November 19, 2012 3:50 PM
  • Forgot to mention one step (4a):

    1. In the left nav folder list, click on "[Gmail]"

    2. Right click on [Gmail] .. IMAP folders

    3. Query for folders containing "All"

    4. Subscribe to "[Gmail]/All Mail"

    4a. Tick the box "When displaying hierarchy in Outlook, show only subscribed folders"

    5. Restart Outlook 2013

    • Proposed as answer by Gani Thursday, November 22, 2012 7:29 AM
    Monday, November 19, 2012 8:50 PM
  • Forgot to mention one step (4a):

    1. In the left nav folder list, click on "[Gmail]"

    2. Right click on [Gmail] .. IMAP folders

    3. Query for folders containing "All"

    4. Subscribe to "[Gmail]/All Mail"

    4a. Tick the box "When displaying hierarchy in Outlook, show only subscribed folders"

    5. Restart Outlook 2013


    I tried this and it works. Thanks.
    Thursday, November 22, 2012 7:31 AM
  • thanks, this works (including using step 4a below) a>
    • Edited by ALN6 Monday, November 26, 2012 10:09 PM
    Monday, November 26, 2012 10:08 PM
  • Just ticking "only show subscribed" worked for me without restarting Outlook.
    • Proposed as answer by Paulo V Rocha Thursday, December 20, 2012 7:55 AM
    Friday, December 07, 2012 7:54 AM
  • The key to getting this to work for me was checking the checkbox for "When displaying hierarchy in Outlook, show only subscribed folders" and restarting Outlook. I tried checking the checkbox, but I didn't restart Outlook. I still didn't see the folder. I also tried subscribing and restarting Outlook with no success.  Everything worked perfectly when I followed rosswesleyporter's directions exactly as stated.

    Saturday, December 08, 2012 4:17 PM
  • Just ticking "only show subscribed" worked for me without restarting Outlook.

    Worked for me too. All that is needed is tick "only show subscribed". No need to do anything else assuming you have subscribed to all folders.

    BTW, I think this shows that this is a bug in Outlook 2013.

    In Outlook 2010, without ticking the box, all folders showed in the hierarchy (as expected).

    Issue is easily reproducible by anyone.

    Solved for now I think with the workaround above

    Thursday, December 20, 2012 7:57 AM
  • I was doing the same thing, but didn't restart outlook. Now it works fine...
    Thursday, January 24, 2013 5:59 AM
  • I also needed the Only-show-subscribed to get it to show up in the Outlook folder bar
    Sunday, February 10, 2013 3:38 PM
  • This fixed it -- thanks!

    Observe the following sequence of events:

    1. The [Gmail]/All Mail folder is missing from the Outlook hierarchy.

    2. I right-click on one of the folders in the folder list and click "IMAP Folders"

    3. I click on Subscribed -> Query, and observe that All Mail is in the list. Yet, All Mail doesn't show up in the folder hierarchy in the mail app.

    4. I check "When displaying hierarchy in Outlook, show only subscribed folders" and push OK.

    5. The "All Mail" folder pops into view like magic.

    This is definitely an Outlook bug. Why should clicking a checkbox that says it will exclude folders from the view cause folders to appear instead? Thanks to Technet, I was able to find this obscure dialog box (the first time I've found this one in my 11 years of fighting with Outlook) and work around yet another bug. They want us to pay $99/year for this?

    Sunday, February 17, 2013 6:32 PM
  • Weird - but it works! Thank you all... does clicking the box exclude any folders? I have many folder in Gmail and I think they are all there, but... any worries?
    Tuesday, July 16, 2013 11:46 AM
  • So if it is not GMAIL then please explain what it is.


    Mark D. Albin IT Master Services www.itmasterservice.com (775) 229-4254

    What was the point of you even writing on this particular thread?
    Wednesday, October 02, 2013 7:59 PM
  • After spending hours with Microsoft level II folks the only solution is that Outlook 2013 will not work effectively with IMAP - this is a real problems with this edition of office among others. The only solution I came up with was to change all my email accounts to POP - which did resolve the problem.

    Frankly I think Outlook 2013 is poorly thought out and is very difficult to use. Does anyone know if one can keep Office 2013  and replace Outlook 2013 with 2010?

    Saturday, November 09, 2013 1:27 PM
  • Forgot to mention one step (4a):

    1. In the left nav folder list, click on "[Gmail]"

    2. Right click on [Gmail] .. IMAP folders

    3. Query for folders containing "All"

    4. Subscribe to "[Gmail]/All Mail"

    4a. Tick the box "When displaying hierarchy in Outlook, show only subscribed folders"

    5. Restart Outlook 2013

    If you do this and it still doesn't work. Just manually create a folder called 'All Mail'. Right-click on the folder and click Process Marked Headers.

    Everything will work normal after that.

    Super User question


    • Edited by Jamel Thursday, November 21, 2013 4:32 AM
    • Proposed as answer by WillieQ Tuesday, December 03, 2013 4:44 AM
    Thursday, November 21, 2013 4:32 AM
  • Thank you! I tried all the other tips multiple times, including playing with the settings on Gmail. The trick of manually creating an "All Mail" folder was the only thing that finally worked. I was getting especially frustrated after all those threads from people where the "show only" trick worked.

    Clearly a bug in Office 2013. My "All Mail" folder has always displayed just fine in Outlook 2010 and on my iPhone and online.

    • Proposed as answer by KKHKY1 Thursday, December 05, 2013 7:49 PM
    Tuesday, December 03, 2013 4:47 AM
  • Thank you. It works for me.
    Tuesday, December 03, 2013 7:23 AM
  • Sweet baby Jesus with bacon, I've been through 50 threads and just your hint saved my day. Thanks!!
    Friday, December 06, 2013 10:37 AM
  • This is what did the trick for me.  Thanks a million. Now outlook just became useful to me.
    Saturday, December 07, 2013 3:08 PM
  • "I was having the same problem i.e. "All Mail" was visible in Outlook 2012 but not visible after upgrade to Outlook 2013. To resolve, I "subscribed" to the folder:

    1. In the left nav folder list, click on "[Gmail]"

    2. Right click on [Gmail] .. IMAP folders

    3. Query for folders containing "All"

    4. Subscribe to "[Gmail]/All Mail"

    5. Restart Outlook 2013"

    I can't seem to get this fix to work. All of the other folders show up just fine, but not All Mail. Is it possible that my All Mail folder is too big? I haven't seen size considerations addressed in this thread, but I wonder if that might be a factor.

    UPDATE:

    Gmail reports that I have 12,000 messages plus in "All Mail". I have confirmed in my gmail settings that

    "Do not limit the number of messages in an IMAP folder (default)" is selected.

    In my Outlook settings, I've confirmed that "Mail to keep offline: All" is selected.

    I still suspect that my message quantity could be a factor here, but the settings all look correct.

    Other ideas?

    Saturday, January 04, 2014 8:42 PM
  • I had the same probleem that this fix here didn't help me.

    But then I found this solution and it worked for me:

    manually create folder "All Mail" under Gmail folder. Tehn Right-click on it and select "Process Marked Headers" on the context menu, and the folder will populate.

    Friday, January 10, 2014 12:07 AM
  • I too confirmed that All Mail was a subscribed folder and checked the option to only display subscribed folders. That solution did not work for me. After creating a New Folder labeled All Mail and clicking Process Marked Headers the messages in the All Mail folder began to populate. hukko's solution worked for me.

    Saturday, January 11, 2014 3:18 PM
  • I found that creating an "All Mail" folder manually and then subscribing to the folder when you right click on [Gmail] populated that folder.
    Monday, January 13, 2014 3:26 AM
  • Thanks so much, this issue was driving me nuts while i'm trying to migrate about 10 users to 365.  

    Kris Wagner, MVP, MCITP, MCTS Twitter @sharepointkris Blog: http://www.sharepointkris.com/blog

    Saturday, January 18, 2014 5:44 AM
  • Your instructions of manually creating the "All Mail" folder was the only solution that worked for my 4 gmail accounts.  Thank you.
    Wednesday, January 22, 2014 6:01 PM
  • Thanks hukko! That worked for me!!
    Thursday, January 23, 2014 6:01 AM
  • I had the same probleem that this fix here didn't help me.

    But then I found this solution and it worked for me:

    manually create folder "All Mail" under Gmail folder. Tehn Right-click on it and select "Process Marked Headers" on the context menu, and the folder will populate.

    Thanks. This was the only thing that worked for me.

    Friday, January 31, 2014 2:58 AM
  • I'm curious as to why you want the All Mail folder in Outlook. It contains duplicates of the mail in other folders and I always unsubscribe it. 


    Diane Poremsky [MVP - Outlook]
    Outlook & Exchange Solutions Center
    Outlook Tips
    Subscribe to Exchange Messaging Outlook weekly newsletter

    Friday, January 31, 2014 4:27 AM
  • I'm curious as to why you want the All Mail folder in Outlook. It contains duplicates of the mail in other folders and I always unsubscribe it. 


    Diane Poremsky [MVP - Outlook]

    Because it allows you to archive a conversation without applying a label to it (like hitting the Archive button in the gmail interface).  Not sure there's any other way to do this.
    Friday, February 21, 2014 8:40 AM
  • I had the same probleem that this fix here didn't help me.

    But then I found this solution and it worked for me:

    manually create folder "All Mail" under Gmail folder. Tehn Right-click on it and select "Process Marked Headers" on the context menu, and the folder will populate.

    I have a related question about this.  I did this and it worked.  However, now I want to remove the All Mail folder in Outlook.  How do I do this?  I'm afraid if I just delete the folder, it will delete all of my mail in Gmail.  I tried renaming it in Outlook to see what would happen, but it still syncs with the All Mail folder in Gmail even with the new name.  I have "Unsubscribed" to this folder via the "IMAP Folders" right-click action, but it still syncs.  Where do I go from here?  I suppose I might be able to temporarily disable IMAP through the gmail interface, delete my IMAP account in Outlook, re-enable IMAP in Gmail, and then re-create the account in Outlook.  Any thoughts?  I really don't want to accidentally dump my entire Gmail "All Mail" folder!


    Thanks for any help.

    Friday, February 21, 2014 8:44 AM
  • Thanks for the tip. This is really the only way that it works. 

    However I had to insert the new "All Mail" folder label between the "Trash"and "Spam" labels, otherwise it will not populate when clicking on "Process Marked Headers"

    I first inserted the "All Mail" folder just below "[Gmail]" label, and it would not populate. No idea why, but putting below "Trash" works just fine.

    Friday, February 21, 2014 3:54 PM
  • Forgot to mention one step (4a):

    1. In the left nav folder list, click on "[Gmail]"

    2. Right click on [Gmail] .. IMAP folders

    3. Query for folders containing "All"

    4. Subscribe to "[Gmail]/All Mail"

    4a. Tick the box "When displaying hierarchy in Outlook, show only subscribed folders"

    5. Restart Outlook 2013


    I did this, no result, but then found: "What did work for me though is in Outlook under the Gmail folder, I created a new folder called All Mail. A couple seconds later it started filling up with all the mail I would normally see there." on another site.

    So step 6. should be "make a map/folder in Outlook" 

    That worked for me!

    Sunday, February 23, 2014 6:16 AM
  • Fantastic,  I thought I was going to be the lone issue with this after everyone was posting "IT WORKED" with the original instructions from rosswesleyporter.   The manual insertion was the trick for me as well.  Weird how it affects others differently.  Must be some conflict within the application and GMail?  I actually love 2013.  I bought it for $9.95 through a buy back program at work and being on 2007 ... this one is actually a treat.  It's my understanding that the Ballmer is more geared toward ALL Cloud and that this getting toward the end of the road for locally stored office or at least the option too.

    Thanks to either Jamal or WillieQ (I guess) or both!

    Sunday, May 25, 2014 2:10 PM
  • I'll tell you what I am curious about is why do you "MVP"s always ask questions like that?  Why not provide a solution and not worry about "why would you want to do that?"?  Not everyone has to conform to your way of daily tasks.  It's amazing how inundated these kind of forums are with comments like this.  That also goes for the other one earlier on (I realize this is an old post) that got a little SA about "well if it's not, why don't you tell me?" basically.

    Try being helpful, that would be a plus.  :D



    • Edited by Zipdrive Sunday, June 01, 2014 4:32 PM
    Sunday, May 25, 2014 2:30 PM
  • Actually just create the folder as there is a 90% chance that All Mail is already selected.  Once you create the folder and click it, they come rolling in.  Technically restarting Outlook is not necessary.   But you would want to do the IMAP option to check and make sure you are subscribed but I'm betting once you just create the folder, you're golden.
    Sunday, May 25, 2014 2:35 PM
  • So if it is not GMAIL then please explain what it is.


    Mark D. Albin IT Master Services www.itmasterservice.com (775) 229-4254

    Simply put... this comment was absolutely pointless.  Is there anyway to give negative points on this? :)
    Sunday, June 01, 2014 4:28 PM
  • Hi,

    I have tried all the solutions offered here

    Windows 7 PC with outlook 2013 

    I unscribed and then resubscribed and carried out a send and receive, and the sytem looked like to was downloading the emails - as we waited quite a while for the sync to complete.

    But no sign of a Gmail "all mail" - there are 20,000 emails in the folder, and i did select to not limit emails in any folder

    I also noticed the OST file for the account was now 1.5GB in size, so the files are there

    BUT unable to get the folder in the list ......

    any suggestions welcome - thanks 

     


    • Edited by ETAFWS Thursday, June 05, 2014 4:56 PM
    Thursday, June 05, 2014 4:56 PM
  • I have found a setting that will control if labels are displayed in outlook 2010 imap account

    If you log into you gmail account via a web browser
    > Then click on the Cog on the right hand side (settings)
    > From the menu choose "settings"
    > This will now open the settings menu options - across the page will be menu items "General" "Labels" "inbox" etc
    > Click on "Labels"
    A list of folders will now appear
    On the left will be the labels (folders) on the right will be tick boxes with "show in IMAP"

    Is the "All Mail" label check box "show in IMAP" ticked
    If not , then that is the reason its not showing up in your outlook

    At least thats the case for outlook 2010 ,

    when i'm next at my friends, I will check his outlook 2013

    Thursday, June 05, 2014 10:43 PM
  • I've tried everything on here. I now have the All Mail folder showing up and it says I have 9456 emails in it, but when I click on it, nothing shows up.  Has anybody else experienced this?
    Thursday, June 12, 2014 12:18 PM
  • I have tried everything I can think off and still no all mail folder

    The folder is selected in gmail setting

    the folder is subscribed to 

    and I have ticked the only subscribed files and made no difference 

    At a loss now as to why its not working on 2013 - 

    Wednesday, June 25, 2014 8:00 PM
  • Could be. I had over 11,000 and had to resort to the manual folder create too.
    Monday, August 11, 2014 1:33 AM
  • Brilliant! This did it. :)
    Sunday, August 17, 2014 8:50 PM
  • I'm going through a legal discovery process and need to provide a mass of emails.  I must save each individual email as a PDF  along with any attachments.  My email file is 20+ GB's.

    I'm currently using Gmail and have found that Outlook 2013 and its search functions, along with Acrobat Pro, may work the best.  I am still trying to work out a process that works and am not at a point that I know the searches are accurate.  (If there is a better way, I am open to suggestions.)

    Acrobat Pro effortlessly allows me to highlight the emails in a particular folder, like what is done to copy, then a PDF 'portfolio' is created and saved to a file.  From the portfolio, at the touch of a button, all emails will then be extracted and also saved individually as a PDF file.  (This saves a huge amount of time instead of saving each email individually.) The file name given to the email is the subject line of the email.  (At this point, I have found that attachments have to be opened up and saved individually.  I assign the same file name for each attachment as the subject line of the email but add "-att1" after it or, if more than one, attachment in the email, the number '1' goes to '2' and so on.)

    I seem to get different results with my searches.  If I am looking for email that I sent bcc "to" somebody, I have to search in both the "sent" folder and the "inbox" and I am not confident that all emails are being found.  It would be my preference to search the "All Mail" folder but , of course, it isn't visible.

    I have tried the suggestions of subscribing and, though visible in the imap querry, "All Mail" doesn't show up.  I have not tried manually creating an "All Mail" folder.  Before I do, I am wondering if someone can answer a couple questions:  

    1. If I create an "All Mail" folder, will syncing use data?  (We're in a rural area and have to use a Verizon jetpack for internet service.  We're on a 10 GB plan that is close to not being sufficient.)  2.  Because I have such a large email file (74,000 in Gmail's "All Mail" folder), will I be able to sync to Outlook, and 3.  Will syncing taking an enormous amount of time?

    I am beginning to feel that I am making progress and I don't want the system to crash or freeze because of being overloaded.

    Thanks!

     

    Sunday, August 31, 2014 6:07 AM