none
external user not able to login with lync FE HA

    Pregunta

  • Hi, My Senario, I have three lync Front-End servers (FE01,FE02,FE03)and two Edge (EG01,EG02 )servers with HA (DNS Loadbalner). My external client uable to login when My one Front Server is down (FE01). I checked all event but could find the reason why all the external request going to only one Server (FE01). Thanks, Deepak
    lunes, 06 de febrero de 2012 5:37

Respuestas

  • Hi,Deepak,

    Would you please double check that you have DNS A records with Access Edge external interface FQDN(e.g. Access.domain.com) points to  the two IP addresses of your Access Edge external interface on your external DNS server?Also make sure you have DNS SRV records sip.<sipdomain> with TLS 443 point to your Access Edge FQDN on external DNS server.

    Regards,

    Sharon


    Sharon Shen

    TechNet Community Support

    ******************************************************************************************************************************************************* Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community memb

    lunes, 13 de febrero de 2012 9:26

Todas las respuestas

  • Hi,

    Do your Edge servers point a DNS server split from internal network? Could you check whether it returns FE01, FE02 and FE03's IP addresses or only FE01's one for the FQDN of Front-end pool?

    Regards,


    Yutaka
    • Editado Yutaka, N lunes, 06 de febrero de 2012 14:54
    lunes, 06 de febrero de 2012 14:53
  • Hi,

    I have checked all DNS entries and run the nslookup with Pool name on both Edge Server and got all three Front-Ends server IP. Ping and telnet is also working fine.

    Deepak

    martes, 07 de febrero de 2012 5:24
  • Hi,

    I understand DNS configurations for Edge servers have no problem. I have no confidence to solve your issue, but please confirm the following points.

        (1) When your external clients cannot login, is FE01 network-reachable (only Lync service down)? If so, can your clients login after shutting down it?

        (2) If you use Windows Server 2008 R1 and the same internal subnet as Front-end server's subnet for Edge servers, could you configure DNS client configuration of Edge servers as the following KB says?

        Windows Vista and Windows Server 2008 DNS clients do not honor DNS round robin by default
        http://support.microsoft.com/default.aspx?scid=kb;EN-US;968920

    I understand DNS load balancing of Lync is different from DNS round robin, but the cause of your issue seems that DNS client features of Edge servers do not work as expected as in general.

    Regards,


    Yutaka


    • Editado Yutaka, N martes, 07 de febrero de 2012 16:00
    martes, 07 de febrero de 2012 15:58
  • Hi,

    1- I had checked with shut down the Front-End (FE01) but issue was same.

    2- I am using Windows Server R2.

    Thanks,

    Deepak

    miércoles, 08 de febrero de 2012 6:34
  • Hi,Deepak,

    I supposed your three Front End servers are in the same pool and you are also using DNS load balancing for them.

    Would you please check your DNS records with DNS requirements for Lync Edge and DNS requirements for Lync FE ?

    Also please check the certificate assigned to your Lync server and Edge server are following the certificate requirements.

    Regards,

    Sharon


    Sharon Shen

    TechNet Community Support

    ******************************************************************************************************************************************************* Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community memb

    miércoles, 08 de febrero de 2012 6:35
  • Hi,

    yes, I am using DNS load balacing for FE pool and Edge pool . All entries are correct in DNS . i checked HA internaly it is working fine.

    issue with external users only.

    Thanks,

    Deepak

    miércoles, 08 de febrero de 2012 9:23
  • Hi,Deepak,

    Would you please double check that you have DNS A records with Access Edge external interface FQDN(e.g. Access.domain.com) points to  the two IP addresses of your Access Edge external interface on your external DNS server?Also make sure you have DNS SRV records sip.<sipdomain> with TLS 443 point to your Access Edge FQDN on external DNS server.

    Regards,

    Sharon


    Sharon Shen

    TechNet Community Support

    ******************************************************************************************************************************************************* Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community memb

    lunes, 13 de febrero de 2012 9:26