none
Excel file on Sharepoint 2007 server opens read-only on Excel 2010 when accessed thru load balancer

    Question

  • I have this farm with the following configuration

    <Server Specs>
    Altheon Load Balancer(http://aaa)
    Web Server 1(http://<WebServer1hostname>)
     -WinServer 2003 R2
     -Sharepoint 2007 + SP1 + InfrustructureUpdate
    Web Server 2(http://<WebServer2hostname>)
     -WinServer 2003 R2
     -Sharepoint 2007 + SP1 + InfrustructureUpdate
    *Database & Index(Search) functions are on other separate server.

    When clients with the following specs access my site and
    try to open excel thru Load Balancer(http://aaa),
    the files open up as read only and cannot edit or save
    ("read only" is displayed on title bar of excel),
    however clients with same specs as below try to do same
    operation directly thru Web Server 1(http://<WebServer1hostname>) or
    Web Server 2(http://<WebServer2hostname>)
    excel file open up normally and the user can edit and save files
    wihout problems.

    <Client Specs>
    (1) WinXP + Excel 2010
    (2) Win7 + Excel 2010

    Additional info:
    - Excel file version is Excel 2003
    - Sharepoint User has sufficient privilege
    - Client OS User has administrator privilege
    - Same operation on client with winXP + excel2003 has no problem
    - All URL(load balance, WebSer1, WebSer2) are displayed as intranet in IE
    - Clients open excel files via customized context menu

    Tried these procedures to NO EFFECT:
    - Set "http://aaa" in IE Intranet Zone & Trusted site
    - Set Excel 2010 Protected mode all check box to off

    Can someone please help me with this
    im having this problem only in production
    since only there that we use a load balancer.
    dimanche 11 mars 2012 07:40

Réponses

  • Finally i figured out the cause to this problem. After having the load balancer data packet we took last week analyzed by the manufacturer and checking the http connections(using FIDDLER) being thrown by client machine to the load balancer, we found out that the problem is caused by the following:

     1) Insufficient setting in the Load Balancer

     2) Change in http method handling between Office 2003 & Office 2010

    Solution:

     Unlike Office 2003, office 2010 seems to be throwing LOCK/UNLOCK method towards the server regularly which is unfortunately NOT SUPPORTED BY DEFAULT  on our  load balancer(OS:Alteon 25.0.0.0). This blog helped me alot:

     http://hongbohe.wordpress.com/2011/05/14/share-point-protocol-support-in-alfresco-3-4-continued/

    After adding the LOCK and UNLOCK http method to the supported method list, i finally got the "read-only" problem to go away and everything is working fine now.

    Hope someone else out there find this solution helpful.

    /Yujibao


    • Marqué comme réponse Yujibao mercredi 21 mars 2012 07:22
    • Modifié Yujibao mercredi 21 mars 2012 07:23
    mercredi 21 mars 2012 07:22

Toutes les réponses

  •  

    Hi Yujibao,

    Have you ever put your document address in to your trust location after you configure load balancing? Central Administration ->SharedServices1->Excel Services Settings->Trusted file locations. Please add your document library in your it.

    Load balancing for Excel services happens between servers that run Excel services, not front end. So, Central Administration ->SharedServices1->Excel Services Settings->Edit Excel Services settings->Load Balancing, please choose “Round Robin”.

    Another things is What’s your load balancing server ?  Some Load Balancer server may be caused this. Here is an article and solution.

    http://blogs.msdn.com/b/vsofficedeveloper/archive/2008/10/03/sharepoint-cisco-css-switch-issue.aspx

    Thanks,

    Jack

    lundi 12 mars 2012 09:54
  • Hello Jack Gao

    Thank you for your reply.. really appreciate it.

    Regarding the Excel Service settings,

    After consulting with development team they informed me that the Excel files (ver.2003) created in farm does not use/utilize MOSS Excel Services,  instead those files were created thru a customized program using Server-side Excel automation and then saved in a document library.

    I looked into the settings you mentioned and found out there is no URL added in the Trusted Files Locations and Load balanacing is not set to Round robbin.

    This issue happens only in production so my hands are somewhat tied and cannot immediately test your suggestions; but based on the info above do you think i should test the method you suggested  anyway?

    Regarding the Load Balancer settings, 

    I checked the link you posted and forwarded to our network team. Im waiting for their reply. Although we use a different type of Hardware (not CISCO) we are checking if the setting in the link you provided is applicable to our case.

      We are using: Alteon Nortel Application Switch 2208

    Thank you for your time and if you have other suggestions i will really appreciate it.

    /Yujibao


    • Modifié Yujibao mardi 13 mars 2012 06:19
    mardi 13 mars 2012 05:34
  •  

    Hi Yujibao,

    After my search, this this may be the OWSSUPP.DLL problem. By default it lives at C:\Program Files\Microsoft Office\Office12\OWSSUPP.DLL This is the DLL that should be used with MOSS and WSS. So, here is a blog, you can refer to it.

    http://justgeeks.blogspot.com/2008/12/excel-spreadsheet-is-read-only-after.html

    Thanks,

    Jack

    jeudi 15 mars 2012 10:34
  • Jack,

    Thanks for your reply.

    After reading the contents of the blog i checked the office version installed in the client machine having this problem and found out that ONLY Office 2010 is installed and no other older version. Therefore the method in your link doesnt apply in my case i think.

    An update on my case,

    We decided to perform data packet capture on the load balancer and sent the logs to the manufacturer they then got back to us saying they found out that LOCK request for Excel files coming from Win7+Excel 2010 machine thru load balancer (http://aaa) are not recognized and an error 501 not supported is generated (normally there would be "OK" -> "UNLOCK")

    They suggested a couple of configuration tweaks on the load balancer side and we are looking into testing it this weekend or next week (not sure if it will work)

    I will update this thread after we complete testing.

    thanks for your time and again would appreciate some more suggestions

    /Yujibao

    • Marqué comme réponse Yujibao mercredi 21 mars 2012 07:22
    • Non marqué comme réponse Yujibao mercredi 21 mars 2012 07:31
    vendredi 16 mars 2012 03:56
  • Finally i figured out the cause to this problem. After having the load balancer data packet we took last week analyzed by the manufacturer and checking the http connections(using FIDDLER) being thrown by client machine to the load balancer, we found out that the problem is caused by the following:

     1) Insufficient setting in the Load Balancer

     2) Change in http method handling between Office 2003 & Office 2010

    Solution:

     Unlike Office 2003, office 2010 seems to be throwing LOCK/UNLOCK method towards the server regularly which is unfortunately NOT SUPPORTED BY DEFAULT  on our  load balancer(OS:Alteon 25.0.0.0). This blog helped me alot:

     http://hongbohe.wordpress.com/2011/05/14/share-point-protocol-support-in-alfresco-3-4-continued/

    After adding the LOCK and UNLOCK http method to the supported method list, i finally got the "read-only" problem to go away and everything is working fine now.

    Hope someone else out there find this solution helpful.

    /Yujibao


    • Marqué comme réponse Yujibao mercredi 21 mars 2012 07:22
    • Modifié Yujibao mercredi 21 mars 2012 07:23
    mercredi 21 mars 2012 07:22