locked
Process cannot access blob cache file

    Pertanyaan

  • We frequently get the following error on our SharePoint 2007 web front end. It is runninig on 64 bit Windows Server 2003. We only have one applicaiton pool using the blob cache. How do I resolved this error?

    NT Event Log : Office SharePoint Server An error occured in the blob cache.  The exception message was 'The process cannot access the file 'x:\blobCache\1811074914\flushcount.bin' because it is being used by another process.'.

    01 September 2011 16:33

Jawaban

  • We determined that the blob cache was not a good fit for our environment because our sites are all collaborative and have frequent changes. Rather than a bug, I suspect this error may have occurred when the files were locked during updates to the cache caused by changes to resources in the databases that were being cached. We noticed the errors coincided with the site becoming unresponsive for several seconds as requests queued while the cache updated. Once the update completed the site processed the queued requests and return to normal performance levels.  Stefan Goßner made reference to this issue in this blog post:

    http://blogs.technet.com/b/stefan_gossner/archive/2010/10/08/blob-caching-be-careful-when-flushing-the-cache.aspx

    He was quoting this TechNet article on planning for caching and performance.

    http://technet.microsoft.com/en-us/library/ee424404.aspx

    His post and the article are targeted at 2010 but, in our experience, the information is also applicable to 2007.

    • Ditandai sebagai Jawaban oleh mbuckingham 17 Februari 2012 15:49
    17 Februari 2012 15:49

Semua Balasan

  • Hi mbuckingham,

     

    Was this error Event ID 5538?

    You can patch the August 2009 CU for your SharePoint and check again, there is an article with similar issue, you can check.

    http://mysharepointofview.com/2010/01/an-error-occured-in-the-blob-cache-event-id-5538/

     

    Thanks


    Regards, Daniel
    • Ditandai sebagai Jawaban oleh mbuckingham 06 September 2011 14:22
    • Tanda sebagai Jawaban dihapus oleh Mike Walsh FIN 07 September 2011 15:02
    06 September 2011 9:07
  • I installed the August 2011 cumulative update on our servers last night. This morning we are still getting teh error message all though much less frequently.

    NT Event Log : Office SharePoint Server An error occured in the blob cache.  The exception message was 'The process cannot access the file 'x:\blobCache\1811074914\flushcount.bin' because it is being used by another process.'.

    Any suggestions?

    07 September 2011 14:40
  • Hi mbuckingham,

    After installing the CU, you need to run the SharePoint Configuration Wizard, then check again.

    Thanks 


    Regards, Daniel
    08 September 2011 12:25
  • Yes. I installed the WSS update, ran the configuration wizard to apply the update then installed the MOSS update and ran the configurtion wizard to install that update. All completely successfully and the farms show the appropriate version number, 12.0.0.6565. However, we still get the error message a few times a day.

     

    Event Type: Error
    Event Source: Office SharePoint Server
    Event Category: Publishing Cache
    Event ID: 5538
    Date:  9/7/2011
    Time:  8:50:10 PM
    User:  N/A
    Computer: JAXMOSSPRD1
    Description:
    An error occured in the blob cache.  The exception message was 'The process cannot access the file 'x:\blobCache\1811074914\flushcount.bin' because it is being used by another process.'.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    08 September 2011 12:47
  • HI,

    After the wizard have you rebooted your server? If not then proceed to do so.

     


    Thanks, Rahul Rashu
    09 September 2011 2:11
  • After I ran the installer for each cumulative update I was prompted to reboot and did a reboot before running the configuration wizard. So the process went like this.

    Install WSS CU

    Reboot

    Run Configuration Wizard

    Install MOSS CU

    Reboot

    Run Configuration Wizard

    I don't mind rebooting again after hours tonight. Do you normally need to do that after running the configuration wizard?

    09 September 2011 14:21
  • Hi,

    Yes we do that.

    So please proceed and do let us know the results.

     


    Thanks, Rahul Rashu
    09 September 2011 15:15
  • We determined that the blob cache was not a good fit for our environment because our sites are all collaborative and have frequent changes. Rather than a bug, I suspect this error may have occurred when the files were locked during updates to the cache caused by changes to resources in the databases that were being cached. We noticed the errors coincided with the site becoming unresponsive for several seconds as requests queued while the cache updated. Once the update completed the site processed the queued requests and return to normal performance levels.  Stefan Goßner made reference to this issue in this blog post:

    http://blogs.technet.com/b/stefan_gossner/archive/2010/10/08/blob-caching-be-careful-when-flushing-the-cache.aspx

    He was quoting this TechNet article on planning for caching and performance.

    http://technet.microsoft.com/en-us/library/ee424404.aspx

    His post and the article are targeted at 2010 but, in our experience, the information is also applicable to 2007.

    • Ditandai sebagai Jawaban oleh mbuckingham 17 Februari 2012 15:49
    17 Februari 2012 15:49