none
BUG - Outlook 2010 'send as' permissions - Workaround within

    Pertanyaan

  • issue : when a user attempts to 'send as' another mailbox, the email fails with Undeliverable message: "You can't send a message on behalf of this user unless you have permission to do so. Please make sure you're sending on behalf of the correct sender, or request the necessary permission. If the problem continues, please contact your helpdesk ".

    This error only occurs once the email address has been cached (ie: 2nd attempt to 'send as' a user). Permissions are correct as 'send as' worked fine when using outlook 2007. upgrading a client to outlook 2010 results in the above error.

     

    scope : outlook 2010 clients with exchange 2007/2010 (appears to be client related, not exchange server). windows updates as of 22-dec-2010 have not resolved this.


    workaround : Cached Exchange Mode is ENABLED. Disabling this and restarting outlook resolves this issue. (Outlook 2010 > File > Account settings > Account settings... > double click the default account on the 'EMAIL' tab > untick 'used cached exchange mode'.)

     

     

    i hope this helps other people; i've been googling for a resolution to this issue since beta/RC. now i've got office 2010 RTM the issue was still present. no forums/blogs could shed light on this issue.

    Is this the correct way to report bugs, or is there another way? i've tried connect.microsoft.com, but theres no "accepting bugs" for the outlook/office suite.

    • Diedit oleh Veehexx 22 Desember 2010 10:40 formatting
    22 Desember 2010 10:38

Jawaban

Semua Balasan

  • Hi,

     

     

    You can refer to the totallytonto’s recommends in the “SEND AS Permissions problem”  article.

     

    http://www.experts-exchange.com/Networking/Protocols/Application_Protocols/Email/SMTP/Q_26241145.html

     

    Sincerely,

     

    Harry 

    • Ditandai sebagai Jawaban oleh Harry Yuan 27 Desember 2010 9:16
    24 Desember 2010 6:47
  • Someone should post a answer and not a link to a extort money site
    13 April 2012 23:16
  • Nothing particularly useful in that thread either:

    by: busbarPosted on 2010-06-07 at 08:12:05ID: 32933664

    1) looks like you have an issue with the DC plesae check it
    2) restart the information store and system attendant to speed it.
    3) send as is managed using send as permissions in the EMC http://technet.microsoft.com/en-us/library/bb676368.aspx

     

    by: totallytontoPosted on 2010-06-07 at 08:45:34ID: 32934043

    dont amend the settings in active directory for exchange 2010 servers. use the exchange management console> recipient config>mailbox and use 'manage send as permission' in the right pane.

     

    by: coderccPosted on 2010-06-07 at 19:00:23ID: 32938614

    Or bypass it all with a 3rd party app: http;//www.servolutions.com/changesender.htm

     

    by: ExchisaPosted on 2010-06-08 at 01:20:07ID: 32940097

    SatyaPathak: :

    I already tick the checkbox to inherit all the permissions from the parent , now for those who

    are members of any protected group , this check box keep un-ticked  again every 15 min ,

    active directory keep synchronize these permissions with adminsdholder .

    anyway my problem are still open , hope it solved .

    wait something


     

    by: totallytontoPosted on 2010-06-08 at 04:28:40ID: 32940992

    Hi Exchisa,

    Many, many apologies, as I mis-read your query and missed the vital bit of info (serves me right for reading it on my mobile...)

    I'm afraid you are a bit stuck. Members of the protected groups are automatically reset to the approved permissions at regular intervals as a security measure.

    I'm afraid you are not going to be able to use the 'send as' facility on any member of such a group.
    Either move the user to another group or change the e-mail address to suit your needs.

    EG:

    Lets say you want to 'send as' administrator:-
    a) change the administrator's email from {administrator@domain.com}to {administrator2@domain.com} and disable automatic recipient policy updates for the user.
    b) Create a distribution group for {administrator@domain.com}and set administrator as a member so they receive messages as they would have before.
    c) set the send as permissions on the distribution group {administrator@domain.com}to allow users to send as, including the administrator user.

    This is technically a workaround, not a solution.

     

    by: ExchisaPosted on 2010-06-21 at 08:07:03ID: 33037008

    Dear All .

    I still stuck to have this feature working perfectly .

    Now I don't want to use this feature to enable users to send as by each other , i only want the users on any given group to send by the name of this group , i did not configure any thing in the ADUC snap in , i only configure this feature from the EMC .

    i recieve this error from outlook 2010 :

    You can't send a message on behalf of this user unless you have permission to do so. Please make sure you're sending on behalf of the correct sender, or request the necessary permission. If the problem continues, please contact your helpdesk.

    I surprised that this feature are working sometimes and sometimes not (this is the truth).

    does this feature need a CAL like archiving ??

    Wait a reply  

     

    by: totallytontoPosted on 2010-06-21 at 08:39:56ID: 33037354

    No you do not need a CAL for this.
    Is the mailbox that you are sending as still a member of a protected group in AD?
    If yes, send as permissions will be reset at random intervals and cannot be changed as long as the user is a member of the protected group.

     

    by: ExchisaPosted on 2010-06-22 at 01:43:00ID: 33043673

    totallytonto:

    No It's NOT .

    Thanks

     

    by: ExchisaPosted on 2010-07-25 at 15:37:57ID: 33285888

    totallytonto : I leave configure this from the EMC , instead , i use the ACL for that group in AD , in order to enable SEND AS , just tick the send as permission  

    22 Mei 2012 2:43
  • had the same issue with Outlook 2013. OWA worked OK, but Outlook had this issue (tested on Outlook 2010 and 2013 on different machines).

    switching off cached mode solved the problem although working offline is impossible now

    01 Nopember 2013 13:52
  • had the same problem, took me two hours to solve!

    You Can leave Exchange Cached Mode ON!

    Only disable OAB caching by adding next KEY to registry: 

    Key: HKEY_CURRENT_USER\Software\Microsoft\Office\<version>\Outlook\Cached Mode
    Value name: DownloadOAB
    Value type: REG_DWORD
    Value: 0


    04 April 2014 10:39