none
Missing Form Library Filter Fields in Web Part Page

    Domanda

  • Hi,

    I've created a Web Part Page in SP Designer where one of the web parts connects via DataFormWebPart to a Form Library.  When I turn on filtering through the Data View Properties, the only field the filter will show is the Title field.  The other fields do not show up.  Some of the other fields are propogated via InfoPath form and some are custom columns that I defined in the Form Library.  Does anyone know how to add fields to filter on to the Filter menu?

    Thanks!

    giovedì 8 marzo 2012 20:21

Risposte

Tutte le risposte

  • Hi kwoodruff,

    I tried to reproduce your issue, but it worked well in my environment.

    Could you provide more information (e.g. Form Library columns type) and the steps of creating Data View Webpart you used ?

    I would suggest you delete this issue DataFormWebPart, re-create it and check result again, here is an article about creating Data View Webpart,

    https://www.nothingbutsharepoint.com/sites/eusp/Pages/data-view-web-part-the-basics-insert-a-dvwp-on-your-page.aspx

    Thanks


    Daniel Yang

    TechNet Community Support

    martedì 13 marzo 2012 08:01
  • Hi Daniel,

    Thank you for your reply.

    Here are the basic steps:
    1. InfoPath form promotes form fields to SP Form Library (i.e. Start Date, Count, etc.)
    2. Create a web part page in SP.
    3. Open the web part page in SP Designer.
    4. Add a DataFormWebPart to one of the web parts on the page.
    5. Connect the DataFormWebPart to the SP Form Library in #1.
    6. Add some of the promoted fields and custom columns to the DataFormWebPart.
    7. Enable the filter options on the DataFormWebPart.

    After I do all these steps, the only column available with the filter options is "Title".  None of the other columns (promoted or custom) are options to filter on.


    FYI, I'm using InfoPath 2010 on SP 2007, so Compatibility is "Web Browser Form (InfoPath 2007)".  We're upgrading to SP 2010 in this summer.  I noticed in InfoPath 2010 (Web Browser Form), that there are 2 ways to promote fields to SP 2010, "fields as columns in SP sites" and "fields as SP Web Part connection parameters".  Could the problem be that I'm trying to do something that is not available in SP 2007?
    • Modificato kwoodruff lunedì 19 marzo 2012 19:26 additional info
    lunedì 19 marzo 2012 19:18