none
Excel Macro is disabled (it is ghosted)

모든 응답

  • Hi

    What version of XL are you using.

    If it's Excel Startup,you can't use macro.

    You need to upgrade to a full version

    Cimjet


    Cimjet

    2012년 5월 22일 화요일 오후 7:53
  • It is Microsoft office porfesssional plus 2007. And I have the same image on different computers that do not have the same issue.
    • 편집됨 butheman 2012년 5월 24일 목요일 오후 4:56
    2012년 5월 24일 목요일 오후 4:55
  • Hi,

    Try to use registry to set the security level of macro settings:

    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Excel\Security\VBAWarnings

    Macro security level (DWORD): 1 (0x00000001)=low (enable all macros), 2 (0x00000002)=medium (warn user), 3 (0x00000003)=high

    Jaynet Zhang

    TechNet Community Support

    2012년 5월 28일 월요일 오전 1:57
  • Hi,

    Thanks for your feedback, I have set it to Macro security level (DWORD): 1 (0x00000001)=low (enable all macros) and rebooted, but no luck in getting this resolved.


    abu hussien

    2012년 6월 6일 수요일 오후 12:24
  • Hi,<o:p></o:p>

    I'd like to know whether you are now alone in your home using the Excel 2007 or you are working in your company in an Enterprise environment?<o:p></o:p>

    Generally, these options could be disabled by group policy settings controlled by your domain admins, if so, you could hardly to make a change without permission from them.<o:p></o:p>

    If you are now home alone, try to check your group policy settings. Typing GPEDIT.MSC in the Run box. Navigate to<o:p></o:p>

    User Configuration/Administrative Templates/Microsoft Excel 2007/Excel Options/Security/Trust Center/Trusted Locations/VBA Macro Notification Settings Enabled

    Disable this setting if it is enabled.<o:p></o:p>

    You may need to use the gpupdate /force command to have this change to take effect.<o:p></o:p>



    Jaynet Zhang

    TechNet Community Support

    2012년 6월 7일 목요일 오전 1:25
  • Hi Yaynet,

    I work for a company on an Enterprise environment. What does not make any sense is that, I have a few computer with the same operation system, the same model and the same image. All the other PC's do not have the same problem with the excel macro's. Just this one PC. And also when I type GPEDIT.MSC in the run box, and navigate to where you suggested, I see up to  Administrative Templates, but there is no microsoft Excel 2007.


    abu hussien

    2012년 6월 7일 목요일 오후 5:05
  • Hi,

    It is my fault, the correct path is that:

    User Configuration/Administrative Templates/Classic Administrative Templates (ADM)/Microsoft Excel 2007/Excel Options/Security/Trust Center/Trusted Locations/


    Jaynet Zhang

    TechNet Community Support

    2012년 6월 11일 월요일 오전 1:50