none
Outlook 2010 SP1 - mailto link fails when forwarding an email to someone?

    Pergunta

  • This works fine in OWA so it is a client Outlook 2010 SP1 problem.  To recreate it perform the following:

    1. Email yourself from an EXTERNAL email address

    2. Within Outlook forward that email to another person in your environment internally (your external email address shows in the body of the email as mailto: you@email.com)

    3. When the person receives the email get them to click on the mailto: you@email.com link in the body.  Outlook will not put the email address in the TO field as expected, but will put the whole link in - ie the TO box will show [mailto:you@email.com].  If you click send it fails as this isnt a proper email address.  It will auto resolve eventually in Outlook if you have the external email address as a contact, so remove any cached entries for your external email address before performing the test

    4. If you do the same using OWA it works OK

    Is this a bug that has been fixed?  The same problem is listed on Experts Exchange here:

    http://www.experts-exchange.com/Software/Office_Productivity/Groupware/Outlook/Q_27546150.html

    domingo, 1 de abril de 2012 21:27

Respostas

  • Install MS hotfix http://support.microsoft.com/kb/2597052

    Workaround: pressing Ctrl + K you can double click the resolved address and see what the email type is. If its set to MAILTO it will not work. You can however press the internet type button and it will change it to SMTP (which will allow it to send).

     

    Stay Hungry, Stay Foolish

    segunda-feira, 2 de abril de 2012 01:33

Todas as Respostas

  • Install MS hotfix http://support.microsoft.com/kb/2597052

    Workaround: pressing Ctrl + K you can double click the resolved address and see what the email type is. If its set to MAILTO it will not work. You can however press the internet type button and it will change it to SMTP (which will allow it to send).

     

    Stay Hungry, Stay Foolish

    segunda-feira, 2 de abril de 2012 01:33
  • Thanks.  The hotfix you linked to is for Word 2010?  Does this work for Outlook 2010 too as Outlook hooks into Word or something similar?
    segunda-feira, 2 de abril de 2012 02:47
  • Hi,

    Outlook treat Word as default mail editor. You can try the hotfix mentioned by SoulForJ.

    Best regards,


    Rex Zhang

    TechNet Community Support

    sexta-feira, 6 de abril de 2012 03:25
  • Hello,

    Did you get any solution for this?

    sexta-feira, 6 de abril de 2012 11:43
  • You can also, in Outlook, go to Options > Mail > Spelling and Autocorrect > Proofing > AutoCorrect Options > AutoFormat, and uncheck the box under Replace labelled Internet and network paths with hyperlinks. That makes it so the email address in the forwarded email is not a clickable link.

    -Peter

    sexta-feira, 6 de abril de 2012 23:05
  • Tried that fix and it did nothing to resolve the issue.
    segunda-feira, 24 de março de 2014 15:00