none
A Microsoft SharePoint Foundation compatible application could not be found

    Question

  • Hi,

    I created two Excel Reports and saved them in a SharePoint 2010 folder (with the help of Andrew Lavinsky).

    But when I try to edit them in Excel, I get the message:

    "Message from webpage: The document could not be opened for editing".

    A Microsoft SharePoint Foundation compatible application could not be found to edit the document".

    How can I fix this issue?

    Thanks for your help.

    Wednesday, April 06, 2011 3:47 PM

Answers

  • My user attempted two things and now his problem is resolved.  Don't know if it was a combination of both or just the second action.

    1.  Performed steps outlined in this KB Article:  http://support.microsoft.com/kb/833714

    2.  Then had user enable Add Ons in Internet Explorer

    1.                   Go to Tools in IE

    2.                   Click on Internet Options

    3.                   Click on Programs at the top

    4.                   Click on “Manage add-ons” near the bottom

    5.                   Click on Publisher, so you can see all of Microsoft Corporation together

    6.                   Scroll to SharePoint names (May be one or several)

    7.                   Make sure they are all enabled by clicking on the name; the Enable button is towards the bottom.

    8.                   Then click OK and OK and restart IE


    Jason J. Jones
    Wednesday, August 17, 2011 3:42 PM

All replies

  • Hi,

    I assume you do have Office installed?  this is normally a message indicating that Internet Explorer cannot launch the local instance of Excel for some reason.

    Perhaps make sure your PWA is configured as a trusted site (with the Low security settings applied on the Trusted Site zone).  Also try a repair\reinstall of your Office installation.


    http://blogs.umtsa.co.za/nicoo
    Wednesday, April 06, 2011 7:52 PM
  • Hi Nico,

    I just have Excel 2010 installed. Not all the Office 2010 suite.

    I set the security level to low : I'm able to open the Excel Reports in the PWA interface, but I still have the same error when I try to edit them in Excel.

    Any idea?

    Thanks

     


    Wednesday, April 06, 2011 8:08 PM
  • hmm...can you perhaps do a full install of Office?  I have not yet tested out if Excel alone will work with SharePoint like this....

    for one, I think you need to install the SharePoint support option for Office, which is not part of the Excel tree in the setup page (not sure now where it is in the tree, i think its under Office Tools).


    http://blogs.umtsa.co.za/nicoo
    Thursday, April 07, 2011 6:45 AM
  • I Nico,

    I installed the SharePoint support which is in the Office tools. But nothing changed: I still have the same error.

    One more information: when I click "Open in Excel" while the Excel Report in displayed in the PWA interface, I get another message:

    "To open this workbook, your computer must have a version of Micosoft Excel installed and your Web browser must support opening files directly from Excel in the browser"

     

    • Proposed as answer by Roshan_X Tuesday, March 06, 2012 10:55 AM
    Thursday, April 07, 2011 8:29 AM
  • Did you manage to solve the issue?
    Saturday, April 30, 2011 4:44 PM
  • Hi Richard,

    No, I still have the issue :-(

    Saturday, April 30, 2011 5:11 PM
  • Your not running into the url size limit are you?

    Check out http://technet.microsoft.com/en-us/library/ff919564.aspx That error message will pop up if you have some very long strings, I noticed you said the magic folder word, so you might be nudging it.


    Alex Burton
    www.epmsource.com | Twitter
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page
    Wednesday, May 04, 2011 12:09 PM
    Moderator
  • WLID::

    Have you enabled ActiveX for your trusted sites zone. PWA uses an ActiveX object to launch Office Apps.


    Gary Chefetz, MCITP, MCP, MVP msProjectExperts
    Project and Project ServerFAQs
    Project Server Help BLOG
    Wednesday, May 18, 2011 2:56 PM
    Moderator
  • Gary:

    Yes, I enabled ActiveX for my trusted sites zone... with no avail.

    • Proposed as answer by Jason J. Jones Wednesday, August 17, 2011 3:36 PM
    • Unproposed as answer by Jason J. Jones Wednesday, August 17, 2011 3:36 PM
    Monday, May 30, 2011 12:38 PM
  • My user attempted two things and now his problem is resolved.  Don't know if it was a combination of both or just the second action.

    1.  Performed steps outlined in this KB Article:  http://support.microsoft.com/kb/833714

    2.  Then had user enable Add Ons in Internet Explorer

    1.                   Go to Tools in IE

    2.                   Click on Internet Options

    3.                   Click on Programs at the top

    4.                   Click on “Manage add-ons” near the bottom

    5.                   Click on Publisher, so you can see all of Microsoft Corporation together

    6.                   Scroll to SharePoint names (May be one or several)

    7.                   Make sure they are all enabled by clicking on the name; the Enable button is towards the bottom.

    8.                   Then click OK and OK and restart IE


    Jason J. Jones
    Wednesday, August 17, 2011 3:42 PM
  • Try updating your internet explorer.

    Thursday, December 01, 2011 6:28 PM
  • HI all,

    I had the same issue. One of my user had a issue with windows 7 and office 2010 sp1 he had full installation of office but the plug-ins were not installed, tried to register the dlls manually, re-install tools > share point components,  Installed office service packs. But could not resolved. 

    Finally i removed all office components office + Visio + Project then > restart and re-installed the office 2010, then it start to work.

    -roshan


    -roshan

    • Proposed as answer by Roshan_X Tuesday, March 06, 2012 11:03 AM
    Tuesday, March 06, 2012 10:55 AM
  • Had the same Issue, loste 2 days verifying installation of Office component,

    was using IE 64bits. and I had Office 32bits installed !!!

    Using IE 32bits ==> work as a charm

    Hope this could help

    Zediude

    • Proposed as answer by Chamil Udayanga Thursday, November 08, 2012 12:27 PM
    Wednesday, May 16, 2012 1:53 PM
  • Had the same Issue.

    Was using IE 64 bits and Excel 2010 64 bit (alone with Office Tools for Sharepoint) but doesn't work.

    I tried with IE 32 bit and Excel 2010 64 bit and works fine.

    I think the problem reside in IE 64 bit features.

    Hope could Help

    Alessandro

    Tuesday, July 03, 2012 9:38 AM
  • We have SharePoint 2010 enterprise on premise and Office 2010 prof plus 32bit(complete install), win7 ent 64bit. All latest versions.

    I have the same error;

    in Dutch: "Er is geen Microsoft SharePoint Foundation compatibele toepassing gevonden waarmee het document kan worden bewerkt"

    In English: "A Microsoft SharePoint Foundation compatible application could not be found"

    When I try to open/edit a Microsoft Word(docx) of Excel(xlsx) document in SharePoint.

    I checked IE 64 and 32 bit, but both don't have the mentioned plugins listed.

    After reinstall Office 2010 completely I saw an option for SharePoint(see screenshot below), but it didn't make any difference.

    Question is; How do you get these plugins?

    Office 2010 prof plus installation option for SharePoint Foundation support Dutch

    Wednesday, September 05, 2012 9:53 AM
  • I confirmed that this problem exists when attempting to use IE 64 bit.  If I switch to IE 32 bit, it works fine.  Just as an FYI to those who are having trouble trying to 'repair' Office or those who are looking for illusive plugins.
    Wednesday, September 12, 2012 8:46 PM
  • Your answer is very helpful Jason. Thank you very much.
    Friday, October 12, 2012 5:58 AM
  • I am running Windows 8 x64 and Office 2013. I checked the Add-ons in IE 10 and they were all enabled.

    I could not understand why I had a problem because I was able to edit documents on my other laptop with the same specs and also when running a Windows 7 x64 VM with Office 2010 on the laptop with the above problem.

    The good news is that running an Office 2013 Repair fixed the problem.

    Jason, thanks for posting your solution. I think it may help several of my students as they often have browser issues with Publishers' online homework sites.

    Saturday, November 17, 2012 8:19 PM
  • Thanks for posting about looking at Add-Ons.  Had to select "Show:  All add-ons" to see the screen pictured, though.  My document I had this issue with was an Excel document and I had SharepointOpenXMLDocuments, not SharepointOpenDocumentsClass like pictured, but I disabled and re-enabled it, and the problem went away - at least I was able to click on and open my checked-out Excel document, finally, anyway.  Thanks!
    • Edited by navyjax2 Tuesday, November 20, 2012 7:11 PM
    • Proposed as answer by navyjax2 Tuesday, November 20, 2012 7:11 PM
    Tuesday, November 20, 2012 7:10 PM
  • Internet Explorer x64 is currently not an optimal approach since many Microsoft- and thirst-party ActiveX objects still do not support 64 bits. Office 2007/2010 does not ship 64-Bit controls for SharePoint integration, such as single document upload or multiple document upload, or "Connect to Outlook", "Open in Explorer View" and many more. Considering these limitations you may want to use the 32 bit version of Internet Explorer for the future to take benefit of the SharePoint integration features.

    The required component / add-ons are simply missing for IE x64 and therefore causing several features not to function, being greyed-out or generate an [error] message once requested, such as "Message from webpage: The document could not be opened for editing".. The Plan Browser Support page (http://technet.microsoft.com/en-us/library/cc263526.aspx ) will show you in more detail.

    • Proposed as answer by Brokobana Thursday, January 10, 2013 8:37 AM
    • Unproposed as answer by Brokobana Thursday, January 10, 2013 8:37 AM
    • Proposed as answer by Brokobana Thursday, January 10, 2013 8:39 AM
    • Unproposed as answer by Brokobana Thursday, January 10, 2013 8:39 AM
    • Proposed as answer by Darryl in Oz Wednesday, February 06, 2013 2:37 AM
    Friday, November 23, 2012 2:39 PM
  • Hi!

     

    same issue here :(

     

    my envirement: Office365 SharePoint + Windows 8 Pro x64 + Office 2013 x64 + the file path is 150 chars long
     + the SharePoint addons are enabled in IE.
    Any news on this issue?

    Wednesday, December 05, 2012 11:44 AM
  • Hi Buds


    Willem

    Thursday, January 10, 2013 7:32 AM
  • Yes agreed.  You need to use IE 32 bit.  IE 64 bit will return this error.  Works perfectly fine using IE 32 Bit.  You should already have 32 Bit IE available on your Windows 7 64 Bit PC - have a look under programs and should be able to see 2 versions of IE in the list (one with a 64 bit post fix and one plain one - the plain one is the 32 bit version).

    Give it a try.
    Wednesday, February 06, 2013 2:40 AM
  • My user was getting error when trying to click on Excel Web Part and "Open in Excel"

    "To open this workbook, your computer must have a version of Microsoft Excel installed and your Web browser must support opening files directly from Excel in the browser."

    Checked the Add-ons first and noticed most were not even installed.

    Ran the MS Office Repair and after repair was complete, issue disappeared completely

    Wednesday, April 10, 2013 9:10 PM
  • I've also problem similar problem.

    Windows 7 x64, Office 2010 32bits, Lync, IE 32bits 10 = works with Office 365. After I installed Visio 2013 32bits I cant open SharePoint documents in Excel/Word. When I click open in Excel/Word I got msg 'page unavailable'. I found out that Visio bring SharepointOpenDocumentsClas version 15. So, from appwiz I repaired Office 2010. Now SharePointOpenDocs add-on is versioned as 14 but it still doesn't work.

    I use only IE32bits, previously v10 than I downdgrade to 9 - with no effects.


    br kyrik

    Thursday, April 11, 2013 12:06 PM
  • still same issue :(
    Tuesday, April 30, 2013 3:44 PM
  • Win 7, ie9 32bit, office 2010 32bit, lync basic 2013, office 365 small business

    If I remove lync 2013 and repair office 2010 it works

    if lync 2013 installed it don't,

    I need to find a way to remove sharepoint foundation support out of lync basic 2013 so it runs with office 2010,

    Any ideas as lync basic 2013 does not come with add/remove features like the full client install

    thanks

    Monday, May 13, 2013 3:29 AM
  • Open "Manage Addons" from IE go to "Sharepoint open document class", right click on it and select "more information" then click "Allow on all sites" button.
    Friday, June 07, 2013 4:00 PM
  • Thanks a lot for the "Addon" solution. I disabled and enabled SharePoint related addons and now it started to work.
    Monday, July 15, 2013 10:21 AM
  • Issue has been resolved by installing jre Latest version.

    Regards,

    Nishant Chhokar

    +919999006432

    Wednesday, July 31, 2013 11:25 AM
  • Wrong. I just re-installed the newest Java RE (7 update 25) from the Oracle site, and rebooted. Still getting the same error. Running 64-bit Windows 7, 32-bit IE 10, 32-bit Office 2010, SharePoint 2010. The spreadsheet opens properly on other computers here, so I figure it's not a URL length problem. Tried disabling and re-enabling the SharePoint OpenDocumentClass and OpenXMLDocuments, and selecting "allow on all sites" for both of them. Ran a full repair of Office and rebooted. Still no luck.

    Am I the only one who finds it a bit outrageous that a Microsoft product running on a Microsoft platform, calling another Microsoft product fails, and we accept that the way to deal with the problem is "hey, try this" "hey, try that" "hey, didja try this other thing?" As though you can't really expect Microsoft to provide predictably functional products, or useful error messages.


    tom

    Thursday, August 22, 2013 7:39 PM
  • It's definitely frustrating Tom.   I'm experiencing the same issue.   I tried most of these ideas but within the managed add ons (show all add ons) there aren't any sharepoint options to choose from

    Interestingly,  I was successful in opening the spreadsheet using Firefox. 

    More assistance needed please... 

    Saturday, August 24, 2013 2:47 AM
  • Just FYI - there's an issue with non-American users of Office 2013 and SharePoint 2010:

    SharePoint 2010 and Office 2013 Can't edit documents
    http://social.msdn.microsoft.com/Forums/sharepoint/en-US/31c6d108-e94d-41a1-99a9-570b3880eb33/sharepoint-2010-and-office-2013-cant-edit-documents

    Description of the Office 2013 hotfix package (Owssupp-x-none.msp): June 11, 2013
    http://support.microsoft.com/kb/2726997

    • Proposed as answer by Kamil Tatar Thursday, February 06, 2014 8:50 AM
    Friday, September 06, 2013 6:30 AM
  • No, I still have the issue :-(

    Dear All, 

    I am working on Sharepoint Foundation 2010 on Windows 7 64-bit; 
    I have a Sharepoint site with document library. 
    upload Microsoft word documents, when I select one of them and click on "Edit in Microsoft Word" then I got an ERROR 
    "The document could not be opened for editing. A Microsoft SharePoint Foundation compatible application could not be found to edit the document. " 
    I have already installed MS Office Professional Plus 2010 64-bit on my machine.. 

    Please let me know what is the problem and how to resolve this... 
    I am waiting your valuable reply. 

    Thanks & Regards

    Tuesday, November 12, 2013 6:36 PM
  • This problem may apear using Internet Explorer x64, because required functionality may still be not avaliable for IE x64.

    Try IE x86.

    Also try repairing your MS office.

    Here is a refence to a article I found usefull troubleshooting this issue.

    http://sharepointknowledgebase.blogspot.com/2013/08/to-open-this-workbook-your-computer.html


    Taras1234567

    Tuesday, December 03, 2013 5:30 PM
  • I solved that issue by disable compatibility view in the IE

    • Proposed as answer by S3rgio Friday, March 14, 2014 2:32 PM
    • Unproposed as answer by S3rgio Friday, March 14, 2014 2:32 PM
    Thursday, February 20, 2014 5:03 PM
  • I have Windows 8.1 x64, IE11, Office 2013 32 bits.
    Site is Sharepoint 2010.

    Tried to browse the web site using IE 9 emulation and it works well.


    S3rgio

    Friday, March 14, 2014 2:34 PM