none
Arquivo .exe não executa no DC

    Pergunta

  • Instalei um AD no Win 2003 Server e o seguinte problema está acontecendo. Não consigo da maquina DC execuar qualquer aplicativo que esteja em outra maquina Win2003 ou XP, mesmo com o usuário Administrador. E isso aconteceu somente depois que instaleu o AD.

     

    Por exemplo: Estou tentando instalar o Acrobat Reader na maquina DC, o Instalador está em outra maquina (Win 2003 que não está no Domínio). Quando abro a pasta compartilhada nessa outra maquina e executo o arquivo .exe do instalador do Acrobat recebo a seguinte mensagem: "O windows não pode acessar o dispositivo, caminho ou arquivo especificado. Talvez você não tenha as permissões adequadas para acessar o item."

     

    De qualquer outra maquina na rede (Win XP) consigo executar o .exe. Somente da maquina DC, não executa. Outros arquivos como .doc, .xls, .txt consigo abrir normalmente.

    Se executar um arquivo .exe que esteja na própria maquina DC, executa normal. Somente no compartilhamento em outra maquina que não. Ahhhh arquivo .bat também não abre.

    Sabem de alguma política default que possa estar causando isso?!?!?! Ou alguma outra coisa?

     

    Estou desesperado galera!!!! Valeu!

    segunda-feira, 24 de março de 2008 01:42

Respostas

  • Ilton,

     

    Eu estava com o mesmo problema e nosso amigo Marcus_z postou a solução pra mim

     

    ------------------------------------------------------------

    Bom dia Wilson,

     

    Você já tentou adicionar o nome do servidor1 no Sites confiáveis do Internet Explorer, tive este mesmo problema aqui e pesquisando vi  precisava adicionar o servidor que eu queria executar algum programa na lista de sites confiáveis.

     

    Espero ter ajudado,

    -------------------------------------------------------------

     

    Espero que ajude, é só cadastrar o nome do servidor na lista de sites confiáveis

     

    Abraço

    segunda-feira, 24 de março de 2008 12:26

Todas as Respostas

  • Olá Ilton,

     

    Já tentou copiar o executável localmente para o DC e rodá-lo novamente com os privilégios administrativos?

    Pois da mesma forma que existem alguns programas que não executam a instalação via TS, alguns executáveis podem também não abrirem normalmente via rede.

     

    Ilton, em relação a GPO's, você poderia dar uma olhada em restrições de softwares, talvez haja algum regra de Hash bloqueando esse executável em questão ou alguma chave do regsitro fazendo isso

     

    Um grande abraço

    segunda-feira, 24 de março de 2008 03:34
  • Caro Roberto,

    Localmente o executavel roda normalmente, até mesmo sem previlégios administrativos. Com a relação ao Adobe, foi só um exemplo que peguei. Pois o que acontece é que o DC não executa nenhum .exe, .msi, .bat pela rede, dando a mensagem de erro citada no 1o post.

    O grande problema é que tenho uma aplicação nessa outra maquina, os arquivos executaveis dessa aplicação ficam  compartilhados para que as estações a executem através do compartilhamento. Todas as maquinas Win XP da rede a executam normalmente, menos o DC.

    Com relação as GPO's e restrições de software não foi aplicado nada. O DC e o domínio estão com as políticas default.

    Valeu!!
    segunda-feira, 24 de março de 2008 11:17
  • Ilton,

     

    Eu estava com o mesmo problema e nosso amigo Marcus_z postou a solução pra mim

     

    ------------------------------------------------------------

    Bom dia Wilson,

     

    Você já tentou adicionar o nome do servidor1 no Sites confiáveis do Internet Explorer, tive este mesmo problema aqui e pesquisando vi  precisava adicionar o servidor que eu queria executar algum programa na lista de sites confiáveis.

     

    Espero ter ajudado,

    -------------------------------------------------------------

     

    Espero que ajude, é só cadastrar o nome do servidor na lista de sites confiáveis

     

    Abraço

    segunda-feira, 24 de março de 2008 12:26
  • Ilton,

     

    Faz um teste, clica encima do .exe com o botao direito do mouse e coloca RUN AS ou Executar como.

    Coloque as credenciais de um administrador da maquina ou do dominio e veja se funciona.

     

    Post aqui o resultado

     

    Se foi util classiifique

     

    Abrax

    segunda-feira, 24 de março de 2008 12:29
  • Wilson,

    Valeu pela dica!!! Estou de boca aberta até agora!!!! Nunca imaginei que o IE iria bloquear acesso a uma aplicação pela rede. Adicionei o nome da maquina em sites confiáveis e funcionou na hora!!!

    Valeu demaaaais!!!
    segunda-feira, 24 de março de 2008 12:49
  • remova o "Configuração de Segurança do Internet Explorer", que tb resolverá seu problema

    segunda-feira, 24 de março de 2008 13:11
  • Olá Ilton,

     

    Realmente não tinha pensando nisso, mas não entendi coo o IE pode bloquear um aplicativo via rede. A não ser que seu aplicativo utilize uma interface via browser, asism o Enhanced Security do Windows Server 2003 vai bloquear mesmo

     

     

    Abraço

    segunda-feira, 24 de março de 2008 13:17
  • Roberto,

    Também não sei como o IE pode bloquear. Mas ele bloqueia a execução de qualquer aplicativo (arquivo .exe, .msi, .bat) não somente a execução do aplicativo em si (como eu havia dito antes, nem deixar executar o instalador do Adobe, ou um winrar por exemlo, ele deixava executar). Além do que o aplicativo que utilizo não utiliza interface via browser.
    segunda-feira, 24 de março de 2008 14:44
  • Ilton,

     

    ele bloqueia, é normal, tendo em vista que quando vc acessa a parte de arquivos pelo IE dando um \\servidor ele assume funçao do windows explorer entende?

     

     

    abrax

    segunda-feira, 24 de março de 2008 14:48
  • Entendi!!! Mas nunca tinha visto isso acontecer..... e o Engraçado que tenho outros DC's rodando e não tinha dado isso. E esse problema especificamente soh acontece quando instala o AD. Se estiver sem o AD funciona normal.

    Vivendo e aprendendo!!!!

    Valeu, abraço!
    segunda-feira, 24 de março de 2008 15:47
  • Fala Ilton, tudo bom!!

     

     

    Cara, tenho aqui um srv 2003 membro que tmb não deixa que nada da rede seja instalado.

    Na epoca, eu postei aqui o problema e ninguem conseguiu me ajudar, pois realmente era um problema bem estranho, ma, olhe só agora, olhei seu post por acaso, testei e é que funciona mesmo!!.

     

     

    Quem diria, nosso amigo IE ataca novamente!! rsrsrsrs.

     

    VALEU!!

     

    segunda-feira, 24 de março de 2008 16:16
  • Hehehe!!! Os problemas não acabaram!!!!

    Como faço agora para que essa aplicação seja liberada lah no IE para diferentes usuários que logam via TS nessa maquina, sem que eu tenha q ir de usuário em usuário e adicionar o endereço da outra maquina nos sites confiáveis????

    Resumindo: Tem alguma politica que defino o endereço dessa outra maquina como sendo 'site confiável' para todos os usuários que logam no TS??? Ou tem com desativar esse controle para esses usuários por GPO???
    segunda-feira, 24 de março de 2008 19:28
  • Tem sim Ilton

     

    vai nesse link q ele explica direitinho como inserí-los em suas zonas confiáveis via GPO

     

    http://stewedprunes.com/blogs/stewed_prunes/archive/2006/01/21/398.aspx

     

    abraços

     

    Caso tenha ajudado não esqueça de marcar como respondida

    terça-feira, 25 de março de 2008 19:33
  • Roberto,

    Valeu pela dica, mas infelizmente não funcionou.
    Criei uma GPO pro grupo dos usuários que acessam via TS, fiz as alterações sugeridas no documento, mas não deu certo.
    Na verdade ficou como se eu nem tivesse feito alteração nenhuma na GPO, pois pelo que entendi, no IE do usuário iria aparecer somente os sites inseridos no GPO. No entanto no usuário continua aparecendo todos os sites que lá já haviam, e não aparece o que eu coloquei no GPO.
    quarta-feira, 26 de março de 2008 12:54
  • Ilton,

     

    Uma duvida, vc aplicou essa GPO em uma OU com usuarios ou grupo de usuarios?

     

    Abraços

    quarta-feira, 26 de março de 2008 13:04
  • Em uma OU que criei para os usuários que acessam via TS.
    quarta-feira, 26 de março de 2008 13:43
  •  

    Sim, entendi, porem dentro desta OU estao os usuarios que vao acessar ou vc criou um grupo de usuarios e inseriu o grupo la dentro?
    quarta-feira, 26 de março de 2008 13:48
  • Caro Ilton,

     

    Então tenta o seguinte:

     

    User Configuration / Windows Settings / Internet Explorer Maintenance / Security / Security Zones and Content Ratings

     

    E adicione os sites na zonas confiáveis

     

    Um abraço

    quarta-feira, 26 de março de 2008 13:48
  • Luiz,

    Coloquei os usuários dentro da OU.
    quarta-feira, 26 de março de 2008 13:53
  • Roberto,

    Quando acesso o 'Security Zones and Content Ratings' e coloco a opção de 'Importar as configurações atuais da zona de segurança e privacidade' e vou em 'Modificar Configurações' e em 'Sites Confiáveis' ele não permite adicionar nenhum site.

    P.S.: Estou acessando com o usuário Administrador.
    quarta-feira, 26 de março de 2008 14:07
  • Ilton,

     

    Essa opção só fica desabilitada em duas opções:

     

     - Caso vc não tenha permissão para isso (O que não é o nosso caso)

     

     - Ou caso vc esteja com o Internet Enhaced Security instalado e habilitado

     

    Caso a segunda opção seja verdadeira, vá até o Add/Remove Programs, desisntale esse recurso e tente novamente

     

    Abraços

     

    quarta-feira, 26 de março de 2008 14:13
  • É Roberto....

    A coisa tah feia!!!! desinstalei o Internet Enhanced Security e mesmo assim não habilita a opção para adicionar os sites.

    Alguma outra luz?!?!
    quarta-feira, 26 de março de 2008 20:08