none
Windows Update não atualiza

    Pergunta

  • O windows update do meu windows 7 não executa masi atualizações.

    Quando executo manualmente tenho a seguinte mensagem:

    "O Windows Update não pode procurar atualizações no momento porque o serviço não está em execução. Talvez seja necessário reiniciar o cumputador."

    Acontece que acesso o services e ele está sendo executado em modo automático e o serviço não está parado.

    Alguem pode me ajudar?

    quarta-feira, 23 de maio de 2012 15:56

Respostas

Todas as Respostas

  • Não aparece nenhum número de erro? do tipo 0x800e... as vezes aparece, mas já tentou deixar em MANUAL e dar um INICIAR?
    quarta-feira, 23 de maio de 2012 16:14
  • Caro Marcos,

    experimente resetar as configurações/componentes do Windows Update usando esse fix da Microsoft.

    http://support.microsoft.com/kb/971058

    []s

    quarta-feira, 23 de maio de 2012 17:27
  • O windows update do meu windows 7 não executa masi atualizações.

    Quando executo manualmente tenho a seguinte mensagem:

    "O Windows Update não pode procurar atualizações no momento porque o serviço não está em execução. Talvez seja necessário reiniciar o cumputador."

    Acontece que acesso o services e ele está sendo executado em modo automático e o serviço não está parado.

    Alguem pode me ajudar?

    Caro Marco,

    exatamente o mesmo problema que estou tendo. Ja tentei a dica do professor Akira abaixo, sem resultados.

    O windows update esta "congelado".

    Murilo

    quarta-feira, 30 de maio de 2012 02:40
  • Cara,

    Eu passei por esse mesmo problema em um computador de um amigo e resolvi verificando os logs do sistema (cultura adquirida por ser um usuário Linux). Ao consultar esses logs vi a msg abaixo:

    wuaueng.dll (940) SUS20ClientDataStore: Erro -1811 (0xfffff8ed) ao abrir o arquivo de log C:\windows\SoftwareDistribution\DataStore\Logs\edb.log.

    Visualizei que se tratava de um arquivo de log corrompido e então deletei para que o sistema criasse outro. Logo em seguida mandei checar o windows update e tudo funcionou perfeitamente.

    Att.

    Michel Peterson

    • Sugerido como Resposta Mario877 sábado, 16 de junho de 2012 19:18
    terça-feira, 5 de junho de 2012 14:39
  • Cara,

    Eu passei por esse mesmo problema em um computador de um amigo e resolvi verificando os logs do sistema (cultura adquirida por ser um usuário Linux). Ao consultar esses logs vi a msg abaixo:

    wuaueng.dll (940) SUS20ClientDataStore: Erro -1811 (0xfffff8ed) ao abrir o arquivo de log C:\windows\SoftwareDistribution\DataStore\Logs\edb.log.

    Visualizei que se tratava de um arquivo de log corrompido e então deletei para que o sistema criasse outro. Logo em seguida mandei checar o windows update e tudo funcionou perfeitamente.

    Att.

    Michel Peterson

    Funcionou para mim.

    Bastou deletar todos os arquivos de log, e voltou a funcionar.

    Obrigado.

    • Sugerido como Resposta lac10 sábado, 4 de agosto de 2012 15:09
    segunda-feira, 23 de julho de 2012 09:52
  • OK! pessoal funcionou perfeitamente, estava com esse problema alguns meses e não sabia o que fazer, boa dica!
    • Sugerido como Resposta CRLSGST quarta-feira, 19 de setembro de 2012 20:12
    sábado, 4 de agosto de 2012 15:11
  • Michel, bom dia

    funcionou comigo também, valeu!!!

    Muito obrigado mesmo!

    segunda-feira, 13 de agosto de 2012 15:41
  • Valeu Michel,

    Sua dica foi perfeita! É a cultura Linux resolvendo os problemas do Windows.

    Evilson

    segunda-feira, 24 de setembro de 2012 17:23
  • Comigo não resolveu... ao deletar os arquivos .log, na instalação e reinicio de maquina, o windows cria-os novamente, e novamente pára nos 15% e reinicia sozinho, e não instala porra nenhuma.

    já fiz de tudo, já usei o fix da microsoft, ja desisntalei anti-virus e malware bit, ja configurei no msconfig para inicializar com as opcoes minimas e nada, nada!

    como dizem, microsoft não presta!  o jeito vai ser guardar dinheiro e comprar um imac.

    segunda-feira, 1 de outubro de 2012 14:49
  • O Windows Update é um mecanismo deveras idiota.

    Eu não entendo o porquê de você instalar dez updates da mesma natureza. Não faz sentido.

    Se você instala o Windows XP com o Explorer 6, o WU atualiza o IE 6, depois instala o IE7, depois atualiza o IE7 e depois instala o IE8. Ao invés de instalar o IE8 direto, já com todas as atualizações, temos que esperar a atualização de todos os programas obsoletos.

    Daí vão dizer "por que não baixa o instalador do IE8 e pula as atualizações"? Tudo bem, até pode ser... Mas e como faço com o dot net? Tem como instalar o 4 com todas as atualizações? Não tem! Você instala o 4 (que já demora pra caramba) e depois tenho que esperar os trocentos updates...

    No Linux, se você faz uma atualização, ele já instala a última versão do que quer que seja. Se você instala uma distribuição com o Kernel 2.0, ele não atualiza para o 2.1, depois pro 2.2. Ele já atualiza para a última versão e ponto. E tudo em poucos minutos.

    A MS realmente está piorando a cada dia que passa. Acho que o Ballmer fez um pacto com a Apple e o Google para afundar o Windows. Eu estou usando o Windows 8 agora, porque estou instalando no PC de um cliente. O Windows Update até agora não deu tanto problema, porque o Windows 8 não tem tantos updates assim pra fazer.

    Mas esse mecanismo é realmente uma vergonha. Chega a insultar a inteligência de quem possui QI superior a de um chimpanzé retardado.

    quarta-feira, 5 de dezembro de 2012 15:19
  • Cara hoje mais de 1 ano depois me deparei com este problema e graças a deus achei sua dica.. perfeita.. foi apenas deletar os logs que o Windows update voltou a funcionar.

    obrigado pela dica.

    abs

    sábado, 9 de novembro de 2013 22:22
  • Marco Torsone, boa tarde

    Executei o procedimento mencionado acima, mas antes eu fui até o painel de controle > ferramentas administrativas > serviços e desliguei o serviço Update antes de realizar o procedimento abaixo:

    Fui até o caminho abaixo:

    C:\windows\SoftwareDistribution\DataStore\Logs\edb.log.

    Funcionou normalmente na atualização de teste que realizei, como haviam mais 67, o equipamento ficou fazendo as atualizações. Postarei posteriormente se solucionou totalmente.

    Marcos Arley

    Analista de Suporte

    sexta-feira, 17 de janeiro de 2014 16:00
  • Cara,

    Eu passei por esse mesmo problema em um computador de um amigo e resolvi verificando os logs do sistema (cultura adquirida por ser um usuário Linux). Ao consultar esses logs vi a msg abaixo:

    wuaueng.dll (940) SUS20ClientDataStore: Erro -1811 (0xfffff8ed) ao abrir o arquivo de log C:\windows\SoftwareDistribution\DataStore\Logs\edb.log.

    Visualizei que se tratava de um arquivo de log corrompido e então deletei para que o sistema criasse outro. Logo em seguida mandei checar o windows update e tudo funcionou perfeitamente.

    Att.

    Michel Peterson

    funcionou valeu.
    segunda-feira, 3 de fevereiro de 2014 02:49
  • Cara,

    Eu passei por esse mesmo problema em um computador de um amigo e resolvi verificando os logs do sistema (cultura adquirida por ser um usuário Linux). Ao consultar esses logs vi a msg abaixo:

    wuaueng.dll (940) SUS20ClientDataStore: Erro -1811 (0xfffff8ed) ao abrir o arquivo de log C:\windows\SoftwareDistribution\DataStore\Logs\edb.log.

    Visualizei que se tratava de um arquivo de log corrompido e então deletei para que o sistema criasse outro. Logo em seguida mandei checar o windows update e tudo funcionou perfeitamente.

    Att.

    Michel Peterson

    Funcionou para mim.

    Bastou deletar todos os arquivos de log, e voltou a funcionar.

    Obrigado.


    Vlw, funcionou perfeitamente aqui.
    quinta-feira, 20 de fevereiro de 2014 22:51
  • Cara,

    Eu passei por esse mesmo problema em um computador de um amigo e resolvi verificando os logs do sistema (cultura adquirida por ser um usuário Linux). Ao consultar esses logs vi a msg abaixo:

    wuaueng.dll (940) SUS20ClientDataStore: Erro -1811 (0xfffff8ed) ao abrir o arquivo de log C:\windows\SoftwareDistribution\DataStore\Logs\edb.log.

    Visualizei que se tratava de um arquivo de log corrompido e então deletei para que o sistema criasse outro. Logo em seguida mandei checar o windows update e tudo funcionou perfeitamente.

    Att.

    Michel Peterson

    Perfeito man!

    Aqui bastou deletar o arquivo edb.log, reiniciar o windows, e problema resolvido. WU funcionando normalmente agora. :)
    sábado, 22 de fevereiro de 2014 13:06
  • Isso mesmo, estava com este problema , removi o log  e funcionou perfeitamente.
    domingo, 16 de março de 2014 14:44
  • Obrigado pela ajuda. O meu caso foi só deletar o edb.log que o Windows Update voltou ao normal.

    Abraços.

    quinta-feira, 1 de maio de 2014 14:45
  • Deu certo pra mim também!! Muito Obrigadooo!
    terça-feira, 8 de julho de 2014 21:20
  • cara procurei em varios blogs.. ja ia formatar meu pc novamente por causa desse problema.

    Vlw mesmo!!!


    sexta-feira, 18 de julho de 2014 17:08